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Chapter 

1 
What You Should Know 

Overview 

There’s a lot that’s new in SI7, some of the more noticeable additions/changes are described in chapter 2 

“What’s New?”. Below is some general information that should be useful for anyone that is just getting 

started with SKY Index v7.0. 

Tips for Upgraders 

If you are upgrading from a previous version of SKY Index, you will find many improvements to make 

your life easier and your indexing go faster. For instance, some of the things you used to need macros for 

can now be done with built-in commands. A good example is the new Swap Acronym command. 

There are several changes you should know about in order to make your first use of SKY Index 7.0 (SI7) 

a pleasant one. Below are a few tips that will help you get started. 

1. There have been a number of keyboard shortcut changes made in order to bring SI7 into 

compliance with industry standards and to make the shortcuts easier to use and remember for 

first time users. For upgraders, this will obviously create a degree of heartburn, but you should 

know that testers ultimately found the changes one of their favorite features of SI7. Although it 

is strongly recommended that you learn the new shortcuts, there are two commands that you can 

temporarily change to work the way they did in v6.0. You can change those shortcuts through 

Preferences (Options>Preferences) They are: 

 Use Ctrl+A for Append New (in v7.0 you can use Ctrl+; (Control + semicolon) 

 Use Ctrl+P for Duplicate and Swap (in v7.0 the command is Ctrl+F4) 

2. Take the time to read the included information on the new keyboard shortcuts in 

Appendix B and the Chapter on Editing Commands later in this document. The new 

shortcuts are intelligently laid out and will ultimately make remembering each of the 

commands much easier. 

3. In v6.0, selecting records and pressing Delete would simply mark the records as deleted and you 

could filter the index so they did not appear. In v7.0 they are actually deleted. If you want to 

mark them as you did in v6.0, you can use v7.0’s labeling features to mark the records and the 

Filter feature to hide them just as you could in v6.0. Note: The Delete key always deletes in v7.0. 

You must use the appropriate keyboard shortcut to label records when attempting to duplicate 

this feature in v7.0. 

4. To open a v6.0 index, choose File>Open and then change Files of Type to: “All readable SKY 

Index versions”. You will then be able to choose a version 6.0 index. If you choose to open a 

version 6 index, the v6.0 index will not be altered, but all of its data and settings will be copied 

into a new v7.0 index and that new index will be opened. 
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5. Ty Koontz (one of SI7’s testers) has been kind enough to create and share a keyboard shortcut 

cheat sheet. That cheat sheet is included during installation as a PDF file and can be printed by 

navigating to: Start menu>Programs>SKY Software>SI7 Keyboard Shortcut Cheat Sheet. You 

will need the Adobe Acrobat Reader (or equivalent) program to open this file. 

6. There is a keyboard template that you can print out and place above your keyboard to also help 

you learn the new keyboard shortcuts. You can find the template on your computer here: Start 

menu>All Programs>SKY Software>Keyboard Template. 

7. For those of you that used to enter formatting using the actual codes, please note that it is 

impossible in v7.0 to enter formatting using codes. Those codes will be recognized as regular text 

and displayed as such. You will need to use the included keyboard shortcuts to change text style 

in SI7. 

8. If you have macros, some of them will likely have to be rewritten because of keyboard shortcut 

changes. However, please be sure to read the documentation on Editing Commands because you 

may find that some, or all, of your macros are no longer needed because SI7 includes built-in 

commands for many of the things that v6.0 users used to need macros for. 

Tips for New Users 

1. The tutorial takes you through many of common tasks of writing an index. You should read and 

perform the entire tutorial. 

2. Get to know the core editing commands. One of the most powerful and useful new features of 

SKY Index v7.0 is the creation of the core editing commands. These are a set commands based on 

eight function keys that can be modified using the Control and Shift keys in a consistent manner 

to make them even more powerful. 

3. Get to know all of the methods that are available to select records. 

4. Get familiar with the new Edit View. Initially you’ll be using Data Entry View to add your index 

entries, but once you’ve finished your data entry, Edit View is a superior view for performing 

final cleanup of your index. 
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Chapter 

2 
What’s New? 

Overview 

SKY Index Professional v7.0 (SI7) is a major upgrade to SKY Index. Certainly there are many new 

features, but the enhancements don’t stop there. Many of the existing features have been refined and 

extended. Here are a few highlights: 

Undo/Redo 

 SI7 now has both Undo and Redo and both are virtually unlimited. 

User Interface 

 You can now arrange the Data Entry Grid and Preview Pane side-by-side, so that they both 

display more entries. 

 The program's appearance has been improved giving it a more refined look. 

 Toolbars can be docked at the top, left, bottom, or right of the program screen. 

 You can now tear the toolbars off the docking area and let them float anywhere on your 

computer's screen. 

 There are now more toolbar icons for your common tasks 

Configuration 

 There are many new options for configuring the style of your index and there is now a live 

preview of the index so you can see exactly how your changes will affect your index. You can 

scroll throughout the entire index in the live preview and the changes you make are immediately 

visible. 

 There are now "Manager" dialogs for Acronyms, AutoComplete, AutoEntry, Macros, and 

Translations. They are all grid based and all include Import and Export features. 

Index Structure 

 There are now up to 6 subheading levels 

 There are now up to 9 section labels for locators (a section label is the same as a chapter or 

volume label) 

 You can define default prefix and suffix text for all locators and for all section labels. 

 You can now define custom alphabet separators and can also define what characters will appear 

in each section of the index. 
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Editing (general) 

 All core editing commands are now assigned to single function key for quick editing. 

 Core editing commands have modifiers for duplicating and grouping making it much easier to 

remember the commands for performing these compound commands. 

 You can now apply "Note" formatting to text so that the text will appear in the data entry grid 

and the Preview Pane, but will not sort and will not appear in the generated index. You can 

group on this new text style. 

 The Data Entry Grid now allows you to select an entire column by clicking on the column header. 

You can then use any of the commands on the Format menu to apply that formatting to that 

heading level for all entries in the index. 

Editing 

There are new Editing commands to make editing your index even faster and easier than before. 

Swap Acronym – allows you to swap the full text and acronym text with a single keystroke. 

Example: Change “American Society for Indexing (ASI)” to “ASI (American Society for 

Indexing)”. 

Toggle see/see also – Toggles a cross-reference from see to see also and vice versa with a single 

keystroke 

Consume Subheadings – Removes all subheadings of the current main heading (or subheading), 

and adds the locators of all those subheadings to the main heading. 

Create Subheadings from locators – Creates a new subheading with the first locator of the 

current main heading. That locator is removed from the main heading. 

Split – Allows you to automatically split entries according to a split delimiter and a split delimiter 

count in order to create new index entries with a single keystroke. Example: Split this one entry 

“Wilson, Samuel R., Roberts, John H.”, into these two entries: “Wilson, Samuel R.” and “Roberts, 

John H.” Note: If there are more than two names, just keep executing the command until all 

names have been split into new entries. 

Create Reciprocal Cross-reference – Creates a Reciprocal cross-reference with a single 

keystroke. Example: Given this entry: "American Society for Indexing. see also Indexing 

Societies" SI7 will create a new entry like this: "Indexing Societies. see also American Society for 

Indexing." 

Copy/Cut/Paste/Delete Heading – You can now cut, copy, paste, and delete entire headings 

(which include all of their subheadings) with a single keystroke. 

Edit View 

Edit View allows you to edit your index at the heading level. In Edit View, you will be presented with a 

formatted index in indented style. At the bottom of the program screen are three text boxes – one for the 

current heading, one for locators, and one for cross-references. As soon as you move the marquee to a 

particular index heading in the Preview Pane, it and its locators and cross-references will appear in the 

edit pane ready for you to make changes. Although the data entry grid offers all of the editing ability of 

Edit View, there are certain types of editing that can be done more efficiently and more intuitively in 

Edit View. Don't worry, though, the Data Entry Grid is still there to handle the special editing tasks that 

simply can't be handled by any other paradigm. 
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Find/Replace 

 Totally new user interface allows you to easily locate text with or without consideration of 

character style 

 Allows up to nine criteria (subsearches) using Boolean AND or OR and a new PLUS feature 

 There is now a "whole word" option 

 Your 20 most recent searches and your 20 most recent replaces are saved for reuse. They are 

saved with the index so they can be reused even if you close and reopen the index. 

 You can create up to 20 'Saved Searches' that are saved for all indexes and can be accessed 

through the Search menu or the Saved Searches toolbar 

 Press Ctrl+F3 to search for the currently highlighted/selected index heading. 

 Press F3 to find the next match or Shift+F3 to find the previous 

 Press Ctrl+Shift+F3 to create a group based on the currently highlighted/selected text. 

AutoComplete 

 When you AutoComplete cross-references, you can now optionally choose to remove trailing 

parenthetical text. 

 AutoComplete can be configured to update the AutoComplete list if you edit an existing index 

entry. If you make a spelling mistake and then correct it, the old misspelled entry will no longer 

be suggested by AutoComplete. 

Labels 

 You can now use up to 9 labels 

 Each label can be assigned a name 

 Each label has a user configurable color 

 The labels are shown in both the data entry grid and the preview pane 

 There is a Go to next label function 

 There is a Group on current label function 

 There is a Label tool window to allow you to easily set or clear any of the nine labels while 

working on your index. 

 The status bar shows the name of the current record’s label 

 There is a keyboard shortcut to toggle any of the nine labels 

Cross-references 

 You can configure SI7 to AutoCapitalize cross-references just as you can main or subheadings. 

 You can instruct SI7 to not apply formatting to "see" or "see also" if the target has formatting 

applied. 

 You can configure SI7 to force the target text in a cross-reference to match exactly the actual text 

it refers to. (Capitalization and formatting) 

 SI7 will recognize and automatically format 'under' when used in a cross-reference. 

 SI7's Error Scan will correctly verify cross-references that use 'under'. 

 SI7's Error Scan will now ignore general cross-references during error scan. (You specify what 

leading text constitutes a general cross-reference.)  

 You can instruct SI7 to automatically place general cross-references after all other subheadings. 

 You can Ctrl+Click on a cross-reference to display the cross-reference's target in a mini preview 

pane. Press Esc or simply move to a different record to close the mini preview. 
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Other Improvements 

 Full Unicode support. The Translation Table now includes the ability to define Unicode character 

translations quickly and easily making it a simple matter to include Unicode characters in your 

index. 

 The file open/save dialog now keeps track of the 9 most recently accessed directories for single 

click access. 

 The list of recently opened files now lists up to 9 indexes. 

 The merge command now allows you to select multiple indexes to be merged all at once. 

 The proofing report will now group records by locator when the index is in Page Ordered View 

prior to generating the proofing report. 

 The Title Case formatting command won’t capitalize words that are in the ignored words list 

 The SmartSwap list will now accept phrases instead of just single words and now works 

independently of the Ignored Words list. 

 You now have significantly more control over sorting. You define what characters are equal to a 

space, what characters are symbols, and what characters will be interpreted as a full stop. 

 You can now configure SI7 to automatically merge orphan subheadings. 

 There is now a Group on Orphan subheadings command so that you can manually merge 

orphans, if desired using the Promote or Combine command. 

 Group on the heading under the marquee or the currently selected text by pressing 

Ctrl+Shift+G. 

 Roman numerals that are part of a page range are now consumed if the Consume Locators 

option is turned on. 

 You can now group on a range of Roman numeral locators. 
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Chapter 

3 
Tutorial 

Tutorial Outline 

Below is the basic outline for creating an index with SKY Index. In the tutorial, you will write a small 

index using this outline. 

 Create an Index 

 Add Entries 

 Editing the Index 

 Find and Replace 

 Duplicating Index Records 

 Editing the Index in Edit View 

 Configuring the Index 

 Generate an RTF File 

 Loading Your Index into Your Word Processor 

 Conclusion 

Create an Index 

To create an index, do the following: 

1. Choose File>New or click the  toolbar icon. SKY Index will display a Files dialog. 

2. Type “tutorial” in the File name text box 

3. Click Create. SKY Index will create a new index with the name "tutorial.sk7" and will open the 

new file ready for data entry. 

Add Entries 

SKY Index has many features designed specifically to reduce typing. You add index entries in a fashion 

similar to that of many spreadsheet and database programs.  

Headings, Subheadings and Page Numbers (Locators) 

For our tutorial we are going to enter the following entries from a fictitious computer manual (displayed 

here as "heading, subheading, page"). 

command, open, 1 
command, new, 1 
command, merge, 2, 3 
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command, close, 3 
command, import, 3–4 
command, export, 4 
command, backup, 5–6 
command, restoring, 5–6 

To enter the first index entry start by typing command. As soon as you type the letter c SKY Index goes 

into edit mode. Any text already in the cell would be erased and replaced by the letter c. After you enter 

the remainder of the word ommand, press Enter or, if you prefer, press Tab to move the grid marquee to 

the next cell, Sub1. Note that you can move backward by pressing Shift+Tab. 

Now type open and press Enter to put the marquee in the Page field; then type 1. You have entered 

your very first index record. Press Enter one more time to save the current record to disk and start a 

new record. Your data entry grid should now look like the example below. 

 

 

Data Entry Grid 

Now let's enter the next record. Because SKY Index is set by default to repeat the main heading and the 

page field, you should now have "command" in the Main field. Press Enter to move to the Sub1 field. 

Now type new. This time press Down Arrow because the page number has been automatically repeated 

by SKY Index. You are now ready to enter the third record. 

Press Enter to move to the Sub1 field and then type merge. Now press Alt+Enter instead of pressing 

Enter. Pressing Alt+Enter always moves the grid marquee to the page field regardless of its current 

position. So even if the marquee had been in the Main field, it would have moved to the Page field. Now 

type 2. 

 

Note: This entry requires you to type two page numbers, both 2 and 3. As you proceed, notice that when 

you press the comma to enter the second page reference that SKY Index duplicates the current record 

and puts the cursor in the Page field, ready for the next page number. Both numbers will appear 

together separated by a comma in the Preview Pane above the grid after you finish entering the second 

page reference, but they will be in separate records in the grid. 

To finish the entry, type a comma and then, finally, type 3. Press Enter to save the record. 

You have now covered the basics of entering index records. Go ahead and enter the remaining records on 

your own. (The remaining records have been repeated below for your convenience.) 

command, close, 3 
command, import, 3–4 
command, export, 4 
command, backup, 5–6 
command, restoring, 5–6 
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When you finish, the data entry grid should appear similar to the one shown below (The first record you 

typed has scrolled off the top of the grid in this example screenshot): 

 

 

Data Entry Grid 

In the Preview Pane above the grid, you will see this: 

 

 

Preview Pane 

You now know how to enter headings, subheadings and page numbers in SKY Index. Next we’ll discuss 

how to enter cross-references. 

Cross-references 

Most indexes will require at least a few cross-references and it is important to know how to enter them. 

Let's enter a few cross-references into the index to learn the proper technique. The cross-references to be 

entered are: 

new. see command, new 

merge 
   see also export, import 

The first cross-reference is an example of a cross-reference that directly follows the heading from which 

it is made. The second is an example of a cross-reference that is displayed as a subheading of the 

heading from which it is made. This kind of cross-reference can appear either as the first subheading or 

the last. We will configure SKY Index to display these cross-references at the top of the subheading list 

for the tutorial. 

All cross-references in SKY Index are entered in the Page field. How the cross-references are formatted 

and their position in the final index is determined purely by the configuration of the Cross-references tab 

of the Index Options dialog. Let’s go ahead and configure the cross-reference settings now. 
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Configure Cross-references 

To bring up the configuration dialog for cross-references: 

1. Choose Options>Index (The Index Options dialog will appear) 

2. Click the Cross-references tab 

All the settings are as we want them except that we want cross-references from subheadings to be the 

first subheading. To do that: 

1. Under Presets, click on the drop-down list for ‘See also’. (A list of options will appear.) 

2. Choose the first option which is ‘see also Reference’. 

Notice that the Placement for See also cross-references has been changed to “First Subheading” as in the 

dialog below and that the Prefix which was a period and a space (as it is for ‘See’ cross-references, has 

been removed. 

 

 

Index Options – Cross-references tab 

Verify your dialog looks like the one above and click OK to save the changes we made. 

Entering cross-references 

To continue with the tutorial, press Ctrl+; (Control + semicolon) to start a new record. You can also press 

Ctrl+Ins to do the same thing. Now type new in the Main field and press Alt+Enter to move the 

marquee to the page field. In the Page field type see command, new. This completes the entry of the 

first cross-reference. 

To enter the second cross-reference, first type Enter to start a new record if you have not already done 

so. Now, type merge and press Alt+Enter to move the marquee to the Page field. Finally, type see also 
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import. Do NOT press Enter yet. To enter the third cross-reference, type the semi-colon. Notice that 

SKY Index duplicates the current record, complete with the words "see also", ready for you to enter the 

next cross-reference. SKY Index requires that there be only one cross-reference per index record. Type 

export and then press Enter to save the record. Your data entry grid should now look similar to the one 

below. 

 

 

Data Entry Grid 

You now know how to enter cross-references in SKY Index. Next, we’ll show you how to edit entries 

you’ve already made. 

Editing the Index 

Simple editing of index entries requires only that you know how to toggle in and out of edit mode. There 

are two ways to put the grid into edit mode with the keyboard. The first way is to simply start typing. If 

you use this method, SKY Index will delete any text in the cell and will replace it with the text that you 

type. 

The second way is to press F2. If you use this method, SKY Index will not erase any existing text. The 

text cursor will be placed at the end of any existing text, ready for you to add more. If you wish to delete 

or add text in the middle or beginning of the existing text you will need to use the cursor keys (or mouse) 

to move the cursor to the appropriate place to make your edits. SKY Index supports all of the normal 

Windows cursor movement keystrokes. If you are new to Windows see Keyboard Shortcuts for more 

information. 

You can also put the grid into edit mode with the mouse by clicking twice (not a double click) on the 

desired cell. The first click selects the cell and the second click puts the grid into edit mode. If the cell is 

already selected then it only requires one mouse click. 

As an example let's change the word "restoring" to "restore". To do this, move the grid marquee over the 

word "restoring". Next press F2 to go into Text Edit Mode. Finally, press Backspace three times to erase 

"ing" and then type e. You can exit Text Edit Mode by pressing F2 or by performing any action that will 

move the grid marquee to another cell in the grid. For now, press Down Arrow. 

Find and Replace 

There are times when you may wish to change an entry in your index or to simply find a set of related 

entries. You can do this with the Find and Replace features of SKY Index.  

Finding index entries 

To demonstrate, let's use Find to find all entries in the index that contain the word "merge". 

To do this, choose Edit> Find or click the  toolbar icon. The keyboard shortcut is Ctrl+F. In the 

resulting dialog box, type "merge" in the Find textbox. Next, check the Group Results checkbox. This 
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tells SKY Index to create a group out of the records that satisfy the search criteria. The Find dialog 

should look like this: 

 

 

Find Dialog 

Finally, click Find. SKY Index will search the index and will display the four records that contain the 

word merge as shown below. 

 

 

Data Entry Grid with Group Results for ‘merge’ 

You are now in Group Mode. To exit the Group Mode so that you can see all records in the index again, 

choose Group>Ungroup (Ctrl+Shift+U). 

Finding and Replacing Index Entries 

Next, to demonstrate the Replace function, we are going to change all occurrences of "command" to 

"commands". Press Ctrl+H to bring up the Replace dialog. The cursor will be in the Find textbox. Type 

“command” in that textbox. Now, we want to move to the Replace textbox. There’s a keyboard shortcut to 

move between the Find and Replace textboxes. That shortcut is Ctrl+Tab. Go ahead and press Ctrl+Tab 

now to move the cursor to the Replace textbox. Now type “commands”. The Find/Replace dialog should 

look like this: 

 



 Tutorial 13 

 

Replace dialog 

To start the process click Find. SKY Index will stop at the first occurrence of the word "command". 

Notice that the Find Pane shows the text that was found and what will happen if the replacement is 

actually made. It looks like this: 

 

 

Find Pane 

Since we wish to replace all occurrences, click Replace All. SKY Index will replace every occurrence of 

the word "command" with "commands". 

Click OK to close the message indicating that 10 entries were replaced. Then click Close to close the 

Find/Replace dialog. 

Tip: Although you should always be cautious about performing a Replace All, you can undo the changes 

you made by using Undo if you make a mistake. 

Duplicating Index Records 

SKY Index provides many ways to manipulate records to make the editing process go quickly. The 

tutorial covers a few of the more commonly used techniques. 

First you will simply duplicate an index record. To do this, move the grid marquee to the index record 

"commands, open, 1". Now duplicate the record by pressing Ctrl+D. 

An exact copy of the record will appear at the bottom of the data entry grid. You can make any desired 

changes at this point. For now, you will simply delete the duplicated record. To delete the record, press 

Ctrl+S to select it and then press Delete (on some keyboards it may be Del). 

Next you will duplicate a record and swap the Main and Sub1 headings at the same time. To do this, 

move the cursor to the index record "Commands, open, 1" and press Ctrl+F4. The record will be 

duplicated and Main and Sub1 headings will be swapped. You now have the entry "open, commands, 1". 

Now delete the record you just created by pressing Ctrl+S and then Delete. 
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Another task that you might want to do while editing an index is to duplicate an entire set of entries 

that have the same main heading. You could then swap the Main and Sub1 headings so that you end up 

double posting the entries. For the tutorial, we will duplicate all entries with the main heading 

commands and then swap the main and subheadings after changing the main heading to command 

instead of commands. We will then also combine the Sub1 entries with the Main heading. As a partial 

example, you will be duplicating the entries like these: 

commands 
 open 
 close 
 merge 

to create entries like these: 

open command 
close command 
merge command 

This requires several steps as follows: 

Step One: Select, duplicate and group all entries that have the main heading “commands”. 

To do this, put the marquee over the main heading of any record that has the main heading 

commands. Then press Ctrl+Shift+F8. 

 

F8 is the command to select a heading. The Ctrl key tells SKY Index to duplicate after selecting and 

the Shift key tells SKY Index to create a group out of the duplicated records. All of the ‘core’ editing 

commands of SKY Index are assigned to a function key and the Ctrl and Shift keys work for all of 

those commands. You can learn more details in the Editing Commands chapter later in this manual. 

A group of the duplicated entries will be created and all of the duplicated records will be selected as 

shown below. Notice that in the status bar, the view mode is displayed as “(As Entered)”. As Entered 

means that you’re seeing the entries in the order you entered them and the parentheses around the 

view mode tells you that you are currently in Group Mode. You can also tell from the status bar that 

there are nine records in your group. 

 

 

Data Entry Grid after Duplicate Heading Command 

Step Two: Change the main heading to Command. 

To do this, make sure that the grid marquee is over any of the main headings. Then press F2 to put 

the grid into Text Edit Mode. Now press Backspace to remove the “s” from “commands”. Finally 

press Alt+Ctrl+Enter to propagate this change through all of the matching main headings. The data 

entry grid will look like this: 
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Data Entry Grid after changing ‘commands’ to ‘command’ 

Step Three: Swap the Main and Sub1 fields 

To do this, choose Edit>Select All to select all of the entries in the grid. Now choose Edit>Swap (F4). 

SKY Index will ask which heading level you wish to swap. Choose Sub1 and click OK. Notice that all 

main and subheadings have been swapped and the all of the records remain selected. This allows you 

to perform another edit command on them as we will do next. 

Step Four: Combine the subheadings with the main heading field. 

To do this, choose Edit>Combine (F7). A dialog will appear asking you which field you wish to 

combine with its parent heading. Choose Sub1 and click OK. 

Your Data Entry grid should now look like this: 

 

 

Data Entry Grid after Combining Sub1 with Main 

Before continuing, let’s exit Group Mode by choosing Group>Ungroup (Ctrl+Shift+U). Now you can now 

see the entire index again. You have now finished the duplicating exercises of the tutorial. Next we’ll 

cover show you how to edit your index in the new Edit View. 

Editing the index in Edit View 

The new Edit View allows you to edit your index in a manner that is similar to using your word 

processor. It presents your index fully formatted and in indented style. There is always one heading that 

is highlighted by the marquee and that is the ‘current’ heading. To enter Edit View, press Shift+F10 (or 

choose View>Edit View). Do this now. You will get a Tips display that describes briefly how to use Edit 

View which you can close. After entering Edit View, you will see a screen that is similar to what is 

shown below. 
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Example of Edit View 

Editing a heading in Edit View 

To demonstrate how to edit, let’s change “restoring command” to “restore command”. To do this, first 

move the marquee so that it is over that heading using the up or down arrow keys. The screen will look 

like this: 

 

 

Edit View after Moving the Marquee 

Now, to edit the heading, press either F2 or Enter. The in-place editor will appear as shown below. 

 

 

Edit View with the In-place Editor Revealed 

Now move the cursor left using the left arrow key until you reach the ‘g’ in ‘restoring’. Then delete the 

three letters ‘ing’ by pressing Backspace three times and then type an ‘e’ so that you’ve changed 

‘restoring’ to ‘restore’.  Now that you’re finished you can save the edit by pressing either F2 or Enter or 

by pressing the up arrow key to move to the previous heading. For the tutorial, let’s press Enter. Now 

the Edit View screen will look like this: 
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Edit View – After finishing the Edit 

Editing a locator 

Now let’s learn how to edit a locator. Let’s change “new command, 1” to “new command, 2, 4”. Move the 

marquee up two headings so that it is over the “new command” heading. Then press F2 or Enter to start 

editing. What you’ll see is this: 

 

 

Edit View - Before Editing the Locator 

Now press Tab. Focus will be moved to the locator and it will slide left and grow to give you a larger 

editing area and will look like this: 

 

 

Edit View – After Tabbing to the Locator Area 

If you wanted to edit a cross-reference, you could press Tab again to move to the cross-reference area. 

Now that focus has been given to the locator area of the in-place editor, type ‘2, 4’ to complete the edit. 

Because the  ‘1’ was selected, it will be deleted as soon as you start to type. Finally, press Enter to 

commit the edit. 

This gives you the basic process of editing in Edit View. You can move back to the Data Entry View (with 

the grid) by pressing Shift+F10 again or you can just type Ctrl+; to start adding new records in Data 

Entry View. It is also possible to add new headings in Edit View using the New Heading and New Child 

Heading commands under the Edit menu, but we’re not going to practice that in the tutorial. 

Other Editing Tasks in Edit View 

Virtually any editing task that you can perform in Data Entry View using the grid can also be performed 

in Edit View. For one example, let’s duplicate and swap the main and subheading “commands” and 

“backup”. To do this, move the marquee over the heading “backup” and press Ctrl+F4. The heading will 

be duplicated and then the main and subheading will be swapped. When you’re done, you’ll have 

something like this: 
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Edit View – After Duplicate and Swap 

The new Edit View is the most efficient place to edit your index. Data Entry View – as the name implies 

– is a more efficient place for doing data entry. You can, however, do data entry in Edit View and editing 

in Data Entry View. 

You can learn more about Edit View in the chapter on Edit View later in this manual. Now that we’ve 

shown you the basics of using Edit View, let’s configure your index. 

Configuring the Index 

As an indexer, your clients will expect you to be able to provide your index in a particular style. SKY 

Index lets you specify the style of your index in the Index Options dialog. We’re going to familiarize you 

with this dialog so that you know where to look in the future to make changes to your index’s style. 

We will assume that our imaginary publisher wants the first letter of main headings to be capitalized 

and we’ll set the sorting method to Letter-by-Letter. 

To configure the index for the tutorial: 

1. Choose Options>Index or click the  toolbar icon. The Index Options dialog box will be 

displayed with the Sorting tab shown by default. 

2. Click the arrow on the Sort Method drop-down list box to set the sorting method to Letter-by-

Letter (ISO). The Sorting tab of Index Options should appear as below. 

 

 

Sorting tab of the Index Options Dialog 
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3. Click the Heading Style tab. 

4. Check the Initial Cap option button. The Heading Style tab of Index Options should now appear 

as shown below. Notice that the Preview at the right side of the dialog shows all your main 

headings with a capital letter now and that the Preview is of the actual index entries you made 

earlier. 

 

 

Heading Style tab of the Index Options Dialog 

5. Click OK to save your settings. You will be informed that SKY Index needs to resort your index 

because of the changes you made. 

6. Click OK to let SKY Index resort your index. 

You’ve now configured your index to suit our imaginary publisher. The next step is to generate a file 

for our client. 

Generate an RTF File 

By default SKY Index generates your index using Rich Text Format (RTF). RTF is one of the most 

widely supported word processor file formats in existence and it is unlikely that you will find a modern 

word processor that does not support this format. Unless your word processor does not support RTF it is 

strongly recommended that you use this format since SKY Index can only provide page layout formatting 

information for indexes generated in RTF format. 

To generate your index, choose Index>Generate or click the  toolbar icon. SKY Index will generate an 

index file that has the same name as your index, but with a filename extension of .rtf instead of .sk7. 

You’ve now generated your index. The file you generated has the same name as your index, but has a 

.RTF filename extension. The file can be found in the SKY Index folder of your Documents (“My 

Documents” folder for Windows XP) folder. You should examine the generated index before sending it to 

your client. SKY Index makes it easy. The next section of the tutorial tells you how to load your index 

into your word processor. 
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Loading Your Index into Your Word Processor 

SKY Index can invoke your word processor with your index ready to be edited or printed with just a 

single mouse click or a single keystroke. To view your index in your word processor, choose 

Index>Edit/Print or click the  toolbar icon. SKY Index will start your word processor and cause your 

word processor to load the index you have most recently generated. 

 

If your index has been edited since the last time you generated the index, SKY Index will generate the 
index before starting your word processor. You do not need to choose Index>Generate before the 

Edit/Print command. 

You can now print the index or use your word processor's abilities to enhance the index. For instance, 

you may wish to add footnotes to your index, or include a graphic image at the beginning of the index. 

You may also wish to sink the first page so that the body of the index starts slightly lower on the first 

page than on subsequent pages. 

To complete this exercise, click the X at the top right of your word processor’s program window to close 

your word processor.  

Conclusion 

Well, that's all. You have finished the tutorial and you should now be able to write an index with a 

minimum of effort. We do highly recommend that you at least review the editing features of SKY Index. 

If you don't know about them you can't put them to use. 

The editing features of SKY Index have been designed to reduce the amount of time and effort it takes to 

write and edit an index. Please explore your User's Manual or online help to learn the power and 

flexibility that is available. 
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Chapter 

4 
How to Use Help 

There are a number of useful ways to get help while using SKY Index. Knowing the available ways to 

access help will make using SKY Index more enjoyable and will reduce time wasted trying to figure out 

how to accomplish indexing tasks. 

Press F1 

The number one most important thing to remember is to press F1. SKY Index has been designed to be 

context sensitive. If you are viewing a dialog in SKY Index and you don’t understand some of the options, 

press F1. 

When you press F1, SKY Index will display help on the dialog box you are currently viewing. Usually 

there is a graphic image of the dialog box in the help file and you will be able to click on the item you are 

unsure of to view help on that item. In addition, there are frequently references to other parts of the help 

file that may provide additional information. 

Dialog Help Button 

At the top/right corner of almost every dialog you will see a yellow question mark. If you want help 

related to that dialog, just click that yellow question mark and you will receive help that relates to that 

particular dialog. 

 

 

Example of the Dialog Help Button 

Hover 

If you hold the mouse cursor over a toolbar icon for about a second, a popup hint will be displayed that 

provides a brief description of the icon’s function. You can also hold the cursor over an acronym button to 

determine what the expanded acronym is. Similarly you can hold the mouse cursor over a macro button 

to determine what the macro does. 
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Search for Help On 

If the techniques listed above don’t provide satisfactory help, choose Help>Search for Help On. You will 

be presented with an index to the help file. Note: You may have to click on the Index tab to see the 

index. A text box is provided where you can type the first few characters of the topic you wish to find 

help on. If the keyword that you type is contained in the help index it will be displayed. You can then 

click on Display to see the desired help topic. 
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Chapter 

5 
Understanding SKY Index View Modes and Text Editing Modes 

Overview 

SKY Index includes two distinct views for adding and editing index entries. They are Data Entry View 

and Edit View. These two views are, in basic terms, workspaces where you add or edit your index 

entries. A description of these modes is discussed in this chapter. 

Data Entry View  

Data Entry View 

Data Entry View or DEV uses a grid similar to a spreadsheet for data entry and editing. Since the 

columns are clearly labeled and because either the Tab or Enter keys move you to the next cell of the 

grid, performing basic data entry and editing in this view is very straight forward. In this view, you will 

see both a preview of the index, called the Preview Pane, and a grid which is called the Data Entry Grid. 

By default, the Preview Pane is above the grid. An example of this view is shown below. 

 

 

Data Entry View with Preview Pane on Top 
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You can also configure DEV so that the Preview Pane is shown to the left of the grid through a 

Preference setting. An example of this is shown below. Virtually all new computers come with 

widescreen monitors which make this view of the index very appealing. 

 

 

Data Entry View with Preview Pane on Left 

DEV is where you should do the majority of your data entry because the Data Entry Grid is extremely 

well suited to this task. It also allows for unprecedented editing flexibility. In this view, you can see the 

index in As Entered order, Page order or Sorted order. Because the Preview Pane always shows the 

index in Sorted order, you can actually view your index in two sort orders simultaneously by choosing As 

Entered order or Page order. 

Adding records in Data Entry View 

Adding a New Index Entry 

To start a new index record press Ctrl+Ins or Ctrl+;. This places the marquee in the main heading field 

of the append row. Enter the main heading text and press Enter or Tab to move to the Sub1 column. 

Enter the text for subheading 1 and so on. 

Moving From Cell To Cell 

To move to the next column you can press either Tab or Enter. To move back to the previous column you 

can press Shift+Tab. This always works no matter what mode the grid is in. When the grid is in View 

mode, you can also use the left and right arrow keys to move to the previous or next columns. For a 

complete list of keyboard commands for navigating in the grid, see Keyboard Shortcuts. 

Text Edit Mode and View Mode 

When using Data Entry View, understanding SKY Index’s text editing modes is crucial if you want to 

use the program efficiently. Text Edit Mode and View Mode are used to describe two possible states for 
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the Data Entry Grid. When the grid’s marquee is visible, you are in View Mode. When the marquee is 

not visible and the flashing text edit cursor is visible, you are in Text Edit Mode. 

You can toggle between these two modes with the F2 function key. In addition, you can enter Text Edit 

Mode by simply starting to type. In this case, any existing text in the grid cell that had the marquee will 

be erased and the text you type will replace it. 

Whenever you move to a different cell of the grid by any means, you will exit Text Edit Mode and enter 

View Mode. Any edits that you performed prior to moving to a new cell will be saved before the grid 

marquee moves to the new cell. 

Entering Text Edit Mode 

There are three ways to enter Text Edit Mode. They are: 

Method 1 

The easiest way to enter Text Edit Mode is to simply start typing. When you press any key that cannot 

be interpreted as a navigational key or a command key, the following will occur: 

 The entire contents of the current grid cell will be deleted. 

 The data entry grid will be placed into Text Edit Mode. 

 The text that you type will be entered into the current grid cell. 

This is useful when you are adding new records to the index. Especially when you have configured SKY 

Index to repeat the contents of several fields such as the Main and Page fields. If the Main field does not 

contain the desired heading you can replace the contents of that field without any extra keystrokes. 

There is no need to press Del first. 

Method 2 

The second way to enter Text Edit Mode is to press F2. If you enter Text Edit Mode in this manner, the 

contents of the current grid cell will not be deleted and you will be able to make changes to the cell’s 

contents. 

Did you know?: The use of function key (F2) was chosen to enter Text Edit Mode because it is how 

Windows allows you to edit filenames for and is also used in other popular programs for 

renaming/editing text. 

When in Text Edit Mode, you can use all of the standard editing keys that you would expect in a 

Windows based program. 

Method 3 

Click twice on the desired grid cell. Note: This is not a double click. You must click twice slowly. The 

first click selects the cell and the second causes the grid to enter Text Edit Mode. 

Exiting Text Edit Mode (Returning to View Mode) 

To exit Text Edit Mode, and return to View Mode, you can press F2 or any navigational key such as Tab, 

Enter or Down Arrow. 

Notes 

Changes to your index are made on a record-by-record basis. You can undo any changes to individual 

cells by moving the marquee left or right to the desired grid cell (within the current record) and then 

press Esc. Once you move the grid marquee out of the record, you can undo changes to the record by 

using Edit>Undo. 
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Edit View 

Edit View or EV is a heading based editor as opposed to the record based Data Entry View. It always 

appears as an indented style index. This view of the index is extremely useful for cleanup editing of the 

index - editing that you would perform after you’ve finished your data entry. In Edit View you are 

always working with exactly one heading which is highlighted in the Preview of the index and can be 

edited – in-place – by pressing F2 or Enter. Any locators or cross-references are separately split out from 

the heading and can also be edited. Below is an example of the Edit View screen with the in-place editor 

shown. 

 

 

Edit View 

Adding New Headings in Edit View 

Although Data Entry View is, as the name implies, better suited to data entry than Edit View, you may 

still add index entries in Edit View and if you’re only going to add a few entries, this would be preferable 

to switching View Modes to do your data entry. 

Adding a New Heading at the Current Level 

To add a new heading at the current level, choose Edit>New Heading or press Ctrl+N. Note that the 

current level is determined by the location of the blue marquee in the Preview Pane. A new heading will 

be created with the text: <Edit Me> and this text will be selected in the in-place editor ready for you to 

edit. Type your new heading and then press tab to move to the page field to enter the locator. After 

you’ve entered the locator, press Enter (or F2) to save the new heading. 
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Tip: You don’t really have to press Enter. Any action that moves the Preview Pane marquee to a new 

heading will save any changes you’ve made. Switching to Data Entry View will also save any changes 

you’ve made 

Adding a New Child Heading from the Current Level 

To add a new child heading (a subheading) at the current level, choose Edit>New Child Heading or press 

Ctrl+Shift+N. A new subheading heading will be created under the current heading with the text: <Edit 

Me> and this text will be selected in the in-place editor. Type your new heading and then press tab to 

move to the page field to enter the locator. After you’ve entered the locator, press Enter to save the new 

heading. 

About Entering or Editing Locators 

When adding locators, you should separate each additional locator with a comma. Spaces around the 

comma are okay and will be ignored when saving the locators to the index database. 

Notes 

 When there is more than one locator in the Locators textbox, pressing Tab will select the next 

locator in the list. Once the locator that you wish to edit has been highlighted, you may simply 

type the new locator. 

 Pressing tab when the text cursor is within or after the last locator in the Locators textbox, will 

cause focus to be given to the Cross-References textbox and the first cross-reference will be 

highlighted. 

 Pressing Shift+Tab when the text cursor is within or before the first locator in the Locators 

textbox will cause focus to be given to the Heading textbox. 

 It does not matter where in the list of locators that you type a new locator. After the new locator 

is saved, it will be properly sorted with respect to the other locators. 

 If you delete a locator, you do not have to delete the comma before or after it. The deletion will 

still occur normally. 

About Entering or Editing Cross-references  

When adding cross-references, you should separate each additional cross-reference with a semicolon. 

Spaces around the semicolon are okay and will be ignored when saving the cross-references to the index 

database. 

Notes 

 When there is more than one cross-reference in the Cross-references textbox, pressing Tab will 

select the next cross-reference in the list. Once the cross-reference that you wish to edit has been 

selected, you may simply type the new cross-reference. 

 Pressing tab when the text cursor is within or after the last cross-reference in the Cross-

references textbox, will cause focus to be given to the Heading textbox and the heading text will 

be selected. 

 Pressing Shift+Tab when the text cursor is within or before the first cross-reference in the Cross-

references textbox will cause focus to be given to the Locators textbox and the first locator will be 

selected. 

 It does not matter where in the list of cross-references that you type a new cross-reference. After 

the new cross-reference is saved, it will be properly sorted with respect to the other cross-

references. 

 If you delete a cross-reference, you do not have to delete the semicolon before or after it. The 

deletion will still occur normally. 



28    SKY Index 7.0 User’s Guide 

Editing Existing Headings in Edit View 

If you wish to edit an existing heading, simply move the Preview Pane Marquee over the heading you 

wish to edit and press F2 or Enter. The heading text will appear in the in-place editor on top of the 

original text. 

If you wish to completely change the heading, press Shift+Home to select the heading and then type the 

new heading.. 

If you wish to edit the existing entry, use the left or right arrow keys to move the text cursor to the place 

you wish to perform your edit and make your change. 

Navigating in Edit View 

In general, to change the current heading in Edit View, you just press the up or down arrow key. A full 

list of keystrokes is provided under Edit View Keyboard Shortcuts below. You can also drag the scroll bar 

with the mouse to see other heading in your index without changing the current, selected, heading. 

Edit View Keyboard Shortcuts 
 

Keystroke Action 

DownArrow Move the marquee to the next heading. 

UpArrow Move the marquee to the previous heading. 

PgDn Move the marquee down one full screen of headings. 

PgUp Move the marquee up one grid full of headings. 

Ctrl+PgDn Move the marquee to the last heading in the index. 

Ctrl+PgUp Move the marquee to the first heading in the index. 

Ctrl+Home Move the marquee to the first heading in the index. 

Ctrl+End Move the marquee to the last heading in the index. 

Tab Moves the text insertion point to the next textbox. 

Shift+Tab Moves the text insertion point to the previous textbox. 

RightArrow* Move the text insertion point one character to the right. 

LeftArrow* Move the text insertion point one character to the left. 

Ctrl+RightArrow* Moves the text insertion point one word to the right. 

Ctrl+LeftArrow* Moves the text insertion point one word to the left. 

Home* Moves the text insertion point to the front of all text in the textbox with 

focus. 

End* Moves the text insertion point to the end of all text in the textbox with 

focus. 

Any Alphabet key The typed character is added to the textbox that currently has focus. If 

any text is selected, that text is deleted. 

* Holding down the shift key while pressing one of these key combinations will select text. 
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Chapter 

6 
Selecting Records 

Selecting records is an important part of the editing process when polishing your index. Knowing how to 

properly select records can significantly reduce your editing time and it is therefore highly recommended 

that you read and understand the chapter in its entirety. 

Selecting a Single Record (Data Entry View Only) 

The Select Record command will select the current record. Some of SKY Indexes editing features require 

you to first select the records that you wish to edit. For instance, to mark records you must first specify 

the records you wish to mark by selecting them. 

To select an record choose Edit>Select Record. 

Keyboard Shortcut: Ctrl+S 

See also: Selecting an Entry; Selecting a Heading 

Selecting an Entry (Data Entry View Only) 

The Select Entry command will select the current record plus all other records that are identical in the 

Main, Sub1, Sub2, and Sub3 heading levels thereby collecting all page references for the current record. 

To select an entry choose Edit>Select Entry. 

Keyboard Shortcut: F9 

Selecting a Heading (Data Entry View Only) 

The Select Heading command will select all records where the level of the grid's marquee, plus all parent 

levels, match. For instance, if the grid marquee is over a main heading, all records that have the same 

main heading will be selected. If the grid marquee is over the Sub1 heading, then all records that match 

both the Main and Sub1 headings will be selected. 

This feature can be very useful when you want to duplicate the structure of a set of index entries to 

create a new set of entries. 

To select a heading choose Edit>Select Heading. 

Keyboard Shortcut: F8 

Example: Assume you have the following set of entries (ignoring locators): 

bicycles 

 buying 

 maintenance 

 repairs 
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and you want to create the following entries: 

cars 

 buying 

 maintenance 

 repairs 

Simply put the grid marquee over the main heading of any record that has the main heading 'bicycles' 

and press F8. Then duplicate entries by choosing Edit>Duplicate, and group the entries by choosing 

View>Grouped. Finally, change any one of the 'bicycles' main headings to 'cars' and press 

Alt+Ctrl+Enter to propagate the edit through the entire group. 

Tip: You can use the Ctrl and Shift modifiers to duplicate and group in one step as described in chapter 

8 Editing Commands. 

See also: Select Heading 

Selecting All Records (Data Entry View Only) 

The Select All command will select all records in the currently open index. 

To select all records choose Edit>Select All. 

Keyboard Shortcut: Ctrl+A 

Selecting Multiple Records (Data Entry View Only) 

One of SKY Index’s editing strengths is the ability to select multiple records and perform an edit on all of 

the selected records at once. In order to take advantage of this editing power, you must know how to 

select multiple records. The two simplest ways are through the Select Heading and Select Entry 

commands discussed above. There are other ways to select records, however, which are discussed below. 

Selecting contiguous records with the keyboard 

To select more than one record using the keyboard, you simply hold down the Shift key and press one of 

the following keys to extend the selection. 

UpArrow or DownArrow – Extends the selection one record at a time in the direction of the arrow key 

pressed. (Note: The first time you press an arrow key with the Shift key held down, two records will 

be selected – the original current record plus the new current record. Each successive pressing of the 

arrow key will select one additional record. 

PageUp or PageDown – Extends the selection one page (grid screen) at a time. PageUp selects records 

going backwards one page at a time and PageDown selects records going forward one page at a time. 

(Note: The first time you press PageUp the selection will occur from the current record to the top of 

the currently visible grid screen. The first time you press PageDown the selection will occur from the 

current record to the bottom of the currently visible grid screen. Each successive pressing of PageUp 

or PageDown will select one whole page or records. 

Ctrl+PageUp or Ctrl+PageDown – Extends the selection from the current record to the very first 

record in the grid (Ctrl+PageUp) or to the very last record in the grid (Ctrl+PageDown). 
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Selecting contiguous records with the mouse 

Method one (Shift clicking) 

Step one: Move the mouse cursor over the row heading area of the grid. This is the area at the far left 

before the main heading cell. Hold down the Shift key and click in the row header area of the first record 

you wish to be part of the selection. 

Step two: Now scroll the grid, if necessary, using the scroll bar and then click again while still holding 

down the Shift key, in the row header area of the last record you wish to be part of the selection. All 

records between and including the first and last clicked records will be selected. 

Tip: You can extend or reduce the selection by clicking again on a different ‘last’ row. 

Method two (dragging) 

Move the mouse cursor over the row heading area of the grid. This is the area at the far left before the 

main heading cell. Press and hold down the left mouse button and then move the mouse up or down to 

select records in the direction that you move the mouse. 

Tip: After you have released the left mouse button, you can adjust the selection, if necessary, by using 

the keyboard while holding down the Shift key and pressing UpArrow or DownArrow. 

Selecting non-contiguous records with the mouse 

There may be times when you want to select records in the Data Entry Grid that are not next to each 

other – that are non-contiguous. You can do this by holding down the Ctrl key while clicking the left 

mouse button while the mouse cursor is over the row header of a grid row. Doing so will toggle the 

selection state of that one row, but will not affect the selection state of any other rows. 

Selecting a Column (Data Entry View Only) 

There may be times when you want to apply the same character style to every entry in a particular 

column of the Data Entry Grid. To accomplish this you can select a column before applying the character 

style. You can also delete the entire contents of a selected column. 

To Select a Column 

To select a column simply place the mouse cursor over the column header of the column you wish to 

select and click the left mouse button. The entire column will be selected. 
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Chapter 

7 
General Editing 

Overview 

This chapter provides information on some of the more general and often used editing commands of SKY 

Index. 

Append New 

The Append New command will move the grid marquee to the bottom of the data entry grid and into the 

append row ready for a new index entry. 

To append a new record choose Edit>Append New 

Keyboard Shortcut: Ctrl+Ins or Ctrl+; 

Cut 

You can cut the text from any grid cell or cut one or more index records to the Windows clipboard so that 

they may be pasted into the index in another location. You can also cut and paste text or records from 

one index to another index. 

Cutting Text 

Select the text to be cut. Note: If you wish to cut the entire contents of a grid cell, there is no need to 

enter edit mode and select the text since all text in the cell will be automatically selected when you 

perform the cut function. 

Cut the text to the clipboard in one of the following ways: 

 Click the  toolbar icon. 

 Choose Edit>Cut. 

 Press Ctrl+X 

 Right-click on the desired cell and choose Cut from the popup menu. 

Cutting Records 

To cut records to the Windows clipboard, do the following: 

 Select the records to be copied. 

 Cut the selected records to the clipboard in one of the following ways: 

 Click the  toolbar icon. 

 Choose Edit>Cut. 
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 Press Ctrl+X 

 Right-click anywhere on the grid and choose Cut from the popup menu. 

See also: Copy; Delete; Paste 

Copy 

You may copy the text from any grid cell or copy one or more records to the Windows clipboard so that 

they may be pasted into the index in another location. You can also copy and paste text or records from 

one index to another index if desired. 

Copying Text 

Select the text to be copied. Note: If you copy the entire contents of a grid cell, there is no need to enter 

edit mode and select the text since all text in the cell will be automatically selected when you perform 

the copy function. 

Copy the text to the clipboard in one of the following ways: 

 Click the  toolbar icon. 

 Choose Edit>Copy. 

 Press Ctrl+C. 

 Right-click on the desired cell and choose Copy from the popup menu. 

Copying Records 

To copy records to the Windows clipboard, do the following: 

 Select the records to be copied. 

 Copy the selected records to the clipboard in one of the following ways: 

 Click the  toolbar icon. 

 Choose Edit>Copy. 

 Press Ctrl+C. 

 Right-click anywhere on the grid and choose Copy from the popup menu. 

See also: Cut; Delete; Paste 

Paste 

You can paste text from the Windows clipboard to any grid cell or paste entire records to the bottom of 

the data entry grid. 

Pasting Text 

To paste text from the Windows clipboard, do the following: 

 Place the marquee over the grid cell to which you wish to paste text. 

 Paste the text from the Windows clipboard into the cell, or at the current insertion point, in one 

of the following ways: 

 Click the  toolbar icon. 

 Press Ctrl+V. 

 Choose Edit>Paste. 
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Pasting Records 

To paste records from the Windows clipboard into the Data Entry Grid, do one of the following. 

 Click the  toolbar icon. 

 Press Ctrl+V. 

 Choose Edit>Paste. 

Note: The pasted records will be added to the bottom of the data entry grid and will be selected. This 

allows you to perform another function on the pasted records such as a Shift Left. 

See also: Copy; Cut; Delete 

Delete 

You can delete the text from any grid cell or delete one or more index records. 

Deleting One Character at a Time 

If the grid is in Edit mode you can delete a single character at a time in one of two ways: 

 Press Backspace to delete the character to the left of the text cursor. 

 Press Del to delete the character to the right of the text cursor. 

Deleting Several Characters at a Time 

Select the text to delete. Note: If the grid is in View mode and you want to delete the entire contents of a 

cell, you do not need to select the text as all text in the cell is selected automatically. 

Delete the text in one of the following ways: 

 Click the  toolbar icon. 

 Choose Edit>Delete. 

 Press Del. 

 Right-click on the desired cell and choose Delete from the popup menu. 

Deleting a Word at a Time 

With the grid in Edit mode, do either of the following: 

 Press Ctrl+Backspace to delete one word backward. 

 Press Ctrl+Del to delete one word forward. 

Deleting Records 

Select the record(s) to be deleted. 

Delete the selected records in one of the following ways: 

 Click the  toolbar icon. 

 Press Del. 

 Choose Edit>Delete. 

 Right-click anywhere on the grid and choose Delete from the popup menu. 

See also: Copy; Cut; Paste 



36    SKY Index 7.0 User’s Guide 

Undo/Redo 

Undo allows you to reverse changes that you’ve made to your index. In general, to reverse a change, you 

will choose Edit>Undo (Ctrl+Z) to perform the reversal. The one exception to this is when you are editing 

text within a cell of the Data Entry grid or within one of the textboxes of Edit View. If you edit text 

within these textboxes, you can undo your edits by pressing Esc (Escape). This will reverse all edits to 

that textbox as if you had never made any changes. 

Pressing the Escape key applies only to the current textbox (or grid cell). If you move to a different cell, 

you can still undo the changes in the previous cell by pressing Tab or Shift+Tab to move to the desired 

cell and then press Esc. Once you move to a different record, you can undo changes to the record by 

pressing Ctrl+Z or choosing Edit>Undo. 

If you should perform more Undo operations that you had intended to, you can Redo editing that you’ve 

performed by choosing Edit>Redo or by pressing Ctrl+Y. 
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Chapter 

8 
Editing Commands 

Overview 

Core Editing Commands 

There are 9 ‘core’ editing commands in SKY Index. These core commands are assigned a single function 

key as a keyboard shortcut. The core editing commands are: 

 

Command Shortcut 

Swap F4 

Promote F5 

Demote F6 

Combine F7 

Select Heading F8 (Data Entry View Only)  

Select Entry F9 (Data Entry View Only) 

Shift Left to Main F10 

Shift Left F11 

Shift Right F12 

 

The commands are described in detail below with an example of how each command changes your index. 

All nine of these commands allow you to add two modifiers that enhance the command’s action. The 

modifiers are: 

Ctrl – Instructs SKY Index to duplicate the record or records you wish to edit before editing them. 

This leaves an unaltered copy of the original index entries behind. 

Ctrl+Shift – With this modifier, SKY Index will duplicate the records, but in addition, will create a 

group out of the duplicated and edited records when the edit is finished. This allows you to 

manipulate those records further without worrying about affecting the rest of the index. 
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Edit View and Data Entry View 

SKY Index has two “views” for editing your index. Edit View and Data Entry View. All of the above core 

commands work in both editing views with the exception of Select Heading and Select Entry. Use of the 

commands is very similar for both editing views, but we have included explicit instructions for use of the 

commands in each editing view. In order to make it easy for you to narrow in on the instructions you are 

looking for, the Edit View instructions have been highlighted in orange type and Data Entry View 

instructions are in blue type. Of course, the colors of these instructions are only visible if you are reading 

these instructions from the online help or from a downloaded manual (which is in color). The printed 

manual is in black and white and cannot highlight the instructions for these two editing views. 

For more information about Edit View and Data Entry View, see Understanding SKY Index View Modes 

and Text Editing Modes earlier in this manual. 

Copy Heading 

The Copy Heading command copies the current heading and all of its child headings and places them 

into an internal buffer. The copied heading can then be pasted as a subheading into any other heading in 

the index with the Paste Heading command. 

Example 

Assume you have the following entries: 

indexing  
 software 
  back-of-book 
  embedded 
  HTML 

If you place the marquee over software and perform the Copy Heading command, the heading software 

and all of its child headings will be placed into the heading paste buffer. This heading can then be pasted 

into any other entry in the index using the Paste Heading command. 

To Copy a Heading in Edit View 

1. Put the marquee over the entry that you wish to copy. 

2. Choose Edit>Copy Heading 

To Copy a Heading in Data Entry View 

1. Place the marquee over the heading that you wish to copy in the Preview Pane. (Important: Do 

not use the grid to select your heading. You must use the Preview Pane. You may need to hold 

down Alt+Ctrl and press UpArrow or DownArrow to highlight the appropriate heading in the 

Preview Pane prior to using this function.) 

2. Choose Edit>Copy Heading. 

Keyboard Shortcut: Ctrl+Shift+C 

See also: Cut Heading; Delete Heading; Paste Heading 
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Copy Locators 

The Copy Locators command collects all locators (excluding cross-references) for the current index 

heading and places them into an internal buffer. These locators can then be pasted into any other entry 

with the Paste Locators command. 

Example 

Assume you have the following entry: 

indexing software, 12, 33, 45 

If you perform the Copy Locators command, the locators 12, 33, and 45 will be placed into the locator 

paste buffer. These locators can then be pasted into any other entry in the index using the Paste 

Locators command. 

Note: This command is heading based. That means if you put the grid marquee over a main heading, it 

will collect all locators for every entry under that main heading. In other words it will include the 

subheadings. If you put the grid marquee over a subheading, it will collect only the locators for that 

subheading (and any sub-subheading, if they exist). 

To Copy Locators in Edit View 

1. Put the marquee over the entry that you wish to collect the locators from. 

2. Choose Utilities>Copy Locators. 

To Copy Locators in Data Entry View 

1. Place the marquee over the grid cell of the entry that you wish to collect all locators for. 

2. Choose Utilities>Copy Locators. 

Keyboard Shortcut: Alt+Ctrl+C 

See also: Paste Locators 

Combine 

The Combine function allows you to combine a subheading with its parent heading separating the two 

with a space. This is identical to the Promote command except that the Promote command uses both a 

comma and a space when combining the child and parent headings. 

If you place the text cursor in the middle of a phrase, the text before the cursor will be removed from the 

current heading level and will be added, following a space, to the parent heading level. The text after the 

cursor will remain. If an entire subheading is combined, any child headings below it are promoted by one 

level. 

Example 

If you have the following structure: 

print 
 command 
 settings 
 preview 
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If you place the marquee over ‘command’ and execute the Combine command, you will get: 

print 
 settings 
 preview 
print command 

To Combine in Edit View 

1. Place the marquee over the heading you wish to combine with its parent heading. 

2. Choose Edit>Combine.  

To Combine in Data Entry View 

Combining a Single Subheading 

1. Place the marquee over the grid cell to combine. 

2. Choose Edit>Combine.  

Combining the Subheadings of Several Index Entries 

1. Select the records that contain the subheadings to combine. 

2. Choose Edit>Combine. (A Select Field dialog will be displayed.) 

3. Select the appropriate subheading level. 

4. Click OK. 

Keyboard Shortcut: F7 

Modifiers:  Ctrl: Duplicates the selected records prior to combining. 

Ctrl+Shift: Duplicates the selected records, performs the combine and then groups on 

the combined records. 

See also: Demote, Promote, Swap 

Consume Subheadings 

There may be times while editing your index when you find that you have a main heading with just a 

few subheadings and you decide that you want to eliminate all of the subheadings but keep their locators 

and move them to the main heading. That is what Consume Subheadings does. 

Example 

Let’s say you have the following entries: 

bicycles 
 buying, 14 
 maintenance, 13 
 repairs, 22 

If you perform the Consume Subheadings command on the main heading bicycles, you will end up with 

this entry in your index: 

bicycles, 13, 14, 22 
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To Consume Subheadings in Edit View 

1. Place the marquee over the main heading (or subheading) for which you wish to consume all the 

subheadings. 

2. Choose Utilities>Consume Subheadings 

To Consume Subheadings in Data Entry View 

1. Place the marquee over the main heading (or subheading) for which you wish to consume all the 

subheadings. 

2. Choose Utilities>Consume Subheadings 

Keyboard Shortcut: Alt+Ctrl+K 

See also: New Child Heading, Take Selected Locator 

Convert Cross-reference 

The Convert Cross-reference function will convert a cross-reference into fully qualified index entries. For 

example, you may have the following entries in your index: 

automobiles. see cars 

cars 

 body styles 

 general maintenance 

 safety features 

 seating capacity 

The cross-reference saves duplication of information in the index thus saving space, but it also forces the 

reader to spend more time finding the desired information. If you find that the space allocated for the 

index is sufficient, you can convert the cross-reference into fully specified entries using the Convert 

Cross-reference command as shown below : 

automobiles 

 body styles 

 general maintenance 

 safety features 

 seating capacity 

To Convert a Cross-reference in Edit View 

1. Place the marquee over the heading containing the cross-reference. 

2. Choose Utilities>Convert Cross-reference 

To Convert a Cross-reference in Data Entry View 

1. Place the grid marquee over any field of the record containing the cross-reference. 

2. Choose Utilities>Convert Cross-reference. 

Keyboard Shortcut: Alt+Ctrl+X 

See also: Create Reciprocal Cross-reference 
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Create Reciprocal Cross-reference 

Creates a main heading from the target of a cross-reference. The new entry will also contain a cross-

reference. The target of that cross-reference will be the main heading of the original entry. You would 

use this command if you have two separate headings in your index which reference related material that 

the reader might also want to know about. 

Example 

Given this entry: 

"American Society for Indexing. see also Indexing Societies" 

This command will create a new entry like this: 

"Indexing Societies. see also American Society for Indexing." 

To Create a Reciprocal Cross-reference in Data Entry View 

1. Place the marquee over the main heading of the index entry containing the cross-reference that 

you for which you wish to create a reciprocal cross-reference. 

2. Choose Utilities>Create Reciprocal Cross-reference. 

Keyboard Shortcut: Alt+Ctrl+D 

See also: Convert Cross-reference 

Create Subheadings from Locators 

This command creates new child headings from the locators of the current heading. Those locators are 

then removed from the current heading. This command is an aid for those situations where you find that 

you have too many undifferentiated locators from a main (or other) heading. 

Example 

Assume that you have the following entry: 

bicycles, 13, 14, 22 

If you put the marquee over that entry and execute Create Subheadings from Locators, you will now 

have these entries: 

bicycles 
    <New Sub 13>, 13 
    <New Sub 14>, 14 
    <New Sub 22>, 22 

You can then edit the temporary subheading names to differentiate the locators you took from the parent 

heading. When using this command in Edit View and with the in-place editor enabled, the first 

temporary heading will be automatically placed in Edit Mode so that you may simply type the new 

heading name. Once you press Enter to commit the new heading name, you'll be taken directly to the 

next temporary heading and so on. 

To Create Subheadings from the Locators of a Heading in Edit View 

1. Put the marquee over the entry for which you wish to create a new subheading. 

2. Choose Utilities>New Child Heading, Take Selected Locators. 
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To Create Subheadings from the Locators of a Heading Data Entry View 

1. Put the marquee over the grid cell of the entry for which you wish to create a new subheading. 

2. Choose Utilities>Create Subheadings from Locators. 

Note: This command is not available in Data Entry View with Page Ordered sort. 

Keyboard Shortcut: Alt+Ctrl+H 

See also: Consume Subheadings 

Cut Heading 

The Cut Heading command copies the current heading and all of its child headings and places them into 

an internal buffer. It then deletes the heading from the index. The copied heading can then be pasted as 

a subheading into any other heading in the index with the Paste Heading command. 

Example 

Assume you have the following entries: 

indexing  
 software 
  back-of-book 
  embedded 
  HTML 
proofreading 
 technical text 
 an index 

If you place the marquee over software and perform the Cut Heading command, the heading software 

and all of its child headings will be placed into the heading paste buffer and the heading will be deleted 

from the index. The result will appear as shown below: 

indexing  
proofreading 
 technical text 
 an index 

To Cut a Heading in Edit View 

1. Put the marquee over the entry that you wish to cut. 

2. Choose Edit>Cut Heading. 

To Cut a Heading in Data Entry View 

1. Place the marquee over the heading that you wish to cut in the Preview Pane. (Important: Do 

not use the grid to select your heading. You must use the Preview Pane. You may need to hold 

down Alt+Ctrl and press UpArrow or DownArrow to highlight the appropriate heading in the 

Preview Pane prior to using this function. 

2. Choose Edit>Cut Heading. 

Keyboard Shortcut: Ctrl+Shift+X 

See also: Copy Heading; Delete Heading, Paste Heading 
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Delete Heading 

The Delete Heading command deletes the currently highlighted heading and all of it child headings from 

the index. 

Example 

Assume you have the following entries: 

indexing  
 software 
  back-of-book 
  embedded 
  HTML 
proofreading 
 technical text 
 an index 

If you place the marquee over software and perform the Delete Heading command, the heading software 

and all of its child headings will be deleted. The result will appear as shown below: 

indexing  
proofreading 
 technical text 
 an index 

To Delete a Heading in Edit View 

1. Put the marquee over the entry that you wish to delete. 

2. Choose Edit>Delete Heading. 

To Delete a Heading in Data Entry View 

1. Place the marquee over the heading that you wish to delete in the Preview Pane. (Important: 

Do not use the grid to select your heading. You must use the Preview Pane. You may need to 

hold down Alt+Ctrl and press UpArrow or DownArrow to highlight the appropriate heading in 

the Preview Pane prior to using this function.) 

2. Choose Edit>Delete Heading. 

Keyboard Shortcut: Ctrl+Shift+Del 

See also: Copy Heading; Cut Heading; Paste Heading 

Demote 

The Demote function removes any text following the demote separator, which is a comma and a space by 

default, in the currently highlighted heading and shifts that text into the next lower heading after 

placing a demote separator before the existing text in the subheading. Any text before the demote 

separator becomes the current heading. If there is no comma in the heading being demoted, the entire 

heading is moved leaving the current heading empty. 

If you place the text cursor in the middle of a phrase, the text after the cursor will be removed from the 

current heading level and will be added to the child heading. The text that was already in the child 

heading will be appended to the demoted text after a comma and a space. The text before the cursor will 

remain where in the current heading. 
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Note: The demote separator is a comma and a space by default, but can be changed in Program 

Preferences. 

Example 

Assume you have the following index entries entered as main headings: 

Main     Sub1 
Columbus, Christopher 
Newton, Sir Isaac 
Smith, John 

If you place the marquee over ‘Columbus, Christopher’ and execute the Demote command, you will get: 

Main     Sub1 
Columbus    Christopher 
Newton, Sir Isaac 
Smith, John 

Tip: You can demote all three entries at the same time by selecting them first. 

To Demote in Edit View 

1. Place the marquee over the heading you wish to demote 

2. Choose Edit>Demote or click the  toolbar icon. 

To Demote in Data Entry View 

Demoting the Heading of a Single Record 

Method 1 (Entire Heading) 

1. Place the marquee over the grid cell to demote. 

2. Choose Edit>Demote or click the  toolbar icon. 

Note: If the text in the highlighted cell contains a demote separator, only the text following the demote 

separator will be demoted. The demote separator will be removed prior to demoting the text. 

Method 2 (Part of a Heading) 

1. Place the text cursor directly after the text to demote or select the text to demote. 

2. Choose Edit>Demote or click the  toolbar icon. 

Demoting the Headings of Several Records 

1. Select the records that contain headings to demote. 

2. Choose Edit>Demote or click the  toolbar icon. A dialog will be displayed. 

3. Select the heading level that you wish to demote. 

4. Click OK. 

Keyboard Shortcut: F6 

Modifiers:  Ctrl: Duplicates the heading prior to demoting. 

Ctrl+Shift: Duplicates the heading prior to demoting and then groups on the demoted 

heading 
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See also: Combine; Promote; Preferences 

Tip: If you use the Merge Orphan Subheadings function and then change your mind about merging 

them, you can use the demote function to undo all or some of the promoted headings. 

Duplicate 

The duplicate function makes a copy of the current record, or of all selected records, and appends them 

to the end of the index 

To Duplicate in Edit View 

1. Place the marquee over the heading to be duplicated. 

2. Choose Edit>Duplicate. 

To Duplicate in Data Entry View 

Duplicating a Single Record  

1. Place the marquee over any cell of the record to be duplicated. 

2. Choose Edit>Duplicate. 

Duplicating Several Records 

1. Select the records to be duplicated. 

2. Choose Edit>Duplicate. 

Note: After duplicating, the original records are unselected and the new duplicated records are selected. 

This allows you to perform another function on the duplicated records. 

Keyboard Shortcut: Ctrl+D 

See also: Duplicate and Group; Duplicate and Swap 

Duplicate and Group 

The duplicate and group function makes a copy of the current record, or of all selected records, and 

creates a group out of the newly created records. 

To Duplicate and Group in Edit View 

1. Place the marquee over the heading to be duplicated. 

2. Press Ctrl+Shift+D. 

To Duplicate and Group in Data Entry View 

Duplicating a Single Record  

1. Place the marquee over any cell of the record to be duplicated. 

2. Press Ctrl+Shift+D. 
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Duplicating Several Records 

1. Select the records to be duplicated. 

2. Press Ctrl+Shift+D. 

Note: After duplicating, the original records are unselected and the new duplicated records are selected. 

This allows you to perform another function on the duplicated records. 

Keyboard Shortcut: Ctrl+Shift+D 

See also: Duplicate and Swap; Duplicate 

Duplicate and Swap 

To perform a duplicate and swap, add the Ctrl modifier key to the Swap command which would be: 

Ctrl+F4. If you wish to specifically swap Main and Sub1 regardless of where the grid marquee is, you 

can use the keyboard shortcut: Ctrl+F1 

For more information on swapping headings, see Swap later in this chapter. 

Duplicate, Swap and Combine 

The Duplicate, Swap and Combine command will duplicate one or more records, swap the contents of 

any two headings and then combine the child heading with its parent heading separating the two with a 

space. 

Example 

If you have the following index entries 

 

 Main Sub1 Page 

 Washington George 22 

 Jefferson Thomas 22 

 Franklin Benjamin 23 

And you select all those records and perform the Duplicate, Swap and Combine function, you will have: 

 

 Main Sub1 Page 

 Washington George 22 

 Jefferson Thomas 22 

 Franklin Benjamin 23 

 George Washington  22 

 Thomas Jefferson  22 

 Benjamin Franklin  23 
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To Duplicate, Swap and Combine a Single Record 

In Edit View 

1. Place the marquee over the heading to be swapped and combined. 

2. Press Ctrl+F2. 

In Data Entry View 

1. Place the marquee over the cell of the heading level to be swapped and combined. 

2. Press Ctrl+F2. 

To Duplicate, and Swap and Combine Selected Records (Data Entry View Only) 

In Data Entry View 

1. Select the records to be duplicated, swapped and combined. 

2. Press Ctrl+F2. 

Note: After duplicating, the original records are unselected and the new duplicated and combined 

records are selected. This allows you to perform another function on those records. 

See also: Combine; Promote; Duplicate 

Keyboard Shortcut: Ctrl+F2 

Half Swap 

Some of you may be familiar with the term “Half Swap” or “Half Flip” from the use of another indexing 

program. In SKY Index, the same effect is achieved with Shift Left. Please see Shift Left, later in this 

chapter, for more information. 

Paste Heading 

The Paste heading command will paste headings that have been copied using the Copy Heading 

command as a subheading of any other heading in the index. 

Example 

Assume you have the following entries: 

computer 
 hardware 
  installing 
  repairing 
indexing  
 software 
  back-of-book 
  embedded 
  HTML 

If you place the marquee over software and perform the Copy Heading command, the heading software 

and all of its child headings will be placed into the heading paste buffer. If you now place the marquee 

over computer and perform the Paste Heading command, you will have this: 
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computer 
 hardware 
  installing 
  repairing 
 software 
  back-of-book 
  embedded 
  HTML 
indexing  
 software 
  back-of-book 
  embedded 
  HTML 

To Paste a Heading in Edit View 

1. Put the marquee over the entry that you wish to paste the contents of the heading paste buffer 

into as a subheading. 

2. Choose Edit>Paste Heading. 

To Paste a Heading in Data Entry View 

1. Place the marquee over the heading that you wish to paste the contents of the paste buffer into 

as a subheading. (Important: Do not use the grid to select your heading. You must use the 

Preview Pane. You may need to hold down Alt+Ctrl and press UpArrow or DownArrow to 

highlight the appropriate heading in the Preview Pane prior to using this function.) 

2. Choose Edit>Paste Heading. 

Keyboard Shortcut: Ctrl+Shift+V 

See also: Copy Heading; Delete Heading; Cut Heading 

Paste Locators 

The Paste Locators command will add all locators in the Page buffer (created using the Copy Locators 

command) to the current index entry. 

Example 

Let’s assume that you have previously collected this series of locators using the Copy Locators command: 

“5, 21, 44, 91”. Let’s also assume that you have this existing heading in your index: 

software, 37, 114 

If you place the grid marquee over the main heading ‘software’ and press Alt+Ctrl+V to paste those 

locators, the software heading will now appear like this: 

software, 5, 21, 37, 44, 91, 114 

To Paste Locators in Edit View 

1. Place the grid marquee over the grid cell of the appropriate heading level of the entry that you 

wish to paste locators into. 

2. Choose Utilities>Paste Locators. 
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To Paste Locators in Data Entry View 

1. In the Preview Pane, highlight the appropriate heading of the entry that you wish to paste 

locators into. (Please note that in Data Entry View, you may have to use the 

Alt+Ctrl+UpArrow/DownArrow keyboard shortcuts to move the highlight in the Preview Pane 

over the desired heading. You must use the Preview Pane as your point of reference.) 

2. Choose Utilities>Paste Locators. 

Keyboard Shortcut: Alt+Ctrl+V 

See also: Copy Locators 

Promote 

The Promote function allows you to combine a subheading with its parent heading following a promote 

separator. The promote separator is a comma and a space by default, but can be changed in Program 

Preferences. 

If you place the text cursor in the middle of a phrase, the text before the cursor will be removed from the 

current heading level and will be added, following a promote separator, to the parent heading level. The 

text after the cursor will remain. If an entire subheading is promoted, any child headings below it are 

promoted by one level. 

 

Example 

Assume you have the following index entries entered as main heading plus subheading: 

 

Main Sub1 

Columbus Christopher 

Newton Sir Isaac 

Smith John 

 

If you place the marquee over ‘Christopher’ and execute the Promote command, you will get: 

 

Main Sub1 

Columbus, Christopher  

Newton Sir Isaac 

Smith John 

 

Tip: You can promote all three entries at the same time by selecting them first. 

To Promote in Edit View 

1. Place the marquee over the heading you wish to promote 

2. Choose Edit>Promote or click the  toolbar icon. 
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To Promote in Data Entry View 

Promoting a Single Subheading 

Method 1 (Entire Subheading) 

1. Place the marquee over the grid cell to promote. 

2. Choose Edit>Promote or click the  toolbar icon. 

Note: If the subheading in the highlighted cell contains a promote separator, only the text before the 

separator will be promoted. In this case, the separator will be removed prior to promoting the text. 

Method 2 (Part of a Subheading) 

1. Place the text cursor directly after the text to be promoted or select the text to be promoted. 

2. Choose Edit>Promote or click the  toolbar icon. 

Note: Only the text before the cursor or the selected text will be promoted. Text after the cursor or 

text that was not selected will remain. 

Note: If there is a comma and a space in the text and you place the cursor directly before, after, or in 

the middle of the comma and space, the text before the comma will be promoted, the comma and 

space will be removed, and the text after the space will remain. 

Promoting the Subheadings of Several Index Entries 

1. Select the records that contain the subheadings to promote. 

2. Choose Edit>Promote or click the  toolbar icon. A dialog will be displayed. 

3. Select the subheading level that you wish to promote. 

4. Click OK. 

Note: When the grid is in View mode, Backspace can be used to promote the contents of the 

currently highlighted cell. 

Keyboard Shortcut: F5 

Modifiers:  Ctrl: Duplicates the heading prior to promoting. 

Ctrl+Shift: Duplicates the heading prior to promoting and then groups on the promoted 

heading 

See also: Demote; Preferences (Data Entry) 

Select Entry (Data Entry View Only) 

The Select Entry command will select the current record plus all other records that are identical in all 

heading levels thereby collecting all page references for the current entry. 

To select an entry choose Edit>Select Entry 

Keyboard Shortcut: F9 

Modifiers:  Ctrl: Duplicates the selected entry 

Ctrl+Shift: Duplicates the selected entry and then creates a group from it. 

See also: Select Heading; Finding Locators for the Current Entry 



52    SKY Index 7.0 User’s Guide 

Select Heading (Data Entry View Only) 

The Select Heading command will select all records where the level of the grid's marquee plus all parent 

levels match. For example, if the grid marquee is over a main heading, all records that have the same 

main heading will be selected. If the grid marquee is over the Sub1 heading, then all records that match 

both the Main and Sub1 headings will be selected. 

This feature can be very useful when you want to duplicate the structure of a set of index entries to 

create a new set of entries. 

To Select Heading 

1. Place the grid marquee over the cell of the heading to be selected. 

2. Choose Edit>Select Heading. 

Keyboard Shortcut: F8 

Modifiers:  Ctrl: Duplicates the selected heading. 

Ctrl+Shift: Duplicates the selected heading and then creates a group from it. 

See also: Select Entry 

Tip: Using Select Heading with the modifiers to duplicate and group will allow you to duplicate the 

structure of one set of entries and so that you have the same structure with a different main 

heading. 

Example: Assume you have the following set of entries (ignoring locators): 

bicycles 
 buying 
 maintenance 
 repairs 

and you want to create the following entries: 

cars 
 buying 
 maintenance 
 repairs 

 

Simply put the grid marquee over the main heading of any record that has the main heading 'bicycles' 

and press Ctrl+Shift+F8 (this will select all entries with the main heading ‘bicycles’, duplicate them, and 

then group them. Now change any of the main headings to 'cars' and press Alt+Ctrl+Enter to propagate 

the edit through the entire group. 

Shift Left 

The Shift Left function allows you to shift entries in one or more records to the left by one cell in Data 

Entry View and moves a subheading up one level in Edit View replacing its parent heading. The result is 

the same in either editing view. You can use this feature to create headings from subheadings, but you 

can also create subheadings from sub-subheadings and so on. 
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Example 

Shift Left (also known as Half Swap or Half Flip) allows you to move a subheading and all of its children 

up one level. The contents of the higher (parent) field are discarded. For example, assume you have the 

following index entries: 

indexing  
 software 
  back-of-book 
  embedded 
  HTML 

If you place the marquee over software and execute the Shift Left command, you will now have these 

entries: 

software 
 back-of-book 
 embedded 
 HTML 

To Shift Left in Edit View 

1. Place the marquee over the subheading you wish to shift left. 

2. Choose Edit>Shift Left or click the  toolbar icon. 

To Shift Left in Data Entry View 

Shifting a Single Entry 

1. Place the marquee over any cell in the record to shift left. 

2. Choose Edit>Shift Left or click the  toolbar icon. 

Shifting Several Entries 

1. Select the records to shift left. 

2. Choose Edit>Shift Left or click the  toolbar icon. A Select Field dialog will appear. 

3. Choose the lowest field to shift left. 

4. Click OK. 

Keyboard Shortcut: F11 

Modifiers:  Ctrl: Duplicates the selected records prior to shifting left. 

Ctrl+Shift: Duplicates the selected records, performs the shift left and then groups the 

edited records. 

See also: Shift Right; Shift Left to Main 

Shift Left to Main 

Shift Left to Main is the same as the Shift Left function, but always shifts left all the way to a Main 

heading whereas the Shift Left function always shifts left a single level at a time. 
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Example 

Shift Left to Main allows you to move a subheading and all of its children up to the Main heading level. 

The contents of the higher level headings are discarded. For example, assume you have the following 

index entries: 

education 
 indexing  
  software 
   back-of-book 
   embedded 
   HTML 

If you place the marquee over software and execute the Shift Left to Main command, you will now have 

these entries: 

software 
 back-of-book 
 embedded 
 HTML 

To Shift Left to Main in Edit View 

1. Place the marquee over the subheading you wish to shift left to main. 

2. Choose Edit>Shift Left to Main. 

To Shift Left to Main in Data Entry View 

Shifting a Single Entry 

1. Place the marquee over the heading level that you wish to shift left into the Main heading field. 

2. Choose Edit>Shift Left to Main. 

Shifting Several Entries 

1. Select the records to shift. 

2. Choose Edit>Shift Left to Main. A Select Field dialog will appear. 

3. Choose the desired heading level. 

4. Click OK. 

Keyboard Shortcut: F10 

Modifiers:  Ctrl: Duplicates the selected records prior to shifting left to main. 

Ctrl+Shift: Duplicates the selected records, performs the shift left to main and then 

groups on the edited records. 

See also: Shift Left; Shift Right 

Notes: When shifting left to Main, SKY Index uses the SmartSwap list to intelligently alter the contents 

of the current subheading before it becomes a main heading. See Data Entry Options, Smart Swap 

for more information. 
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Shift Right 

The Shift Right function allows you to shift entries in one or more records to the right by one cell, but 

you can also create Sub1 headings from Sub2 headings and Sub2 headings from Sub3 headings. 

Example 

Shift Right allows you to move a subheading and all of its children down one level. This leaves an empty 

parent heading which you can then edit as desired. For example, assume you have the following index 

entries: 

indexing 
 back-of-book 
 embedded 
 HTML 

If you place the marquee over back-of-book and execute the Shift Right command, you will now have 

these entries: 

indexing  
 < Edit Me > 
  back-of-book 
 embedded 
 HTML 

You can then edit the now empty Sub1 heading to be software to get: 

indexing  
 software 
  back-of-book 
 embedded 
 HTML 

Tip: If you select all three subheadings before performing the Shift Right, you can add the parent 

heading software to all of them with one command. 

To Shift Right in Edit View 

1. Place the marquee over the heading that you wish to shift right. 

2. Choose Edit>Shift Right or click the  toolbar icon. 

To Shift Right in Data Entry View 

Shifting a Single Entry 

1. Place the marquee over any cell in the record to shift right. 

2. Choose Edit>Shift Right or click the  toolbar icon. 

Shifting Several Entries 

1. Select the records to shift right. 

2. Choose Edit>Shift Right or click the  toolbar icon. A Select Field dialog will appear. 

3. Choose the highest field to shift right. 

4. Click OK. 
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Keyboard Shortcut: F12 

Modifiers:  Ctrl: Duplicates the selected records prior to shifting right. 

Ctrl+Shift: Duplicates the selected records, performs the shift right and then groups on 

the edited records. 

See also: Shift Left; Shift Left to Main 

Split 

The split command splits an index entry into two index entries based upon a split separator. 

How the split command works: 

It will remove any text after the user configurable Split Separator (also getting rid of the separator) and 

create a new record in the index using that text. 

If you explicitly place the cursor in the text, the text will be split at the cursor location. The text after the 

cursor will be removed and placed in a new index record. The text before the cursor will remain in the 

original record. 

You can configure a 'Split Count'. If you set the count to a number greater than one, the split command 

will count backwards to find the appropriate place to split the text into two records. This means that if 

the count is set to two, and you have the entry "Schreiner, K., Wilson, L., Yantis, N.". Each execution of 

the command will split a whole name (the surname and initial will not be separated from each other). 

Note: The split separator is a comma and a space by default and the split count is one by default. They 

can both be changed in program Preferences. 

Example 

Assume you have the following index entry entered as a main heading and that you have the Split Count 

set to two (2): 

Main     Sub1 
Columbus, C., Smith, J., Wilson, L. 

If you place the marquee over this main heading and execute the Split command, you will get: 

Main     Sub1 

Columbus, C., Smith, J.  
Wilson, L. 

If you execute the Split command again, you will get: 

Main     Sub1 
Columbus, C. 
Smith, J. 
Wilson, L. 

To Split in Edit View 

1. Place the marquee over the heading you wish to split 

2. Choose Utilities>Split. 
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To Split in Data Entry View 

Splitting a Single Record 

Method 1 (Automatic) 

1. Place the marquee over the grid cell to split. 

2. Choose Utilities>Split. 

Note: If the text in the highlighted cell contains a split separator, only the text following the split 

separator will be removed from the heading and a new index record that includes the text after that 

separator will be created. If no split separator exists, no changes will be made to the current record and 

a duplicate record will be created. 

Method 2 (User Specified) 

1. Place the text cursor directly after the text to demote or select the text to demote. 

2. Choose Utilities>Split. 

Splitting Several Records 

1. Select the records that contain headings to split. 

2. Choose Utilities>Split. A dialog will be displayed. 

3. Select the heading level that you wish to split. 

4. Click OK. 

Note: There will be one new record added to the index for each selected record. The records will remain 

selected so you can perform the operation again. 

Keyboard Shortcut: Alt+Ctrl+P 

See also: Split Separator 

Swap 

This is simply the swapping of two heading levels. This is frequently done in order to double post an 

entry. 

Example 

Swapping allows you to swap the contents of Main and Sub1, Sub1 and Sub2 and so on. For example, if 

you have the following entry: 

1812, war of, 74 

You can swap the Main and Sub1 headings to create the entry below: 

war, of 1812, 74 (Notice the intelligent swap of the preposition) 

Swap in Edit View 

1. Place the marquee over the subheading to be swapped with the parent heading. 

2. Choose Edit>Swap. 
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Swap in Data Entry View 

Swapping Headings in a Single Record 

1. Place the marquee over any cell in the row to swap headings. 

2. Choose Edit>Swap. 

Swapping Headings in Several Records 

1. Select the records in which you wish to swap headings. 

2. Choose Edit>Swap.  

Swap using Drag and Drop 

You can swap headings using drag and drop by using the mouse to drag a heading from one cell to 

another. If the two cells are in the same row, the headings will be swapped. If the two cells are in 

different rows, the heading being dragged will replace the contents of the cell where it is dropped. 

Keyboard Shortcut: F4 

Modifiers:  Ctrl: Duplicates the selected records prior to swapping. 

Ctrl+Shift: Duplicates the selected records, performs the swap and then groups on the 

swapped records. 

See also: Combine, Demote, Promote 

Notes: When swapping, SKY Index uses the SmartSwap list to intelligently swap the contents of the two 

fields. See Data Entry Options, Smart Swap for more information. 

Tip: You will usually want to use this command in conjunction with duplicating.  

Swap Acronym 

The swap acronym command will swap the text in an entry that has parentheses such that the text that 

is outside the parentheses will be swapped with the text that is within the parentheses. 

Example 

If you have this entry: 

Customer Management System (CMS) 

If you execute the Swap Acronym command you will get: 

CMS (Customer Management System) 

To Swap Acronym in Edit View 

1. Place the marquee over the heading containing the text for which you wish to swap the acronym. 

2. Choose Utilities>Swap Acronym 

To Swap Acronym in Data Entry View 

1. Place the grid marquee over the heading containing the text for which you wish to swap the 

acronym. 

2. Choose Utilities>Swap Acronym 
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Tip: If you want to use this command on all entries in your index that contain main headings with 

acronyms, create a group that contains all entries of those entries, select the entire group, Duplicate 

and group those entries (Ctrl+Shift+D) and then use the Swap Acronym Command. 

Keyboard Shortcut: Alt+Ctrl+S 

See also:  

Toggle See, See also 

This command changes a ‘see’ cross-reference to a ‘see also’ cross-reference or vice versa. 

Example 

If you have the following cross-reference: 

see also indexing software 

If execute the Toggle See, See also command on the cross-reference you will have: 

see indexing software 

To Toggle see/see also in Edit View 

1. Place the marquee over the heading containing the text for which you wish to toggle see or see 

also. 

2. Choose Utilities>Toggle See, See also 

To Toggle see/see also in Data Entry View 

1. Place the grid marquee over the heading containing the text for which you wish to toggle the see 

or see also. 

2. Choose Utilities>Toggle See, See also 

Keyboard Shortcut: Alt+Ctrl+T 

See also: Create Reciprocal Cross-reference 





 Other Editing Commands 61 

Chapter 

9 
Other Editing Commands 

Overview 

Below are some editing commands that are not found in the Edit or Utilities menus, but that are none-

the-less very useful in the right situations. Many of these commands are available through their 

keyboard shortcuts only. 

Duplicate Records and Change Locator (Data Entry View Only) 

There may be times during data entry when you have entered a set of entries for a particular page and 

know in advance that those same entries will also be applicable to another page. You can easily 

duplicate all of those entries and change the locator in one step using this command. 

For example, if you have the following entries: 

 

 Main Sub1 Page 

 commands cut 5 

 commands delete 5 

 commands paste 5 

 commands copy 5 

And you know that these same entries will be made on page 32. You can duplicate all of those records 

and change the duplicated record’s locator with the Duplicate Records and Change Locator command so 

that you have this: 

 

 Main Sub1 Page 

 commands cut 5 

 commands delete 5 

 commands paste 5 

 commands copy 5 

 commands cut 32 

 commands delete 32 

 commands paste 32 

 commands copy 32 

To Duplicate Records and Change Locator 

1. Select the records to be duplicated. (see Selecting Records to learn how to select records) 

2. Press ‘,’ (comma) – a dialog will appear asking you to enter the new locator. 

3. Enter the new locator and press OK. 
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The selected records will be duplicated and the new locator will be assigned to all of the duplicated 

records. 

1. Place the marquee over the cell of the heading level to be swapped and combined. 

2. Press Ctrl+F2. 

Locator Increment or Decrement (Data Entry View Only) 

Sometimes, during data entry, you will encounter situations where you will want to increment or 

decrement the locator. These commands allow you to do just that. Please note that these commands only 

work in Data Entry View. 

Example 1 

By default, SKY Index will repeat the current locator automatically when you start a new record. There 

are two common situations you’ll encounter while doing your data entry. First, you may simply get to the 

point of needing to increment the current page by one. For example, let’s say you have completed an 

entry from page 1, the grid marquee is now in the Append Row of the grid as shown below and you want 

to enter the main and subheading “clients, building a good relationship with” on page 2: 

 

 Main Sub1 Page 

 indexing back-of-book 1 

*   1 

To do this, you would type the main and subheadings and then press Tab or Enter so that the marquee 

is over the Page field as shown below: 

 

 Main Sub1 Page 

 indexing back-of-book 1 

 clients building a good relationship with 1 

*    

Before incrementing 

Then you would press either the plus key (+) on the keypad or Ctrl+. (Control+Period) to increment page 

1 to page 2. Note: Although the marquee does not have to be over the Page field, the marquee must be 

visible for this command to work. This means you cannot be in Text Edit Mode. 

 

 Main Sub1 Page 

 indexing back-of-book 1 

 clients building a good relationship with 2 

*    

After incrementing 

Example 2 

Let’s assume that you have completed the entry below from page 1, and when you flip the page, you 

realize that this topic continues on page 2. In this case you want to create a page range of 1-2. 

 

 Main Sub1 Page 

 indexing back-of-book 1 

*    
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To do this, you press Alt+. (Alt+Period) which will create a page range with the second number one 

higher than the existing number: 

 

 Main Sub1 Page 

 indexing back-of-book 1-2 

*    

Incrementing or Decrementing Locators 

The following must be true for this feature to work 

 You must be in Data Entry View 

 The grid must be in View Mode (the marquee must be visible) 

 

Command Keystroke 

Increment left number Ctrl+. (period) or Keypad + (plus) 

Decrement left number Ctrl+, (comma) or Keypad – 

(minus) 

Increment right number Alt+. (period) 

Decrement right number Alt+, (comma) 

Notes: 

 It may make it easier to remember these commands if you note that the characters above the 

comma and period keys are ‘<’ and ‘>’. 

 Any time a decrement or increment would result in both the left and right numbers being equal, 

the range is deleted. 

 Anytime you use an 'Alt' command on a locator that does not have a range, a range is created. 

 These functions will work on both Arabic numbers and Roman Numerals 

 These functions will also work on multiple selected records. 

Viewing the Target of a Cross-reference 

While editing your index, you may wish to view the target of a cross-reference you have entered. You can 

view the target in a mini preview pane by Ctrl+Clicking on the cross-reference. To close the mini preview 

pane, press Esc, move to a different record in the data entry grid, or click the close button in the mini 

preview pane. 

Propagate Edits (Data Entry View Only) 

The Propagate Edits command is used when you are working with the index in Data Entry View. If you 

change the text of a heading – for example a main heading – you can make that change occur in all other 

matching main headings using the Propagate Edits command. This command also works on subheadings 

or sub-subheadings. 

For example, if you have the following entries: 

 

 Main Sub1 Sub2 Page 

 commands edit cut 1 

 commands edit delete 4 

 commands edit paste 3 

*     
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And you change "edit" to "editing" in the first record and then press Alt+Ctrl+Enter you will then have: 

 

 Main Sub1 Sub2 Page 

 commands editing cut 1 

 commands editing delete 4 

 commands editing paste 3 

*     

To Propagate Your Edits 

After changing the text (and while still in Text Edit Mode), press Alt+Ctrl+Enter 

Notes:  

 You must be in Text Edit Mode to propagate an edit. 

 You cannot propagate an edit once you’ve exited Text Edit Mode. 

 Edit View performs propagation automatically and it is one of the advantages of working in Edit 

View while performing your final editing. 
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Chapter 

10 
Generating Your Index and Other Index Operations 

Generating Your Index 

The purpose of using SKY Index is to create a sorted and formatted index. The generate index function 

will create a sorted and formatted index and store the index on your hard drive. 

Generating an Index 

To generate an index choose Index>Generate or click the  toolbar icon. The index will be generated 

using the index style specified in the Index Options dialog and using the document attributes specified in 

the Document Options dialog. After the index is generated you may wish to view or edit the index using 

the View/Edit/Print function available by choosing Index>Edit/Print. 

Tip: The index will be generated using only the records that are currently available in the data entry 

grid. This can be very useful. For instance, if you want to generate an index of only those entries that 

have pages in volume two of a five volume set, create a group that contains only those records by using 

the Group by Volume/Chapter function prior to generating the index. This can be extended to any other 

kind of group including those created using the Find function. 

Note: It is important to configure your index prior to generating it. You should examine and adjust these 

option dialog boxes before generating your index: 

 Index Options 

 Document Options 

Editing or Printing Your Formatted Index 

The purpose of an indexing program is to create a formatted index that your client/publisher will be able 

to use. Although you can generate a number of different file formats with SKY Index, you will most 

likely want to see what the final index will look like before you send it to the publisher. Further, if you 

are the publisher, you will want to import your index into your word processor for final edits and 

ultimately for printing. The Edit/Print function will invoke your word processor and will cause your word 

processor to load your index. 

Printing Your Index 

To print your index choose Index>Edit/Print or click the  toolbar icon. This will invoke your word 

processor and cause it to load your index. After the index has been loaded in your word processor, you 

can then edit the index or print it using your word processor. 

Note: When you use the Edit/Print function, if your index has been modified since the last time it was 

generated, SKY index will regenerate the index prior to invoking your word processor. 
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Resorting Your Index 

If you believe your index is not sorted correctly, it may be that one or more the index’s sort keys have 

become corrupted. You can fix these keys by resorting the index. 

Resorting an Index 

To resort an index, choose Index>Resort or click the  toolbar button. 

Tip: You can see the currently configured sort method displayed at the bottom right of the program 

screen in the status bar. If you right click on that status area, the Index Options dialog will appear and 

you can change the sort method. 

Subheading Levels 

Allows you to specify how many subheading levels the index will contain. When you change the number 

of subheading levels, the index must be resorted and SKY Index will do this automatically. If you reduce 

the number of subheadings, any entries that have entered text in heading levels lower than what you 

have specified will not appear in the Preview Pane and will be ignored when you generate the index. 

They will not, however, be deleted. You can later change the number of subheadings to a higher number 

and the hidden entries will reappear. 

To change the number of subheading levels, choose Index>Subheading Levels and then the number of 

desired subheading levels. 

Note: This selection is identical to the one you can make in the Index Options dialog. 
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Chapter 

11 
Index Views 

As Entered View 

When you create a new index, it is displayed in As Entered view. In this view, the index records are 

displayed in the order that they were entered. This view is often similar to, but not identical to, Page 

Ordered view. 

To view the index in As Entered order, choose View>As Entered. 

Keyboard Shortcut: Shift+F5 

See also: Filtered View; Grouped View; Page Ordered View; Sorted View  

Grouped View 

The Grouped view will display all records in your index that have a specified main heading. 

Creating a Group 

To create a group, do the following: 

1. Place the marquee over any cell of a record containing the main heading to use for the group. 

2. Create the group in one of these ways: 

3. Choose View>Group. 

4. Click the  toolbar icon. 

5. Right-click on the selected record and choose Group from the popup menu. 

To return to a non-grouped view of your index, choose another view. 

Keyboard Shortcut: Shift+F6 

See also: As Entered View; Page Ordered View; Sorted View; Filtered View 

Grouping Selected Records 

You can create a group of selected records by selecting the desired records prior to choosing 

View>Grouped. 
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Example 

Assume you have the following index entries: 

 

 Main Sub1 Page 

 indexing back-of-book 21 

 indexing web 106 

 indexing html 42 

 indexing embedded 83 

If you select the first two records as shown below: 

 

 Main Sub1 Page 

 indexing back-of-book 21 

 indexing web 106 

 indexing html 42 

 indexing embedded 83 

 

And now you press Shift+F6 to group on those records, you will see this:  
 

 Main Sub1 Page 

 indexing back-of-book 21 

 indexing web 106 

Page Ordered View 

The Page Ordered view displays your index sorted first by page number and then by record number. The 

result is that records are displayed in page number order with all records for a particular page grouped 

together. Within that group, the records will appear in the order they were entered. 

To view the index in page number order choose View>Page Ordered or click the  toolbar icon. 

Keyboard Shortcut: Shift+F7 

See also: As Entered View; Sorted View; Filtered View; Grouped View 

Sorted View 

The Sorted view displays your index alphabetically. This is the same as the order in the preview pane. 

To view the index in sorted order, choose View>Sorted or click the  toolbar icon. 

Keyboard Shortcut: Shift+F8 

See also: As Entered View; Page Ordered View; Filtered View; Grouped View 

Filtered View 

Sometimes you may want to see a subset of your index. For instance, you might wish to see only those 

records that are labeled with a particular label or all entries that were edited on a particular day or by a 

particular indexer. The Filtered view lets you to do these and other filtering tasks. You may filter on the 

following index attributes: 
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 Labeled records 

 Date Created (the date a record was added to the index) 

 Date Edited (the date a record was most recently edited) 

 Creator Initials (the initials of the indexer that added an index entry) 

 Editor Initials (the initials of the indexer that most recently edited an index entry) 

Below is a screen shot of the Filter Dialog: 

 

 

Filter dialog 

Defining a Filter 

To define a filter, do the following: 

1. Choose View>Filtered or click the  toolbar icon. 

2. Specify the criteria for each field that you wish to perform a comparison on. (More information on 

specifying criteria is provided below.) 

3. Make sure that the filter or filters that you have specified have been enabled. In other words, 

make sure that at least one of the following filter types is checked: Labeled Records, Date 

Created, Date Edited, Creator Initials, Editor Initials. 

4. Click OK. 

The filter will be applied to the index. When an index is filtered, the status bar will contain the word 

'Filtered' to let you know that you are seeing a subset of the index. 

Keyboard Shortcut: Shift+F9 

See also: As Entered View; Page Ordered View; Sorted View; Grouped View 

Options 

Labeled Records – Allows you to filter the index to show only the records that have been labeled with 

the labels that you specify. There are nine labels and the color and name of each label is shown to help 

you select the appropriate label(s). 
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Hide Selected Labels – If checked, instead of showing only the checked labels, all records in the index 

except the ones you’ve checked will be displayed. In other words, the labels you specify will be hidden.  

Date Created – If checked, only the records created within the dates you specify will be shown. 

Date Edited – If checked, only the records edited within the dates you specify will be shown. 

Creator Initials – If checked, only the records that were added by the indexer with the initials you 

specify will be shown. The initials are not case sensitive. 

Editor Initials – If checked, only the records that were edited by the indexer with the initials you 

specify will be shown. The initials are not case sensitive. 

Clear – All filter options will be reset to their default settings. The default settings result in no filtering 

being applied to the index. All records will be shown 

Showing/Hiding Toolbars 

You can show or hide any toolbar according to your own preferences. To show or hide a toolbar, do either 

of the following: 

 Right click on an empty area of any toolbar or in the toolbar docking area. A menu will appear. 

Place a checkmark next to all toolbars you wish to be shown. Any unchecked toolbars will be 

hidden. 

 Click the View menu and then the Toolbars menu item and place a checkmark next to the 

toolbars you wish to be shown. Any unchecked toolbars will be hidden. 

View Creator 

SKY Index keeps track of who creates an index entry by adding the indexer's initials to the Creator field 

of the index database. The Creator submenu of the View menu allows you to toggle the display of this 

field in the Data Entry Grid on and off. 

Showing/Hiding the Creator Field 

To show or hide the Creator field in the Data Entry grid, choose View>Creator. If the Creator field is not 

visible, it will become visible. If it is already visible, it will be hidden. A check mark in front of the 

Creator submenu indicates that the Creator field is visible. 

View Editor 

SKY Index keeps track of who edits an index entry by adding the indexer's initials to the Editor field of 

the index database. The Editor submenu of the View menu allows you to toggle the display of this field 

in the Data Entry Grid on and off. 

Showing/Hiding the Editor Field 

To show or hide the Editor field in the Data Entry grid, choose View>Editor. If the Editor field is not 

visible, it will become visible. If it is already visible, it will be hidden. A check mark in front of the Editor 

submenu indicates that the Editor field is visible. 

View Date Created 

SKY Index keeps track of the date an index entry is created by adding the time of creation to the Created 

field of the index database. The Date Created submenu of the View menu allows you to toggle the display 

of this field in the Data Entry Grid on and off. 
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Showing/Hiding the Created Field 

To show or hide the Created field in the Data Entry grid, choose View>Date Created. If the Created field 

is not visible, it will become visible. If it is already visible, it will be hidden. A check mark in front of the 

Date Created submenu indicates that the Created field is visible. 

View Date Edited 

SKY Index keeps track of the date an index entry is edited by adding the time of edit to the Edited field 

of the index database. The Date Edited submenu of the View menu allows you to toggle the display of 

this field in the Data Entry Grid on and off. 

Showing/Hiding the Edited Field 

To show or hide the Edited field in the Data Entry grid, choose View>Date Edited. If the Edited field is 

not visible, it will become visible. If it is already visible, it will be hidden. A check mark in front of the 

Date Edited submenu indicates that the Edited field is visible. 

View Record Numbers 

The proofing report tool allows you to print the record numbers of all of the entries in your index. The 

View Record Numbers menu option allows you to toggle the display of record numbers in the Data Entry 

Grid on and off. 

Showing/Hiding Record Numbers 

To show or hide record numbers in the Data Entry grid, choose View>Record Numbers. If record 

numbers are not visible, they will become visible. If they are visible, they will be hidden. A check mark 

in front of the Record Numbers submenu indicates that record numbers are visible. 

Equal Column Widths 

Normally, all columns of the data entry grid are of equal size. However, you can change the width of any 

column and therefore make the columns unequal in width. (See Sizing a Column for more information 

on sizing columns.) If you resize a column and later decide that you would like the columns to be equal in 

width again, you can use the Equal Column Widths function to equalize the width of all columns. 

To make all columns equal in width choose View>Equal Column Widths. 

Keep Equal Column Widths 

If checked, SKY Index will always make sure that all columns have the same width and that the total 

space of all columns is equal to the available space of the program screen. 

Edit View 

Shows/Hides Edit View. For more information on Edit View, see Edit View in Chapter 5. 
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Refresh 

If you add a new record that should be hidden because of a currently active filtering option, that new 

record will remain visible in the Data Entry Grid until you refresh the grid using the Refresh command. 

It will, however, be hidden in the Preview Pane immediately. In addition, if you have set the grid's View 

mode to Page Ordered or Sorted, any new records that you add, and records that you edit, will be 

potentially out of order. The Refresh command will force any edited, or newly added, records to appear in 

their correct position in the Data Entry grid. 

Refreshing the Data Entry Grid 

To refresh the Data Entry Grid, choose View>Refresh. 

Keyboard Shortcut: Alt+F11 

Reveal codes 

If checked, SKY Index will display the Reveal Codes pane at the bottom of the program screen. This will 

allows you to see the internally used coding for formatting instead of using the WYSIWYG (What You 

See Is What You Get) text. This is generally only useful for debugging of sorting problems. It is 

recommended that you do not use Reveal Codes unless it is necessary. 
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Chapter 

12 
Managing Index Files 

Using the SKY Index Files Dialog 

The Files dialog box is a standard dialog that allows users of SKY Index to have a consistent method of 

choosing or specifying files. You will need to understand the Files dialog box to use the file management 

functions of SKY Index. An example of a Files dialog box for opening files is shown below. The dialog box 

for saving a file is similar. 

 

 

Files Dialog 

Basic operation 

In its simplest form, you can find the desired file in the list of files below the Look in drop-down list box 

and double click on it to select it and close the dialog box. You can also enter the name of the file in the 

File name text box and click Open. If the desired file is not in the current directory, you can use the 

features described below to select your file. 

Options 

Drive   Specifies the hard drive or other media in which to look for files. 

Look in   Specifies the folder (such as Desktop) in which to look for files. 

File name   Specifies the name of the file which you wish to open, save, or choose. 
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Files of type   Specifies the types of files that you may see in the Files list. 

Files   Presents a list of existing files that you may choose from. 

Previous Locations   A list of the ten most recently accessed folders. If you click on one of these 

locations, the “Drive” and “Look in” settings will be set to that location. If you want to delete one of 

these previous locations, you can right click on that location. You’ll be asked if you want to delete it 

and if you respond yes, it will be removed from the list until you access that location again. 

Backing up an Index 

Indexers frequently work to very tight schedules and losing an index to a power outage or computer 

problem can be disastrous. To help prevent this situation, SKY Index provides convenient Backup and 

Restore functions. 

 

 

Backup dialog 

To Back Up the Currently Open Index 

To back up the currently open index do the following: 

1. Choose File>Backup or click the  toolbar icon. A Files dialog box will appear. 

2. Enter a name for the backup file. The default name is the same name as your currently open 

index with a date and time stamp added. 

3. If desired, specify a different drive and directory for the backup to be placed in. 

4. Click Backup. 

Note: SKY Index will remember the most recently used path for a backup so that the next time you use 

this function you may be able to simply click OK to perform the backup. 
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How to Backup and How Not to Backup 

Unfortunately, some indexers don’t realize just how bad a loss of data can be for them until it is too late. 

What would you do if the hard drive on your computer went bad and all of your work for the last week 

was lost? What would you do if you accidentally deleted your own index? What would you do if there 

were a power failure that corrupted your computer’s hard drive? 

Over the years, SKY Software has determined some bad habits that get indexers into trouble when 

backing up their indexes. Since we’d like your indexing experience to be as positive as possible, below are 

a few bad habits and good habits for you to consider. 

Bad Backup Habits 

 Not backing up at all – This is unforgivable. Anyone who depends on information that is 

stored on their computer for their livelihood must have a good backup strategy and must backup 

often. Hopefully it will not take the loss of two weeks of work at the end of a grueling schedule 
and with a customer waiting for the finished product to get you to backup your indexes. You 

must backup your indexes!!! 

 Backing up using the Save As command – The Save As command changes either the name 

of the current index, the location, or both. After you use the Save As command, the current file is 

now the one you ‘Saved As’ and not the original file you were working with. If you fail to re-open 

the original, you’re almost guaranteed to become confused at some point when the file you think 

you’ve been using doesn’t contain the last two or three days of work. Although there are 

justifiable reasons for using the Save As command, backing up should not be one of them. The 

Save As command is the single most likely way to cause backup confusion. Please don’t use it! 

 Saving the index under two or more names – Although using different names for a backup 

is an acceptable practice, saving the index you’re working on under different names as anything 

other than a backup is not. It will likely lead to confusion at some point. If you need to flag a 

certain point in time where you’ve made a big change to your index, do so with a backup, not 

using Save As. 

Good Backup Habits 

 Backup Frequently Using the Backup Command – SKY Index’s built-in backup command 

is designed to help you create useful backups and to be able to go back in time by using a 

timestamp. When you use the Backup command, SKY Index will automatically add a timestamp 

to the filename that has minute resolution. The backups cannot be opened directly; they must be 

restored using the Restore command. This prevents you from accidentally editing the contents of 

the backup. 

 If you would like to backup to more than one location (a good idea), then use the 

Export command to backup to a second location – Exporting is quicker than backing up 

and, during an indexing session, SKY Index will remember the folder that you’re exporting to 

making subsequent exports very quick. Please note that exported indexes contain only the index 

entries, they do not contain any index settings, Translations, Acronyms, and so on. Use exporting 

only as a secondary backup. Never as a primary backup. 

 If you want to be sure to be able to find a particular version of an index later because 

of a big change or other reason, do not use Save As – In a case like this, append a note to 

the filename of a backup and keep the timestamp. 

 Make sure the Documents folder on your computer is backed up daily and that your 

entire computer is backed up at least once a month – All versions of Windows include 

software that can backup your Documents folder on a schedule. Some include software that will 

back up the entire computer. Depending on the version of Windows you have, you may need to 

buy a third party program to backup your entire computer. Consult the Windows’ Help system 

for information on setting up a backup schedule. 
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Options 

For a description of File Dialog options, see Using the SKY Index Files Dialog 

See also: Restoring an Index from a Backup 

Closing an Index 

To close the currently open index choose File>Close or click the  toolbar icon. If a record is being 

edited, the changes will be saved first and then the index will be closed. 

Compacting an Index 

As you edit your index, the index file can become fragmented and can contain wasted space. This 

generally has little effect on performance and is usually unimportant unless you are running low on hard 

drive space. 

Compacting an index will rewrite the index to a new temporary file, getting rid of unused space, and 

then delete the original file and rename the temporary file to the same name as the original file. 

Compacting your Index 

To compact your index choose File>Compact. 

Deleting an Index 

After you have finished and published an index, you may wish to remove it and all the related support 

files from your hard drive. You should use SKY Index’s Delete function to do this. 

Deleting an Index 

1. Choose File>File Management>Delete. A Files dialog box will appear. 

2. Select the index to delete and click OK. A warning will be displayed asking you to confirm that 

you wish to delete the index. 

3. Click OK. 

Note: When you use the delete function, SKY Index will delete all files containing the same name as the 

index. It is the same as the DOS command: DEL <filename>.* 

Exporting an Index 

SKY Index can export your index as a delimited text file. This is a file format supported by almost all 

database programs and indexing programs. 

 

 

Export Options dialog 
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Exporting Your Index 

1. Open the index to export. 

2. Choose File>Export. The Export Options dialog will appear. 

3. Modify the export options (described below) if desired. 

4. Click OK. A Files dialog box will appear asking for a name to give the exported file. 

5. Enter any legal filename in the File name text box. 

6. Click Export. 

Options 

Output Type – Specifies the output format of the exported file. Your options are: 

Text w/SKY Index v7.0 formatting codes – The file will be exported with settings and with 

coding that are appropriate for import into SKY Index v7.0. This option creates a file with a 

SKY7 filename extension. 

Text w/SKY Index v6.0 formatting codes – The file will be exported with settings and with 

coding that are appropriate for import into SKY Index v6.0. This option creates a file with a TXT 

filename extension. 

Text w/SKY Index v5.x formatting codes – The file will be exported with settings and with 

coding that are appropriate for import into SKY Index v5.0 or v5.1. This option creates a file with 

a TXT filename extension. 

Delimited Text File – The file will be exported as a plain text file using the four additional settings 

described below. 

CINDEX ‘DAT’ File – The file will be exported in a format that can be read by the CINDEX 

indexing program. This may be useful if you need to collaborate with another indexer that uses 

that program. Note: Although the conversion is generally quite good for most standard indexes, 

there are some formatting and characters that won’t transfer intact. There are some SKY Index 

features for which there is no equivalent in CINDEX and vice versa. You should perform some 

tests on sample index entries before committing to collaboration with another indexer or 

accepting work from an indexer that uses CINDEX. 

Tip: You should set the page range separator to a hyphen in your index options prior to 

exporting as CINDEX expect page ranges to be indicated with a hyphen – not an en dash. 

MACREX ‘MBK’ File – The file will be exported in a format that can be read by the MACREX 

indexing program. This may be useful if you need to collaborate with another indexer that uses 

that program. Note: Although the conversion is generally quite good for most standard indexes, 

there are some formatting and characters that won’t transfer intact. There are some SKY Index 

features for which there is no equivalent in MACREX and vice versa. You should perform some 

tests on sample index entries before committing to collaboration with another indexer or 

accepting work from an indexer that uses MACREX. 

Single character delimiter – Specifies the single character that is to be placed between each field. 

Include field names – If checked, the first line of the exported file will be the names of each field. For 

example: “Main”,“Sub1”,“Sub2”,“Page” 

Enclose fields within quotes – If checked, the exported index will have quotes around the contents of 

each field. Note: This is common practice if a comma is used as a delimiter. 

Include Formatting – If checked, SKY Index v7.0’s standard formatting codes will be included in the 

exported file. Otherwise, no formatting information of any type will be included in the exported file. 
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Importing an Index 

Overview 

There may be times when you wish to include in an existing index, or create a new index, index entries 

that come from a source other than SKY Index. Using the Import function allows you to import data 

from other popular indexing programs and virtually any database program. 

There are four basic file types that are supported by SKY Index v7.0. They are: 

 SKY Index v7.0 

 Text Delimited 

 CINDEX (DAT format) 

 MACREX (MBK format) 

The first, SKY Index v7.0, is simply a text delimited file that includes SKY Index’s internal formatting 

codes so that transfers between other computers running SKY Index will include formatting information. 

The Text Delimited format is an ASCII t ext file that has each heading level delimited by a user 

configurable character. You can also specify that each field is enclosed within quotes. 

The CINDEX and MACREX (dat) and (mbk) formats are file formats specific to those two programs and 

allow data interchange between SKY Index and those programs. 

NOTE: SKY Index v6.0 indexes are imported by simply opening them with the Open function, not by 

importing them. 

About Importing 

If you attempt to import data when an index is currently open, the data you import will be appended to 

the currently open index. If you attempt to import data when there is no index currently open, you will 

be prompted for the name to give to the new index that will be created as part of the import process. 

Importing a CINDEX DAT File 

To import a CINDEX DAT file, do the following: 

1. Choose File>Import (a File selection dialog will appear) 

2. From the File of Type list at the bottom of the dialog, choose “CINDEX (*.dat)” 

3. If necessary, navigate to the folder containing the DAT file to be imported 

4. Select the desired file 

5. Click OK 

The import process will start immediately. After the import is complete, the index will be resorted and 

you will then be able to edit or add entries to the index. Be sure to configure the index as appropriate 

after the import is complete. 

Importing a MACREX MBK File 

To import a MACREX backup file with a filename extension of “mbk”, do the following: 

1. Choose File>Import (a File selection dialog will appear) 

2. From the File of Type list at the bottom of the dialog, choose “MACREX (*.mbk)” 

3. If necessary, navigate to the folder containing the MBK file to be imported 

4. Select the desired file 
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5. Click OK 

The import process will start immediately. After the import is complete, the index will be resorted and 

you will then be able to edit or add entries to the index. Be sure to configure the index as appropriate 

after the import is complete.   

Importing a SKY Index v7.0 Text Delimited File 

To import a delimited text file with a filename extension of “sky7”, do the following: 

1. Choose File>Import (a File selection dialog will appear) 

2. From the File of Type list at the bottom of the dialog, choose “SKY Index v7.0 (*.sky7)” 

3. If necessary, navigate to the folder containing the sky7 file to be imported 

4. Select the desired file 

5. Click OK 

The import process will start immediately. After the import is complete, the index will be resorted and 

you will then be able to edit or add entries to the index. Be sure to configure the index as appropriate 

after the import is complete.  

Importing a Text Delimited File 

To import a standard text file with a tab or other delimiter between fields, do the following: 

1. Choose File>Import. 

2. Use the List files of type list box to choose Text Delimited (*.txt; *.tab; *.csv). 

3. Select the file to be imported. 

4. Click OK. (The Import Field Mapping dialog box will appear.) 

5. Use the Import Field Mapping dialog to map the fields in the text file to the fields in your index. 

Use the drop-down list box next to each index field to choose which imported field is to be 

mapped to that field. Index fields that will not be used should be set to "(not mapped)". More 

information on using this dialog is provided below. 

6. When you have finished mapping the fields, click OK. (A Files dialog box will appear.) 

7. Enter a name for the index. 

8. Click OK. 

Using the Import Field Mapping Dialog 

The Import Field Mapping dialog is used to map the fields that exist in a text file to the fields in your 

index. Each list box next to an index field contains a list of all fields contained in the first record of the 

text file being imported. For each index field (Main, Sub1, Sub2, …, Page) you will choose a field from 

the list box to assign to it. There will likely be fields that you do not want to assign and, for those fields, 

choose “(not mapped)”. Although you can assign the same text file field to more than one index field, to 

do so would usually be undesirable. An example of the dialog is shown below. 
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Import Field Mapping Dialog 

Options 

Show Field Contents   If checked, the actual field contents of the first record of the text file being 

imported will be displayed in the drop-down list boxes. This can sometimes make it easier to map the 

fields in a text file. Note: If First Record Has Field Names is checked, the Show Field Contents check 

box is automatically checked and cannot be unchecked. 

First Record Has Field Names   If checked, the field names of the import file will be used in the drop-

down list boxes. In addition, the Show Field Contents check box will be checked. Finally, the first 

record of the file will not be imported since it does not contain data. 

Fields Are Enclosed In Quotes   If checked, the fields to import are expected to be enclosed in quotes. 

Delimiter   Specifies the single character delimiter between fields in the text file. This is usually a 

comma or a tab. You can select one of the predefined delimiters from the drop down list or you can 

type any single character. 

Troubleshooting Import Problems 

Things to know when importing Text Delimited files 

 There should not be any blank lines in Text files that are being imported. In particular, the first 

line cannot be blank because it is used to determine the number of fields in each record of the file 

being imported. 

 For Text Delimited files, each record of the file must contain exactly the same number of fields 

and in the same order. 

Things to know when importing CINDEX (.dat) files 

 SKY Index does not import font information from DAT files. 

 If the file being imported was exported from a file that contained characters with diacritic marks, 

it is possible that some of those characters will not import properly. You should check the 

imported file for improper importing of these characters. 
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Merging Two or More Indexes Together 

There may be times when you work on a team project for an index that is very large. When this happens 

you will eventually want to combine the indexes written by the individual team members into a final 

master index. This is the purpose of the Merge function. 

To Merge Two or More Indexes Together 

1. Create a new index. The new index will be the master index. 

2. Open the master index. (If you just performed step one, it will already be open.) 

3. Make any desired configuration changes to the index. (You may wish to import the configuration 

of an existing index.) 

4. Choose File>File Management>Merge. A Files dialog box will be displayed asking you what file 

you wish to merge into the master index. 

5. Select the file or files to merge. (Note: You can select more than one file by holding down Ctrl to 

select non-contiguous files or Shift to select all files from the first selected record to the record 

you Shift+Click on.) 

6. Click Merge. SKY Index will merge the selected file into the master index. 

Creating a New Index 

Each time you wish to start a new indexing project you will need to create a new index file. 

Creating a New Index 

1. Select File>New or click the  toolbar icon. A Files dialog box will be displayed. 

2. Enter a filename for the new index in the File Name text box. 

3. Click OK. The new index will be created and opened ready for data entry. 

Note: If the index "default.skx" exists, its configuration (Index Options, Data Entry Options etc.) will be 

applied to the new index. 

Opening an Existing Index 

Opening an Existing Index 

1. Choose File>Open or click the  toolbar icon. A Files dialog box will appear. 

2. Select the index you wish to open. 

3. Click OK. 
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Printing a Draft Copy of Your Index 

On occasion, you may want to print a draft copy of your index for proofing. The Print Draft command will 

print a simple single column version of your index for proofing purposes. 

Printing a draft copy of your index 

To print a draft copy of your index, do the following: 

1. Choose File>Print Draft. A dialog will appear allowing you to choose the printer to use to 

perform print setup if desired. 

2. Choose a printer. 

3. Click OK. 

Note: The Print Draft command uses the WordPad applet that comes with all 32-bit versions of 

Windows to print the index. WordPad must be installed on your computer to use this feature. WordPad 

is always installed when Windows is installed, so you should not have to worry about this unless you 

have manually removed it from your computer. 

Print Setup 

When you print a proofreading report using the Proofing Report function, the report will be printed 

using the current printer settings for paper size and paper handling and will be printed to the default 

printer. If you want to change any of these settings before printing your proofreading report, you can use 

Print Setup to make desired changes. 

 

 

Print Setup dialog 

To Set Printer Options 

1. Choose File>Print Setup. 

2. Select a printer or set your printer’s options. 

3. Click OK. 

Note: This is an operating system and printer specific dialog box. Once the dialog box appears you can 

press F1 to learn more about it or you can click on the question mark at the top right corner of the dialog 

box and then click on the item you want to learn about. 
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Recently Opened Indexes 

SKY Index keeps track of the nine most recently opened indexes so that you can quickly open them. The 

nine most recently opened indexes are listed at the bottom of the File menu just before the Exit menu 

item. They are numbered 1 through 9. These indexes can be opened by choosing File plus the desired 

index. 

Renaming an Index 

You may find it desirable to change the name of an existing index. Although you could rename the index 

using Window’s File Manager or Explorer, it is better to use SKY Index's built-in rename function since 

it will also rename associated files. 

Renaming an Index 

To rename and index, do the following: 

1. Choose File>File Management>Rename. A Files dialog box will appear. 

2. Select the index to rename. 

3. Click OK. Another Files dialog box will appear asking for the new name. 

4. Enter new filename. 

5. Click OK. 

The index and all related files will be renamed. 

Repairing an Index 

If you experience a power outage, or if for some reason you exit SKY Index abnormally, you may not be 

able to open the index that was in use at the time of the abnormal shutdown. This is because the index 

database contains header information that must show that the database was properly closed before it 

can be opened. If you cannot open your index for some reason, you should use this function to try to cure 

the problem. 

Repairing a Damaged Index 

To repair and index, do the following: 

1. Choose File>File Management>Repair. A Files dialog box will appear. 

2. Select the index to be repaired. 

3. Click OK. 

SKY Index will attempt to repair the index and will display a message indicating whether the repair was 

successful or not. 

Note: The repair process cannot repair all possible index problems. If you the repair is reported as 

successful, there is a slight possibility that the index still contains some corruption. If you continue to 

have problems with an index after using the Repair function, create a new index and use the Merge 

function to merge the index entries of your corrupt index into the new index. 

Restoring an Index from a Backup 

If your index becomes unreadable due to a power outage or hardware problem, you can restore the most 

recent backup of your index by using the Restore function. 
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Note: You can only restore to a file that already exists. If you want to use the Restore feature to restore 

to an index that does not exist, you must first create the new index using File>New and then use the 

Restore feature. 

1. Choose File>File Management>Restore. A “Restore From” Files dialog box will appear. 

2. Select the backed up index to restore your index from. 

3. Click OK. A “Restore To” Files dialog box will appear. 

4. Select the index file you are restoring to. Note: Since the file already exists, you will be warned 

that it will be overwritten. 

5. Click OK. The index will be restored. 

Saving an Index under a Different Name 

If you want to create a copy of the current index using a different name, you can use the Save As 

function. If you wish to rename an index you should use the Rename file management function. 

Saving an Index under a Different Name 

1. Choose File>Save As. A Files dialog box will appear. 

2. Enter a name for the new index. 

3. Click OK. 

SKY Index will save a copy of the current index database under the new name and will make the new 

index the current index. 

Note: If you create a group prior to choosing Save As, you will be asked if you wish to save only the 

contents of the group. If you respond Yes, only the records contained in the group will be saved in the 

new index. The new index will have the same configuration settings as the original index. 

Saving your Index’s Options for Reuse in another Index 

It is common for an indexer to work on several indexes that require the same configuration settings. 

After you have configured one index, you can reuse its configuration by using SKY Indexes ability to 

save and load the Index Options of an existing index as a template. 

Saving Index Options 

1. Open the index whose configuration you wish to save. 

2. Choose Options>Save as Template. A Files dialog box will appear. 

3. Provide a name for the index options template. 

4. Click OK. 

The configuration of the currently open index will be saved under the name you provided. 

Note: The templates created using this function contains all configuration information from the Index 

Options dialog plus all information from the Data Entry Options dialog. This includes, but is not limited 

to, AutoComplete entries and Acronyms. 

Tip: If you configure the current index to satisfy your most common index style and format, and you 

export its configuration under the name "default" SKY Index will automatically apply its configuration 

to any new indexes you create. 
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Loading Previously Saved Index Options 

It is common for an indexer to work on several indexes that require the same configuration settings. 

After you have configured one index, you can reuse its configuration by using SKY Indexes ability to 

import the configuration of an existing index. 

Loading Index Options 

1. Open the index whose configuration you wish to change. 

2. Choose Options>Load from Template. A Files dialog box will appear. 

3. Select the template with the configuration you wish to load. 

4. Click OK. 

Tip: You can also load the index options from any existing index. To do this, after choosing 

Options>Load from Template, change the Files of Type to “SKY Index v7.0 (*.sk7). Then you will be able 

to navigate to where your index is and select that index. 

Options 

After you click OK, you’ll receive an Import Options dialog that has the following options: 

 

 

Import Options Dialog 

Acronyms – If checked, all acronyms will be imported from the template. 

AutoComplete – If checked all AutoComplete entries will be imported from the template. 

AutoEntry – If checked, all AutoEntry entries will be imported from the template. 

Translations – If checked, all translations will be imported from the template. 
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Chapter 

13 
Labels 

Overview 

Labels provide a way for you to apply an attribute to index entries. A label in its simplest form does 

nothing more than provide a way to distinguish the labeled entries from all other index entries. An 

example of this would be to use labels for all name entries in a subject and name index thus allowing you 

to create a group of just the name entries or just the subject entries. 

Another possible use for labels would be to label entries you’ve made in your index that you want to 

revisit later for some reason – perhaps to reconsider its wording. 

Labels can also be used as a system for bookmarking entries you’ve made when used in conjunction with 

the Next Active Label command. 

About Labels in SKY Index 

SI7 provides you with nine labels. Each label has a unique color that is user configurable and each label 

can also be given a name. Each record in the data entry grid can be assigned one and only one label. 

Once a record has been labeled, the background of the record in the data entry grid will appear in the 

color of the label that’s been assigned to it. The name and color of the label for the current record is also 

shown in the status bar at the bottom of program screen. 

About the Active Label 

There is always one label that is considered the “Active” label. This label can be toggled on and off using 

the Toggle Active Label command (Ctrl+M). The active label is special in that you can group on the 

active label using the Group on Active Label command (Ctrl+Shift+M) and you can move the current 

grid record to the next record that has been labeled with the active label using the Move to Next Active 

Label command (Alt+Ctrl+M) 

Setting the Active Label and Other Label Attributes 

The active label is set by using the Label Manager (shown below). The label manager can be displayed 

by choosing Labels>Set Active Label or by pressing Alt+Ctrl+J. Once you’ve displayed the label 

manager, you can set the active label by pressing a number one through nine or by clicking on the 

desired number with the mouse. 

Note: Selecting the active label by typing a number only works until you give focus to one of the 

textboxes for naming the labels. Then you will need to hold down the Alt key while you press the number 

for the label you wish to be active. After you have setup your label names and colors, you will generally 

only use this dialog to set the active label and you will be able to do that by pressing Alt+Ctrl+J follow by 

a single number and then pressing Enter.  
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Label Manager 

The Label Manager is shown above. In the above example, the label names for labels one and two have 

been changed to “Names” and “Subjects”. 

If you want to change the color of a label, click on the dotted button to the right of the label’s current 

color. This will display the Color Dialog which will allow you to define any color of your liking. An 

example of the Color Dialog is shown below. 

 

 

Color Dialog 
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After you’ve defined your color, click on Add to Custom Colors and then click OK to assign it to the label. 

After you’ve specified the active label, changed the name any labels that you want to rename, and 

defined custom colors for any labels that have a color you wish to modify, Click OK to save your changes. 

Click Cancel to abandon all changes you’ve made. 

Labeling a Record in the Data Entry View 

There are two ways to label a record using the data entry grid. They are: 

 Choose Labels>Toggle Active Label 

 Press and hold down Ctrl and then press the number of the label you wish to assign to the 

current record in the data entry grid. 

This is what happens when you attempt to label a record: 

 If the current record is not labeled, it will be labeled with the label you have specified. 

 If the current record is already labeled with the label you’ve specified, the label will be removed 

from the record. 

 If the current record is already labeled with the label that is different than the one you’ve 

specified, the old label will be removed and the record will be labeled with the label you specified. 

 

 

Example of two labeled records in Data Entry View 

Labeling a Heading in the Edit View 

When labeling in Edit View, please note that the label is applied to all records of the current heading. 

This almost always means that more than one record will be labeled when you look at the index in Data 

Entry View. There are two ways to label a heading in Edit View. They are: 

 Choose Labels>Toggle Active Label 

 Press and hold down Ctrl and then press the number of the label you wish to assign to the 

current record in the data entry grid. 

This is what happens when you attempt to label a record: 

 If the current record is not labeled, it will be labeled with the label you have specified 

 If the current record is already labeled with the label you’ve specified, the label will be removed 

from the record 

 If the current record is already labeled with the label that is different than the one you’ve 

specified, the old label will be removed and the record will be labeled with the label you specified. 
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Example of a labeled heading in Edit View 

Grouping on the Active Label 

There will likely be times when you want to see only the index entries that have been labeled with the 

active label. To do this, you can choose Labels>Group on Active Label or press the keyboard shortcut 

Ctrl+Shift+M. All records that are not labeled with the active label will be removed from the current 

view leaving only those records that are labeled with the active label. 

Tip: You can also filter your index to include or exclude one or more labels by filtering your index. See 

Filtered View for more details. 

Moving to the Next Label Record 

One of the nice features of the active label is that it can act as a way of bookmarking records in your 

index. If you have labeled records using the active label, you can jump directly to the next label in the 

current view of the index by choosing Labels>Goto Next Active Label or pressing Alt+Ctrl+M. 

Once you’ve reached the last record with the active label, the search will resume at the top of the current 

index view. 

Labeling Miscellaneous 

Here are a few things about labeling that may make using labels a little easier: 

 When you press the Ctrl key on your keyboard, the active label color and name appear in the 

Status bar in case you’ve forgotten which label is the active label 

 If you select more than one record before applying a label, all selected records will be labeled. 

 Labeling a record does not affect sorting of the labeled record 

Working with Labels (The Label Selector) 

If you are using a lot of labels for your project, you may find it beneficial to be able to see all of the 

available labels onscreen while you’re working on your index. The Label Selector is a floating toolbar 

that displays all nine labels as buttons that you can click to apply the label. Each button contains the 

name of the label to help you remember the purpose of each label. A screenshot of the Label Selector is 

shown below. 
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Label Selector 

 

To display the Label Selector, choose View>Toolbars>Label Selector. The ‘active’ label is shown within 

the less than and greater than signs (<>) and also appears indented rather than raised. In the example 

above, “<Bookmark set>” is the active label. You can change the active label by Control clicking on any 

label. 

While working on your index, you can apply any of the nine labels to the current record in the data entry 

grid (or heading in Edit View) by clicking on the desired label. Clicking again will remove the label since 

the label buttons act as a toggle. 
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Chapter 

14 
Finding Text 

Overview 

The Find function is designed to assist in the location of one or more records in your index. Pattern 

matching is available for more advanced searches. You can also create a group of your search results if 

desired. 

Using the Find Dialog 

To invoke the Find/Replace function, choose Search>Find or click the  toolbar icon. An example of the 

Find dialog is shown below. 

 

 

Find Dialog 

General Options 

And/Or/Plus – If you choose one of these options, an additional ‘sub-search’ will be revealed and you 

will be able to specify additional criteria that must be met in order for a match to occur. See 

Subsearches below for more information. 

Close – Closes the Find dialog. 

Direction – Specifies the direction of your search. You have three options: 

All – Searches forward through the entire index starting with the first record regardless of what 

record is the current record. 

Forward – Searches forward through the index starting with the current record. 
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Backward – Searches backward through the index starting with the current record. 

Find (text box) – The text that you wish to locate in the index. This text can contain wildcards as 

described later. 

Find (button) – Causes SKY Index to find the first occurrence of the text you specified in your search 

criteria. 

Group Results – If checked, a subset (group) of your index will be created containing only those records 

that match the search criteria. This makes it possible to make a visual comparison of similar index 

entries. 

Match Case – If checked, case will be considered significant when comparing text in your index with 

your search text. Otherwise, case will not be considered important. 

More – Clicking More will reveal additional search options which are described below under Options 

Revealed by Clicking More. 

Not – If checked, a match occurs only if the specified search criterion is NOT met. For instance, if you 

have added special symbol such as ‘~’ to the beginning of all names in a name and subject index, you 

can filter the index to contain only entries that do not contain names by searching for ‘~’ but with 

Not checked. 

Options – Displays a dialog that lets you define what happens each time you open the Find dialog. Your 

options are: 

Reset the dialog to its default state – Clears all settings to their default values. 

Reset, but remember “Group” setting – Clears all settings to their default values except the 

Group Results checkbox will retain the same setting that it had the last time the Find dialog was 

used. 

Restore the last search or replace – Restores the Find dialog to the same state it was in the last 

time you used it. 

 

 

Find Options Dialog 

Pattern Matching – If checked, SKY Index will use pattern matching to determine if a match occurs. 

See What is Pattern Matching? below for more information.  

Previous Searches – Contains a list of searches that you have performed in the past. The list contains 

the 20 most recently performed searches and the list is saved and restored when you close and 

reopen an index. 

Reset – Resets the Find dialogs settings back to their defaults. 

Save – Allows you to save this search so that it can be reused in this or any other index that you work 

on. See Saved Searches for more information. 

Style – This list box lets you choose the common character styles bold, italic, and underline in all 
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possible combinations. If you choose Any (the default) character style will be ignored during the 

search. If you specify a style, a match will only occur if the text matches the style you specify. If you 

specify None, a match will only occur if the found text does not contain any character styling. 

Whole Word – If checked, a match will occur only if the text found is a word by itself. If it is part of a 

larger word, a match will not occur. For example, if you search for the word test with Whole Word 

checked, the phrase test results will match and the word testing will not. If you do not check Whole 

Word, a match will occur in both cases. 

Options Revealed by Clicking More 
 

 

Find dialog with Advanced Options revealed 

Style 

Don’t Care – If checked (the default), character style will not be considered during the search. 

None – If checked, a match will occur only if the found text has no character styling applied. 

Bold – If checked, a match will only occur if the found text has bold style applied. 

Italic – If checked, a match will only occur if the found text has italic style applied. 

Underline – If checked, a match will only occur if the found text has italic style applied. 

Strikeout – If checked, a match will only occur if the found text has strikeout style applied. 

Superscript – If checked, a match will only occur if the found text has superscript style applied. 

Subscript – If checked, a match will only occur if the found text has subscript style applied. 

Special 

Don’t Care – If checked, the Ignored, Hidden, and Note Text special attributes will not be considered 

during the search. 

None – If checked, a match will only occur if the found text has does not have one of the ignored, hidden, 

or note attributes assigned. 

Ignored Text – If checked, a match will only occur if the found text has the Ignored attribute assigned. 

Hidden Text – If checked, a match will only occur if the found text has the Hidden attribute assigned. 

Note Text – If checked, a match will only occur if the found text has the Note attribute assigned. 
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Field 

Field – Specifies the field(s) to be searched. The available options are: 

Any – All fields will be included in the search. This is the default setting. 

Main – Only the Main heading field will be searched 

Sub1 through Sub6 – Only the subheading field you choose will be searched. Note that subheading 

levels that are not legal will be enclosed in curly braces. For instance, if you’ve specified that 

your index has only one subheading level, levels 2 through 6 will be enclosed in curly braces and 

you will not be able to select those fields. 

Page – Only the Page field will be searched. 

Font – Specifies a specific font to be searched for. The available options are: 

Any Font – The font of the found text will not be considered when performing the search. 

Default Font – A match will occur only if you have not applied an alternative font to the text. In 

other words, a match will occur if the found text has the default (unaltered) font. 

(Specific fonts) – If you choose a specific font from the list, a match will only occur if the found text 

has that specific font applied. 

Finding Text 

In its simplest form the Find function will search for text that occurs in any field of any record in the 

index. To perform a search, simply enter the character, word, or phrase to search for (the search text) in 

the Find textbox and click Find. 

If you have not changed any of the default settings, SKY Index will search your index starting at the 

beginning of the index and will search every field for entries containing the search text. If a record is 

found that contains the search text, the record and field containing the search text will be highlighted. 

The found text will also be displayed in the Find Pane as shown in the screen shot below. Notice that the 

text that matched the search is highlighted in orange text. In the example below, the term being search 

for was ‘H2O’ and it was found in the heading ‘water (H2O)’ 

 

 

Find Pane 

You can find the next matching entry by clicking Find Next or stop the search and return to editing your 

index by clicking Close. 

Note: If the field that contains the matching text is currently hidden, SKY Index will highlight the Main 

field, but will display the actual matching text in the Find Pane. 

Canceling a Search 

If you should wish to stop a search before it finishes, you can click the Cancel button or press Esc on your 

keyboard. 

Note: The Close button becomes a Cancel button while a search is being performed. 
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Finding Text with Specific Attributes 

If you wish to limit your search to text that contains specific attributes, you can choose a Style from the 

Style listbox or you can click the More button to reveal additional attributes. If you do so, the search will 

not produce a match unless the found text contains the attributes you have chosen. 

Example 1 (Finding text with a particular character style) 

Let’s assume you wish to find all locators that have fig. in italics. You would type ‘fig.’ in the Find 

textbox, choose Italic from the Style listbox and, finally, click more to reveal the Fields listbox and choose 

Page. When you click Find, a match will occur only if the text ‘fig.’ is found and it has italic character 

style applied. If you wish to find all locators that have the text ‘fig.’ but that you’ve forgotten to italicize, 

click the None checkbox instead of Italic checkbox before clicking Find. 

Example 2 (Finding hidden text) 

Let’s assume you wish to find all index entries that you’ve forced to sort differently than they normally 

would by adding hidden text to the entry. To do this, type an asterisk (*) in the Find textbox. This 

creates a Wild Match (see Wild Matching above for more information). Then click More and choose 

Hidden Text from the options available under Special. Finally, check the Group Results checkbox. When 

you click Find, all entries in your index that contain hidden text will be displayed as a group. NOTE: To 

see all index entries again, choose one of the three main views from the View menu: As Entered, Page 

Ordered, or Sorted. 

Wild Matching (matching attributes only) 

There may be times when you want to find all records with text that has a specific attribute applied. To 

do this, you will use a “Wild Match” search. To perform a wild match search, type an asterisk (*) in the 

Find textbox. This will cause all text in every field of every record to match. Then choose an attribute 

that you want to find. The search will return any entry that has that attribute in it unless you specify 

you wish to limit your search to a specific field. In that case, the match will occur only if there is text in 

that field that has the attribute you are seeking. 

Matching an Empty Field 

You may, on occasion, wish to find empty fields in your index. If you wish to find a subheading level that 

has no text, just leave the Find textbox empty and select the desired subheading from the Fields listbox 

and click Find. As an example, you may wish to find all index entries that have a main heading that is 

italicized and that do not have any subheading text. To do this, reveal the Fields listbox by clicking 

More. Then type an asterisk in the Find text box and check Italics from the list of Styles. You will want 

to choose Main from the field list. Now create a new subsearch by clicking ‘And’. Here, just leave the 

Find textbox empty and choose Sub1 from the Fields listbox. Finally, check the Group Results checkbox 

and click Find. 

Subsearches 

There may be times when you want to find entries in your index that contain some text that has no 

attributes applied along with some text that does. You can do this by creating a subsearch. Subsearches 

also allow you to create searches that contain Boolean logic (AND or OR). 

When you click And, Or, or Plus, you will see a new Find textbox appear. You will also see new 

And/Or/Plus options and a new Not option. 
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Logic Choices 

You have three logic choices that will create a subsearch. They are: 

And – A match will occur only if both the current Find text and the Find text in the next subsearch are 

both found. 

Or – A match will occur if either the current Find text or the Find text in the next subsearch are found. 

Plus – A match will occur only if both the current Find text and the Find text in the next subsearch are 

found and they are contiguous. For instance, if you have both the terms H2O and H2O in your index and 

want to locate only those occurrences where the ‘2’ is subscripted you would use the Plus operator with 

three subsearches. The dialog below shows a search setup to find H2O with the ‘2’ subscripted. In other 

words, it is set to search for a plain ‘H’ plus a subscripted ‘2’ plus a plain ‘O’. 

 

About the Plus operator 

There may be times when you wish to find a phrase that has more than one character style 

applied or maybe part of the phrase has no character style and another part is in italics 

and you wish to differentiate between these phrases and other phrases in your index that 

have identical text, but differing character styles. You can use the Plus operator to find 

these types of index entries. 

You may have up to 10 subsearches. Each subsearch has its own criterion which means you can specify a 

different Style or Font or Field for each subsearch. 

 

 

Find dialog with subsearches 

Knowing What Subsearch You’re Working With 

When there are one or more subsearches visible, a blue line appears with pointers at the top that point 

to the current subsearch. The blue line encircles the attributes that apply to that subsearch. Any 

changes you make to Style or other attributes always affect the current subsearch. 
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How Logic is Evaluated 

When evaluating logic in subsearches, the operators are evaluated as follows: 

1. All PLUS subsearches are evaluated and the result saved. 

2. All AND subsearches are evaluated using the saved PLUS evaluations and the results saved. 

3. All OR subsearches are evaluated using the saved AND evaluations. 

Saving a Search for Reuse in Any Index 

If you would like to save a search that you’ve done for reuse in this index and any future index, you can 

click the Save button. Your search along with all options you’ve chosen will be immediately saved as one 

of your 20 available Saved Searches which can be recalled with just a few keystrokes or mouse clicks in 

any index that you work on. For more information on Saved Searches, see Saved Searches later in this 

User’s Guide. 

Helpful Keyboard Shortcuts 

Below is a list of keyboard shortcuts that you may find useful when using Find. 

 

Function Shortcut 

Bold Ctrl+B 

Italic Ctrl+I 

Underline Ctrl+U 

Ignored Text Ctrl+K 

Hidden Text Ctrl+T 

Note Text Alt+Ctrl+N 

Superscript Ctrl+Shift+P 

Subscript Ctrl+Shift+B 

Strikeout Ctrl+Shift+K 

Plain Text Alt+F10 

AND* Ctrl+& 

OR* Ctrl+| 

PLUS* Ctrl++ 

Close a subsearch Ctrl+Q 

Close Esc 

Toggle More/Less Ctrl+M 

Find or Find Next Enter 

Change from Replace Mode to Find Mode Ctrl+F 

Change from Find Mode to Replace Mode Ctrl+H 

Reset (sets to Find Mode with an empty search) Ctrl+R 

Search Main field only Ctrl+0 

Search Sub1 field only Ctrl+1 

Search Sub2 field only Ctrl+2 

Search Sub3 field only Ctrl+3 

Search Sub4 field only Ctrl+4 

Search Sub5 field only Ctrl+5 
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Function Shortcut 

Search Sub6 field only Ctrl+6 

Search Page field only Ctrl+P 

Search Any field Ctrl+’ (accent grave) 

Cycle Focus between the Find textbox and Replace 

textbox 

Tab 

* Note that you have to hold down the shift key to type a &, |, or +. (The 

keypad + does not require the shift key) 

A Few Examples 

Note: These examples assume that you have already opened the Find dialog and are starting from a 

reset condition. 

Finding all Main Headings that are in Italics 

Let’s assume that you’re working on a book that contains many titles that are entered in italics and you 

wish to find all of those titles. To do this, you would: 

1. Type an asterisk in the Find text box 

2. Press Ctrl+I. (Ctrl+I is the shortcut to set Find to match only text with italic character style.) 

3. Press Ctrl+0. (Ctrl+0 (zero) is the keyboard shortcut to set Find to only look at main headings.) 

4. Press Alt+G. (Alt+G is the keyboard shortcut to set Find to group the search results.) The dialog 

will look like this: 

 

 

Find Dialog Set to Find Main Headings in Italics 

5. Press Enter. (Pressing Enter is equivalent to clicking Find.) 
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Finding all Empty Subheadings 

If you wish to find all records in the index that have no subheading text, do this: 

1. Leave the Find textbox empty. 

2. Press Ctrl+1. (Ctrl+1 is the keyboard shortcut to set Find to look only at the Sub1 field.) 

3. Press Alt+G. (Alt+G is the keyboard shortcut to set Find to group the search results.) The dialog 

will look like this: 

 

 

Find Dialog Set to Find Empty Subheadings 

4. Press Enter. (Pressing Enter is equivalent to clicking Find.) 

Finding all Cross-references 

If you wish to find all records in the index that contain a cross-reference in the Page field, do this: 

1. Type ‘see ’ in the Find textbox. Notice the trailing space. 

2. Press Ctrl+P. (Ctrl+P is the keyboard shortcut to set Find to look only at the Page field.) 

3. Press Alt+G. (Alt+G is the keyboard shortcut to set Find to group the search results.) The dialog 

will look like this: 
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Find Dialog Set to Find All Cross-references 

4. Press Enter. (Pressing Enter is equivalent to clicking Find.) 

Tip: You may find it useful to save this search as a Saved Search 
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Chapter 

15 
More Ways to Find Index Entries 

Overview 

Although finding text using the Find dialog is a great way to find index entries, there are times when 

other ways of finding those entries may be faster. There are several ‘Go to’ commands and a Browse 

command that may be better than using the find dialog under some circumstances. These commands are 

described in this chapter. 

Finding Entries by Browsing 

The Browse function allows you to seek main headings in your index according to the first few letters of 

the heading. You can optionally specify the first few letters of subheadings by separating the main 

heading from the subheading with a semicolon. While you are searching, the Browse Pane will be visible 

as shown below. 

 

 

Browse Pane 
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Using the Browse Pane 

The basic process of browsing starts by revealing the Browse Pane which is done by choosing 

Search>Browse. Then you simply type the first few letters of the main heading of the index entry you are 

seeking. After you’ve started browsing, you can continue to type to refine the heading you wish to see. If 

you type an incorrect letter, press Backspace to erase it. To start a new search, press Ctrl+Backspace 

which will clear the current search. Notice that the letters you’ve typed so far are shown in the title bar 

of SKY Index. 

 

 

Example of Title Bar while Browsing 

If you wish to narrow your search even further by specifying the first few letters of a subheading, just 

type a semicolon and any letters you type after the semicolon will be used to further refine the search at 

the subheading level. Once you have viewed the heading you wish to see, you can close the Browse Pane 

by pressing Escape (or click the close button at the top right of the Browse Pane). This will close the 

Browse Pane and will leave the current index heading unchanged. If, instead, you wish to “go to” the 

heading that you’ve browsed to in the Browse Pane, press Enter. That will close the Browse Pane and 

will make the heading that you browsed to the current heading so that you can edit it. 

Browsing in Data Entry View 

To Browse in Date Entry View, choose Search>Browse. The Browse Pane will appear directly to the 

right of the Preview Pane and will take up half of the available space. 

Keyboard Shortcut: Alt+Ctrl+B 

Browsing Through your Index Using the Keyboard 

An alternative way to browse in Data Entry View is to browse using the keyboard. When using this 

method, the Browse Pane will not appear, but the entry you are browsing to will temporarily be 

displayed in the Preview. To browse using this method, you hold down Alt+Ctrl+Shift and then press the 

first letter of the main heading you wish to seek. This will take you to the first main heading in your 

index that starts with that letter. It will be highlighted in grey. If you continue to hold down 

Alt+Ctrl+Shift and press additional letters, the additional letters will refine the search. For example, if 

you hold down Alt+Ctrl+Shift and press ‘s’, then ‘o’, then ‘f’, you might be taken to the main heading 

“software”. 

Notes 

 The record that browsing highlights is bookmarked, but is not the current record. This allows you 

to examine other parts of your index without leaving your current editing point. If you wish to 

make the highlighted record current, use the Goto Bookmark command by pressing 

Alt+Ctrl+Space. This will bookmark your current record and then change your current record to 

the one that you found by browsing. You can toggle back and forth between these two records by 

repeatedly using the Goto Bookmark command. 

 To start a new search, just release all keys and start again by pressing Alt+Ctrl+Shift followed 

by the first letter of the main heading you wish to seek. 
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Browsing in Edit View 

With the in-place editor enabled 

To Browse in Edit View and with in-place editing enabled (the default), you simply start typing the first 

few letters of the main heading you wish to find. The Browse Pane will appear directly to the right of the 

Preview Pane and will take up half of the available space. 

With the in-place editor disabled 

To Browse in Edit View with in-place editing disabled, choose Search>Browse. The Browse Pane will 

appear directly to the right of the Preview Pane and will take up half of the available space. 

Keyboard Shortcut: Alt+Ctrl+B 

Finding Entries using ‘simple’ Find 

Sometimes the normal Find dialog is simply more than you need and all you want to do is find the 

currently highlighted index heading or the currently selected text. There are keyboard shortcuts 

available to make this quick and easy. 

Finding the currently highlighted index heading or the currently selected text 

To find the currently highlighted index heading (the heading with the marquee over it), or to search the 

currently selected text, press Ctrl+F3. This will find the next occurrence of that text in the index starting 

from the current position in the index. 

Notes 

 In Edit View, if you use this function with a full index entry highlighted, SKY Index will search 

for the heading text and will ignore any highlighted locators or cross-references. 

 When you use this feature, the Find Pane will appear and it will highlight the found text in 

orange. 

 To close the Find Pane, click the ‘X’ at the top right of the pane. 

Finding the next match (Find Next) 

To find the next matching text or heading, press F3. If reach the end of the index and there are no more 

matches, you will receive a message letting you know that no more matches exist after the current 

location in the index. You may wish to use the Find Previous command described below to search 

backward at this point. 

Finding the previous match (Find Previous) 

To search backwards in the index and to find the previous matching text or heading, press Shift+F3. If 

reach the beginning of the index and there are no more matches, you will receive a message letting you 

know that no more matches exist prior to the current location in the index. You may wish to use the Find 

Next command described below to search forward at this point. 

Grouping by using ‘simple’ Find 

If you wish to create a group of all index records that contain the currently highlighted heading or your 

currently selected text, press Ctrl+Shift+F3. This will create a group of all matching index records. To 

exit the group, press Ctrl+Shift+U. 
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Finding Entries by Record Number 

Sometimes it is convenient to be able to go directly to a specific record in the data entry grid using its 

record number. A good example of this is during proofreading of the index. The Proofing Report provides 

the record number and if you find a problem with an entry in the Proofing Report, being able to go 

directly to the desired record to make the correction would save considerable time. 

 

 

Goto Record Dialog 

Finding a Specific Record by its Record Number 

To go directly to a specific record in the data entry grid, do the following: 

1. Choose Search>Goto Record. 

2. Enter the record number of the record you wish to go to. 

3. Click OK. 

Keyboard shortcut: Alt+Ctrl+R 

Finding Entries by Locator 

There may be times when you want to find an entry by its locator. The Goto Locator command provides 

this function. 

 

 

Goto Locator Dialog 
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Finding an Entry by its Locator 

 Choose Search>Goto Locator. 

 Enter the page number that you wish to find and optionally a chapter and/or volume label. 

 Click OK. 

Options 

Remain in current view – Your index will remain in the view that it was in prior to invoking this dialog. 

Change to As Entered view – Your index will be put in As Entered order prior to finding the locator. 

Change to Page Ordered View – Your index will be put in page order prior to finding the locator. 

Remember Options Setting – If checked, your option selection will be remembered the next time you use 

this function. 

Keyboard shortcut: Alt+Ctrl+L 

Notes 

 If the locator you are seeking includes prefix or suffix text, you must enter it in the Page number 

textbox. 

 Although entering a chapter or volume labels is optional, you should include them if you want to 

narrow your search to a specific volume and/or chapter. 

Finding Entries by Heading Text 

If you are trying to locate a particular index entry in a very large index it could be very time consuming 

to scroll the grid until the desired entry appears. The Goto function is a fast way to locate an index entry 

using all or part of its main heading and/or subheading. 

 

 

Goto Dialog 

Finding an Entry by its Heading 

To quickly go to a particular index entry, do the following: 

1. Choose Search>Goto or click the  toolbar icon. 

2. Enter the Main heading of the record that you wish to locate, or the first few letters of the 

heading in the Main textbox. 

3. Click OK.  
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Notes 

 If you wish to, you can refine a search by adding subheadings. You can enter the entire 

subheading or enter only the first few letters if desired. The closest matching record will be 

displayed. 

 The dialog will display the same number of textboxes as there are heading levels for your current 

index. 

Keyboard Shortcut: Ctrl+G 

 

Finding Locators for the Current Entry 

When you are using the Data Entry Grid for data entry or for editing and have the grid sorted in either 

As Entered order or Page Order, the index records for the currently displayed entry in the Preview Pane 

will most likely not be visible together on the screen. If you should want to quickly move to one of the 

other index records that contain the other locators, you can use one of two methods. 

Method 1: Displaying a list of all locators which you can choose from 

To display a list of all locators for the current entry as a popup menu, choose Search>Find All Pages for 

Entry or press Alt+Ctrl+A. The resulting popup list will contain all of the locators and you can choose 

the locator you wish to go to. If you use the mouse, just double click on the desired locator. Double click 

on the Cancel menu to abandon the search. If you’re using the keyboard (recommended) use the up/down 

arrow keys to highlight the desired locator and then press Enter to go to that record or press Esc to 

abandon the search. 

Method 2: Move consecutively to the next or previous locator 

There are two commands that will allow you to move to either the next (usually the next highest 

numerically), locator for the current entry or to the previous locator. The commands are: 

Next Locator for Current Entry 

To move to the next locator for the current entry, press Alt+Ctrl+] (right bracket). This will cause SKY 

Index to search forward in the grid for the next record that matches the current entry in all heading 

levels. If you reach the end of the grid, the search will begin again at the first record of the grid. 

Previous Locator for Current Entry 

To move to the next locator for the current entry, press Alt+Ctrl+] (right bracket). This will cause SKY 

Index to search forward in the grid for the next record that matches the current entry in all heading 

levels. If you reach the end of the grid, the search will begin again at the first record of the grid. 
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Chapter 

16 
Replacing Text 

Overview 

Replacing existing text with something different is a common task during the indexing process. This may 

range from a simple change of one word or phrase to another, but may also require advanced techniques 

for matching the character style of the text or of part of the text, the font of the text, or even special 

attributes that SKY Index allows you to apply to your index entries. You can accomplish this and much 

more using the Replace dialog. 

Replacing Text 

Replacing text is exactly like finding text with the following two exceptions: 

1. You will be specifying text that you want to replace the found text with. 

2. The search cannot include Boolean operators since that would potentially result in the text being 

found in more than one place leaving it impossible to determine where the replacement text 

should go. Note: Although you cannot use Boolean operators in a replace operation, you can use 

the Plus operator. 

The basic outline for replacing text is: 

 Bring up the Replace dialog 

 Specify the text you want to be replaced (the Find Text) 

 Specify the text to be used in place of the found text (the Replace Text) 

 Find the first occurrence of the Find Text 

 Replace each occurrence of the Find Text with the Replace Text case-by-case using Replace or… 

 Replace each occurrence of the Find Text with the Replace Text globally all at once using Replace 

All. 

See also: Propagate Edits 

Notes 

 When replacing an existing locator in the page field with a page range. Be certain that you enter 

the locator correctly and fully expanded (not abbreviated/conflated) because using Find/Replace 

to enter a locator circumvents the normal checks that are performed during data entry to ensure 

the proper formation of the locator. 

 Use Replace All carefully. Although you can use Undo to undo a global replacement, we still 

recommend that you backup your index prior to any kind of global change. 
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Bringing Up the Replace dialog 

To bring up the Replace dialog, choose Search>Replace (Ctrl+H). The Replace dialog will appear as 

shown below. 
 

 

Replace Dialog  

Specifying the Find Text 

For most replacements, you will simply type in a word or phrase to be searched for in the Find textbox. 

On occasion, though, you may wish to specify that your Find Text only match under certain conditions 

such as having a specific character Style or that it be at a specific heading level. These are described in 

the previous chapter Finding Text. However, a few of the more common options are described below: 

Commonly used Find Options 

Match Case – If checked, case will be considered significant when comparing text in your index with 

your search text. Otherwise, case will not be considered important. 

Field (Revealed by clicking the More button) – Specifies the field(s) to be searched. The available options 

are: 

Any – All fields will be included in the search. This is the default setting. 

Main – Only the Main heading field will be searched 

Sub1 through Sub6 – Only the subheading field you choose will be searched. Note that subheading 

levels that are not legal will be enclosed in curly braces. For instance, if you’ve specified that 

your index has only one subheading level, levels 2 through 6 will be enclosed in curly braces and 

you will not be able to select those fields. 

Style – This list box lets you choose the common character styles bold, italic, and underline in all 

possible combinations. If you choose Any (the default) character style will be ignored during the 

search. If you specify a style, a match will only occur if the text matches the style you specify. If you 

specify None, a match will only occur if the found text does not contain any character styling. 

Whole Word – If checked, a match will occur only if the text found is a word by itself. If it is part of a 

larger word, a match will not occur. For example, if you search for the word test with Whole Word 

Find Text 

Replace Text 
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checked, the phrase test results will match and the word testing will not. If you do not check Whole 

Word, a match will occur in both cases. 

After you have entered the text to be searched for and set any options you wish to use, you will specify 

next specify the text that will replace the text that matches your search criteria. 

Specifying the Replace Text 

As with specifying Replace Text, the normal situation will be to simply type a word or phrase into the 

Replace textbox. There are, however a number of options available to help you out with unique 

situations. Those options are discussed below. 

 

 

Replace with More options revealed 

Replace Options 

Maintain Case – Tells SKY Index to match the case of the original text. When this option is enabled, 

SKY Index examines the first two letters of the original text and adjusts the replacement text as 

follows: 

 If the first letter is not capitalized, the entire replacement text will be in lower case. 

 If only the first letter is capitalized, only the first letter of the replaced text will be capitalized 

 If both the first and second letters were capitalized, the entire replacement text will be 

capitalized. 

Style (Some of these options are revealed by clicking the More button) 

Don’t Change – If checked (the default), the style of the original Find Text will be maintained. 

None – If checked, the Replace Text will not have any character style applied regardless of any 

character style that may have existed in the Find Text. 

Bold – If checked, the Replace Text will have bold character style applied in addition to any style 

that existed in the Find Text prior to the replacement. 

Italic – If checked, the Replace Text will have italic character style applied in addition to any style 

that existed in the Find Text prior to the replacement. 

Underline – If checked, the Replace Text will have underline character style applied in addition to 

any style that existed in the Find Text prior to the replacement. 

Strikeout – If checked, the Replace Text will have strikeout character style applied in addition to 

any style that existed in the Find Text prior to the replacement. 
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Superscript – If checked, the Replace Text will have superscript character style applied in addition 

to any style that existed in the Find Text prior to the replacement 

Subscript – If checked, the Replace Text will have subscript character style applied in addition to 

any style that existed in the Find Text prior to the replacement. 

Special (You must click the More button to reveal these options) 

Don’t Change –    If checked, the Replace Text will have the same special attributes as the text that 

it replaced. 

None – If checked, the Replace Text will have the Ignored Text attribute applied. 

Ignored Text – If checked, the Replace Text will have the Ignored Text attribute applied. 

Hidden Text – If checked, the Replace Text will have the Hidden Text attribute applied. 

Note Text – If checked, the Replace Text will have the Note Text attribute applied. 

 

Font (You must click the More button to reveal these options): 

Don’t Change – If checked (the default), the font of the original Find Text will be maintained. 

Default Font – If checked, all font information will be removed. This will result in the default font 

being used. 

(Specific fonts) – If you choose a specific font from the list, the Replace Text will have the font you 

choose applied to it. 

Whole Field – If checked, instead of just replacing the Find Text with the Replace Text, the entire field 

that the Find Text was found in will be replaced with the Replace Text. 

After you have specified your Replace Text and any desired replace options, the next step is to find the 

first occurrence of the Find Text. 

Finding the First Occurrence of the Find Text 

To find the first occurrence of the Find Text, simply click the Find button. If the text is found, the search 

will stop and the text will be highlighted. The Replace and Replace All buttons will also be enabled. If 

the Find Text is not found, you will be notified that the search did not result in a match. 

Assuming that the text you’re seeking is found, SKY Index will display the found text at the bottom of 

the program window in the Find Pane. The entire field text of the field in which the text was found will 

be displayed with the actual Find Text highlighted in orange. In addition, the result of the replacement 

will be shown directly below the found text. This allows you to determine if the replacement is really 

what you want to do. 

Let’s assume that you are searching for ‘program’ and wish to replace it ‘routine’. Let’s also assume that 

one of the main headings in your index is ‘indexing programs’ 

When finding ‘program’ in that heading, the Find Pane would appear as shown below. 

 

 

Find Pane example 

Notice that there is no guessing about the result. Once you’ve found text that you wish to replace, you 

can proceed with either replacing the text on a case-by-case basis or globally. 
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Replacing Text on a Case-by-Case Basis 

If you think that there may be or know that there are some headings in your index in which the Find 

Text will be found, but you will not want to perform the replacement, you can do the replacement on a 

case-by-case basis by clicking Replace for those matches where you wish to perform the replacement and 

Find Next if you want to skip the current match. Clicking Replace will perform the replace and then 

search again for the next match. 

Replacing all Text 

If you are certain that you want to replace all occurrences of the Find Text with the Replace Text, click 

Replace All. Clicking Replace All will cause SKY Index to replace all occurrences of the Find Text in the 

index that match your criteria with the Replace Text. 

Note: In general, it is smarter to do a replace on a case-by-case basis, but if you should perform a Replace 

All and then notice that you really should not have. You can Undo the Replace All using Edit>Undo 

(Ctrl+Z).  

Example: Using Plus 

Plus allows you to specify different attributes to different parts of your replacement text. For instance, if 

your replacement text will be H2O, you will need to somehow specify that the ‘2’ is to be subscripted. You 

do this with the Plus operator. Your replacement would be a plain ‘H’ plus a subscripted ‘2’ plus a plain 

‘O’.  

Example 

To enter the replacement text “H2O”, do the following: 

1. Enter the ‘H’ in the Replace textbox 

2. Click Plus  

3. Enter ‘2’ in the Replace textbox 

4. Click More 

5. Check Subscript 

6. Click More 

7. Enter ‘O’ in the Replace textbox 

The result would look like this: 

 



114    SKY Index 7.0 User’s Guide 

 

Using Plus to Setup H2O Replacement Text 

Note: If you were to click in the textbox containing the ‘2’, you will see that the Subscript checkbox was 

checked for that replacement text. 

Example: Changing all Main Headings that are in Italic Style to Underline Style 

Let’s assume that you’re working on a book that contains many titles that are entered in italics and you 

wish to find all of those titles and change the italic style to underline style. To do this, you would: 

Note: This example assumes that you have already opened the Replace dialog and are starting from a 

reset condition. 

1. Type an asterisk (*) in the Find textbox 

2. Press Ctrl+I. (Ctrl+I is the shortcut to set Find to match only text with italic character style.) 

3. Press Ctrl+0. (Ctrl+0 (zero) is the keyboard shortcut to set Find to only look at main headings.) 

4. Press Ctrl+Tab to move focus to the Replace textbox. 

5. Press Ctrl+U to set the replacement text in underlined character style. 

6. Type an asterisk (*) in the Replace textbox. The dialog will look like this: 
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Replace Dialog Set to Change Main Headings in Italics to Underlined 

7. Press Enter. (Pressing Enter is equivalent to clicking Find.) 

8. Click Replace All. 
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Chapter 

17 
Saved Searches 

Overview 

What are Saved Searches? 

Saved searches are searches, replacements, or groupings that you save for reuse. When you save a 

search by clicking on the Save button in the Find or Replace dialogs, all attributes of that search are 

placed in one of the twenty available saved search slots. The Saved Search Manager allows you to modify 

the name that is generated for the search so that it makes more sense to you and allows you to specify if 

the search is to be executed immediately when chosen from the Search menu or from the Saved Search 

toolbar. 

The Saved Search Manager 

The saved search manager, shown below, displays all twenty available saved searches. You can rename 

the searches and change their order. You can also specify if the saved search should be executed 

immediately or if it will simply be displayed so that you can modify it before executing the search. 

 

 

Saved Search Manager 
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Displaying the Saved Search Manager 

To display the Saved Search Manager, choose Search>Saved Search Manager. 

You can edit the search names by clicking on the desired name and then pressing F2. Clicking on the 

Execute checkbox will toggle the check on/off. The search Type is informational only and cannot be 

changed. 

Options 

New   Let’s you define a new saved search. 

Choose   Let’s you add a search from a list of searches that you previously executed during the current 

indexing session. 

Delete   Delete’s the current saved search as indicated by the black pointer in the row header of the 

grid. 

Refresh   Refreshes the grid. (This option is generally of no use and is included only for consistency with 

other Manager dialogs. 

Revert   Undoes all changes you’ve made and restores the list to the state it was in when you first 

opened the Saved Search Manager dialog. 

Up/Down   Moves the current search as indicated by the black triangle in the row header of the grid up 

or down on row. Note: The order that the searches appear in the Saved Search Manager is the same 

order they will appear in the Search menu and in the Saved Search toolbar. 
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Chapter 

18 
Pattern Matching (advanced Find/Replace) 

Overview 

What is Pattern Matching? 

Pattern matching allows you to find text in your index by finding text that meets a certain criteria. The 

criteria are specified using special symbols in the search text. For instance, you can search for only 

numeric text and even only numeric text that contains certain digits. You could also search for any text 

that has the form of a date. After finding text, there are additional features of pattern matching that 

allow you to change the order of the found text during a replacement. 

Although the standard Find/Replace suits most needs, there may be times when the more advanced 

features of pattern matching can save you a tremendous amount of time when manipulating the text in 

your index entries. 

Summary of criteria symbols 

SKY Index supports an extensive list of criteria symbols. They are below: 

 

Criteria Symbol Function 

* (asterisk) Matching any number of characters 

? (question mark) Matching any single character 

# (pound sign) Matching any single digit 0-9 

[ ] (square brackets) Matching characters in a user defined list 

< (less than symbol) Matching characters at the beginning of a field 

> (greater than symbol) Matching characters at the end of a field 

& (ampersand) Matching whole numbers 

~ (tilde) Matching a word 

Criteria Symbols 

SKY Index supports eight criteria symbols each of these symbols is discussed below along with examples 

of how to use them in a search. 

* (asterisk) – wild card 

The asterisk will match any number of characters including none (it will match nothing). Any 

characters, in any amount, and in any order will provide a match. If you enter a single asterisk as your 

pattern, every field of every record in your index database will match. If you add text of other patterns 
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before or after the asterisk it will limit what will match because, to match, the text found must now also 

include the additional text or patterns that you have specified. For instance, if you enter (in Find What): 

1* 

A match will occur every time the number one is encountered in the text being searched. In addition, the 

match will include all of the characters, if any, after the number one. 

If you enter (in Find What): 

(*) 

A match will occur every time a pair of parenthesis is encountered in the text being searched. All of the 

text within the parenthesis, if any, and the parenthesis themselves will be included in the matched text. 

If you want to search for an asterisk, enclose the asterisk within square brackets '[*]' and it will not be 

treated as a criteria symbol. 

? (question mark) – match any single character 

The question mark will match any single character. For example if you wish to find text that includes at 

least four characters and it does not matter what four characters they are, you would enter (in Find 

What): 

???? 

Unlike the asterisk, the question mark will not match if there is no character at all. There must be a 

single character, but it does not matter what character it is. If you want to search for a question mark, 

enclose the question mark within square brackets '[?]' and it will not be treated as a criteria symbol. 

# (pound sign) – match any single digit 

The pound sign acts just like the question mark (?) except that it will only match the numeric digits 0 

through 9 inclusive. If you want to search for a pound sign, enclose the pound sign within square 

brackets '[#]' and it will not be treated as a criteria symbol. 

[ ] (square brackets) – character list 

The square brackets create what is known as a character list. The characters in this list – any characters 

you type between the square brackets – specify what characters will be considered a match in the 

searched text when encountered at the appropriate position in the searched text. A character list will 

match only one character. If you want to have several characters in a row match the same character list, 

you must enter the character list for each match that you wish to achieve. 

Symbols that have special meaning within a character list 

! (exclamation mark) 

You can specify a list of characters that will not match by entering an exclamation mark (!) as the 

very first character within the character list. The exclamation mark itself will not be part of the list. 

It will simply serve to make the character list a list of characters not to be considered a match. If you 

enter an exclamation mark in any position other than the first position, the exclamation mark 

becomes part of the list. 

- (dash) 

You specify a range of characters that will represent a match by entering a range such as a-z or A-Z. 

(You would read this as 'a' through 'z' or 'A' through 'Z'.) If you want to enter several ranges, do not 

put a delimiter such as a space between the ranges. Enter them directly next to one another like this: 

[a-zA-Z]. If you wish to enter the dash character (-) within a character list such that it is not part of a 
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range, it must be the very first character in the list or, if it is a not list, it must follow the exclamation 

mark directly. 

Some character list examples: 

[a-zA-Z]  Matches any character in the alphabet regardless of case 

[a-z]   Matches only lower case letters 

[abc]   Matches only the letters 'a', 'b', or 'c'. 

[!ABCa-z]  Will not match the uppercase letters 'A', 'B', and 'C' or any lowercase letter. Any 

other character will be a match. 

[!0123456789] Will not match any numeric digit in the range 0-9. This is the opposite of the 

pound sign (#) criteria symbol. 

[-[]   Will match only the dash character '-' or a left bracket '['. 

Note: If you do not check the Match Case check box, the character list [A-Za-z] will be the same as [a-z] 

since case will not be taken into account. 

< (less than symbol) – match only if matching text includes first character 

The less than symbol is used to specify that a match can only occur if the match is at the beginning of 

the searched text. If you use the less than symbol, it must be the first symbol to appear in the pattern. 

The less than symbol itself will be ignored except that it instructs the pattern parser that a match can 

only occur at the beginning of the searched text. If you want to enter a less than symbol as the first 

character of a pattern, enclose it within square brackets '[<]'.  

Note: If you are searching using Any as the Field choice, each record of the index is searched as a single 

text phrase. This means that the ‘<’ criteria symbol will only match for main headings. If you wish to use 

this symbol to match headings other than the main heading, you will need to search using a specific field 

or use the AND feature of Find to search each field that you wish to include in the search. 

> (greater than symbol) – match only if matching text includes last character 

The greater than symbol is used to specify that a match can only occur if the match is at the end of the 

searched text. If you use the greater than symbol, it must be the last symbol to appear in the pattern. 

The greater than symbol itself will be ignored except that it instructs the pattern parser that a match 

can only occur at the end of the searched text. If you want to enter a greater than symbol as the last 

character of a pattern, enclose it within square brackets '[>]'. 

Note: If you are searching using Any as the Field choice, each record of the index is searched as a single 

text phrase. This means that the ‘>’ criteria symbol will only match for the Page field. If you wish to use 

this symbol to match headings other than the Page field, you will need to search using a specific field or 

use the AND feature of Find to search each field that you wish to include in the search. 

& (ampersand) – match a whole number 

The ampersand symbol is used to match any whole number. A whole number is a number that does not 

include a decimal point or a comma. It will match any sequence of digits, in any order, and in any 

amount. If you preface the ampersand with a digit, then a match will only occur if a number is found 

that starts with that digit. For instance, if you enter the pattern (in the Find What text box): 

45& 

The following texts will match (matching portion shown in bold). 

I have entered 450 index entries. 

There are 4500 records in the database. 

There were 45000 people that showed up for the rally. 
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Note that if there had been a comma in the number 45,000 in the last example, a match would not have 

occurred. If you want to search for an ampersand, enclose the ampersand within square brackets '[&]' 

and it will not be treated as a criteria symbol. 

~ (tilde) – match a word 

The tilde is used to match a "word". A word in this case is any sequence of characters in the alphabet, in 

either upper or lowercase, and in any amount. A word cannot contain a space. If you want to search for a 

tilde, enclose the tilde within square brackets '[~]' and it will not be treated as a criteria symbol. 

Pattern Matching Examples 

Patterns are formed by combining criteria symbols (described above) with normal text. The best way to 

describe how to use patterns is to provide some examples. For the example: 

The text being searched is: "The 12 quick brown (foxes)" 

The replacement text is "zzz". 

Note: Quotes, if shown, are only used to indicate that there is a leading or trailing space. 

 

Pattern Matching Text Result of Replacement 

* The 12 quick brown 

(foxes) 

zzz 

*The* & The 12 zzz quick brown (foxes) 

(~) (foxes) The 12 quick brown zzz 

quick quick The 12 zzz brown (foxes) 

quick* quick brown (foxes) The 12 zzz 

& ~ 12 quick The zzz brown (foxes) 

[vwxyz] w The 12 quick brozzzn (foxes) 

[!A-Z hquic]~ brown The 12 quick zzz (foxes) 

quick & <no match> n/a 

& quick 12 quick The zzz brown (foxes) 

(&) <no match> n/a 

?&? " 12 " Thezzzquick brown (foxes) 

[b]~ brown The 12 quick zzz (foxes) 

~ # The 1 zzz2 quick brown (foxes) 

 

Notice that the search text, "the", is very different from the search text "*the*". If you use "the" in a 

replace operation, only the word "the" will be replaced with the replacement text. If you use "*the*", the 

whole field containing the word the will be considered a match and therefore the entire contents of the 

field will be replaced. 

If you want to include a criteria symbol as a literal character in your search text, enclose the criteria 

symbol within square brackets. Examples: [*], [~], [&], [#]. 

Another Example 

To find all acronyms in your index that are enclosed in parentheses use the pattern “([A-Z]*[A-Z])” This 

will only find text within a parentheses and which start and end with a capital letter. 
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Pattern Groups 

What are Pattern Groups? 

Pattern groups are portions of a pattern that can be used during the replacement of text to represent a 

found part of a pattern. Pattern groups are created by enclosing part of a pattern within braces '{ }'. The 

braces are ignored except for acting as a way of specifying a portion of the pattern to be used later. 

Using Pattern Groups 

SKY Index allows you to define any number of pattern groups, but only the first nine may be referenced 

for use in replacement text later. This makes it useless, but not an error, to create more than nine 

pattern groups. Pattern groups are numbered according to the location of the opening braces within the 

pattern. Pattern groups can be nested within another pattern group. 

During replacement of text, you can insert the text that matched a particular pattern group by entering 

a number 1-9 enclosed within braces into the Replace With text. For example, {2} would represent the 

text that matched the second pattern group. The best way to help you understand how this works is with 

a very simple example. Let us assume that the text being searched is: 

indexing is a demanding profession 

and that the pattern entered was: 

{~} {~}{*} 

The pattern will match the first two words encountered in the text being searched. In this case they are 

"Indexing" and "is". It will then match all trailing text. In this case that is " a demanding profession". By 

using pattern groups you can create a question out of the original text by using the following Replace 

With text: 

{2} {1}{3}? 

{1} represents what was matched by the first pattern group which is "Indexing" and {2} represents what 

was matched by the second pattern group which is "is" and so on. The question mark simply gets added 

to the end. The final result is: 

is indexing a demanding profession? 

Pattern Group Zero {0} 

The pattern group {0} is a predefined pattern group that represents all of the matching text regardless of 

whether other pattern groups exist or how many exist. For instance, if you entered the pattern: 

{??}/{??}/{??} 

to find dates in your index, pattern group {1} would contain the month, pattern group {2} would contain 

the date, pattern group {3} would contain the year, and pattern group {0} would contain the entire date 

including the forward slashes. 
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Limitations 

Pattern Groups 1 through 9 Don’t Include Character Styling 

With the exception of pattern group zero ‘{0}’, pattern groups contain text only. They never contain 

character style information. Consequently, using pattern groups within formatted text can sometimes 

produce unexpected results. For example if you have the following formatted text: 

My example formatted text 

Internally, this is represented like this in SKY Index:  

/b1My example /i1formatted /i0text/b0 

Any pattern you use to replace text will contain the text only. So if you attempt to swap ‘example’ and 

‘formatted’. You will end up with ‘formatted’ in bold only because the italicized word is removed and a 

non-formatted word is placed inside text that already has bold formatting applied. Performing the swap 

would work out fine if both ‘example’ and ‘formatted’ where both in bold style only. 

You cannot use both subsearches and pattern groups at the same time 

Because the use of Boolean AND or OR with pattern groups could lead to overlapping and potentially 

invalid pattern groups, SKY Index will not allow you to use pattern groups along with the AND, OR, or 

PLUS operators. The work around for this is to first create a group using your subsearches and then 

perform your replace operation on the group using a single search pattern. 

Another Example 

Let’s say that you’ve entered many entries of bird names using the form “common name (scientific 

name)”. Later you decide that you want to italicize all of the scientific names. Here is how you would do 

it: 

Note: This example assumes that you have either created a group of all entries you wish to modify 

or that there are no entries containing trailing parentheses that you do not want to modify. If neither 

case is true, Find Next with Replace should be used rather than Replace All in step 5. 

1. Open the Replace Dialog by choosing Search>Replace 

2. In the Find What textbox, type {*}({*}) – notice that the parentheses are not included in the 

second pattern group. 

3. Then create four replace strings using the Plus operator like this: 

 

Replace Text Description 

{1} The part of the found text that matches the first pattern group. This is 

the common name. 

( a left parenthesis 

{2} 

Also choose “Italic” 

from the Style list. 

The part of the found text that matches the second pattern group. This 

is the scientific name. You need to choose Italic from the Style list to 

change the style of this text to italic. 

) a right parenthesis 

4. Click Find 

5. Click Replace All 
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Some Potentially Useful Patterns 
 

Pattern Description 

(&) A number enclosed within parenthesis 

(*) Any text enclosed within parenthesis 

[jfmasond][aepuco][nbrylgptvc]. Abbreviated months of the year (jan., feb., mar., apr., 

may., jun., jul., aug., sep., oct., nov., dec.). Note: This is 

likely to match only these abbreviations, but can match 

other character sequences like: jab. This is useful if a 

search is restricted to the page field and if abbreviated 

months have been used as an identifier of some sort. 

{*}:{*} If used on locators of the form Volume:Page, the first 

pattern group {1} will represent the volume label and the 

second {2} will represent the page. 

<& Any number, but only if it appears at the beginning of the 

searched text. 

{??}/{??}/{??} Can be useful to locate dates in the form mm/dd/yy and to, 

for instance, change the year to a four digit format by 

using a Replace With text of: {1}/{2}/19{3} 

[1-9]& A number that does not start with a zero. 

[0]& A number that starts with a zero 

&-& If used in the Page field will find all page ranges. 
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Chapter 

19 
Creating Groups 

Overview 

Groups are simply a subset of the index. For instance if you find all locators in the index that fall in the 

range twenty one through forty and display only those records, that is a group. In its simplest form, a 

group would be a collection of records that contain a word or phrase, but there are many ways to create 

groups with SI7 and knowing how to create them can be a very valuable tool during editing of your 

index.  

Group on Locator 

The Group on Locator function allows you to create a group of records that contains only the range of 

locators that you specify. 

 

 

Group on Locator dialog 
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Grouping Records by Locator 

To create a group of records that contain a specific range of locators, do the following: 

 Choose Group>Group on Locator. The Group on Locator dialog box will appear as shown above. 

 Enter the page number and, if desired, Chapter, Volume, or section labels of the locators that 

you wish to group on. 

 Click OK. 

A group will be created containing only records that have locators in the range that you specified. 

Options 

Page number   The range of page numbers that you wish to create a group on. You may include a page 

prefix or suffix if desired. See Locator Format for more information on how SKY Index handles 

locators. 

Volume (Sec. 1)   An optional volume label that, if specified, will restrict your group to a single volume. 

Chapter (Sec. 2)   An optional chapter label that, if specified, will restrict your group to a single 

chapter. 

Section 3-9 – An optional section label that, if specified, will restrict your group to sections that match 

the text that you’ve entered. 

Include all pages in a page range – If checked, SI7 will examine page ranges and if the range 

includes any locator within the range that you’ve specified for ‘Page number’, it will be included in 

the group. For example, if you specify that the group should include pages 5 to 10 and SKY Index 

encounters a locator such as 4–12, that locator will be considered a match because it includes 

locators that match your specified range. 

Include cross-references in the group – If checked, all cross-references will be included in the group. 

If not checked, no cross-references will be included. 

Keyboard Shortcut: Alt+Ctrl+O 

See also: Grouping on Text; View Grouped 

Notes 

You can group on a range of Roman numerals by entering a Roman numeral in both Page Number 

textboxes. You cannot enter a range that contains both Roman and Arabic numbers. 

Grouping on a Word or Phrase 

There are times when you would like to view a subset of the index that contains only a certain word or 

phrase. The Group on Text function allows you to create such a subset. 

 

 

Group on Text dialog 
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Grouping on Text 

To create a group containing only the text that you specify, do the following: 

1. Choose Group>Group on Text. The Group on Text dialog will appear as shown above. 

2. Enter the text that you wish to create a group on. 

3. Click OK. 

Options 

You can use pattern matching when creating your group. The following pattern matching characters 

may be used: 

 

Characters Matches 

? Any single character 

* Zero or more characters 

# Any single digit (0 – 9) 

[charlist] Any single character in charlist 

[!charlist] Any single character not in charlist 

 

Notes: 

 If you want to enter a question mark (?), asterisk (*), pound sign (#), or left square bracket ([) as 

part of your search phrase, you must enter them within square brackets like this [?], [*], [#] or 

[[]. 

 The Group on Text function does not ignore formatting. If you search for “italic style” and there 

is a heading in the index: “italic style”, the text you are searching for will not be found as a 

match. Use the Find function with Group Results turned on to find text without regard to 

formatting. 

 This function will always start with an ungrouped index when you use it and so you cannot get a 

group within a group as you can with the Find command. 

Tip: The Group on Text command is significantly faster than creating a group with the Find/Replace 

function. You should use Group by Text unless features of the Find/Replace function are needed. 

Keyboard Shortcut: Alt+Ctrl+G 

See also: Finding Text 

Grouping on the Current Heading or Selected Text 

Grouping on the Current Main Heading 

If you wish to create a group of all index entries that contain the current main heading, choose 

Group>Group on Main Heading. This will create a group of all index entries in the index that match the 

current main heading. The current main heading is the main heading of the current record in Data 

Entry View and is the main heading of whatever heading is currently displayed in the Heading textbox 

when in Edit View. To exit the group, choose Group>Ungroup or press Ctrl+Shift+U. 

Keyboard Shortcut: Shift+F6 
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Group on the Text under the Grid Marquee 

If you are in View Mode (that’s when there is no flashing cursor) you can group on the text that is under 

the grid marquee by choosing Group>Group on Current. 

Keyboard Shortcut: Ctrl+Shift+F3 

Grouping on the Current Word or on Selected Text 

If you are in Text Edit Mode (that’s when you have a flashing cursor) you can group on the word that’s 

under the cursor or, if you have selected some text, on the selected text by choosing Group>Group on 

Current. 

Keyboard Shortcut: Ctrl+Shift+F3 

Creating a Group with Find 

You can use the Find function of SI7 to create Groups. This gives you more flexibility than other 

methods since there are more attributes that you can use to narrow your grouping. 

To create a group using Find, choose Group>Group using Find. The Find dialog will appear. Set your 

search criteria and click Find. A group of all entries matching your criteria will appear. 

For more extensive information on finding text, see: Finding Text 

Grouping on the Active Label 

There will likely be times when you want to see only the index entries that have been labeled with the 

active label. To do this, you can choose Labels>Group on Active Label. All index entries that are not 

labeled with the active label will be removed from the current view leaving only those records that are 

labeled with the active label. 

Keyboard shortcut: Ctrl+Shift+M 

Creating a Group of all Orphan Subheadings 

Although SKY Index automatically merges orphan subheadings by default, you may elect to turn off that 

feature and merge orphans manually. Another reason for examining orphan subheadings is that you 

may want some of those orphans to be combines with their parent heading rather than promoted. If you 

wish to see a group consisting of all orphan subheadings, choose Group>Orphan Subheadings. 

 

 

Group on Orphan Subheadings Dialog 
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Chapter 

20 
Changing Text Style or Case 

Applying Character Styles (Bold, Italic, Underline, etc.) 

SI7 supports six character styles: bold, italic, underline, strikeout, superscript, and subscript. Character 

styles can be applied with the keyboard or the mouse. The examples below assume you are applying a 

bold character style. To apply italic or some other character style, substitute the appropriate style. 

Applying a Character Style as You Type 

1. Press the keyboard shortcut for the format that you wish to apply. This inserts a format on code. 

2. Type the text that you wish to format. 

3. Press the keyboard shortcut for the format that you are applying again. This inserts a format off 

code. 

Applying a Character Style to Selected Text 

To apply a character style to selected text, do the following: 

1. Select the text to format. 

2. From the Format menu, choose the style you wish to apply or use one of the keyboard shortcuts 

shown below. 

Applying a Character Style to All Text in a Column of the Index 

To apply a character style to all the text in a column of the Data Entry Grid, do the following: 

1. Click on the column header 

2. From the Format menu, choose the style you wish to apply or use one of the keyboard shortcuts 

shown below. 

The selected style will be applied to all of the text in that column. 

Keyboard Shortcuts for Applying Character Style 

Bold: Ctrl+B 

Italic: Ctrl+I 

Underline: Ctrl+U 

Superscript: Ctrl+Shift+P 

Subscript: Ctrl+Shift+B 

Strikeout: Ctrl+Shift+K 
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About Strikeout and Small Caps Character Styles 

The strikeout and small caps character styles cannot appear simultaneously in the index. Internally, 

small caps is handled as strikeout text, but you can configure SKY Index to generate strikeout text as 

small caps. See the description of the Preferences dialog for more information. 

Tip: You should be aware that if you type an uppercase letter, it will be a full size capital letter in the 

generated index. If you want a ‘small’ capital letter, you must type a lowercase letter. 

Changing the Case of Text 

Overview 

There are occasions when you may want to change the case of an index entry. For example, if you have 

the AutoCapitalize feature enabled and you enter the surname deLaWar, the initial "d" will be 

capitalized. Surnames that start with a lowercase letter are relatively rare, but it is easy to fix this 

problem using the First Letter To Lower function. This and the other case-changing functions are 

described in the following sections. 

Tip: You can use all of these functions on more than one record at a time by selecting records prior to 

invoking the function. If you use this method, you will be asked which field the function will be applied 

to before performing the function. 

Tip: You can use all of these functions on an entire grid column by selecting the column prior to invoking 

the function. 

Uppercase 

This function changes the case of selected text to uppercase. If the grid is not in Edit mode, the entire 

contents of the current grid cell are changed. If the grid is in Edit mode and no text is selected, the 

character to the right of the cursor is changed. 

Keyboard Shortcut: Ctrl+E 

Lowercase 

This function changes the case of selected text to lowercase. If the grid is not in Edit mode, the entire 

contents of the current grid cell are changed. If the grid is in Edit mode and no text is selected, the 

character to the right of the cursor is changed. 

Keyboard Shortcut: Ctrl+L 

Change Case 

This function changes the case of selected text to the opposite of its current state. If the grid is not in 

Edit mode, the entire contents of the current grid cell are changed. If the grid is in edit mode and no text 

is selected, the character to the right of the cursor is changed. 

Keyboard Shortcut: Ctrl+Shift+H 

First Letter to Lowercase 

This function changes the first letter of the word containing the text cursor to lowercase. 

Keyboard Shortcut: Ctrl+W 

  



 Changing Text Style or Case 133 

First Letter to Uppercase 

This function changes the first letter of the word containing the text cursor to uppercase. 

Keyboard Shortcut: Ctrl+R 

Title Case 

This function changes the first letter of each word of the selected text to uppercase. Any words in the 

Ignored Words list (such as ‘of’) will not be capitalized. 

Keyboard Shortcut: Ctrl+Shift+T 

Notes 

This function will only convert case from lower to upper. It will not convert from upper to lower (accept 

those words in the ignored words list) in order to avoid lowercasing words that should be in upper case 

such as acronyms. If you are trying to change text that is in all upper case to Title case, first use the 

Lower Case function and then the Title Case function. Creating a macro might be useful if you need to 

do a lot of this. 

Note about all Functions that Change Case Based on Words 

SKY Index considers a space and the following characters to be word delimiters: 

 

.  period 

( left parenthesis 

[  left bracket 

{  left curly brace 

@  commercial at sign 

"  straight quote 

'  apostrophe 

“ beginning double quote 

‘ beginning single quote 

-   hyphen 
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Chapter 

21 
Changing the Sorting of or Adding a Note to a Heading 

Overview 

There will be times when you will need to override the default sorting of a heading for a number of 

reasons. For example, you may wish to sort “11” as if it were spelled out “Eleven” thus making it sort 

with the E’s. To do this with SI7 you will use hidden text or a combination of both hidden text and 

ignored text. 

For most resorting that you need to perform, you’ll be able to simply add hidden text at the beginning of 

the heading you wish to resort. If we use the same example described above, we would simply type in the 

text ‘eleven’ in front of ‘11’ and then assign that text the Hidden Text attribute. Below is an example 

with text within curly braces being hidden text 

{eleven}11 

Leaving the ‘11’ is unlikely to cause any sorting issues with surrounding headings, but if it does, you 

would simply instruct SI7 to ignore the ‘11’ by applying the Ignored Text attribute to it. Below ignored 

text is shown within square brackets. 

{eleven}[11] 

This text will be sorted as if the text of the heading was ‘eleven’ even though what the reader of the 

index will see is ‘11’. 

How to apply hidden and ignored text is discussed below. 

Hiding Text (affects the sort, but does not print) 

The Hide Text command causes text to be hidden during the printing process, but is still used by sorting 

routines. The text will not appear in the generated index, but will still be used when sorting the index 

entry it is contained in. You apply the Hide Text attribute in the same way as you would apply 

formatting attributes such as Bold or Italic. When you apply the Hide Text attribute, the hidden text will 

appear in a different color in the data entry grid. This is blue by default. 

Applying the Hidden Text Attribute 

To hide text in your index, do the following: 

1. Select the text to be hidden. 

2. Choose Format>Hide Text. 

Keyboard Shortcut: Ctrl+T 

See also: Ignoring Text; Adding a Note to a Heading 
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Ignoring Text (prints, but does not affect sorting) 

The Ignore Text command causes text to be ignored by sorting routines. The text will appear normally in 

the generated index, but will have no effect on the sort order of the index entry it is contained in. You 

apply the Ignore Text attribute in the same way as you would apply formatting attributes such as Bold 

or Italic. When you apply the Ignore Text attribute, the ignored text will appear in a different color in 

the data entry grid. This is green by default. 

Applying the Ignoring Text Attribute 

To ignore text in your index, do the following: 

1. Select the text to be ignored. 

2. Choose Format>Ignore Text. 

Keyboard Shortcut: Ctrl+K 

See also: Hiding Text; Adding a Note to a Heading 

Tip: If you wish to ignore the first word of a heading so that it does not affect sort – for example to 

ignore the word ‘The’ in a title – be sure to also ignore the space that follows the word so that the 

heading does not end up sorting at the top of the index. 

Adding a Note to a Heading (does not print or affect sort order) 

The Note Text command causes text to be both ignored and hidden. (Please note that although the text is 

hidden in the generated index, it is visible in the Data Entry Grid and Preview Pane.) The text will have 

no effect on the sort order of the index entry it is contained in and will not appear in the generated index. 

It will, however, appear in the Data Entry Grid and Preview Pane. You apply the Note Text attribute in 

the same way as you would apply formatting attributes such as Bold or Italic. When you apply the Note 

Text attribute, the Note text will appear in a different color in the data entry grid. You can change this 

color using Preferences. 

Applying the Note Text Attribute 

To ignore text in your index, do the following: 

1. Select the text you wish to be a note. 

2. Choose Format>Note Text. 

Keyboard Shortcut: Ctrl+Shift+O 

See also: Ignoring Text; Hiding Text 

Plain (removing all formatting from text) 

To remove all formatting, including font attributes, from the currently selected text, choose 

Format>Plain. 

Keyboard Shortcut: Alt+F10 
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Chapter 

22 
Edit View 

Overview 

The new Edit View of SI7 allows you to edit your index at a heading level rather than a record level. 

Editing headings rather than records is more visually intuitive for certain types of editing and requires 

few keystrokes in many cases too. 

Although the data entry grid is still where you’ll spend most of your time in SKY Index, you should learn 

the benefits of Edit View to ensure that you are working as efficiently as you can. The envisioned use for 

Edit View is for the editing that occurs after you’ve finished your primary data entry. This is where you 

are shaping your index - verifying terminology, checking consistency, and fine tuning the structure of 

your index. 

Working in Edit View 

To enter Edit View, choose View>Edit View. The keyboard shortcut is Shift+F10. This is a toggle and if 

you press Shift+F10 again, you will be returned to Data Entry View (the grid). Once you’ve entered Edit 

View, you will see the screen below. 

 

 

Edit View 
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There are three fields for editing index entries: 

Heading – This is the heading that is currently highlighted by the marquee in the Preview of the index. 

Locators – This is where all locators for the current heading will appear and where you can edit them. 

Each locator is separated from the previous locator with a comma and a space. 

Cross-references – This is where all cross-references, separated by a semicolon and a space, will 

appear and where you can edit them. 

Editing 

Editing is similar to editing in Data Entry View. As soon as you move the marquee in the Preview to a 

new entry, that entry will appear in the textboxes described above ready for you edit them. The heading 

text will be selected by default. If you wish to replace that text with new text, just start typing. If you 

wish to edit the existing text, pressing RightArrow will unselect the heading text and move the text 

cursor to the end of the text. Pressing LeftArrow will unselect the heading text and move the text cursor 

to the beginning of the text. At this point you simply type your changes. 

Applying your Changes to the Index 

When you edit any of the text in any of the three textboxes in Edit View, those changes will be applied to 

the index when you do any of the following: 

 Press Enter 

 Use any navigation key to move to a different heading (Example: UpArrow, PgDn) 

 Switch to Data Entry View 

 Use an Edit Command 

Things to Note about Edit View 

Here are a few tips that may help you become more efficient in Edit View: 

 Pressing tab while in the Heading textbox will select the first locator in the Locators textbox. 

Pressing tab again will select the next locator, if there is one, or will move you to the cross-

references textbox if no additional locators exist,. 

 Pressing tab while in the Locators textbox will select the first cross-reference in the Cross-

references textbox. Pressing tab again will select the next cross-reference, if there is one, or will 

move you to the Heading textbox if no additional cross-references exist. 

 When adding new locators, you don’t have to include both a comma and a space, just a comma is 

enough. 

 When deleting locators, don’t worry about deleting the comma between locators, SKY Index will 

remove that automatically 

Adding New Headings in Edit View 

Although Data Entry View is the recommended view for adding index entries, if you only need to add one 

heading or a few headings, you can do so using the following commands: 

New Heading – Creates a new heading at the same level as the Preview marquee. A new heading will 

be added with the text “<Edit Me>”. That text will be selected and you can simply start typing to change 

the text to your desired heading text. 

New Child Heading – Creates a subheading under the heading the marquee is over in the Preview. 

The new subheading will be added with the text “<Edit Me>”. That text will be selected and you can 

simply start typing to change the text to your desired heading text. 
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Miscellaneous 

Directly after the ‘Heading:’ label for the heading textbox, SKY Index lists all parent headings for the 

currently highlighted entry in the Preview. Each heading level is separated from the other with an 

orange em dash. 

In Edit View, there is no need to hold down Alt+Ctrl when using the navigation keys to move around in 

the Preview of the index as is needed in Data Entry View. Pressing them will still work, however. 
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Chapter 

23 
Preferences 

Overview 

Preferences are settings that are not specific to any particular index. That is, the settings are in effect 

for all indexes you work on. These settings have been split into four groups: 

General – Settings that are not part of the remaining three groups. 

Program Font – Lets you specify the font and font size used while editing your indexes. 

File Locations – Lets you specify the default location for special folders used by SKY Index. 

User Info – Your name and initials 

The settings for each of these groups are discussed in detail in this chapter. 

Common Options 

Revert – Will restore all settings for the current tab back to the state it was in when you first navigated 

to that tab. 

Question mark – Will provide help on the tab of the dialog that is currently active. 

OK – Will save your changes and close the dialog 

Cancel – Will abandon any changes you have made and will close the dialog. 
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General Preferences 

 

 

Preferences Dialog – General tab  

Configuring Options that affect all Indexes 

To configure general options, do the following: 

1. Choose Options>Preferences. 

2. Set your options as desired. 

3. Click OK. 

General Preferences 

Options 

Automatically Load Last Index – If you frequently work on one index that takes more than one 

session to complete, it is convenient if the last index that you worked on is automatically opened 

when you start SKY Index. This is the default behavior of SKY Index. 

Seek Current Record When Changing Views – If checked (the default), the entry that is current 

when you choose a new view mode will be located and made current in the newly selected view mode. 

This is generally very desirable. If, however, you have a very large index and a slow computer, it can 

take some time to locate the record and you may find it more convenient in this case to disable the 

default action. 

Proportional grid scrolling – If checked, SKY Index will allow you to scroll the grid proportionally by 

dragging the thumbnail of the grids vertical scroll bar. This setting also affects the Preview Pane's 

scroll bar. 
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Note: If your index exceeds about 32,000 records, this feature will be turned off automatically to ensure 

efficient movement within the grid and preview pane. 

Display Preview Pane on the Left – If checked, the Preview Pane will be displayed on the left side of 

the data entry grid. Otherwise the grid will be displayed above the data entry grid. 

Include sort information when embedding – If checked, SKY Index will include forced sorting 

information when embedding entries into a word processor using drag and drop. 

Use Metric System Measurements – If checked, millimeters will be used as the default measurement 

for those configuration items where it makes sense to do so. 

Adjust Punctuation – If checked, trailing punctuation will be adjusted as follows: 

 Any comma or period that occurs directly after a closing single or double quote or apostrophe will 

be moved inside the quote at the end of an index heading.  To force commas outside quotes with 

this option checked, use a translation for the trailing quote character. 

 Any comma that follows a question mark or exclamation mark will be removed. 

 Any period that follows another period will be removed.  To enter an ellipsis character with this 

option checked, use the ellipsis character in the Character Map or the Ctrl-Alt-Period shortcut. 

Use Alternate Mouse Wheel Detection – If checked, mouse wheel movements will be left up to the 

mouse driver. If not checked, SKY Index will attempt to detect mouse wheel movement on its own. 

You should leave this item unchecked unless you are having trouble scrolling with the mouse wheel. 

Please note that you cannot scroll the Preview Pane with the mouse wheel while in Edit View. 

Generate strikeout text as small caps – If checked, any text that is formatted as strikeout will be 

converted to small caps when the index is generated. 

Start in Data Entry View – If checked, SKY Index will start in Data Entry View. If not checked, SKY 

Index will start in Edit View. 

Data Entry Options / Text Colors 
 

 

Preferences Dialog – General tab (Data Entry section)  
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Options 

Immediately verify cross-references – If checked, SKY Index will verify the existence of cross-

references as soon as you enter them. If the referenced entry does not exist, you can ignore the error, 

edit the cross-reference, or automatically add a new entry that satisfies the cross-reference. 

Next page reminder – If checked, SKY Index will track how many entries you make per page and will 

display a warning that you may have forgotten to change the page number if you significantly exceed 

the average. 

Note: The Next Page Reminder function can be helpful in reducing the likelihood of this happening. 

If you enable this feature, the average number of entries you make per page will be noted, and, if you 

go significantly beyond this number, a message will be displayed asking if you have forgotten to 

change the page number. 

Tip: If you have forgotten, you can use the Change Page Number function to change the page 

number of the entries that were incorrectly entered. 

Formatting replaces page field contents – If checked, when you apply formatting to the page field 

and the data entry grid is in view mode, the contents of the page field will be erased and the proper 

coding to start the specified formatting will be entered. 

Note: Normally when the data entry grid is in view mode and you apply formatting such as bold or 

underline, the entire field contents are changed to reflect the specified formatting. This may not be 

the most efficient action in the page field for certain indexes. SKY Index gives you the option to alter 

this default mode of operation. 

Automatically create maiden name entries – If checked, SKY Index will automatically generate 

maiden name entries during data entry. 

Smart Quotes – If checked, any straight quotes that you type during data entry will be converted to the 

more formal curly quotes that tilt in toward the text they surround. This option affects both single 

and double quotes, and the apostrophe used when forming contractions. 

Remove double spaces – If checked, all occurrences of two consecutive spaces will be changed to a 

single space. This option is useful if you find that you sometimes create two spaces by mistake while 

typing. 

Use Ctrl+A for Append New – If checked, Ctrl+A will be used for Append New and Ctrl+Ins will be 

used for Select All. This option is provided for backward compatibility with v6.0 of SKY Index. 

Use Ctrl+P for Duplicate and Swap – If checked, Ctrl+P will be used for Duplicate and Swap instead 

of for Print Draft. This option is provided for backward compatibility with v6.0 of SKY Index. 

Use in-place Edit View editor – If checked, the normal Edit View editor that appears at the bottom of 

the screen will not appear. Editing will occur in-place by pressing F2 or Enter. 

Paste Plain Text Only – If checked, SKY Index will ignore Rich (formatted) text in the Windows 

clipboard and will, instead, use only plain text from the clipboard. If you have trouble pasting text 

from a PDF or word processor document, try using this option to cure the problem. 

Reset Tips – SKY Index includes a number of helpful tips for beginners. When these tips are displayed, 

you are given the opportunity to suppress the display of the tip in the future. If you have done this 

and wish for the tips to be displayed again, click Reset Tips button. Note: You cannot reset 

individual tips. You can only reset all tips. 

Hidden text color – The color that hidden text will be displayed in. Click the Change button to alter 

this color. 

Ignored text color – The color that ignored text will be displayed in. Click the Change button to alter 

this color. 
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Note color – The color that will be applied to note text. Note text is text that does not sort and does not 

print in the final generated index. It does, however, appear in the grid and Preview Pane. Click the 

Change button to alter this color. 

Promote / Demote / Split 
 

 

 Preferences Dialog – General tab (Promote/Demote/Split section) 

Options 

Promote Separator – When you use the Promote function, you can specify the character or characters 

that you want to be used when combining the child heading with its parent heading. By default a 

comma and a space (, ) are used. 

Demote Separator – When you use the Demote function, you can specify the character or characters 

that are used to determine the text that will be demoted when separating a single field into two 

fields. By default, a comma and a space (, ) are used. 

Split Separator – Specifies the character or characters that act as a delimiter when using the Split 

command. 

Split Count – Specifies how many delimiters the Split command should count backwards from the end 

of the heading text before splitting the text. 

File Locations 

Many indexers like to keep their data files in specific locations on their computer's hard drive. Although 

we strongly suggest using SKY Index's default settings, you may specify where the files that SKY Index 

generates are stored or created by default using the File Locations tab of the Program Options dialog.  
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Preferences Dialog – File Locations Tab 

Specifying File Locations 

To specify file locations, do the following: 

1. Choose Options>Preferences. 

2. Click the File Locations tab. 

3. Enter the paths for your indexes, backups, and Templates. 

4. Click OK. 

Options 

Indexes – Specifies the path that will be the default path when you choose to open or create an index. 

By default, this is  c:\My Documents\SKY Index\. It is strongly recommended that you do not 

change the default path. 

Backups – Specifies the path that will be the default path when you backup an index. By default, this is 

c:\My Documents\SKY Index\Backups\. If you have a removable media device such as a Zip drive 

that you normally leave a disk in, you can safely change the path to point to that device. However, it 

is not recommended that you change this path to point to a standard floppy drive since your floppy 

drive is likely to not have a disk present and because large indexes can exceed the capacity of a 

standard floppy. You can always override this default setting when you perform a backup. This is 

simply the default path, not the required path. 

Templates – Specifies the path that will be used for storing index configuration information that you 

save separately from the index itself. This includes index templates, acronyms, macros, and 

translations. By default, this is c:\My Documents\SKY Index\Templates\. It is strongly 

recommended that you do not change the default path. 
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User Dictionary – Specifies the path, including the filename, of the dictionary file that will be used 

when you make additions to the user dictionary during spell checking. By default, this is c:\My 

Documents\SKY Index\Templates\UserDictionary.dic. You can switch to a different user dictionary 

file by changing this path. 

Create a new user dictionary – Allows you to create a new user dictionary file. This may be useful if 

you work on indexes in different specialty fields such as medicine, botany, and law. You can switch 

between two or more user dictionaries by changing the user Dictionary Path. 

The browse button  opens a Choose Path dialog allowing you to change the current path. 

Tip: User dictionary files are simple text files that contain a single word on each line of the file. If 

you have a list of single word terms available for an index in a field that uses uncommon words, 

you can create a user dictionary by creating a text file that contains all of these terms. Give the text 

file a filename extension of ".dic". Place the file in the Templates directory and then change the User 

Dictionary path to point to the new file. 

Word Processor – Choose your word processor from this drop-down list box. When you make a 

selection from this list box, the Open Path text box will be filled in automatically. If your word 

processor is not listed, choose (Custom). If you choose (Custom), you will need to enter the path 

yourself or use the Browse function, described below, to locate your word processor's program file. 

Open Path – The path to your word processor is filled in automatically unless you choose (custom) as 

the word processor. If you choose (custom), enter the full path including the drive letter to your word 

processors program file in this text box. (A program file ends with the filename extension .exe.) If 

you don't know the path to your word processor, click the Browse button to find the program file with 

a Files dialog box. 

Browse – If you need to fill in the path to your word processor and you don't know the path, you can 

click this button to bring up a Files dialog box.  Use the dialog box to navigate your hard drive to find 

your word processor's program file. (A program file always ends with the file extension .exe.) 

When you find your word processor’s program file, click OK. The path to your word processor will be 

filled in automatically. 

Note: If you need to manually enter the path to your word processor, please be aware that this is 

not the path to SKY Index or to your index file, but to your word processor's program file. Program 

files are always located in a subdirectory of “C:\Program Files”. 

Tip: If you can’t find the path to your word processor’s executable file try using the Find function of 

Windows. If you don’t know the file name of your word processor’s executable file, call the software 

manufacturer to learn the name of the executable file and then use the Find function to locate it. 
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Program Font 

Program Font 

Indexers who have diminished eyesight, or who have monitors that do not display a clear image may 

wish to change the font and/or font size used by SKY Index. The selected font and font size is used by the 

data entry grid, preview pane and some other parts of the main program screen. 

 

 

Preferences Dialog – Program Font Tab 

Configuring the Program Font 

To configure the program font, do the following: 

1. Choose Options>Preferences. 

2. Click the Program Font tab. 

3. Set the font and font size. 

4. Click OK. 

Options 

Font – Specifies the font that you wish to use for data entry in SKY Index. 

Font Size – Specifies the font size that you wish to use for data entry in SKY Index. 

Use this font and font size instead of the index settings – If checked, SKY Index will use the 

settings of this dialog for all heading levels when displayed in the Preview Pane. If not checked, The 

Preview Pane will appear using the settings for font, font size, space before, and space after that you 

have made in the Heading Style tab of the Index Options dialog. 
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User Info 

There may be times when you work on an indexing project that is large enough to require a team of 

indexers. The indexer that does the final editing may want to be able to see what member of the team 

added or edited certain records. In order to keep track of this, SKY Index requires you to enter your 

name and initials when you first run the program. Your initials are then added to each entry you make 

and to each entry that you edit. If you wish to change your initials, you can change them here. 

 

 

Preferences Dialog – User Information Tab 

Specifying User Information 

To specify the name and initials of the program’s user, do the following: 

1. Choose Options>Preferences. 

2. Click the User Info tab. 

3. Enter your name and initials. 

4. Click OK. 

Options 

Indexer – Enter your name here. Although the program does not currently use this information, it may 

be used in a future release. 

Indexer Initials – Enter your initials here. Your initials are saved with a record each time you create 

or edit it. 

Reset Creator tag – Resets the creator field of all index entries to initials that you specify. 

Reset Editor tag – Resets the editor field of all index entries to the initials that you specify. 
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Notes 

When you start SKY Index for the first time, you will be presented with the User Information dialog 

asking you to enter your name and initials. This information is used to keep track of who entered and 

edited index entries and is useful for team projects. The User Information dialog is shown below. 

 

 

User Information Dialog 
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24 
Document Options 

Overview 

The Document Options dialog provides access to options that affect how the general document of the 

index is styled. This includes page size, margins, headers and footers and the file format used when 

writing the index to disk. 

For those settings of this dialog that specify a size, the size can be specified in the American/British 

standard of inches or the Metric system using mm or cm. The default setting can be specified using the 

Preferences dialog. Even if you have chosen the Metric system as the default scale system, you can enter 

sizes in inches by simply typing a quote (“) after the size or by typing ‘in’ after the size. Conversely, you 

can also specify millimeters by including ‘mm’ after a size or centimeters by including ‘cm’ after a size. 

A preview of the setting made using the Margins and Layout and Headers and Footers tabs of this dialog 

is shown in the Preview area at the right side of the dialog. Margins are shown as a dotted gray line. 

This line is usually only visible between columns. Column boundaries are shown with a dotted blue line. 

The preview shows you headers and footers. The actual header and footer text are shown scaled to 

approximate relative size. The Left page header and footer captions are shown by default, but you can 

see the Right page captions by placing the insertion point cursor within the header or footer Right 

Caption textbox. 

The Revert button will restore all settings for only the current tab back to the state it was in when you 

first navigated to that tab. To change all setting of all tabs back to their original state, click the Cancel 

button. After you navigate away from a particular tab, those setting s become permanent unless you 

click Cancel. 

The question mark provides help on the tab of the dialog that is currently active. 

Details of each configurable document area are described in detail below. 

 

  



152    SKY Index 7.0 User’s Guide 

Headers and Footers 

You can define headers and footers for both the left hand and right hand pages of your printed index. 

Options for the placement and formatting of headers and footers are discussed in this section. 

 

 

Document Options – Headers and Footers Tab 

Configuring Headers and Footers 

To configure headers and footers, do the following: 

1. Choose Options>Document. 

2. Click the Headers and Footers tab. 

3. Make any desired changes to the configuration. 

4. Click OK. 

Options 

Header/Footer 
 

The settings you make will apply to either the header or the footer as specified in the tab bar above 

the settings. 

 

Right Page Caption – Specifies the header or footer text that will be printed on all right-hand (odd 

numbered) pages. If you do not check Mirror Margins in the Page Setup dialog, this text will be 

displayed on all pages. An example of your choice will be displayed in the preview window. Note: 

You may apply format attributes such as bold and italic. You may find it convenient to use the Text 
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Editor that can be invoked by pressing F2. 

Left Page Caption – Specifies the header or footer text that will be printed on all left-hand (even 

numbered) pages. If you do not check Mirror Margins in the Page Setup dialog this text will be 

ignored. An example of your choice will be displayed in the preview window. Note: You may apply 

format attributes such as bold and italic. You may find it convenient to use the Text Editor that can 

be invoked by pressing F2. 

Font – Specifies the font to use for the header or footer. An example of your choice will be displayed in 

the preview window. 

Font Size – Specifies the font size to use for the header or footer. An example of your choice will be 

displayed in the preview window. 

Border – Specifies whether to place a border (a horizontal line) below the header or above the footer. 

You may choose no border, a thin border, or a thick border. An example of your choice will be 

displayed in the preview window. Note: The thickness of the line may vary from one word processor 

to another. 

Alignment – Specifies whether to center the header or footer text or if the text will be placed on the 

outside edge of the page. An example of your choice will be displayed in the preview window. 

Page Numbering 

Alignment – Specifies where page numbers will be placed in a printed index. You may choose centered 

in the header, outside edge of the header, centered in the footer, or outside edge of the footer. (The 

outside edge is the unbound edge.) Your choice will be reflected in the preview window. 

Starting Page – Specifies the page number for the first page of the index. This should always be an odd 

number unless your index is not being printed on both sides of the page. 

Style – Specifies the style of the page numbers used when printing your index. You can choose either 

Arabic (1, 2, 3) or Roman (i, ii, iii) numbering. For most indexes this should be left in the default 

style of Arabic. If you do not want page numbers, choose Don’t number pages. 
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Margins and Layout 

The margins and layout tab allows you to specify the page size and orientation, how many columns your 

index will contain, and margins. A screen shot is shown below. 

 

 

Document Options – Margins and Layout tab 

Configuring Page Margins and Layout 

To configure page margins and layout, do the following: 

1. Choose Options>Document. 

2. Click the Margins and Layout tab. 

3. Make any desired changes to the configuration. 

4. Click OK. 

Options 

Page Size 

Predefined Page Formats – You may choose from four common page sizes or you may specify your 

own custom paper size. Your choices are: 

Letter - 8.5" by 11.0" 

Legal - 8.5" by 14.0" 

Executive - 7.25" by 10.5" 

A4 - 210mm by 297mm 
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Custom - You specify the size of the paper in the Width and Height text boxes. 

Width – Specifies the width of the paper in inches. Do not enter the inch symbol ("). The paper width 

that you specify must be a width that your printer supports. Consult your printer manual if you are 

unsure if your printer supports the paper size you are specifying. You will see an example of your 

choice in the preview window. 

Height – Specifies the height of the paper in inches. Do not enter the inch symbol ("). The paper height 

that you specify must be a height that your printer supports. Consult your printer manual if you are 

unsure if your printer supports the paper size you are specifying. You will see an example of your 

choice in the preview window. 

Columns – Specifies the number of columns for your printed index. You may specify one to six columns. 

If you want more than six columns, you can specify a higher number using your word processor 

(assuming that your word processor supports more than six columns). You will see an example of 

your choice in the preview window. 

Col. Spacing – Specifies the amount of blank space (in inches) to appear between columns in your 

index. Do not enter the inch symbol ("). 

Orientation – Specifies the orientation of the index when printed. You may choose either Portrait or 

Landscape. If you select portrait, the width of the paper is the narrowest part of the page. If you 

choose landscape, the width of the paper is the widest part of the page. You will see an example of 

your choice in the preview window. 

Margins 

Top Margin – Specifies the amount of space (in inches) to leave between the top of the page and the top 

of the body of the index. Do not enter the inch symbol ("). A header, if you specify one, will be placed 

within this area so it must be large enough to hold the header text. 

Bottom Margin – Specifies the amount of space (in inches) to leave between the bottom of the page and 

the bottom of the body of the index. Do not enter the inch symbol ("). A footer, if you specify one, will 

be placed within this area so it must be large enough to hold the footer text. 

Left Margin – Specifies the amount of space (in inches) to leave between the left edge of the page and 

the left edge of the body of the index. Do not enter the inch symbol ("). If you have checked Mirror 

Margins, this is the inside edge of the page. (The bound edge of the page.) 

Right margin – Specifies the amount of space (in inches) to leave between the right edge of the page 

and the right edge of the body of the index. Do not enter the inch symbol ("). If you have checked 

Mirror Margins, this is the outside edge of the page. (The unbound edge of the page.) 

Header (to edge) – Specifies the amount (in inches) to offset the top of the header text from the top of 

the page. If you enter zero, the header text will appear at the top of the printed page. If you enter a 

number larger than the Top Margin, the header will appear below the header area, or possibly not at 

all, depending on how your word processor handles headers. 

Footer (to edge) – Specifies the amount (in inches) to offset the bottom of the footer text from the 

bottom of the page. If you enter zero, the footer text will appear at the bottom of the printed page. If 

you enter a number larger than the Bottom Margin, the footer will appear above the footer area, or 

possibly not at all, depending on how your word processor handles footers. 

Mirror Margins – If checked, the left margin will be used as the inside (bound) margin and the right 

margin as the outside (unbound) margin for all printed pages. This is desirable if you are printing 

the index on both sides of the page. If checked, and if you choose to have page numbers printed at the 

outside edge of the header or footer, page numbers will be printed at the unbound edge of the page. 

Otherwise, page numbers will always be printed at the right edge of the page. 
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Output Format / Markup Tags 

Each publisher has their own set of requirements for index file formatting. The Output Format tab 

allows you to generate indexes using coding that will satisfy most publishers. Presets are included for 

commonly used coding schemes. The options available are described below. 

 

 

Document Options – Output Format/Markup Tags Tab 

Configuring Output Format and Markup Tags 

To configure Output Format or Markup Tag options, do the following: 

1. Choose Options>Document. 

2. Click the Output Format/Markup Tags tab. 

3. Make any desired changes to the configuration. 

4. Click OK. 

Output Format Presets 

The Presets list box provides several preset code settings for quick configuration. If you choose one of 

these presets, the markup tags, if any, for the selected style will be automatically filled in. If you wish to 

define your own set of markup tags, choose "<custom>". The available presets are: 

RTF – Generates a standard RTF file that includes information for bolding, italics, underlining, 

superscripting, subscripting, font, font size, paragraph spacing, paragraph styles, page size, 

margins, page orientation, headers, footers, and columns. You should use this setting if you are 

going to publish the index yourself. 
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RTF Plain – The same as RTF except it does not contain information for page size, margins, page 

orientation, headers, footers or columns.  

RTF Spaces – Provides a minimal set of RTF commands the will generate an index that does not 

use paragraph styles for indenting. Unlike RTF and RTF (No Headers), these RTF commands 

can be edited as desired. By default, this preset indents subheadings with two leading spaces. 

Each additional subheading level is indented two additional spaces. 

RTF Tabs – Provides a minimal set of RTF commands the will generate an index that does not use 

paragraph styles for indenting. Unlike RTF and RTF (No Headers), these RTF commands can 

be edited as desired. By default, this preset provides indents with tabs. 

UCP (University of Chicago Press) – Generates an index that uses coding required by the 

Chicago Press. 

ANSI – Generates an index that uses coding specified by ANSI (American National Standards 

Institute). 

Plain Text – Generates a standard ASCII file which can be imported into any word processor. 

HTML – Generates an index that can be viewed with a Web browser. 

Quark Xpress – Generates an index that can be used with the popular publishing program Quark 

Xpress. 

 (Custom) – Allows you to specify how the index will be generated by using the Begin and End codes 

described earlier. 

About the HTML Preset 

When you choose the HTML Output Format preset, SKY Index goes into HTML mode. In HTML Mode, 

two things happen. First, the Preview Pane will display hyperlinks as underlined text and with the color 

currently defined for ignored text. Second, cross-references will be automatically turned into hyperlinks 

to the appropriate index entry. 

Example of Useful Translations in HTML Mode 

You may find the following translations useful in HTML mode. This is purely an example and its intent 

is to reduce the amount of typing required to enter hyperlinks in the index. The quotes in the ‘Text’ 

column are included so that you can see the leading space in the second translation. Do not enter them 

into the translation table. To help you remember them, think of ‘w’ meaning (w)ebsite and ‘d’ meaning 

(d)escription. 

 

Text Translation 
“w=” <a href="http://www. 

“ d=” "> 

“..” </a> 

 

Using these Translations, you can form hyperlinks as follows: 

w=myhomepage.com d=My Home Page.. 

is equivalent to 

<a href="http://www.myhomepage.com">My Home Page</a> 

This clearly saves a significant number of keystrokes and is somewhat easier to read in the Page field 

too. It would produce a hyperlink that looked like this in the Preview Pane: My Home Page  

In the generated index, clicking the link would take you to the webpage: “http://www.myhomepage.com” 
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Notes 

The presets for RTF Spaces and RTF Tabs do not use "styles" as are used with the RTF and RTF Plain 

presets. They also do not indent subheadings by using a paragraph indent. Instead, the RTF Spaces 

preset indents Sub1 with two spaces, Sub2 with four spaces, etc. The RTF Tabs preset indents Sub1 with 

a single tab, Sub2 with two tabs, etc. You can modify the default settings to indent differently if you 

desire. Finally, SKY Index will use the font you have selected for the Main heading in the Fonts tab of 

the Index Options dialog when generating an index if you use the RTF preset provided here. 

Markup Tags 

On occasion, you may work for a client that wishes you to provide the index with special codes that help 

them layout the index for publication. These are called markup tags. For example, your client might 

want you to start every main heading of the generated index with a special code such as <Main> and 

then maybe end each main heading with another special code such as </Main>. You might also be asked 

to use special codes to begin and end characters styles such as bold, italic, and underline. You will use 

SKY Index’s Markup Tags feature to satisfy your client’s needs. 

The markup tags are divided into three sections: Document, Headings, and Character Style. Click on the 

appropriate tab to select a section. Each section is described separately below. 

Note: For the RTF output formats, some of the markup tags are disabled because they are handled in a 

specific predefined way that cannot be changed by the indexer. 

Document Markup Tags 
 

 

Markup Tags – Document Tab 

Begin Document – This text will be placed at the beginning of the index when it is generated. Not all 

encoded documents require the use of this feature and it is prohibited for RTF documents. 

End Document – This text will be placed at the end of the index when it is generated. Not all encoded 

documents require the use of this feature and it is prohibited for RTF documents. 

Before Alpha Sep. – If you configure your index to print alphabetic separators, the text in this text box 

will be added just prior to printing the alphabet separator. Tip: This also allows you to indent the 

separator if desired. 

After Alpha Sep. – If you configure your index to print alphabetic separators, the text in this text box 

will be added just after printing the alphabet separator. 

Page Range Separator – Normally a range of pages is shown with either a dash or an en dash. When 

you generate an index using user-defined codes, a simple dash (-) character is used by default. If you 
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want to use another character or if your publisher requires a special code, you can enter that 

character or code here. This option is unavailable for RTF output formats because, for RTF files, it is 

specified in the Style tab of the Index Options dialog. 

Filename Extension – This is the filename extension used when generating an index with user-defined 

codes. The filename will be the same as the name of your index, but with the filename extension that 

you enter here. You can enter up to 3 characters. For RTF documents, the extension is fixed as RTF. 

New Line – Specifies the character or characters to be placed at the end of every line of text. This 

should generally be set to the default value of CRLF, which is the way PC compatible computers end 

a line of text. This option is not available for RTF documents. Your options are: 

 CRLF – Adds a carriage return and a linefeed character to the end of every line. 

 LF – Adds only a linefeed to the end of every line. This is the way the UNIX operating 

system ends lines of text. 

 CR – Adds only a carriage return to the end of every line. 

 <None> – Does not add any characters to the end of a line. 

Heading Markup Tags 
 

 

Markup Tags – Headings Tab 

Main (Begin/End) – Text in the Begin text box will be added to the beginning of each main heading 

when the index is generated. Text in the End text box will be added directly after the main heading. 

Sub1 through Sub6 (Begin/End) – Text in the Begin text box will be added to the beginning of the 

specified subheading level entry when the index is generated. Text in the End text box will be added 

at the end of the subheading. 

Example 

To illustrate how the markup tags are applied, the example below assumes that you have entered 

<Main> in the Main Begin textbox, </Main> in the Main End textbox, <Sub1> in the Sub1 Begin textbox 

and <\Sub1> in the End textbox.  

Without the markup tags your index will look like this: 

tools 
   screwdriver, 1 
   wrench, 2 

With the markup tags your index will look like this: 
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<Main>tools</Main> 
    <Sub1>screwdriver, 1</Sub1> 
    <Sub1>wrench, 2</Sub1> 

Character Style Markup Tags 
 

 

Markup Tags – Character Style Tab 

Bold (Begin/End) – Defines the codes that will turn the bold format attribute on and off during index 

generation. You should place the text that will turn the bold attribute on in the Begin text box and 

the text that will turn it off in the End text box. 

Italic (Begin/End) – Defines the codes that will turn the italic format attribute on and off during index 

generation. You should place the text that will turn the italic attribute on in the Begin text box and 

the text that will turn it off in the End text box. 

Underline (Begin/End) – Defines the codes that will turn the underline format attribute on and off 

during index generation. You should place the text that will turn the underline attribute on in the 

Begin text box and the text that will turn it off in the End text box. 

Superscript (Begin/End) – Defines the codes that will turn the superscript format attribute on and off 

during index generation. You should place the text that will turn the superscript attribute on in the 

Begin text box and the text that will turn it off in the End text box. 

Subscript (Begin/End) – Defines the codes that will turn the subscript format attribute on and off 

during index generation. You should place the text that will turn the subscript attribute on in the 

Begin text box and the text that will turn it off in the End text box. 

Strikeout (Begin/End) – Defines the codes that will turn the strikeout format attribute on and off 

during index generation. You should place the text that will turn the strikeout attribute on in the 

Begin text box and the text that will turn it off in the End text box. 
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Chapter 

25 
Data Entry Options 

Overview 

Data Entry options are options that affect your index during data entry. For instance, when you enable 

AutoCaps, the automatic capitalization occurs as you type and does not affect index entries that have 

already been entered. Ignored Words and SmartSwap are included as data entry options for historical 

reasons. 

The Revert button will restore all settings for only the current tab back to the state it was in when you 

first navigated to that tab. To change all setting of all tabs back to their original state, click the Cancel 

button. After you navigate away from a particular tab, those setting s become permanent unless you 

click Cancel. 

The Help button provides help on the tab of the dialog that is currently active. 

AutoCaps 

Index requirements vary with regard to capitalization. For example, a name index will normally require 

that the first letter of every word be capitalized. The Auto Capitalization feature lets you configure SKY 

Index to perform certain types of capitalization for you automatically during data entry. 

 

 

Data Entry Options - AutoCaps tab 
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Configuring AutoCaps 

To set automatic capitalization options, do the following: 

1. Choose Options>Data Entry or click the  toolbar icon. 

2. Click the AutoCaps tab. 

3. Make your desired settings. 

4. Click OK. 

Options 

Fields – Specifies the field(s) you wish to apply automatic capitalization to. You can use AutoCaps on 

any field or combination of fields except for the page field. 

First word only – If checked, only the first word of the specified heading level will be capitalized. 

Swap capitalization when swapping headings – If checked, capitalization is swapped for the Main 

and Sub1 headings when you use a function that swaps the contents of those two fields. For instance, the 

entry: 

Print, command 

will be adjusted when swapped to: 

Command, print 

Notes 

Automatic capitalization works only during data entry. It does not affect the index globally. Therefore, 

you should set the automatic capitalization options prior to data entry. 

See also the Heading Style tab of the Index Options dialog for information on the similar feature: “Initial 

Cap”. 

AutoComplete 

The AutoComplete tab lets you to configure SKY Index to anticipate your index entries based on 

previously entered index entries. Using this function not only saves time, it promotes consistency in your 

index entries. Note: Although SKY Index Professional allows you to enter a virtually unlimited amount 

of text in the Main through Sub3 heading levels, only the first 255 characters of each heading level are 

stored in the AutoComplete list. 
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Data Entry Options - AutoComplete tab 

Configuring AutoComplete 

To configure AutoComplete, do the following: 

1. Choose Options>Data Entry or click the  toolbar icon. 

2. Click the AutoComplete tab. 

3. Set your AutoComplete options. 

4. Click OK. 

Options 

Main – If checked, SKY Index will attempt to anticipate and automatically fill in entries that you type 

in the Main heading field. 

Sub1 – Sub6 – If checked, SKY Index will attempt to anticipate and automatically fill in entries that 

you type in the fields that you checked. 

Cross-references – If checked, SKY Index will attempt to anticipate and automatically fill in cross-

references that you type in the Page field. 

Remove trailing text in parentheses – If checked, any trailing parenthetical text in the 

AutoCompleted text will be removed. You will still be able to manually override this setting by 

typing parenthetical text manually if an exception occurs in your index. 

Ignore Case – If checked, case will be disregard when anticipating your entries. The anticipated entry 

will maintain its original case, but what you type will be compared to the AutoComplete list as if 

both were in all lowercase. 

Use as Controlled Vocabulary – If checked, you will hear a beep if you make an entry that does not 

exist in the AutoComplete list. Although you may add entries to your index that are not in the 

AutoComplete list, those entries will not be added to the list thus maintaining the original 

vocabulary. 
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Save and Restore List – If checked, SKY Index will automatically reopen the AutoComplete list each 

time you open the index. 

Update when existing entries are edited – If checked and you edit an index entry for which there is 

an AutoComplete entry, the existing AutoComplete entry will be edited to match your new entry.  

The intent is to automatically correct the AutoComplete list when you make a typographical error or 

if you change the phrasing of an existing entry. 

AutoComplete Manager – Opens the AutoComplete Manager where you can add items to or remove 

items from the list. You can also save the list for use in another index. 

Update AutoComplete List – Clears the existing AutoComplete list and rebuilds it using all entries in 

the current index. This is useful if you've misspelled some entries unknowingly and you want to 

remove those misspelled entries from the AutoComplete list. 

How AutoComplete Works 

When you type an entry in the data entry grid, SKY Index will save that entry in an internal database. 

Along with the entry, it keeps track of how many times that entry has been entered and the timestamp 

of the most recent use of the entry. 

When you start to type a new entry, SKY Index will first take a look at what you have typed so far and 

find all matching entries that you’ve typed before. If more than one entry has been used before, SKY 

Index will suggest the one that was used most often. If there are two or more entries that have been used 

the same number of times, the one that was used most recently will be suggested. This makes SKY 

Index’s AutoComplete highly accurate in anticipating the correct entry. 

Notes: 

 SKY Index ignores formatting when attempting to match what you’ve typed to entries in the 

AutoComplete list. If what you’ve typed matches an entry that has formatting applied, the 

formatting will appear, if the matching entry has no formatting, there will be no formatting. This 

means that you do not have to ever apply formatting for AutoComplete to match previously typed 

entries that do have formatting applied. 

 If you start typing an entry and it has formatting applied and you don’t want that formatting, 

press Alt+F10, this will remove all formatting from all text you have already typed and will turn 

off AutoComplete so that you can type whatever formatting you want. 

 Manually invoking any type of character style such as bold or italic will turn off AutoComplete 

until you leave the current grid cell, move to a different entry in the index, or delete all existing 

text within the current textbox. 

Tip: If you enter a phrase such as "indexing books" and later need to enter the single word "indexing", 

you may find that SKY Index anticipates that you want to enter "indexing books". You can get rid of the 

extra text in two ways. First, finish typing the word "indexing" and then do one of the following: 

 Press Del 

 Press the space bar twice. The trailing spaces will be removed when you move the grid marquee 

to the next grid column. 

If you know in advance that you don’t want SKY Index to anticipate your entry, simply begin your entry 

with a space. This effectively prohibits SKY Index from anticipating your entry. The leading space will 

be removed when you move the grid marquee to the next column. 
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AutoEntry 

Some types of indexes have frequent and predictable double postings. SKY Index's AutoEntry feature 

allows you to specify the types of entries that are double posted and the method to use when double 

posting the entry. 

 

 

Data Entry Options - AutoEntry tab 

Configuring AutoEntry 

To configure AutoEntry, do the following: 

1. Choose Options>Data Entry or click the  toolbar icon. 

2. Click the AutoEntry tab. 

3. Set your AutoEntry options. 

4. Click OK. 

Options 

Ignore Case – If checked, SKY Index will disregard case when examining the main headings of your 

index. 

Ignore Formatting – If checked, SKY Index will ignore formatting of main headings when examining 

the main headings of your index. 

Use AutoEntry – If checked, SKY Index will automatically double post records that have main 

headings contained in the AutoEntry list. If you don't want to use this feature, uncheck this box. 

Create From Index – Allows you to automatically create an AutoEntry list by using the current index 

or any other existing index as an example. If you use this feature, SKY Index will examine the index 

that you specify for double postings and will automatically add the appropriate main headings and 

Actions. This can give you a very good starting point for your AutoEntry list. 

AutoEntry Manager – Brings up the AutoEntry Manager.  
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AutoRepeat 

The Repeat Fields feature of SKY Index can save keystrokes by repeating fields in the index that don’t 

change frequently. This is especially true of the page field, but can also be highly useful for the Main 

heading field. SKY Index can be configured to repeat any field during data entry. 

 

 

Data Entry Options - AutoRepeat tab 

Configuring AutoRepeat 

To configure repeated fields, do the following: 

1. Choose Options>Data Entry or click the  toolbar icon. 

2. Click the AutoRepeat tab. 

3. Set your AutoRepeat options. 

4. Click OK. 

Options 

Main – If checked, SKY Index will automatically repeat the text of the Main field of the previous record 

when starting a new record. 

Sub1 – Sub6 – If checked, SKY Index will automatically repeat the text of the previous record for the 

fields you’ve checked when starting a new record. 

Page – If checked, SKY Index will automatically repeat the text of the Page field of the previous record 

when starting a new record. 
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Ignored Words 

Index specifications usually require that prepositions and articles be ignored when they appear at the 

beginning of an entry or subentry. The Ignored Words list allows you to define words that you want to be 

ignored when they appear at the beginning of an entry or subentry. 

 

 

Data Entry Options – Ignored Words tab 

Configuring Ignored Words Options 

To configure Ignored Words options, do the following: 

1. Choose Options>Data Entry or click the  toolbar icon. 

2. Click the Ignored Words tab. 

3. Set your Ignored Words options. 

4. Click OK. 

Options 

Words to Ignore – To add words to the list of words to be ignored, enter them in this text box. After 

typing the word press Enter or click Add. 

Add – If you enter a word in the Words to Ignore text box, you can submit the word by clicking this 

button. 

Delete – Deletes the currently selected word in the Ignore Words list. 

Use Ignore List – If checked, SKY Index will ignore the words in the ignore list when they appear at 

the beginning of an entry. 

Not In Main Heading – If checked, SKY Index will not process the main heading field when checking 

for words to be ignored. 
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Notes/Tips 

 If there are two or more words in the Ignored Words list that appear contiguously at the front of 

a subheading, all of those words will be ignored. 

 If you have a particular entry that starts with a word in the Ignored Words list but it should not 

be ignored, you can enter the word twice – once as hidden text and directly following that again 

as ignored text. In many cases you could probably get away with not ignoring the second one. As 

an example if you did not want to ignore the word ‘The’ in the title The Wind and the Wuthering 

you could enter the title like this (text in curly braces is ignored text and text in square brackets 

is hidden text): 

{The}[The] Wind and the Wuthering 

Smart Swap 

When Main and subheadings are swapped, sometimes there are one or more words or phrases at the 

beginning or end of the subheading that should stay in the subheading field after the swap. In addition, 

these words or phrases usually get moved from the front of the subheading to the back of the subheading 

or vice versa. The SmartSwap feature of SKY Index lets you specify which words or phrases will be 

swapped and whether they will be moved from front to back or not. 

 

 

Data Entry Options - SmartSwap tab 

Configuring SmartSwap 

To configure SmartSwap options, do the following: 

1. Choose Options>Data Entry or click the  toolbar icon. 

2. Click the SmartSwap tab. 

3. Set your SmartSwap options. 

4. Click OK. 
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Note: If you do not want a word or phrase in the SmartSwap list to be moved from the front of a 

subheading to the back (or vice versa), enclose the word or phrase within square brackets. For example 

‘[and]’ is a word that will not be swapped from front to back. 

Options 

Add – If you enter a word in the Swap to opposite side text box, you can add it to the SmartSwap list by 

clicking this button or by simply pressing Enter. 

Delete – Deletes the currently selected word in the SmartSwap list. 

Use SmartSwap – If checked, SKY Index will use the SmartSwap list when you swap Main and Sub1 

headings. 

Examples 

Example 1 

If you enter the word ‘for’ in the SmartSwap list and if you have the following main and subheading: 

 

 Main Sub1 Page 

 indexing software for 1 

*    

 After swapping you will have: 

 

 Main Sub1 Page 

 software for indexing 1 

*    

Example 2 

If you enter the word ‘[and]’ in the SmartSwap list (with the left and right square brackets) and if you 

have the following main and subheading: 

 

 Main Sub1 Page 

 bicycles injury risk and 1 

*    

 After swapping you will have: 

 

 Main Sub1 Page 

 injury risk bicycles and 1 

*    

Example 3 

If you enter the phrase ‘focus on’ in the SmartSwap list and if you have the following main and 

subheading: 

 

 Main Sub1 Page 

 United Nations focus on individual rights 1 

*    

 After swapping you will have: 
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 Main Sub1 Page 

 individual rights United Nations focus on 1 

*    

Notes 

If there are two or more words at the front or end of a subheading that are all in the SmartSwap list, all 

of those words will be intelligently swapped.
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Chapter 

26 
Index Options 

Overview 

The Index Options dialog is where you will configure items that are specific to the currently open index. 

This includes how the index will be sorted, how it will be formatted, how locators will be handled and 

how cross-references will be handled. 

The Revert button on the Index Options dialog will restore all settings for the current tab back to the 

state it was in when you first navigated to that tab. To change all setting of all tabs back to their original 

state, click the Cancel button. After you navigate away from a particular tab, those setting s become 

permanent unless you click Cancel. 

The Help button provides help on the tab of the dialog that is currently active. 

Cross-references 
 

  

Cross-references Tab of the Index Options Dialog 
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Configuring Cross-references 

To configure cross-references, do the following: 

1. Choose Options>Index or click the  toolbar icon. 

2. Click the Cross-references tab. 

3. Set your cross-reference options. 

4. Click OK. 

Options (From Main Headings/Subheadings) 

Presets 

See – Choose the format that you desire for "see" cross-references from the drop-down list. If the exact 

format you need is not displayed, choose the one that is closest and perform any additional 

configuration manually. 

See also – Choose the format that you desire for "see also" cross-references from the drop-down list. If 

the exact format you need is not displayed, choose the one that is closest and perform any additional 

configuration manually. 

Format and Placement 

Format – Specifies how the "see" and "see also" in cross-references will be formatted. You can choose 

Italic, Underline, Bold, or None. 

Placement – Specifies where cross-references will be placed. Your options are: 

Before Locators – cross-references will appear with the heading but before any locators 

After Locators – cross-references will appear with the heading but after any locators 

First Subheading – cross-references will appear at the top of the subheading list. 

Last Subheading – cross-references will appear at the bottom of the subheading list. 

Note: The First Subheading and Last Subheading options are only available for ‘see also’ cross-

references. 

Text – During data entry, SKY Index requires that "see" cross-references start with the words ‘see’ or 

‘see also’ in order for the program to identify them as cross-references. If your publisher requires a 

different word, or if the index is in a language other than English, you can enter the words to be used 

when the index is generated in these textboxes. You will still use ‘see’ or ‘see also’ when entering 

your cross-references, but when the index is generated, the text you provide here will be used 

instead. 

Note: Don’t forget to add a trailing space if you modify this text. 

Prefix – Specifies text to appear directly before the words ‘See’ or ‘See also’ when generating the index. 

Suffix – Specifies text to appear directly after the words ‘see’ or ‘see also’ when generating the index. 

Small Caps – If checked, the words ‘see’ or ‘see also’ will be given small caps character style. 
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See also Orphans 

Merge To – Specifies where orphan cross-references will be placed. Your options are: 

Don't – Orphan subheadings will not be merged. 

Before Locators – Orphan subheadings will be merged with the parent heading and will be placed 

before any locators. 

After Locators – Orphan subheadings will be merged with the parent heading and will be placed 

after any locators. 

Prefix – Any text that you wish to appear prior to the cross-reference. 

Suffix – Any text that you wish to appear after the cross-reference. 

Targets (See) and Targets (See also) 

Style – Allows you to specify that you want cross-reference targets to be generated in a particular 

character style. You may choose to leave them unchanged or any combination of Bold, Italic, and 

Underline. 

Capitalization – Specifies how cross-reference targets will be capitalized. Your options are: 

Don’t Alter – The target will appear exactly as you entered it. 

Initial Cap – The first letter of the first word of the target will be capitalized. 

Lowercase – The entire target will be in lowercase regardless of how it is entered. 

Uppercase – The entire target will be in uppercase regardless of how it is entered. 

Notes: 

 You will generally want to adjust the Capitalization setting to match the capitalization settings 

you make in the Heading Style tab of the Index Options dialog. 

 If you check the Force target formatting to match the actual target option (described below), the 

Style and Capitalization settings are ignored. 

Options (Other Settings) 

Force target formatting to match the actual target – If checked, SKY Index will ensure that the 

formatting of the target matches the actual target exactly when generating the index. 

Remove text in parentheses from AutoCompleted cross-references – If checked, any trailing text 

in parentheses will be removed from AutoComplete text while you’re typing cross-references. 

If target is formatted, remove cross-reference formatting – If checked and if you enter a target 

that has formatting such as italic applied, the see or see also text will appear in plain type instead of the 

normal formatting that you’ve configured. 

Multiple cross-reference separator – This is the character or characters that will be used to separate 

multiple cross-references when your index is generated. By default this is a semicolon plus a space. 

Words indicating the entry is found as a subheading of a main – This is a list of comma separated 

words that introduce a target that is found under a main heading (or subheading). The default is ‘under’ 

and this should, in general, never be changed unless you’re working in a language other than English. 

Example: Tandem Bicycle. See under Bicycles 

General cross-reference identifiers – This is a list of comma separated words that, when they appear 

at the beginning of a target, indicate that the cross-reference does not point to an actual target within 

the index, but specify a general area of the index where the information can be found. These words are 
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used by the error scan so that you do not receive an error message when you use a general cross-

reference since these targets never exist in the index. 

Sort as last cross-reference – If checked, any general cross-references will be sorted to the end 

of any list of non-general cross-references. 

Notes 

All cross-references should be entered in the Page field and should start with "see" or "see also". SKY 

Index will recognize it as a cross-reference and will properly format it. The placement and formatting of 

your cross-references are determined solely by the Cross-references tab of the Index Options dialog, so 

you should not add any formatting of your own. 

Heading Style 

Sometimes the publisher of an index specifies the font, font size and other attributes for your index 

headings. The Heading Style tab of the Index Options dialog is where these attributes are configured 

and considerable flexibility is provided. 

 

 

Heading Style Tab of the Index Options Dialog 

Configuring Heading Style 

To configure your heading styles, do the following: 

1. Choose Options>Index or click the  toolbar icon. 

2. Click the Heading Style tab. 

3. Set your desired options. 

4. Click OK. 
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Options 
 

The settings you make will apply to the heading level specified in the tab bar above the settings. You 

can apply different settings to each heading level and to the alphabetic section labels between 

alphabetic sections of the index. Please take note of the “Apply to all heading levels” button described 
below for assigning the same attributes to all levels. 

Paragraph Style 

Style Name – This is the style name that will be given to the current heading level when you generate 

an index using one of the RTF Output Formats. If your client requires specific style names, enter 

them here. 

Font – Specifies the font that will be applied to the current heading level when you generate your index. 

An example of your choice will be displayed in the preview window. 

Font Size – Specifies the font size that will be applied to the current heading level when you generate 

your index. An example of your choice will be displayed in the preview window. 

Space Before – Specifies the amount of empty space that will be added above the current heading level. 

You can use the spinner control to increment or decrement the spacing with the mouse. An example 

of your choice will be displayed in the preview of the index. 

Space After – Specifies the amount of empty space that will be added below the current heading level. 

You can use the spinner control to increment or decrement the spacing with the mouse. An example 

of your choice will be displayed in the preview of the index. 

Apply to all heading levels – Applies the current Font, Font Size, Space Before, and Space After to all 
heading levels. This does not affect the alphabet separator settings. 

Indention 

Indent – Specifies the amount of space that subheading 1 will be indented from the left margin. This 

space will be doubled for subheading level 2 and tripled for subheading level 3 and so on. If you are 

configuring the alphabet separators style, this is the amount of space that alphabet separators will 

be indented from the left margin. You can use the spinner control to increment or decrement the 

spacing with the mouse. An example of your choice will be displayed in the index preview. This 

setting has a different effect depending on the two options below. 

Fixed – Specifies that each heading's indention depth will be defined independently. The use of this 

option is discouraged unless your client’s specifications clearly dictate unequal indentation of 

subheadings. 

Incremental – Specifies that the indention depth will be incrementally applied to each heading 

level. The value shown in the Indention text box is the amount of indent for the Sub1 heading. 

All other indentions will be automatically calculated to create consistent indentions for all 

heading levels. 

More Options – Clicking this button will toggle between these two styles. The results are shown in 

the Preview window. 

Turnover – Specifies the amount of space, in inches that turnover lines will be indented for the 

currently specified heading level. This setting has a different effect depending on the two options 

below. 

Fixed – Specifies that each heading's turnover depth will be defined independently. This option is 

very rarely needed and is discouraged. 

Incremental – Specifies that the turnover depth will be incrementally applied to each heading 
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level. When this option is chosen, the Turnover is determined by SKY Index and the Turnover 

text box is disabled. There are two styles of incremental indention that are supported. 

More Options – Toggles between two standard indention styles. The results are shown in the 

Preview window. The two styles are: 

 Turnover lines are indented by the indention amount of the current heading, plus 

one half of the indent of the first subheading. 

 Turnover lines are indented by the indention amount of the next heading, plus one 

half of the indent of the first subheading. 

Character Formatting 

Bold – If checked, the current heading will be printed in boldface. 

Italic – If checked, the current heading will be printed in italics. 

Underline – If checked, the current heading will be printed with underlining. 

Small Caps – If checked, the current heading will be printed in small caps. 

Strikeout – If checked, the current heading will be printed with a line through the middle. 

Capitalization 

None – If checked, no modifications will be made to the capitalization of the text for the current heading 

level. 

Initial Cap – If checked the first letter of the first word of the current heading level will be capitalized 

regardless of how it appears in the data entry grid. 

Note: If you enable this feature, you can override its effect by typing a colon as the very first 

character of a heading. The colon will not print and the first letter of the heading will not be 

capitalized. 

Upper case – If checked, the selected heading level will be generated in all capital letters. 

Lower case – If checked, the selected heading level will be generated in all lower case letters. 

Title case – If checked, the selected heading level will be generated in title case. 

Don’t apply to ignored words – If checked, any words that are in the ignored words list will not be 

modified by the Initial Cap or Title Case options listed above. 

Other 

Alternative Fonts – Allows you to define to additional fonts that can be used in your index. By default 

the alternative fonts are the Symbol font and the Courier New font. For more information see 

Alternative Fonts later in this chapter. 

Merge Orphans – Instructs SKY Index to automatically merge orphan subheadings. 

Notes 

 These automatically merged orphans will appear in orange text in the Preview Pane. 

 Your index entries are not physically modified in any way by this setting. 

 Edit View relies on heading levels being separate for editing and therefore orphans do not 

appear merged in Edit View, but they will still be merged when the index is generated. 
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Locators 

The Locators tab of the Index Options dialog box lets you define how locators (page numbers) are printed 

when you generate an index. It also defines the characters that delimit volume and chapter labels during 

data entry. 

 

 

Locators Tab of the Index Options Dialog  

Configuring Locators 

To configure locators, do the following: 

1. Choose Options>Index or click the  toolbar icon. 

2. Click the Locators tab. 

3. Set your locators options. 

4. Click OK. 

Options 

Locators 

Leader – Specifies the character(s) that will precede the first page number after a heading has been 

printed. Normally a comma and a space are used. However, some publishers prefer two spaces. 

Separator – Specifies the character(s) that will separate locators after the initial locator has been 

printed. Normally a comma and a space is used. 

Prefix – Specifies the character or characters that will appear directly before each locator as a prefix.  

Suffix – Specifies the character or characters that will appear directly after each locator as a suffix. 
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Tip: If you want to format all locators with a specific character style, you can place the 

appropriate start code in the Prefix textbox and the appropriate stop code in the Suffix 

textbox. For instance, if you place “/b1” in the Prefix textbox and “/b0” in the Suffix 

textbox, all locators will be in bold face. 

Ignore Duplicates – If checked, duplicate records in your index will be ignored. Otherwise, SKY Index 

will put the number of occurrences (if greater than one) in parentheses directly after the page 

number. This is most useful in genealogical indexes. 

Right Align – If checked, page numbers will be right aligned in your printed index. A dotted leader will 

precede the page numbers if space permits. This style of index is strongly discouraged, but is 

supported for those who have a publisher that requires it. This option is ignored when an index 

output format other than RTF or RTF (No headers) is being generated. 

Note: Because of the way that most word processors handle hanging indents, some page numbers 

may not be right aligned in the generated index. The only solution to this problem is to manually 

enter a Tab before the first page number of pages that are not right aligned or to decrease the indent 

used for subtopics. 

Tip: If you want cross-references to be right aligned put ‘\tab ’ without the quotes 
(notice the trailing space) as a Prefix for the cross-references tab of Index Options. 

Separators take on leading locator style – If checked, the locator separator will appear in the 

generated index in the same style as the locator before it. For example, if the locator before the 

separator is in italics, the separator will be in italics. If the locator before the separator has no 

character style applied, the separator will also have no character style applied. 

Page Ranges 

Conflation – Specifies how page ranges will be handled. Your options are None, Hart’s Rules, Hart’s 

(modified), Chicago 15th Ed., Chicago 14th Ed., and Custom. The options have the following effects: 

 

Style Description 

Simple Page ranges will not be abbreviated. 

Hart’s Rules Page ranges will be abbreviated by removing all but the 

changed portion of the last page in the page range. For 

example, 1911–1914 would be changed to 1911–4. 

Hart’s 

(modified) 

Identical to Hart’s Rules; however, if the last two digits of the 

first number is in the teens, the second number will include 

the leading 1 even if it would not otherwise. Example: 1911–

4 becomes 1911–14. 

Chicago 15th 

Ed. 

Page ranges will be abbreviated using the rules set forth by the 

University of Chicago Press 15th Edition. 

Chicago 14th 

Ed. 

Page ranges will be abbreviated using the rules set forth by the 

University of Chicago Press 14th Edition. 

Custom Displays the Page Range Conflation Rules dialog where you can 

specify custom settings for clients with non-standard 

requirements. See Page Range Conflation Rules Dialog for 

more information 

Separator – Specifies the character that will be used between a range of pages. Your options are a dash 

(hyphen), an en dash or the word "to" surrounded by spaces. Most indexes use an en dash unless the 

pages are number by chapter. If pages are numbered by chapter, the page range "1-12–1-20" would 

be confusing at the very best. For these indexes you should choose " to " which would change the 
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result to "1-12 to 1-20". The dash character should be used only if your word processor does not 

properly import an en dash from an RTF file or if your publisher specifies it. 

Note: This setting only affects indexes generated using one of the RTF output formats. For all other 

output formats, use the Markup Tags ‘Page Range Separator’ setting in the Document Options 

dialog. 

Combine 1, 2, 3 = 1–3 – If checked, SKY Index will automatically create a page range when two or more 

consecutive pages are encountered. For example: 1, 4, 5, 6, 9 will be changed to 1, 4–6, 9. Under 

normal circumstances you would not use this option since just because two or more pages in a row 

contain information on the same topic, it does not mean that it is one continuous discussion. It can, 

however, be useful for genealogical indexes. 

Consume locs in range – If checked, if the locator before or after a page range is part of that page 

range, it will be consumed by the range and not be displayed separately. For example, the locators 5-

10, 8, 11 would appear as 5-10, 11 because the 8 is consumed by the 5-10 range. Similarly, the 

locators 3, 5-10, 7-11, 42 would appear as 3, 5-11, 42 because the ‘7’ of the page range 7-11 is within 

the preceding locator’s range or 5-10. Some more examples are shown below: 

Example #1: 121-124, 123f   (123f will not be consumed because the ‘f’ makes it unique) 

Example #2: 121a-121e, 121c   (121c will not be consumed) 

Example #3: 121, 121-124t, 123t, 124   (121, 123t, and 124 will all be consumed) 

Example #4: 121, 121n3, 121-122n6   (121n3 will not be consumed; 121 will be consumed) 

Format Priority – Displays the Locator Format Priority dialog which allows you to specify the priority 

given to format attributes that have been applied to locators. This allows locators that have had 

character styling applied to appear in a consistent order. See Locator Format Priority Dialog for 

more information. 

Sections (Volumes and Chapters)  

Sections allow you to specify a part of a locator that has higher sorting priority than the page number 

itself and that identifies a different part of the locator. For instance, a volume or chapter label would be 

considered a section and would be sorted with a higher priority than the page number. SKY Index will 

allow you to specify up to 9 sections. In SKY Index we will also refer to these sections as section labels. 

Defining the Part of the Locator that is a Section 

There needs to be a way for SKY Index to know what part of the locator is the section. This is done with 

what is called an Input Delimiter. An input delimiter is simply a single character that is not used for any 

other purpose except to define a break between a section label and a page number. When SKY Index 

encounters a section Input Delimiter, everything to the left of that delimiter is considered to be the 

section label unless you have defined more than one section. If you define more than one section, 

everything to the left of the delimiter that isn’t another section is considered the section label. The 

sections are parsed from left to right. 

Defining the Data Type of the Section 

After you have defined your section input delimiters, you may need to define the data type for the 

section. By default, the data type is set to ‘Mixed’ and this will be adequate for the vast majority of 

section labels, but other types are available and they are defined below under Section Options below. 
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Applying Character Formatting or Capitalization to a Section 

Although you can apply formatting to a section label during data entry just as you can for index 

headings, there may be times when you want all section labels to be bold or italicized. You can apply 

formatting globally if you wish to for all common character formats and you can also apply specific 

capitalization to all section labels. See Formatting below for more information. 

Volumes and Chapters 

You will notice that there are two tabs that are specifically for Volumes and Chapters. These are simply 

convenient tabs for defining sections 1 and 2. When you modify the settings on one of these tabs, you are 

also modifying the corresponding section. 

Section Options 

Input Delimiter – Specifies the character that will be recognized as a volume label separator during 

data entry. By default this character is a colon (:). Any characters to left of this character are 

considered to be a volume label and are sorted as such. 

Output Delimiter – Specifies the character to use as a volume separator when the index is generated. 

By default this character is a colon (:). 

New Section Separator – Specifies the characters that will be used when a new section label is 

encountered when printing the locators. It can be used to make the change from one section to 

another more obvious. For example, if you enter "; " as the new section separator, the sequence "1:2, 

1:4, 1:21, 2:2, 2:5" would become "1:2, 1:4, 1:21; 2:2, 2:5". 

Prefix – Specifies text that will be added to the front of every section. 

Suffix – Specifies text that will be added to the end of every section. 

Data Type – Specifies what kind of data the section label consists of. Your options are: 

Mixed – (the default) Specifies that the section label can contain several different types of text 

including plain text, dates, numbers and Roman numerals. SKY Index will attempt to recognize 

and sort these data types automatically for you. If SKY Index does not automatically recognize 

and properly sort your data type, you can specify one of the data types below or used forced 

sorting to specify the sort order. 

Arabic Number – Specifies that the section label will be an Arabic number. If anything other than 

a number is encountered, the sort key assigned will be equivalent to the number zero (0). 

Alpha – Specifies that the section label will be plain text and it will be sorted according to the sort 

method you have chosen in the Sorting tab of the Index Options dialog. 

Roman numeral – Specifies that the section label will be an Roman numeral. If anything other 

than a Roman numeral is encountered, the sort key assigned will be equivalent to the number 

zero (0). 

Day – Specifies that the section label will be text for a day of the week. Accepted values are: 

Monday, Mon, Tuesday, Tues, Tue, Wednesday, Wed, Thursday, Thur, Thu, Friday, Fri, 

Saturday, Sat, Sunday, and Sun. A period may be included after an abbreviated day. The case of 

the text does not matter. Monday will be given a value of one (1) for a sort key and Sunday will 

be given a value of seven (7) for a sort key If anything other than a valid day is encountered, the 

sort key assigned will be equivalent to the number zero (0). 

Month – Specifies that the section label will be text for a day of the week. Accepted values are: 

January, Jan, February, Feb, March, Mar, April, Apr, May, June, Jun, July, Jul, August, Aug, 

September, Sep, October, Oct, November, Nov, December and Dec. A period may be included 

after an abbreviated month. The case of the text does not matter. January will be given a value 
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of one (01) for a sort key and December will be given a value of twelve (12) for a sort key If 

anything other than a valid month is encountered, the sort key assigned will be equivalent to 

zero (00). 

Year – Specifies that the section label will be an Arabic number of no more than four digits and with 

a value of 0 to 9999. If anything other than a number is in this range is encountered, the sort key 

assigned will be equivalent to the number zero (0000). 

Formatting – Allows you to specify a character style for the section label and/or a capitalization. Your 

selections are applied globally to all of your section labels for the current section. Your options are: 

Character Style – Bold, Italic, Underline, Strikeout, and Small Caps 

Capitalization – None, Initial Cap, Lower Case, Upper Case, and Title Case 

Enabled – Allows you to enable or disable specific section labels. If you disable a section the text will 

either be treated as part of a different section that is enabled or as prefix text for the page number. 

Hide Repeated – If checked, when a list of locators for a single heading contains several with the same 

section label, the section label will only be printed for the first locator in that list. For example II:5, 

II:7-9, II:24, II:55 would be abbreviated to: II:5, 7-9, 24, 55. 

Only in page ranges – If checked, and if Hide Repeated is also checked, the repeated section labels will 

only be hidden in a page range. For example II:5, II:7-II:9, II:24, II:55 would be abbreviated to: II:5, 

II:7-9, II:24, II:55. 

Sorting 

Publishers have varying requirements for the style and sorting of an index. SKY Index provides the 

flexibility to satisfy most publishers’ needs. 

 

 

Sorting dialog 
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To Set Sorting Options for Your Index 

To configure index sorting, do the following: 

1. Choose Options>Index or click the  toolbar icon. 

2. Set your index sorting options. 

3. Click OK. 

Options 

Presets – Specifies one of several preset sorting methods for your index. The available sorting methods 

are: 

Letter by Letter (ISO) – Sorts through words ignoring spaces using International Standards 

Organization rules. 

Word by Word (ISO) – Sorts each word without ignoring the spaces between them using 

International Standards Organization rules. 

Letter by Letter (CMS) – Sorts through words ignoring spaces using Chicago Manual of Style 

rules. 

Word by Word (CMS) – Sorts each word without ignoring the spaces between them using Chicago 

Manual of Style rules. 

ASCII – Sorts using standard ASCII codes (not normally used for professional indexes). 

Selecting one of these presets will automatically make appropriate settings for the following four 

configuration items. 

Ignored Characters – This is a list of all characters that will be ignored when sorting. 

Full Stop Characters – This is a list of characters or sequences of characters that will be interpreted 

as a full stop during sorting. A full stop is equivalent to starting a new subheading. Each character 

or sequence of characters must be separated from the previous by an underscore character (_). 

Space Characters – The characters in this list will be treated exactly the same as if they were a space. 

Symbols – This is a list of all characters that are considered to be symbols. 

Sort Arabic numbers – If checked, SKY Index will automatically detect and sort Arabic numbers. This 

includes numbers that contain a fractional part. SKY Index can detect and sort numbers as large as 

99,999 and as small as .00001. Numbers must be separated from surrounding text by a space to be 

automatically sorted. For example the number 101 will be sorted in the text "101 Dalmatians", but 

will not be sorted in the text "CPU101". 

Sort Roman numerals – If checked, during data entry (this does not work during a find and replace) 

SKY Index will examine any word that starts with a pound sign (#). If the word can be interpreted as 

a Roman numeral, the leading pound sign will be removed and special sort codes will be added to 

make the Roman numeral sort correctly. Note: If you are entering Roman numerals in the Page 

field, you do not need to use the pound sign. 

Sort dates – If checked, SKY Index will automatically detect and sort dates. Dates in many different 

forms are recognized by the program. Some examples are: 

1/1/98 
01/01/98 
Jan 
Jan 98 
Jan. 98 
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Jan 1, 1998 
January 1, 1998 

Any years that are abbreviated will take on the century during which sorting takes place. Normally 

this is the same as the time for which data entry takes place. 

Options – Opens the Date Options dialog that allows you to specify how dates are handled when the 

year is not fully specified. 

Note: A period (.) cannot be used in the page field to abbreviate a month. This is because a period is 

frequently used in legal indexes as a section separator. 

Treat as Name Index – If checked, special name sorting rules will be used when sorting your index. 

For example, M'Cartney, McCartney and MacCartney would all be sorted as if spelled 

MacCartney. 

Sort Leading Symbols – If checked, entries starting with a symbol will be sorted to the top of the index 

and will take on sorting value even if they would normally be ignored or translated to a space 

according to the current sort method. If you are writing the index to a software manual or similar 

computer related book, you will most likely want to use this option to allow the special symbols used 

in those books to sort to the top of the index. 

Recognize Style and Case – If checked the SKY Index will gather together index entries that are 

different only in either the character style of the entry or the case of the entry. 

Sort this heading by page – If checked the heading level that you specify will be sorted by page rather 

than alphabetically. If this option is enabled, Edit View will be disabled because Edit View requires 

that all headings be sorted alphabetically. 

Combine locators – (This feature affects the generated index only and has no effect on the Preview 

Pane or data entry grid.) If checked, all locators for each heading will be gathered together and 

only the first locator for each heading level will be used to determine the sort order of the 

heading that is being sorted by page. This is usually the desired situation.  

Example (first with Combine locators turned off) 

With Combine Locators turned off, locators have absolute priority and if page 6 interrupts the 

gathering of locators for the subheading ‘indexing’ as shown below, it will do so. 

software 
indexing  1, 5 
word processing, 6 
indexing,  7 
database, 27 
indexing, 32, 47 

Turning on the Combine locators option will result in the following entries: 

software 
indexing  1, 5, 7, 32, 47 
word processing, 6 
database, 27 

As you can see, all locators for the subheading ‘indexing’ have been gathered together and only the 

first locator determines the location of the heading within the list of subheadings. 
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Index Style 

Publishers have varying requirements for the style and sorting of an index. SKY Index provides the 

flexibility to satisfy most publishers’ needs. 

 

 

Index Style dialog 

Configuring Index Style 

To configure index style, do the following: 

1. Choose Options>Index or click the  toolbar icon. 

2. Click the Index Style tab. 

3. Set your index style options. 

4. Click OK. 

Options 

Presets – Specifies the style used when generating your index. You can choose Indented or one of 

several Run-on styles. If none of the presets suit your needs, you can create a customized setting. 

Notes: 

 Indented style will display each subheading on a line of its own indented the amount that 

you specify in the Heading Style tab of Index Options. 

 Run-on style will create a paragraph style where subheadings appear after the main heading 

following an initial colon. Additional subheadings are appended to the previous subheading 

after a semicolon. Turnover lines are indented the amount you specify in the Heading Style 

tab of Index Options. 

Cross-reference placement – Lets you choose 
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Subheading Levels – Lets you specify how many subheading levels your index will have. Although you 

can change this setting at any time, it is best to set it when you first start your index. 

Save As – If you modify the default setting of one of the presets, you can save the new style using a 

name you provide by clicking Save As. This new setting may be reused in future indexes. 

Delete – Displays a dialog which will allow you to delete any custom index styles you may have created 

using the Save As button described above. The dialog will present a list of custom index styles. Just 

choose the style you wish to delete and then click OK to delete the style. Click Cancel if you decide 

not to delete any custom index styles. 

Introductory Note – Displays a text editor where you can enter an introductory note for your index. 

You can apply bold, italic, underline, superscript, and subscript style to the text in your introductory 

note by using the same keyboard shortcuts that you use while entering your index entries. You can 

bring up a larger text editor for editing the note by pressing Shift+F2. 

 

The settings you make below for Prefix and Suffix will apply to the heading level specified in the tab bar 

above the settings. You can apply different settings to each heading level. 

Prefix 1 – 4 

You may customize your index's style by specifying a prefix for each heading level. Prefixes are specified 

using up to four of the 20 logical conditions that are provided. To specify a prefix you, enter the prefix 

text, choose the condition for which the prefix will be applied and finally, specify whether a locator or 

cross-reference must precede the heading for the prefix for it to be applied. 

Each time a heading level is printed, your prefixes are examined in order. If the first prefix's condition 

matches the current index state, it will be used and all remaining prefixes will be ignored. If the first 

prefix's condition does not match the current index state, the second prefix's condition will be compared 

to the current index state. If they match, it will be used. Additional prefix conditions will continue to be 

examined until one matches, or until all prefixes you've specified have been exhausted. 

Text – This is the prefix text that will be applied should the conditions that you specify match the 

index's current state. 

Condition – These are the available conditions that will be used to determine if the prefix text will be 

applied to the index. The available conditions are: 

Never – The prefix will never be applied. 

Always  – The prefix will always be applied. 

Start lower level – The prefix will be applied only if the current heading is at a lower subheading 

level than the previously printed one. 

Start higher level – The prefix will be applied only if the current heading is at a higher subheading 

level than the previously printed one. 

Start highest level – The prefix will be applied only if the current heading is a Main heading and 

the previously printed heading was not a Main heading. 

Start lowest level – The prefix will be applied only if the current heading is the lowest level in the 

index and the previously printed heading was not at the lowest level. 

Parent level precedes – The prefix will be applied only if the current heading is the first 

subheading for this heading level. 

Child level precedes – The prefix will be applied only if the current heading is one level higher 

than the previously printed heading. 
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Same level precedes – The prefix will be applied only if the current heading level is the same as 

the previously printed heading. 

A CRLF precedes – The prefix will be applied only if the previously printed heading ended with a 

carriage return and linefeed. 

No CRLF precedes – The prefix will be applied only if the previously printed heading did not end 

with a carriage return and linefeed. 

Level Changed – The prefix will be applied only if the previously printed heading was at different 

heading level than the current level. 

Lowest level – The prefix will be applied only if the current heading is the lowest level associated 

with the current main heading. 

Is main heading – The prefix will be applied only if the current heading is a Main heading. 

Not lowest level – The prefix will be applied only if the current heading is not the lowest level in 

the index. 

Not highest level – The prefix will be applied only if the current heading is not a Main heading. 

Is cross-reference – The prefix will be applied only if the current heading is a cross-reference. 

Is not cross-reference – The prefix will be applied only if the current heading is not a cross-

reference. 

Child level follows – The prefix will be applied only if the current heading has subheadings. 

No child level follows – The prefix will be applied only if the current heading does not have 

subheadings. 

Locator Precedes?  – Use these conditions to specify if a locator or a cross-reference must precede the 

current heading in order for the prefix to be applied. The available conditions are: 

Don't Care – The prefix will always be applied. It does not matter if a locator or a cross-reference 

precedes. 

Yes – The prefix will be applied only if a locator precedes. 

No – The prefix will be applied only if a locator does not precede. 

XRef – The prefix will be applied only if a cross-reference precedes. 

Loc or XRef – The prefix will be applied if a locator or a cross-reference precedes. 

Suffix 1 – 2 

SKY Index allows you to customize your index's style by specifying a suffix for each heading level. 

Suffixes are specified using up to two of the 7 logical conditions that SKY Index provides. To specify a 

suffix you, enter the suffix text and choose the condition for which the suffix will be applied and finally. 

Each time a heading level is printed, SKY Index examines your suffixes in order. If the first suffix's 

condition matches the current index state, it will be used and the second suffix will be ignored. If the 

first suffix's condition does not match the current index state, the second suffix's condition will be 

compared to the current index state and if they match it will be used. 

Text – This is the suffix text that will be applied should the condition that you specify matches the 

index's current state. 

Condition – These are the available conditions that will be used to determine if the prefix text will be 

applied to the index. The available conditions are: 

Never – The suffix will never be applied. 
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Always – The suffix will always be applied. 

Locator exists – The suffix will only be applied if a locator exists for this heading. 

No locator exists – The suffix will only be applied if no locator exists for this heading. 

Child level follows – The suffix will only be applied if a lower heading level follows this heading. 

Locator, child level follows – The suffix will only be applied if a locator was printed for this 

heading and a lower heading level follows this heading. 

No locator, child level follows – The suffix will only be applied if a locator was not printed for this 

heading and a lower heading level follows this heading. 

Other Options 

Double Spaced Output – If checked, the index will be generated with double spaced lines. 

Define Alphabet Sections – Allows you to specify the alphabetic sections of the index. See Defining 

the Alphabet Sections of Your Index below for more information. 

Include Alphabet Separators – If checked, alphabet separators will be placed at the beginning of each 

new heading that starts with a letter different from the previous. You can specify how the separator 

is displayed in the Fonts tab of the Index Options dialog box. 

Blank lines before/after – Specifies the number of blank line that will be printed prior to, or after, the 

alphabet separator. 

Defining the Alphabetic Sections of Your Index 

Overview 

You can define what characters will cause a section break in the generated index and you can also define 

what label will be used. You can specify that the label be written or not written for each section. You can 

create as many sections as you desire. You have full control over the order of the sections. You can even 

make Z come before A if you desire. 

 

 

Define Sections Dialog 
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What Each Column Means 

Section: This is the name for the section. It is what will appear in the generated index just prior to the 

index entries for that section.  

Members: This is a list of all characters that, if they start an entry, will belong to this section. For 

example if you have a section named “A-C” which has the members ’abc’, all of the following entries will 

be included in that section: 

Aircraft, 12, 187 
Boats, 24 
Cars, 33 

Within the section, they will be alphabetized as they normally would be and the index would be 

generated like this: 

A-C 
Aircraft, 12, 187 
Boats, 24 
Cars, 33 

D 
Dogs, 44 

E 
Elephants, 29 

Suppress: If checked, the section name will not be printed in the generated index. The section will still 

be processed, but there will be no section break between it and the previous section. In other words, the 

label will not print and there will be no blank lines inserted either. 

Other Actions 

Add: Adds a new section 

Delete: Deletes the current section 

Up/Down Arrows: Moves the current section up or down one row in the grid 

Notes 

The first section “Unspecified” is a predefined and non-editable section that collects all characters that 

you do not specify in any other section. You cannot edit the Section or Members, but you can elect to 

suppress printing of the section name in your generated index. 
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Alternative Fonts 

Some indexes require the use of more than one font when writing the index. SKY Index allows you to 

define two alternative fonts for use in your index. These are in addition to the normal font you define in 

the Index Option's Font tab giving you a total of three available fonts. 

 

 

Alternative Fonts dialog 

Defining Alternative Fonts 

To define alternative fonts, do the following: 

1. Choose Options>Index. 

2. Click the Heading Style tab. 

3. Click the Alternative Fonts button. 

4. Set your alternative fonts. 

5. Click OK to close the Alternative Fonts dialog. 

6. Click OK to close the Index Options dialog. 

Options 

Alternative Font1 - 3   Specifies the font that will be used when you choose Alternative Font 1, 2 or 3 

from the Format menu. An example of your selection is displayed in the Font Preview window. 

Keyboard Shortcuts: Alternative Font1: Alt+F1 

   Alternative Font2: Alt+F2 

   Alternative Font3: Alt+F3 

Using Alternative Fonts 

Alternative fonts are applied in the same manner as you would apply text formatting attributes such as 

bold or italic. There are two methods. The first is to select the text for which you wish to change the font 

and then apply the font by choosing the appropriate alternative font from the Format menu. 

The second method is to choose the alternative font prior to typing the text and to then toggle the 

alternative font back off again after you've typed all of the text that you wish to be displayed in the 

alternative font by applying the alternative font a second time. For instance, if you wish to type the 

following sentence: 

This is an alternative font. 
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and want the words: "alternative font" to be displayed in courier, first type: "This is an " and then press 

Alt+F1 to start alternative font 1. Then type: "alternative font" and press Alt+F1 to turn the alternative 

font back off. Finally, type the period at the end of the sentence. 

Page Range Conflation Rules Dialog 

If none of the predefined conflation rules meet the needs specified by your client, you can define 

custom rules using the Page Range Conflation Rules dialog. The process for defining custom rules is 

described below. 

 

 

Custom Page Range Conflation Rules dialog 

(Showing Chicago Press 15th Ed. rules) 

Defining Custom Conflation Rules 

To define a custom conflation rule, do the following: 

1. Choose Options>Index 

2. Click the Locators tab 

3. From the Conflation drop-down list, choose (or re-choose) Custom. 

4. Enter your custom rules as defined below. 

5. Click OK. 

How to Enter Custom Conflation Rules 

To specify custom conflation rules, do the following: 

1. Enter a range in the Range column for the first number of a page range for which the rule will 

apply. Whenever SKY Index encounters a page range where the first number of the range falls 

within the range specified here, the rule will be applied. 
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2. Choose a rule. The available rules are: 

 Don’t Elide – no action will be taken. The page range will be displayed in full. 

 Changed Part – only the digits in the second number of the page range that are different 

than in the first number will be used. Note: You can use the MinDigits column to specify a 

minimum number of digits to use. 

 Changed unless all but one digit has changed – only the digits in the second number of the 

page range that are different than in the first number will be used unless only one digit is 

different in which case no abbreviation will occur. For example, in the page range 1456-1502, 

the only different digit is the ‘1’. In this case, instead of 1456-502, you would get 1456-1502. 

However, for 1456-1459, you would get 1456-9. 

3. Choose whether or not to repeat the rule for multiples of 100, 1,000, or 10,000. Your options are: 

 Don’t Repeat – the rule will not be repeated for multiples of 100, 1,000, or 10,000. 

 Repeat 100s – the rule will be repeated for multiples of 100, but not for multiples of 1,000 or 

10,000. 

 Repeat 100s and 1000s – the rule will be repeated for multiples of 100 and 1,000, but not for 

multiples of 10,000. 

 Repeat 100s and 10000s – the rule will be repeated for multiples of 100 and 10,000, but not 

for multiples of 1,000. 

 Repeat 100s and 1000s and 10000s – the rule will be repeated for multiples of 100, 1,000 and 

10,000. 

 Repeat 1000s – the rule will be repeated for multiples of 1,000, but not for multiples of 

10,000. 

 Repeat 1000s and 10000s – the rule will be repeated for multiples of 1,000 and 10,000. 

 Repeat 10000s – the rule will be repeated for multiples of 10,000. 

Example: If you select Repeat 100s for the range 101-109 and specify Changed Part as the rule, 

and then SKY Index encounters the range 301-305, it will be abbreviated to 301-5. If 1201-1205 

is encountered, it will also be abbreviated. If, however, you 2201-2205 is encountered, it will not 

be abbreviated because repeating 1000s was not selected. If you select Repeat 100s and 1000s, 

the range 2201-2205 would be abbreviated as would 3401-3406. 
4. Choose the minimum number of digits to use for an abbreviated page number – normally this 

will be 1, but there are some publishers that want at least two digits used for special cases. For 

example, Chicago Press wants at least two digits for the range 110-199 (repeated for 100s, 1000s 

and 10000s). With this option, if 110-119 is encountered with the Changed Part rule in place, 

instead of 110-9, you will get 110-19. 

Notes 

 If a page range is encountered for which you have not specified a rule, the page range will not be 

elided. This means that the first two rules in the example dialog above are not actually needed, 

but they are included to add clarity to the rules example. 

 Normally, if you want the 100s repeated, you will also want 1,000s and 10,000s repeated. You 

have the option to apply the repeating parts differently, but if you don’t know that hundreds 

should be repeated, and are unsure of thousands and ten thousands, you should choose to repeat 

all three. 

 If you have already chosen Custom as the Conflation and want to edit the conflation settings, 

just choose Custom again and the Page Range Conflation Rules dialog will be presented again. 
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Chapter 

27 
Data Managers 

Acronym Manager 

Acronyms allow you to define abbreviations for lengthy text. These abbreviations are automatically 

expanded during data entry. For instance, the acronym "ram" can be expanded to "Random Access 

Memory" by typing "ram" followed by a space. You may define as many acronyms as you desire. 

 

 

Acronyms dialog 

Defining Acronyms 

To define an acronym, do the following: 

1. Choose Options> Acronym Manager. 

2. Enter an acronym. 

3. Press tab. The cursor will move to the Expansion field. 

4. Enter the text that will replace the acronym. 

5. Press tab. 

6. Repeat steps 2 through 5 for additional acronyms. 

7. Click OK. 
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Columns 

Acronym – Enter an acronym of up to four letters. During data entry, it will be expanded into the text 

in the Expansion field. 

Expansion – Enter the text to replace the acronym during data entry. You can enter up to 254 

characters. If the Expansion text is lengthy, press Shift+F2 to invoke a larger text editor. 

Options 

Export – Allows you to save all entries in the Acronym list to a file that can be imported into another 

index using the Import button. 

Import – Allows you to import an Acronym list that was previously saved to a file using the Export 

button. 

Merge – This is the same as Import except that the entries that are imported are added to the existing 

list rather than replacing the list. 

Print – Prints a list of all Acronyms. 

Refresh – If you have edited the list, this will resort the list and put it back in alphabetical order. 

Revert – Abandons all changes you’ve made and restores the list to the same state it was in when you 

opened the Acronym Manager. 

Help – Displays the help file topic for this dialog. 

OK – Saves your changes and closes the Acronym Manager. 

Cancel – Performs a Revert and then closes the Acronym Manager. 

Using Acronyms 

During data entry, simply type a defined acronym plus a trailing space and it will be replaced with the 

full text plus a space. Do not worry about removing the trailing space if it appears at the end of your 

entry, SKY Index will remove it when you move the marquee to the next grid cell. The acronyms are not 

case sensitive. 

Notes 

 If you type a space after an acronym, the acronym will be expanded to the full ‘Expansion’ text. 

 If  you type an acronym at the end of a heading, pressing Tab or Enter will expand the acronym. 

There is no need to type the trailing space. 

 If you type a hyphen (-) after an acronym instead of a space, the acronym will not be expanded 

and the hyphen will be converted to a space. 

 If you type a period after an acronym, the acronym will be expanded, the period will not appear 

and there will be no space after the expanded text. This will allow you to type additional text 

directly after the expanded text. For example: If you have the acronym ‘s*’ for ‘school’, you can 

type “s*.yard” and you’ll get schoolyard. 

AutoComplete Manager 

The AutoComplete feature can dramatically reduce the amount of typing needed when writing your 

index. The longer the average index entry, the greater are the potential savings. The AutoComplete 

Manager lets you add items to, and remove items from, the AutoComplete list. Note: Because of the 

sophisticated way in which the list is handled internally, adding or removing items should rarely be 

needed. You can also save the list for reuse with future indexes that are similar in nature. 
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AutoComplete Manager 

Accessing the AutoComplete Manager 

To access the AutoComplete Manager, choose Options>AutoComplete Manager. 

Options 

Export – Allows you to save all entries in the AutoComplete list to a file that can be imported into 

another index using the Import button. 

Import – Allows you to import an AutoComplete list that was previously saved to a file using the Export 

button. 

Merge – This is the same as Import except that the entries that are imported are added to the existing 

list rather than replacing the list. 

Print – Prints a list of all AutoComplete entries. 

Refresh – If you have edited the list, this will resort the list and put it back in alphabetical order. 

Revert – Abandons all changes you’ve made and restores the list to the same state it was in when you 

opened the AutoComplete Manager. 

Help – Displays the help file topic for this dialog. 

OK – Saves your changes and closes the AutoComplete Manager. 

Cancel – Performs a Revert and then closes the AutoComplete Manager. 

Notes 

The AutoComplete Manager is generally intended for one purpose – to allow for exporting and importing 

AutoComplete lists. However, you are free to edit the data in the AutoComplete list if you wish to do so. 

The AutoComplete grid behaves in a similar manner as the Data Entry Grid. 
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The AutoComplete Manager cannot store entries longer than 255 characters in length. This is a highly 

unusual event, but is something that you should be aware of. Any entry that is longer than 255 

characters is simply ignored by the AutoComplete Manager. 

How AutoComplete Works 

AutoComplete keeps track of three things whenever you type a new heading. 

1. The actual heading that was typed 

2. How many times this particular heading has been typed into the index 

3. The timestamp of the most recent time the heading has been typed 

Each time you start to type a heading, what you have typed so far is compared to all entries in the 

AutoComplete list. All entries that match the text (formatting is not taken into account) of what you’ve 

typed so far are collected as potential matches. Once the list of potential matches has been created, that 

list is parsed to find the entries that have been typed most often. That entry is the one that is used as 

the best guess unless there are two or more entries with exactly the same frequency of usage. In that 

case, the entry with the most recent timestamp is used to anticipate your typing. 

As you type more characters the anticipated text will become more and more accurate. Because of SKY 

Index’s advanced algorithm for anticipating your entries, you will probably find that most entries require 

only three or four characters to AutoComplete. This has obvious time saving advantages. 

Importing or Exporting an AutoComplete list 

If you work on many similar indexes you may find it beneficial to reuse the AutoComplete list when 

starting a new index. You might also want to start an AutoComplete list based on a list of phrases from 

a client. Doing so will allow SKY Index to immediately start anticipating your entries rather than having 

to wait until you enter those entries for the first time. The directions below describe how to save an 

AutoComplete list and then retrieve it for use in a new index. 

Exporting (saving) an AutoComplete List from an Existing Index 

To save an AutoComplete list for later reuse, click the Export button. A Files dialog will appear. Enter a 

name for the AutoComplete list and click Export to save it. 

Importing (loading) an Existing AutoComplete List 

To load a previously saved AutoComplete list, click the Import button. In the Files dialog that appears, 

choose the AutoComplete file that contains the AutoComplete data you wish to import and then click 

Import.  

Tips 

 While in Data Entry View or Edit View, you can refresh (rebuild from scratch) the AutoComplete 

list at any time by pressing Alt+Ctrl+U. This is the Update AutoComplete command. 

 After you’ve used AutoComplete for a period of time, you will acquire a natural instinct of when 

certain phrases won’t automatically complete as you wish. When you know this is going to 

happen, start the entry with a single space. This will deactivate AutoComplete. The leading 

space will be automatically removed when the entry is saved. 

 If you are attempting to type just the first word of a multiword phrase that has been entered 

previously, and is therefore being AutoCompleted, after you type the word you want, just press 

the Delete key to remove the trailing text. 
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AutoEntry Manager 

Some types of indexes have frequent and predictable double postings. SKY Index's new AutoEntry 

feature allows you to specify the types of entries that are double posted and the method to use when 

double posting the entry. 

 

 

AutoEntry Manager Dialog 

Configuring AutoEntry 

To configure AutoEntry, do the following: 

4. Choose Options>AutoEntry Manager. 

5. Set your AutoEntry options. 

6. Click OK. 

Columns 

Heading – AutoEntry uses the main heading of an entry to determine if it will be double posted. Enter 

all main headings that will be double posted. Whenever you type a record that contains one of these 

main headings, the record will be automatically double posted according to your specifications in the 

Action group discussed below. 

Action – What should happen when an entry that should be double posted is entered. Your options are: 

Duplicate and Swap – Specifies that the double posting will be performed by simply swapping the 

Main and Sub1 headings. 

Duplicate, Swap and Promote – Specifies that the double posting will be performed swapping the 

Main and Sub1 headings and then promoting the Sub1 heading into the Main heading using the 

promote text you specify under Promote With. 

PromoteChar – Specifies the promote text used when an entry is double posted using the Duplicate, 

Swap and Promote technique. Your options are: 
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Space – The subheading text is promoted with a single space. 

Comma + Space – The subheading text is promoted with a comma and a space. 

Options 

Export – Allows you to save all entries in the AutoEntry list to a file that can be imported into another 

index using the Import button. 

Import – Allows you to import an AutoEntry list that was previously saved to a file using the Export 

button. 

Merge – This is the same as Import except that the entries that are imported are added to the existing 

list rather than replacing the list. 

Print – Prints a list of all AutoEntry entries. 

Refresh – If you have edited the list, this will resort the list and put it back in alphabetical order by 

heading. 

Revert – Abandons all changes you’ve made and restores the list to the same state it was in when you 

opened the AutoEntry Manager. 

Help – Displays the help file topic for this dialog. 

OK – Saves your changes and closes the AutoEntry Manager. 

Cancel – Performs a Revert and then closes the AutoEntry Manager. 

Macro Manager 

Macros let you combine actions that would normally take several keystrokes into a single keystroke. 

Macros are invoked by pressing holding down Alt+Shift along with one of the alphabet characters a-z 

giving you a total of 26 possible macros. The Macro Manager lets you define and manage your macros. 

What is a Macro?  

A macro is nothing more than a collection of keystrokes. For instance, to delete a word to the right of the 

cursor and type two colons, you would type: Ctrl+Del (deletes the word) and then ‘::’ (two colons). A 

macro can be written to perform those three keystrokes with just one keystroke. Although this is a 

trivial example, it should let you see the broader benefit of being able to replace ten or twenty keystrokes 

with one. 

Defining Macros 

To define macros, do the following: 

1. Choose Options>Macro Manager 

2. Enter your macros. 

3. Click OK. 
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Macros dialog 

Entering Macros 

To enter macros, enter the text for the macro into the Macro column of the grid next to the Shortcut that 

you wish to use to execute the macro. You should also enter a description of the macro in the Hint 

column so that you can remember what it does at a glance. The description is what will be displayed in 

the buttons of the Macros Toolbar. To enter a description after entering your macro, press Tab and then 

type the description. If you do not enter a description, the macro itself will be used by default. 

Macros can contain commands to perform virtually any keystroke available on your keyboard. Below is a 

detailed description of how to enter them. If you are writing a lengthy macro, you can press Shift+F2 to 

invoke a larger text editor. 

Options 

Export – Allows you to save all entries in the Macro list to a file that can be imported into another index 

using the Import button. 

Import – Allows you to import an Macro list that was previously saved to a file using the Export button. 

Merge – This is the same as Import except that the entries that are imported are added to the existing 

list rather than replacing the list. 

Print – Prints a list of all Macro entries. 

Refresh – Allows you to forcefully redraw the entire grid if you believe there is some sort of grid 

rendering problem. 

Revert – Abandons all changes you’ve made and restores the list to the same state it was in when you 

opened the Macro Manager. 

Help – Displays the help file topic for this dialog. 

OK – Saves your changes and closes the Macro Manager. 

Cancel – Performs a Revert and then closes the Macro Manager. 
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How to Create Macros in SKY Index 

Each key in a macro is represented by one or more characters.  To specify a single keyboard character, 

use the character itself.  For example, to represent the letter A, use "A" for the macro text.  If you want 

to represent more than one character, append each additional character to the one preceding it.  To 

represent the letters A, B, and C, use "ABC" for the macro text. 

The plus sign (+), caret (^), percent sign (%), tilde (~), and parentheses ( ) have special meanings.  To 

specify one of these characters, enclose it inside braces.  For example, to specify the plus sign, use {+}. 

Brackets ([ ]) have no special meaning, but you must enclose them in braces as well, because in other 

applications for Microsoft Windows, brackets do have special meaning that may be significant when 

dynamic data exchange (DDE) occurs. To send brace characters, use {{} and {}}. 

To specify characters that aren't displayed when you press a key (such as Enter or Tab) and keys that 

represent actions rather than characters, use the codes shown below: 

Macro Codes 

 

Key Code 

Backspace {BKSP} or {BS} 

Break {BREAK} 

Caps Lock {CAPSLOCK} 

Clear {CLEAR} 

Del {DELETE} or 

{DEL} 

Down Arrow {DOWN} 

End {END} 

Enter {ENTER} or ~ 

Esc {ESCAPE} or 

{ESC} 

Help {HELP} 

Home {HOME} 

Ins {INSERT} 

Left Arrow {LEFT} 

Num Lock {NUMLOCK} 

Page Down {PGDN} 

Page Up {PGUP} 

Print Screen {PRTSC} 

Right Arrow {RIGHT} 

Scroll Lock {SCROLLLOCK} 

 

Key Code 

Tab {TAB} 

Up Arrow {UP} 

F1 {F1} 

F2 {F2} 

F3 {F3} 

F4 {F4} 

F5 {F5} 

F6 {F6} 

F7 {F7} 

F8 {F8} 

F9 {F9} 

F10 {F10} 

F11 {F11} 

F12 {F12} 

F13 {F13} 

F14 {F14} 

F15 {F15} 

F16 {F16} 

To specify keys combined with any combination of Shift, Ctrl, and Alt keys, precede the regular key code 

with one or more of the following codes: 

 

Key Code 

Shift + 

Ctrl ^ 

Alt % 
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Note: When specifying a keystroke with the ctrl, alt or shift keys, be sure to use a lowercase letter or the 

keystroke will not be recognized. 

To specify that Shift, Ctrl, and/or Alt should be held down while several other keys are pressed, enclose 

the keys' code in parentheses.  For example, to have the Shift key held down while E and C are pressed, 

use "+(ec)".  To have Shift held down while E is pressed, followed by C being pressed without Shift, use 

"+ec". 

To specify repeating keys, use the form {key number}; you must put a space between key and number. 

For example, {LEFT 42} means press the Left Arrow key 42 times; {h 10} means press h 10 times. 

An Example 

For an example let's assume that you are writing an index to a computer manual and that there will be 

frequent instances where you will want to create a new entry out of an existing entry with the following 

modifications: 

standard toolbar, copy button, 32 

Duplicate this and translate to: 

copy button (standard toolbar), 32 

Here is what needs to be done in English: 

1. Use the duplicate and swap feature to duplicate the record and swap the main and Sub1 

headings. 

2. Move the marquee is over the main heading. 

3. Edit the new main heading, adding a space and both opening and closing parentheses. 

4. Move the grid marquee to the Sub1 cell. 

5. Cut the contents of the Sub1 cell to the clipboard. 

6. Move the grid marquee back to the Main cell. 

7. Go into Edit mode and move the text cursor between the opening and closing parentheses. 

8. Paste the contents of the clipboard between the parentheses. 

9. Exit Text Edit Mode 

Below are the macro codes needed to perform these actions. First, the macro’s codes are listed 

numerically according to the action the macro is designed to handle from the list above. Then the entire 

macro as it should be entered into SKY Index is shown. 

1. ^{f4} 

2. {home} 

3. {f2} {(}{)} 

4. {tab} 

5. ^x 

6. {left} 

7. {f2}{left} 

8. ^v 

9. {f2} 

^{f4}{home}{f2} {(}{)}{tab}^x{left}{f2}{left}^v{f2} 

Tip: Using the Alt+F12 keyboard shortcut to force Text Edit Mode can be very useful in macros. 



202    SKY Index 7.0 User’s Guide 

Translation Manager 

What are Translations?  

Translations allow you to substitute a short sequence of characters for a much longer one. They are very 

similar to acronyms in this respect with the important distinction that acronyms are immediately 

expanded when you enter them and translations are not expanded until you generate the index.  

Translations are also the way to add characters to your index that are not included in the standard 

Windows character set. These are Unicode characters and there is an Add Unicode Character button 

included to make this an easy task. 

Translations can also be used to make it easier to enter a character that exists in the Windows ANSI 

character set, but does not have a key on your keyboard. A good example of this would be entering an en 

dash or an em dash. There is no key on your keyboard for these characters so you might want to 

substitute an underscore for an en dash and a double underscore for an em dash making data entry 

much easier. 

You can have an unlimited number of translations and translations are case sensitive. Below is a 

screenshot of the Translation Manager dialog with a few example entries. Note that the double 

underscore comes first in the translation list. If it did not, the individual underscores would be translated 

into two en dashes. 

 

 

Translation Manager Dialog 

Defining Translations 

To define a translation, do the following: 

1. Choose Options>Translation Manager. 

2. Enter the text for a translation. 

3. Press tab. The cursor will move to the Translation column. 
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4. Enter the word or phrase that will be used to replace what you typed in the Text field wherever 

it occurs in the index. 

5. Press tab. The cursor will move to the In Entry Fields column. 

6. Specify if the translation will work in normal entry fields. (Pressing the space bar toggles this 

option). Note: You can apply formatting such as bold, italic, and underline using standard 

keyboard shortcuts. 

7. Press tab. The cursor will move to the In Page Fields column. 

8. Specify if the translation will work in the Page field. (Pressing the space bar toggles this option). 

9. Press tab. The cursor will move to the Allow RTF column. 

10. Specify if the translation is actually coding that should be interpreted as Rich Text coding. 

(Pressing the space bar toggles this option). Use of this option requires knowledge of RTF. 

11. Press tab. 

12. Repeat steps 2 through 11 for additional Translations. 

Options 

Export – Allows you to save all entries in the Translation Table to a file that can be imported into 

another index using the Import button. 

Import – Allows you to import an Translation Table that was previously saved to a file using the Export 

button. 

Merge – This is the same as Import except that the entries that are imported are added to the existing 

list rather than replacing the list. 

Print – Prints a list of all Translation Table entries. 

Refresh – If you have edited the list, this will resort the list and put it back in alphabetical order. 

Revert – Abandons all changes you’ve made and restores the list to the same state it was in when you 

opened the Translation Manager. 

Help – Displays the help file topic for this dialog. 

Add Unicode Character – Brings up a form that you fill in that lets you easily create translations for 

characters that don’t exist in the standard Windows ANSI character. The translation will create RTF 

code for the Unicode character you specify and that character will appear in the generated index. 

OK – Saves your changes and closes the Translation Manager. 

Cancel – Performs a Revert and then closes the Translation Manager. 

Columns 

Text – Enter the text that will be interpreted by SKY Index as a translation. This can be anything, but 

you need to be sure that it will be unique so that you don’t end up altering text that you don’t really 

want to be translated. Examples of good translation text: <a:>, [p], *3*, >>7. Examples of bad 

translation text: a, on, ::, 1-2 

Translation – The text that will replace the word or phrase you entered in the Text field. You can enter 

up to 254 characters. If the Translation is lengthy, press Shift+F2 to invoke a larger text editor. 

In Entry Field – If checked and if the Text is found in any field except the Page field, it will be 

translated into the Translation Text. 
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In Page Field – If checked and if the Text is found in the Page field, it will be translated into the 

Translation text. Otherwise it will be ignored. 

Allow RTF – If checked, the Translation will be assumed to be Rich Text coding and therefore certain 

characters will be handled differently.  Checking this option allows you to enter Rich Text codes 

directly. Do not use this option unless you know and understand Rich Text. 

Using Translations 

During data entry, simply type the text of a Translation wherever you want the translated text to 

appear. The translation will appear in the Preview Pane as soon as the current record is stored. The text 

in the Data Entry Grid will remain unchanged. Please note that the Translations are case sensitive. 

Using the Translation Table to Enable Use of Unicode Characters 

Some indexes require the use of characters that are not part of the Windows ANSI character set. For 

these indexes you can take two approaches. The first is to simply decide upon a code for each of the 

characters and use that code wherever the corresponding character should be in the index. Then tell 

your client what codes you used for each character and allow them to perform the substitution at their 

end. The other approach is to use Translations to perform the substitution during index generation. The 

second approach is discussed here. 

Important: You can only use these Unicode translations for indexes that will be generated as an RTF 

file. 

Overview of the Process 

The basic process for using the translation table to generate Unicode characters is: 

 Decide upon a code that you will use to represent the character 

 Define the translation 

 Use the code you defined when entering headings in your index. 

Below are more explicit details for each step. 

Choosing a Code for the Translation 

The most important aspect of choosing a code is to choose a sequence of characters that you are certain 

will never appear in your index as part of a normal heading. An example of a good code would be 

something like ‘[a:]’ to represent an lowercase ‘a’ with a Diaeresis (ä). An example of a bad code would be 

‘ad’ because the two letters ‘a’ and ‘d’ are likely to appear in your index together as part of normal word. 

As a general rule, it is not a good idea to use one or two character codes and there should be at least one 

non-alpha character in the translation to assure no false translations. SKY Software recommends that 

you start each code with a left bracket ‘[’ and end each code with a right bracket ‘]’, but this is not a hard 

and fast rule, it is a recommendation. 

Defining a Unicode Translation 

To illustrate creating a Unicode translation, we will define a translation for the Latin small letter ‘th’ 

with a strikethrough (ᵺ). We will use the code ‘[th-]’ to represent this character. To define this Unicode 

translation, do the following: 

1. Click the Add Unicode Character button. The Unicode Character Translation Generator dialog 

will appear as shown below. 
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Unicode Character Translation Generator Dialog 

2. In the Text textbox, enter the code you will use to represent the Unicode character. For our 

example, this is ‘[th-]’. 

3. Enter the hexadecimal value of the Unicode character you are creating a translation for. This 

number is shown at the bottom left of the Windows Character Map applet. As shown circled in 

red in the figure below. (Note: This is the ‘Windows’ character map applet. It is not the 

Character Map that you get within SKY Index by choosing Tools>Character Map.) 

 

 

Character Map Example 

4. In the Sort as textbox, enter a character of characters that will be used to sort the code you enter 

so that your index entries are sorted correctly. For our example, we will use ‘th’ 

5. In the Display as textbox, enter a character or characters that you want to be displayed in the 

Preview Pane in place of the code you have defined. This character(s) will appear in a different 

color in the Preview Pane to let you know it is part of a translation. For our example we will the 

two letters ‘th’. 
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6. Optionally, enter a single character that will be used by your word processor in place of the 

Unicode character if that character is not available. Please note that MS Word will substitute a 

valid character of a different font if the desired character does not exist in the current font. You 

should always verify with your client that the font they will be using is a Unicode font and that it 

contains the characters in question. 

7. Click OK. 

An example of the resulting translation is shown in the Translation Manager Dialog screen shot shown 

earlier in this section. During data entry, you will enter ‘<th>’ anywhere you want the Latin character 

‘ᵺ’ to appear. In the Preview Pane, you will see ‘th’ because that is what we defined as the ‘Display as’; 

characters. The generated RTF file will contain the actual Latin small th with a strikethrough ‘ᵺ’. 

Notes 

 Translations do not require surrounding spaces as acronyms do. 

 Unlike Acronyms, Translations are case sensitive. 

 Translations are performed in the order in which they appear in the Translation Table grid. 

 To delete a translation, select the translation by clicking in the row header in front of the 

translation and then press ‘Del’ or ‘Delete’ on your keyboard. 

Recommended Coding for Unicode Characters 

SKY Software recommends the following guidelines when creating a code for a Unicode character: 

Format of code – [ < ID> < Modifier> ]  

ID   One or two characters that identify the Unicode character to be translated 

Modifier   One or two characters that specify attributes of the character being translated 

Example: [a:] 

ID = a (specifies a lower case ‘a’) 

Modifier = : (specifies that the lower case a will have a Diaeresis. 

Notes: 

 Every code will start and end with brackets [  ]. This makes them unlikely to occur in a normal 

heading and they are easy to type because there is no shift key involved. 

 For characters that have an alphabet equivalent, the ID will be that letter and will be followed 

by a one or two characters (modifier) that determine what happens to that character. For 

instance [a:] would become ä, [A’] would become Á, and [a^] would become â, and [o~] would 

become õ. 

 For characters where there is no alphabetic equivalent such as the Latin th with a 

strikethrough, you would use a two letter ID with a one or two letter modifier. Example [th-] = ᵺ 
and [AE] = Æ. 

 These are guidelines, not mandated rules. You are free to use whatever coding you desire. 

 Although not available as of the initial writing of this User’s Guide, SKY Software plans to make 

available a list that can be imported of recommended translations at some point in the future.  

Visit the SKY Software website to check for the availability of this list. 
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Chapter 

28 
Tools 

Overview 

SKY Index provides a number of tools that may help make your indexing go faster, help you modify the 

index in specific and unique ways, or provide information about your index. You may use some of these 

tools frequently and others only occasionally, but they can be invaluable when needed. These tools are 

found under the Tools menu of your program and are described in this chapter. 

Add Prefix 

Purpose 

Allows you to add a letter, word or phrase to the beginning of a field (grid column) for all records that are 

currently selected. 

. 

 

Add Prefix dialog 

Adding a Prefix 

1. Select the records to receive a prefix. 

2. Choose Tools>Add Prefix. The Add Prefix dialog will be displayed. 

3. Click the field that you wish to add a prefix to. 

4. Enter the text for the prefix. 

5. Click OK.  

The text will be added to the specified field of all selected records in the index. 
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Options 

Field   Allows you to specify the index field that you wish to apply the Prefix to. You can choose a field 

by clicking on it with the mouse, using the up or down arrow keys or by typing its name. 

Text   This is the text that will be added to the front of the specified field of all selected records in the 

Data Entry Grid. 

Keyboard Shortcut: n/a 

See also: Add Suffix 

Add Suffix 

Purpose 

Allows you to add a letter, word or phrase to the end of a field (grid column) for all records that are 

currently selected. 

 

Add Suffix dialog 

Adding a Suffix 

1. Select the records to receive a suffix. 

2. Choose Tools>Add Suffix. The Add Suffix dialog will be displayed. 

3. Click the field that you wish to add a suffix to. 

4. Enter the text for the suffix. 

5. Click OK. 

The text will be appended to the specified field of all selected records in the index. 

Options 

Field   Allows you to specify the index field that you wish to apply the Suffix to. You can choose a field 

by clicking on it with the mouse, using the up or down arrow keys or by typing its name. 

Text   This is the text that will be added to the end of the specified field of all selected records in the 

Data Entry Grid. 

Keyboard Shortcut: n/a 

See also: Add Prefix 
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Character Map 

Purpose 

There are times when you may need to add symbols or characters for foreign languages to your index 

entries. To make this easier for you, SKY Index provides a Character Map dialog. 

 

 

Character Map dialog 

Entering Symbols or Special Characters 

To enter symbols or special characters in your index, do the following: 

Place the cursor in the data entry grid where you wish to insert a symbol or special character. 

Choose Tools>Character Map. The Character Map dialog will appear. 

Use the Font drop down list box to select the font that you wish to choose characters from. 

Find the characters that you wish to enter in the dialog and as you find them, double click them. 

This will make them appear in the Characters to copy text box. 

After you've selected all of the characters you wish to enter, click Insert. 

Click Close. 

Options 

Font   Specifies the font that you wish to choose a character or symbol from. 

Copy   Copies the currently highlighted character or symbol to the Characters to copy text box. If any 

characters are already in this text box, the new character is appended to the existing characters. 

Characters to copy   Shows the characters that have been selected so far and that may be inserted into 

your index by clicking Insert 

Select   Selects any characters in the Characters to copy text box so that they can be copied to the 

Windows clipboard by pressing Ctrl+C. 

Insert   Inserts the characters that are currently in the Characters to copy text box at the current 

insertion point in the data entry grid. 
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Error Scan 

Purpose 

There are many different kinds of errors that can creep into an index during the data entry and editing 

process. Error scan is used to find and alert you to many of these common problems. 

 

Error Scan Dialog 

Checking Your Index for Errors 

To check you index for errors, do the following: 

1. Choose Tools>Error Scan or click the  toolbar icon. The Error Scan dialog box will appear as 

shown above. 

2. Select the types of errors you wish to scan for. (Descriptions of your options are below.) 

3. Click OK. 

Options 

Cross-references 

Improperly formed cross-reference – Detects what may be cross-references that are not formed 

according to the rules that SKY Index expects. 

Circular Cross-references – If checked, cross-references will be checked for references that refer 

to an entry that refers back to the original entry. 

Verify that target exists – Verifies that the target of a cross-reference exists. 

Ignore trailing text in parentheses – When verifying that a target exists, any trailing text in 

parentheses will be ignored for comparison purposes. 
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Questionable Entries 

Improperly Formed Index Entries – Detects entries that were not entered in a legal manner. For 

example, entries that have no main heading or entries that have a Sub2 heading, but no Sub1 

heading would be flagged as an error. 

Questionable Entries – Detects entries that may not be desirable. For instance, an entry that has 

a single page reference to a page that is also inside a range of pages like "computers, (5-8), 7, 10" 

is probably a mistake. 

Maximum Locators Per Entry – Specifies the number of locators that, when exceeded for a 

single entry, will raise a warning as a result of the Questionable Entries error scan. 

Other 

Orphan Subheadings – If checked, Any heading that has only one subheading will be flagged. 

Undifferentiated Locators – If checked, any main heading that includes one or more locators and 

also has one or more subheadings will be flagged as a potential problem. 

Select All – Toggles the selection of all options on or off. 

Viewing and Editing the Errors That Where Found 

After SKY Index scans your index for errors, it will display the dialog box shown below. 

 

 

Error Scan Results Dialog 

This dialog box is a stay on top window. While this window is visible, the entire SKY Index program can 

still be accessed. This allows you to fix errors while the list is still visible.  

You can click on an item in the error list to go directly to the record in the index that contains the error. 

You should edit the record to fix the problem and then delete it from the error list by clicking Delete. 

Repeat this process until all errors have been corrected. There will be some errors listed that are 

warnings, not errors. If you find that those items are okay and do not require attention, simply delete 

them from the list. 
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Below the error list is the Details Pane. The Details Pane shows you a brief synopsis of the problem and 

then gives you a more detailed explanation below the synopsis. 

Tip: This dialog box can be resized so you can see more errors at one time. 

Options 

Merge – If the error being viewed is an orphaned subheading, you may merge the orphan by clicking 

Merge. 

Delete – Deletes the current list item from the error list. 

Print – Prints the error list so that you can work from paper rather than on-screen. 

Scan Again – Closes the Error Scan Results dialog and displays the Error Scan dialog so that you can 

scan again. This is useful if you wish to scan for only one type of error at a time. 

Close – Closes the Error Results dialog. 

Statistics 

Information about your index can be useful in tracking your productivity, for billing your clients and for 

getting an idea of your thoroughness. SKY Index provides many details of your index that can be used 

for these and other purposes. 

To see a statistics report for your index, choose Tools>Statistics. The statistics dialog will appear and 

you will be presented with the options described below. 

 

 

Statistics Dialog 

Options 

Pages Indexed – If checked, you will get statistics for how many pages of the document you are 
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indexing that you have index entries for. 

Include Front Matter – If checked, front matter (Roman numeral locators) will be included in the 

page count. 

Count Skipped Pages – If checked, pages where nothing has been index will still be included in 

the count. In other words, if you make entries for page 3 and page 7, but no entries for pages 4, 5, 

and 6, the page count will be 5 because the pages in-between 3 and 7 will be counted. 

Entries Per Page – The total number of index entries you have made on average for each page of 

the document you are indexing. This is calculated as:  

(Total number of records - records that contain cross-references) / Pages indexed. 

Line Count – If checked, you will get a count of lines for your generated index. This is often needed in 

order to satisfy a client’s stated maximum (or minimum) line count. Some clients may ask for a line 

count based on a number of characters per line. This can easily be accommodated using the options 

below. (Note: These stats are based on an indented index regardless of index option settings.) 

Font – The font used when calculating the index line count. Your choices are: 

Index Setting – The font and font size specified in Index Options will be used. Your settings for 

Indent and turnover indent will also be used. 

Mono-spaced font – A mono-spaced font will be used. This option is used in conjunction with the 

Column Width, Indent, and Turnover Indent options. For details, see those options below. 

Column Width – If you specify that a mono-spaced font be used for calculating the line count, you 

must specify here the width of a column in characters. 

Indent – If you specify that a mono-spaced font be used for calculating the line count, you must 

specify here the indent of subheadings in or spaces or tabs. Sub-subheading indents are assumed 

to be incremental. 

Turnover Indent – If you specify that a mono-spaced font be used for calculating the line count, 

you must specify here the indent of turnover lines in or spaces or tabs. Sub-subheading turnover 

indents are assumed to be incremental 

Wrap lines at column width – If checked, and if Mono-spaced Font has been selected for Font, 

when counting the lines, the lines will be wrapped after the number of characters specified in 

Column Width is reached and the new, wrapped, line will be indented according the Turnover 

Indent that has been specified. If Font has been set to Index Settings, the lines will wrap 

according to your current index settings. 

Other – Other options that you may find useful 

Elapsed Time – Provides both the cumulative time and current session time. The session time is 

the time since you most recently opened this particular index. The cumulative time is the total of 

all sessions for this index. 

Number of Cross-references – If checked, provides the total number of cross-references, total 

unique cross-reference, total see cross-references and total see also cross-references. 

Page References – If checked, provides statistics on how many references there are between 1 and 

9, 10 and 99, 100 and 999, and 1000 and 9999. 

Average Entry Lengths – If checked, provides statistics on the average length of entries for Main 

headings, subheadings, and Locators. 
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Add/Remove Volume/Chapter Labels 

If you are working on multi-volume indexing projects or have an indexing project where each chapter is 

numbered individually, there may be times when you want to add or remove a volume or chapter label. 

The Add/Remove Volume/Chapter Labels function performs this task. 

 

Volume Labels dialog 

Adding or Removing Chapter Labels 

1. Choose Tools>Add/Remove Volume/Chapter Labels. 

2. Select the desired action: Add or Remove. 

3. Specify whether to modify volume or chapter labels. 

4. If the Action is Add, enter the new chapter or volume label. Note: You do not need to append the 

volume or chapter separator character. 

5. Click OK. 

If you are adding a chapter label, SKY Index will add the chapter label to all non-empty and non-cross-

reference page numbers. The chapter label will be inserted after any existing volume label and before 

the page number part of the locator. If you are removing chapter labels, all existing chapter labels will be 

removed. 

If you are adding a volume label, SKY Index will add the volume label to all non-empty and non-cross-

reference page numbers. The volume label will be added before the page number part of the locator or 

any existing chapter label. If you are removing volume labels, all existing volume labels will be removed. 

See Index Options (Locators) for more information on how page numbers are handled in SKY Index. 

Options 

Action   Specifies action you wish to take. Choosing Add will instruct SKY Index to add a volume or 

chapter label. Choosing Remove will instruct SKY Index to remove any existing volume or chapter 

labels. 

Act Upon   Specifies what type of label you wish to modify. Choosing Volume will instruct SKY Index to 

act only on volume labels. Choosing Chapter will instruct SKY Index to act only on chapter labels. 

Label   When adding volume or chapter labels, this is where you type the label that you wish to be 

added. Do not include a volume or chapter separator. 
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Process Maiden Names 

When writing a genealogical index, it is often desirable to include entries for a married woman under 

both her married and maiden names. SKY Index will automatically create these entries during data 

entry when using Automatically Create Maiden Name Entries option. If you fail to turn this feature on 

before starting your index, you can process maiden names by using the Process Maiden Name Entries 

function. It will scan the entire index for the commercial at sign (@) and when found, will process the 

maiden name information. 

After you've enabled automatic maiden name creation, enter a married women's name as shown below 

preceding the maiden name with a commercial at sign (@) in the Sub1 field: 

   Schreiner, Bette Ann @Shepherd 

When you complete this record and start a new record, SKY Index will change the record to appear like 

this: 

   Schreiner, Bette Ann (Shepherd) 

And will create a new record under the maiden name like this: 

   Shepherd, Bette Ann 

This feature can save a significant amount of time if you are writing a name index. 

Notes 

 If the maiden name is more than one word, you must put another commercial at sign at the end 

of the maiden name as shown below: 

   Brown, Anna @de War@ 

 The Tools|Process Maiden Name Entries menu item is only available if you have turned on the 

automatic creation of maiden names. 

Proofing Report 

It is often nice to have a printed report of your index for proofreading purposes. This is especially true if 

you are working with a team of people and the person writing the index is not going to be the person to 

proofread it. The Proofing Report function allows you to print a report of your index. 

 

Proofing Report dialog 
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Options 

Print Record Numbers   If checked, the proofing report will include record numbers that can then be 

used to locate the desired record quickly for editing. See Finding Entries by Record Number for 

information on how to locate entries by record number in SKY Index. 

Enhanced Color Printing   If checked, the proofing report will use color to improve the readability of 

the proofing report. For instance, the comma that separates a Main heading from a subheading will be 

printed in red and Ignored and Hidden text will be printed in the colors that you have specified for those 

text attributes. 

Note: The current index view will be used when printing the report. If the index has been grouped, only 

the records in the group will be printed. Normally you will want to choose either As Entered or Page 

Ordered view when printing a proofing report. 

Tip:  Print your report in landscape mode if your index entries are large. To print in landscape mode, 

choose File>Print Setup and select landscape orientation. 

Remove Duplicate Records 

By default, SKY Index is configured to ignore duplicates during the index generation phase and, 

therefore, duplicates are generally of no concern. However, if you should accidentally duplicate a large 

portion of the index, you may wish to physically remove the duplicate records. 

To remove all duplicate records in your index, choose Tools>Remove Duplicate Records. 

Spell Check 

It is often desirable to perform a spelling check on an index prior to final formatting and printing. SKY 

Index includes a built-in spell checker for this purpose. 

To perform a spell check, choose Tools>Spell Check or click the  toolbar icon to perform a spelling 

check. 

 

Spelling Check dialog 

If a spelling error is encountered the Spelling Check dialog will appear as shown above. If the word that 

was not found in the spell checker’s dictionary is incorrectly spelled, you have several options. 
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Options 

Ignore   Ignores the misspelled word and continues spell checking. 

Ignore All   Ignores the misspelled word and any future occurrences of it and continues the spell check. 

Add   Adds the word to your User Dictionary. The word will no longer be considered a misspelled word 

during this spell check or any future spell checks.  

Change   If the proper spelling of the word appears in the Suggestions list, and, if you click on it, the 

Change button will be enabled. Clicking it will change the misspelled word into the word that you 

suggested and spell checking will continue. 

Change All   If the proper spelling of the word appears in the Suggestions list, and, if you click on it, the 

Change All button will be enabled. Clicking it will change the misspelled word into the word that you 

suggested. Spell checking will continue and any additional occurrences of the misspelled word will be 

automatically changed. 

Cancel   Stops the spell check. Any words already checked and changed will remain changed. 

Add Words To   Specifies the currently active user dictionary. To change the current user dictionary or 

to create a new one, see File Locations. 

Change Page Number 

If you should forget to change the page number while writing your index you can quickly correct the 

situation by using the Change Page Number function. 

Changing Page Numbers 

1. Select the records that have an incorrect page number. 

2. Choose Tools>Change Page Number. 

3. Enter the correct page number. 

4. Click OK. The page number field of all selected records will be updated with the page number 

you entered. 

Notes 

 If you enter a single page for the new locator and have selected one or more locators that include 

a page range, the second page in those ranges will be deleted and first page of the range will be 

changed to the new locator. 

 The function does not modify prefix or suffix text around a page number unless you enter prefix 

or suffix text in the new locator. 

 The function does not modify section labels unless you add one to the new locator. 

 The function will not modify cross-references in the page field. 

 The function will retain the character style of the original locator. 
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Renumber Pages 

If your client decides to insert or remove a page in the middle of the book that you are indexing, it could 

be a very time consuming task to renumber all of the affected index entries manually. The Renumber 

Pages function will perform this task in one simple step. You can even renumber chapters or volumes if 

they are numbered using Arabic numbers. 

 

 

Renumber Pages dialog 

Renumbering Page Numbers 

To renumber page numbers, do the following: 

1. Choose Tools>Renumber Pages 

2. Specify whether you are renumbering volume labels, chapter labels, or page numbers. 

3. Specify whether you wish to increment or decrement the numbers. 

4. Enter the lowest number to be modified. 

5. Enter the largest number to be modified. 

6. Enter the amount to increment or decrement each number. 

7. Click OK. 

Options 

Greater than or equal to   Specifies the lowest page number to be modified. The number must be 

greater than or equal to 1, and less than or equal to the total number of pages in the index. It must also 

be lower than or equal to the number specified in the Less than or equal to text box. 

And less than or equal to   Specifies the highest page number to be modified. The number must be 

greater than or equal to 1, and less than or equal to the total number of pages in the index. If must also 

be higher than or equal to the number specified in the Greater than or equal to text box. 

Increment by   Specifies the amount to increment or decrement the range of pages specified in the 

Greater than or equal to and Less than or equal to text boxes. 

Act Upon   Specifies whether what you want to renumber. Only Arabic numbers can be renumbered by 

this function. Roman numerals will be unaffected.  If you wish to renumber Roman numerals, you must 

use the Find/Replace function. Your choices are: 
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Page   Only the page part of the locator will be modified. Chapter and Volume labels will be 

unaffected. 

Chapter   Only the chapter label part of the locator will be modified. Volume labels and page 

numbers will be unaffected. 

Volume   Only the volume label part of the locator will be modified. Chapter labels and page 

numbers will be unaffected. 

Action   Specifies whether you wish to increment or decrement the specified range of page numbers. 

Repaginate 

Sometimes you may be required to index a book that is provided chapter-by-chapter with each chapter 

numbered starting with page one. The published book, however, is to be numbered from one to the 

number of pages in the entire book. After indexing each chapter individually you then have the task of 

repaginating the index. The Repaginate function performs this task. 

 

Repaginate dialog 

Repaginating an Index 

To use this function, you must use chapter labels for each chapter that you index and you must use 

Arabic numbers to number the chapters. The best way to do this is to create a separate index file for 

each individual chapter and index the chapter without using a chapter label. After you have finished 

indexing each chapter use the Add/Remove Volume/Chapter Labels function to add a chapter label 

globally to the entire chapter. Be sure to use the Arabic number (1) for chapter one and the Arabic 

number (2) for chapter 2 and so on. 

After you have indexed all chapters, create a master index and use the Merge function to combine the 

individual chapters into the master index. Finally, use the Repaginate function to remove the chapter 

labels and renumber the document. Be sure to make a backup of all indexes before starting this process. 

To Repaginate an Index do the Following: 

1. Choose Tools>Repaginate. 

2. Specify whether you wish to repaginate the entire index or just one section. 

3. If you are repaginating a single section, enter the chapter number for the section. 

4. Enter the starting page number. 

5. Click OK. 
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Options 

Starting Page   Specifies the page number SKY Index will start with when repaginating. 

Whole Index   Important: For this feature to work properly, you must have indexed something on the 

last page of all chapters. If you have not, you must repaginate each chapter one at a time. 

If you choose this option, SKY Index will assume that the current index contains all chapters that will 

appear in the published book. It will number the pages starting with one for chapter one, page one, and 

will continue sequential numbering until the last chapter has been renumbered. If you do not check the 

One Sided Document check box, SKY Index will take into account that there can be one unused even 

numbered page at the end of each chapter when numbering pages. Otherwise, it will be assumed that 

there are no blank pages. For most indexes this method will be accurate and will be the easiest way to 

repaginate the index. If you want more control of the process you can renumber each chapter 

individually by using the One Section option described next.  

One Section   If you choose this option, SKY Index will renumber only the one chapter that you specify. 

The page renumbering will start with the page entered into the Starting Page text box and will continue 

sequentially. 

One Sided Document   If checked, SKY Index will not assume that if a chapter ends on an odd 

numbered page that there is an unused even numbered page before the start of the next chapter. 

Tip of the Day 

The tip of the day feature allows you to view a new helpful hint each time you start SKY Index. If you do 

not want to see the hints, simply uncheck the Show Tips Next Time I Start SKY Index check box. You 

can also view all tips in one sitting by clicking on the next or previous arrows next to the Close button. 

To disable the tip of the day, uncheck Show tips next time I start SKY Index. 

If you have disabled the tip of the day, you can view them by choosing Tools>Tip of the Day. 
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Chapter 

29 
Using Configuration Dialogs 

Overview 

Some of the configuration dialogs contain controls that have features you may not be familiar with. This 

chapter addresses those controls and describes their functionality so that you can take full advantage of 

them. 

Spin Control 

A spin control is a control used to enter numeric text. For instance, you might enter a page margin size 

in a spin control. SI7’s spin control has several very useful features that you should be aware of. An 

example of a spin control is shown below. 

 

 

Spin Control 

Increment and Decrement 

As you can see there are two small arrows at the right side of each spin control. These arrows allow you 

to increment or decrement the spin control using the mouse. The amount of the increment or decrement 

is determined by SKY Index and the current scale system being used. This is a more-or-less obvious 

feature. 

What isn’t so obvious is that you can also increment or decrement with the keyboard’s Up and Down 

arrow keys. This is very handy for users who like to keep their hands on the keyboard. 

Scale System 

Spin controls use a scale system. Scale systems are simply different ways of measuring the same thing. 

The scale systems supported in SI7 spin controls are: 

 Inches 

 Centimeters 

 Millimeters 

 Points 

 Ems 

 Ens 
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By default, SI7 uses inches as the scale system. However, if you use preferences to tell SI7 to use metric 

system measurements, you will see measurements in millimeters (mm) in all spin controls. 

You can specify a size in any supported scale system simply by typing a scale system specifier after the 

numeric part of the measurement. For instance to specify points you could type: 

 11 pt 

The supported scale system specifiers are: 

 pt 

 in or “ (a single double quote) 

 mm 

 cm 

 em 

 en 

Notes 

 If you specify a scale system other then the default scale system, the next time you open the 

configuration dialog, the default scale system will be used and the value you see will be 

equivalent to the value you had typed in the other scale system. For instance, if you typed “10 pt” 

for Space Before in the Index Options dialog, the next time you open the same dialog, you’ll see 

“0.14” which is the equivalent size in inches. 

 Ems and Ens are based on the font and font size specified for your Main headings when using 

those scale systems in the Index Options dialog. 

 Although you can specify Ems or Ens in the Document Options dialog, those measurements are 

meaningless and will result in undefined results. 

 All sizes are stored in inches internally. 
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Chapter 

30 
Other Dialogs 

 

Immediately Verifying Cross-references 

If you would like SKY Index to notify you when you've entered a reference to an entry that does not 

exist, you can do so by enabling immediate cross-reference verification. 

Enabling Immediate Cross-reference Verification 

To enable automatic cross-reference verification, do the following: 

1. Choose Options>Preferences. 

2. Scroll to the Immediately Verify Cross-references checkbox. 

3. Check the Immediately Verify Cross-references checkbox. 

4. Click OK. 

Once Immediate cross-reference verification has been enabled, each time you add a new record that 

contains a cross-reference to your index, SKY Index will verify that it references a valid, existing index 

entry. If it does not, you will be presented with the dialog below and the following three choices. 

 

 

Bad Cross-Reference dialog 

Options 

Ignore – Ignores the bad cross-reference and lets you continue working. 

Fix – Lets you edit the cross-reference to correct a misspelling or other data entry error. 
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Add – A new record containing the main and subheadings referred to by the cross-reference will be 

added to the index. 

Locator Format Priority Dialog 

Some indexes may contain locators that have formatting attributes applied to them to indicate a special 

meaning. When this is done, you may want locators that are identical other than formatting to appear in 

a specific order. The Locator Format Priority dialog allows you to specify this order. 

 

 

Locator Format Priority dialog 

Specifying Locator Format Priority 

To specify locator format priority, do the following: 

1. Choose Options>Index Options. 

2. Click the Locators tab. 

3. Click the Format Priority button. 

4. Set the format priority. 

5. Click OK to close the Locator Format Priority dialog. 

6. Click OK to close the Index Options dialog. 

Options 

Priority – This list contains the formatting attributes that you can assign a priority to. Highest priority 

is given to the top most attribute in the list and lowest priority is given to the bottom most attribute. 

You can change an attribute's priority by clicking on it to select it and then move it up or down in the 

list using the Move Up or Move Down buttons. 

Move Up – Moves the currently highlighted attribute up one slot in the priority list. 

Move Down – Moves the currently highlighted attribute down one slot in the priority list. 

Use locator formatting priority – If checked, a locator's attribute will be taken into account when 

sorting the locators. Otherwise, the locator's attributes will be ignored during sorting. 
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Select Field 

When performing certain functions on more than one record in the data entry grid it is necessary for you 

to specify which field of each record you wish the function to operate on. The Select Field dialog allows 

you to specify the desired field. 

 

 

Select Field dialog 

Selecting a Field Using the Select Field dialog 

You can select a field using two methods. 

Method 1 

1. Click on the desired field or move the highlight over the desired field by using the <Up> or 

<Down> arrows on your keyboard. 

2. Click OK or press <Enter> to make your selection. 

Method 2 

1. Type the name of the desired field in the Field text box. 

2. Click OK or press <Enter> to make your selection. 

Options 

Promote With/Demote With   When this dialog appears because of the use of the Promote or Demote 

commands, you will be given the option to change the Promote or Demote separator. By default the 

separator that is presented is the same separator that is specified in the Data Entry tab of the 

Program Options dialog. Changing this separator will not change the default separator; it will only 

change it for the duration of the immediate operation. 

See also: Demote; Promote 
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Text Editor 

The Data Entry grid and several configuration dialogs allow you to invoke the Text Editor in order to 

make it easier to work with lengthy text. Those parts of SKY Index that support the Text Editor which 

can invoke the Text Editor by pressing <Shift><F2>. 

 

 

Text Editor Dialog 

Using the Text Editor 

The text editor is invoked by pressing <Shift><F2> while editing index entries, or when index 

configuration items that support formatted text such as headers and footers and the index's introductory 

note. 

The text editor acts just like a simple word processor. The standard editing features are available from 

the keyboard or from the Edit menu and all supported text formatting is available from the Format 

menu. 

If you decide that you want to discard any changes you've made with the Text Editor, you can click 

Cancel. If you click OK, all of your changes will be applied to the grid or to the configuration item that 

you were editing when you invoked the Text Editor. 
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Choose Path Dialog 

 

Choose Path Dialog 

Using the Choose Path dialog 

Use the Path list to find the directory you wish to use for the path. If the directory you wish to use is on a 
different drive, use the Drive drop down list box to choose a different drive. Be sure to choose only a 

fixed hard drive and not a floppy drive or CD-ROM since these devices are not necessarily always 

available. You can always override the default path when you create a backup or template. The path you 

choose will be displayed in the Current Path text box. 

Once you've made your selection, click OK to accept the new path or click Cancel to retain the previous 

path. 

Date Options 
 

 

Date Options dialog 
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Configuring Century Assumptions 

To configure century assumptions, do the following: 

1. Choose Options|Index Options or click the  toolbar icon. 

2. Click the Style/Sorting tab. 

3. Click the Options button next to the Sort Dates check box. 

4. Set your century assumptions. 

5. Click OK to close the Date Options dialog. 

6. Click OK to close the Index Options dialog. 

Options 

Always use the current century   If selected, SKY Index will always use the current century, during 

data entry, to sort years that are not fully specified. If the year is completely absent, the current 

year, during data entry, will be used. 

Note: If the century changes during data entry, so will the century assumed for entries entered after 

the century changes. For that reason, this option is not recommended if you will be working on an 

index during the change of the century. In all other cases, this is the recommended mode of operation. 

Note: If an old index that was written prior to the change of the century and uses date sorting is 

going to be modified after the change of the century, the Index|Resort function should be used to 

ensure that all date entries assume the same century. 

Use the centuries specified below   If selected, SKY Index will use assumptions that you specify. The 

assumptions that you can specify are: 

If the year is between   Specifies a range of dates that will have a century that is specified in the 

Assume that the century is text box. If the first year specified is larger than the second year, SKY 

Index will assume that the range is of dates that pass through a new century. 

Assume that the century is   Specifies the century that will be used if the two digit year is within 

the range you have specified. 

Otherwise, assume the century is   Specifies the century that will be used if the two digit year is 

outside the range you have specified. 

If the year is not specified, assume   The year that will be used whenever no year has been 

specified in a date. 
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Chapter 

31 
Embedding Index Entries 

 

Overview 

Some of your clients may ask that you embed your index entries into a Microsoft Word document. In the 

context of indexing, embedding is the process of adding hidden fields to a document that specify the how 

a particular passage of text will be referenced in the index. This allows the program (Microsoft Word in 

this case) to generate an index. The advantage of embedding is that the text of the document can be 

modified and the index easily regenerated to update the locators. All existing index entries remain valid. 

Only the added text needs to be indexed to create an up-to-date index. 

How SKY Index handles embedding 

The process for creating an embedded index is the same as for a stand-alone index except that you will 

have to embed the entries into the Word document after you have completed the index. Embedding the 

entries is done by selecting the entries to be embedded and then dragging them to the Word document 

and dropping them at the appropriate point in the document. 

Here is an overview of the process: 

 Put the index in page order 

 Select one or more entries to be embedded in the Word document 

 Drag the selected records to the Word document and drop them in place 

 Find any embedded entries that represent a page range and create bookmarks for those entries. 

Preparation 

The process of embedding requires that the Word document be open at the same time as your index 

database. Placing SKY Index and MS Word side-by-side will greatly increase the ease of dragging and 

dropping entries. You should do this before attempting any of the following steps. 

Putting the Index in Page Order 

To put the index in page order, choose View>Page Ordered. 

Selecting Records to be Embedded 

To select records for embedding, place the grid marquee over the record to select and choose Edit>Select 

Record. To select more than one record, hold down Shift and press DownArrow until all records you wish 

to embed are selected. 
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Dragging Selected Records to the Word Document 

Put the mouse cursor over any part of the blue highlighted area of any of the selected records and then 

hold down the left mouse button and while keeping the mouse button down, move the mouse cursor to 

the point in the Word document where the index entries should be placed. Once the mouse is at the 

appropriate point, release the left mouse button. 

Notes 

 Unless you have turned on the option in Word to reveal hidden codes, you will not see anything 

happen. 

 You must place the index entries at, or near, the text they refer to. 

 Cross-references can be placed anywhere in the Word document. 

Creating Bookmarks for Page Ranges 

Microsoft Word uses bookmarks to define the beginning and end of a passage of text which is a 

continuous discussion. This allows Word to create a page range if the text crosses one or more page 

boundaries. When you embed an index entry that contains a page range, SKY Index will create a 

reference to a dummy bookmark labeled “SKY0001”. You will need to find each of these dummy 

bookmarks, create a real bookmark and then replace the dummy bookmark label with label you gave to 

the real bookmark. 

The process is this: 

1. Make sure Word’s option for revealing hidden fields is turned on so you can see and search for 

the dummy bookmark labels. 

2. Use Word’s Find feature to find “SKY0001”. Determine the beginning and the end of the 

continuous discussion and select all text from the beginning to the end. 

3. Create a bookmark from this selection and give it a unique name. 

4. Change the dummy label to reflect the name you gave the bookmark. 

Cleanup 

You will probably want to turn off the feature to reveal hidden fields before you save the document and 

close Word. 

What You Need To Know 

Below are some things that you should know about embedding indexes 

 You should be aware that embedding index entries takes significant additional time and you 

should charge more for your service to make up for that additional time. 

 When indexing the document, orphaned subheadings should be left as orphans. Word will handle 

the orphans automatically and if the document is later revised and another subheading is added, 

the subheadings will not combine properly under the main heading if the subheading has been 

merged. 

 Word will not allow the same page number to appear twice under the same heading. Although 

you may want to (and can) indicate figures using italicized locators, Word will delete one of them 

when it generates the index. 

 You cannot use text of any kind in a locator – only the actual locator will be represented by 

Word. Do not try appending ‘f’ for figure or ‘t’ for table. The f or t will be lost when the entry is 

embedded. 

 Word will consume single locators that fall within a page range. If you have 150, 150-153, Word 

will change it to simply 150-153. However, 150-153, 150 (note 150 is italicized) will come through 
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okay as long as the italicized 150 is embedded in the index after the page range entry. 

Embedding the ‘150’ locator in a table may cause a problem with the embedded index as well. 

 Word will not combine multiple cross-references. For instance, when SKY Index shows you this: 

“indexing. see also alphabetizing; categorizing”, what you’ll get in Word is this: “indexing. see 

also alphabetizing. see also categorizing”. You’ll need to combine these manually in the Word file 

by merging the two embedded index entries into one entry.  
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Appendix 

A 
Support 

 

Your Support Benefits 

You are entitled to free support for your first three support incidents or for a period of one year. After 

one year, your free support expires regardless of the number of support incidents for which you have 

contacted us. After your free support period expires, you may get support on a per incident basis for a 

fee. As of the writing of this document, that fee is thirty dollars (US), but it is subject to change. 

We will provide support for SKY Index v7.0 for up to one year after the end of its life cycle. At that time, 

support may no longer be available. The end of life cycle is defined as the point at which the product is 

no longer offered for sale to the general public. 

Note: Although this is our official policy, we will likely provide free support for you beyond the official 

expiration of your free support period. The official policy is in place to assure that our support benefits 

are not abused. For instance, it is not our intention that our support be used as a substitute for reading 

the manual or for personal tutoring. Never hesitate to contact us for support if you have given an honest 

attempt to learn the solution through reading your manual or using the program’s help system and have 

been unable to find a solution. We want to help you and we want you to be a happy customer. 

The SKY Software Customer Support System 

What is the SKY Software Customer Support System? 

The SKY Software Customer Support System (CSS) is a combination of two services. The first is a 

feedback system that allows you to report problems you may encounter while using your program. This 

might be a simple documentation error or a malfunction of the program. The second is a collection of 

forums where SKY Software customers can create queries to find answers to questions from other SKY 

Index owners. It is also a place where customers can make feature suggestions for future releases of the 

program. The forums can be searched and there is already a significant wealth of information available 

and more information is being added all the time. 

We highly recommend that you create a CSS account because it is a great way to learn about SKY Index 

and to share your own expertise. There are even forums specifically for indexing students. 

How do I create an account? 

To create an account, enter the link below in your Internet browser. 

www.feedback.sky-software.com 

http://www.feedback.sky-software.com/
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In the resulting web page, click the Login button which will lead to a page that will allow you to create a 

new account. Creation of the account requires validation of your email address and we may also require 

a moderator’s approval. 

How do I ask a question? 

To ask a question, login to your account and then click on the Forums link at the top of the web page. 

Then click on the Forums Map link, choose the forum that most closely matches the nature of your 

question and then, after searching the forum to make sure the question has not already been answered, 

click on the Submit a Query to this forum button. 

Who do I contact if I have a problem creating an account? 

If you have a problem creating your account, please write to support@sky-software.com and be sure to 

include a detailed description of the problem you are having. 

How to Get Support through Email 

To receive support through email send the following to: support@sky-software.com  

 The name and version of the product you need support for.  

 Your product registration number (this number can be found by starting SKY Index and then 

choosing Help>About).  

 Your full name, address and phone number.  

 A description of the problem you are having.  

 Send the email to support@sky-software.com  

How to Get Support by Phone 

You are entitled to phone support during your free support period as described at the beginning of this 

appendix. Phone support is available Monday through Friday from 9am to 5pm EST and is available in 

English only. To receive phone support please have the following ready when you call:  

 The name and version of the product you need support for. 

 Your product registration number (usually on the inside front cover of your manual). 

 A description of the problem you are having. 

 Please be seated at your computer so that you can perform requested actions. 

Support Phone Number: 540-751-4336 

 

mailto:support@sky-software.com
mailto:support@sky-software.com
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Appendix 

B 
Keyboard Shortcuts 

Core Editing Commands 

There are 9 ‘core’ editing commands in SKY Index. These core commands are assigned a single function 

key as a keyboard shortcut. The core editing commands are: 

 

Command Shortcut 

Swap F4 

Promote F5 

Demote F6 

Combine F7 

Select Heading F8 (Data Entry View Only)  

Select Entry F9 (Data Entry View Only) 

Shift Left to Main F10 

Shift Left F11 

Shift Right F12 

 

These commands are described in detail below with an example of how each command changes your 

index. All nine of these commands allow you to add two modifiers that enhance the command’s action. 

The modifiers are:  
 

Ctrl: Instructs SKY Index to duplicate the record or records you wish to edit before editing them. This 

leaves an unaltered copy of the original index entries behind. 
 

Ctrl+Shift: With this modifier, SKY Index will duplicate the records, but in addition, will create a group 

out of the duplicated and edited records when the edit is finished. This allows you to manipulate 

those records further without worrying about affecting the rest of the index. 

Shortcuts Listed by Keycap and Modifier 

NOTES: 

If a shortcut is different than the shortcut in version 6.0, the old shortcut(s) are referenced in the 

Replaces column. 

If the Replaces column contains the word “New”, this is a new shortcut and/or a new command. 
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Function keys (Core Commands)  

Shortcut Function Replaces 

F1 Help  

F2 Toggle Text Edit Mode  

F3 Find Next (Industry Standard) New 

F4 Swap Ctrl+F1,F2,F3 

F5 Promote Ctrl+F5 

F6 Demote Ctrl+F6 

F7 Combine Ctrl+F7 

F8 Select Heading Ctrl+H 

F9 Select Entry Ctrl+Space 

F10 Shift Left to Main Alt+Ctrl+S 

F11 Shift Left (Same as Half Swap) Alt+Ctrl+F5 

F12 Shift Right Alt+Ctrl+F6 

Ctrl Modified Function Keys (Duplicates)  

Shortcut Function (Ctrl – Duplicates) Replaces 

Ctrl+F1 Duplicate and Swap (Main and Sub1) Replaces Ctrl+P 

Ctrl+F2 Duplicate, Swap and Combine Replaces Ctrl+F9 

Ctrl+F3 Find current word or selected text New 

Ctrl+F4 Duplicate and Swap New 

Ctrl+F5 Duplicate and Promote New 

Ctrl+F6 Duplicate and Demote New 

Ctrl+F7 Duplicate and Combine New 

Ctrl+F8 Duplicate Heading (Select, then Duplicate) New 

Ctrl+F9 Duplicate Entry (Select, then Duplicate) New 

Ctrl+F10 Duplicate and Shift Left to Main New 

Ctrl+F11 Duplicate and Shift Left (Same as Half Swap) New 

Ctrl+F12 Duplicate and Shift Right New 

Ctrl+Shift Modified Function Keys (Groups)  

Shortcut Function Replaces 

Ctrl+Shift+F1 Duplicate selected records and Group New 

Ctrl+Shift+F2 Duplicate, Swap and Combine and Group New 

Ctrl+Shift+F3 Group on current word or selected text New 

Ctrl+Shift+F4 Duplicate, Swap and Group New 

Ctrl+Shift+F5 Duplicate, Promote and Group New 

Ctrl+Shift+F6 Duplicate, Demote and Group New 

Ctrl+Shift+F7 Duplicate, Combine and Group New 

Ctrl+Shift+F8 Duplicate and Group Heading (Select, then Duplicate, then Group) Ctrl+F8 

Ctrl+Shift+F9 Duplicate and Group Entry (Select, then Duplicate, then Group) New 

Ctrl+Shift+F10 Duplicate, Shift Left to Main and Group New 

Ctrl+Shift+F11 Duplicate, Shift Left and Group (Same as Half Swap) New 

Ctrl+Shift+F12 Duplicate, Shift Right and Group New 
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Shift Modified Function Keys 

Shortcut Function Replaces 

Shift+F1   

Shift+F2   

Shift+F3 Find Previous New 

Shift+F4 Return to Last  

Shift+F5 As Entered  

Shift+F6 Grouped  

Shift+F7 Page Ordered  

Shift+F8 Sorted  

Shift+F9 Filtered  

Shift+F10 Toggle Edit View New 

Shift+F11 Generate Index  

Shift+F12 Edit/Print Index  

Ctrl Key Shortcuts 

Shortcut Function Replaces 

Ctrl+A Select All (Industry Standard) Ctrl+Ins 

Ctrl+B Toggle Bold (Industry Standard)  

Ctrl+C Copy (Industry Standard)  

Ctrl+D Duplicate (D for Duplicate)  

Ctrl+E To Uppercase  

Ctrl+F Find (F for Find) (Industry Standard)  

Ctrl+G Goto Entry (G for Goto)  

Ctrl+H Replace (Industry Standard) New 

Ctrl+I Toggle Italic (Industry Standard)  

Ctrl+J Goto Locator  

Ctrl+K Toggle Ignore Text  

Ctrl+L To Lowercase  

Ctrl+M Toggle Label (M for Mark) New 

Ctrl+N New Heading (Edit View) New 

Ctrl+O Open Index (Industry Standard)  

Ctrl+P Print Draft or Duplicate and Swap (user assignable)  

Ctrl+Q Quit (application)  

Ctrl+R First to Uppercase  

Ctrl+S Select Record  

Ctrl+T Toggle Hide Text  

Ctrl+U Toggle Underline (Industry Standard)  

Ctrl+V Paste (Industry Standard)  

Ctrl+W First to Lowercase  

Ctrl+X Cut (Industry Standard)  

Ctrl+Y Redo (Industry Standard) Snapshot 

Ctrl+Z Undo (Industry Standard)  

Ctrl+Enter Copy cell above and move to the next cell  
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Shortcut Function Replaces 

Ctrl+1 Toggle Label 1 New 

Ctrl+2 Toggle Label 2 New 

Ctrl+3 Toggle Label 3 New 

Ctrl+4 Toggle Label 4 New 

Ctrl+5 Toggle Label 5 New 

Ctrl+6 Toggle Label 6 New 

Ctrl+7 Toggle Label 7 New 

Ctrl+8 Toggle Label 8 New 

Ctrl+9 Toggle Label 9 New 

Ctrl+Space Replaced by F9  

Ctrl+Ins Append New Ctrl+A 

Ctrl+; (semicolon) Append New (alternative shortcut)  

* If you’ve set your preferences to show preview pane shortcuts, they will take precedence over 

labeling. 

Ctrl+Shift Key Shortcuts 

Shortcut Function Replaces 

Ctrl+Shift+A   

Ctrl+Shift+B Toggle Subscript  

Ctrl+Shift+C Copy Heading New 

Ctrl+Shift+D Duplicate and Group New 

Ctrl+Shift+E   

Ctrl+Shift+F   

Ctrl+Shift+G Group using Find New 

Ctrl+Shift+H Change Case  

Ctrl+Shift+I   

Ctrl+Shift+J   

Ctrl+Shift+K Toggle Strikeout  

Ctrl+Shift+L   

Ctrl+Shift+M Group on active label New 

Ctrl+Shift+N New Subheading (Edit View) New 

Ctrl+Shift+O Toggle Note Text New 

Ctrl+Shift+P Toggle Superscript  

Ctrl+Shift+Q   

Ctrl+Shift+R   

Ctrl+Shift+S   

Ctrl+Shift+T Title Case New 

Ctrl+Shift+U Ungroup New 

Ctrl+Shift+V Paste Heading New 

Ctrl+Shift+W   

Ctrl+Shift+X Cut Heading New 

Ctrl+Shift+Y   

Ctrl+Shift+Z   

Ctrl+Shift+Enter Copy contents of cell above New 
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Alt+Ctrl Modified Shortcuts 

Shortcut Function Replaces 

Alt+Ctrl+A Find all pages for entry  

Alt+Ctrl+B Browse  

Alt+Ctrl+C Copy Locators  

Alt+Ctrl+D Create Reciprocal Xref New 

Alt+Ctrl+E Reveal Codes New 

Alt+Ctrl+F   

Alt+Ctrl+G Group by Text   

Alt+Ctrl+H New Child Heading, Take Selected Locators New 

Alt+Ctrl+I   

Alt+Ctrl+J Display the “Choose Active Label” dialog New 

Alt+Ctrl+K Remove Subheadings Keep Locators New 

Alt+Ctrl+L Goto Locator  

Alt+Ctrl+M Goto Next Label New 

Alt+Ctrl+N   

Alt+Ctrl+O Group by Locator  

Alt+Ctrl+P Split New 

Alt+Ctrl+Q   

Alt+Ctrl+R Goto Record  

Alt+Ctrl+S Swap Acronym New 

Alt+Ctrl+T Toggle See, See Also New 

Alt+Ctrl+U Update AutoComplete List New 

Alt+Ctrl+V Paste Locators  

Alt+Ctrl+W   

Alt+Ctrl+X Convert cross-reference  

Alt+Ctrl+Y   

Alt+Ctrl+Z   

Alt+Ctrl+F1   

Alt+Ctrl+F2   

Alt+Ctrl+F3   

Alt+Ctrl+F4 Close Index  

Alt+Ctrl+F5   

Alt+Ctrl+F6   

Alt+Ctrl+F7   

Alt+Ctrl+F8   

Alt+Ctrl+F9   

Alt+Ctrl+F10   

Alt+Ctrl+F11   

Alt+Ctrl+F12   

Alt+Ctrl+[ Previous locator for current entry  

Alt+Ctrl+] Next locator for current entry  

Alt+Ctrl+DownArrow Scroll Preview Pane marquee down  

Alt+Ctrl+UpArrow Scroll Preview Pane marquee up  

Alt+Ctrl+Home Scroll Preview Pane marquee to first entry  

Alt+Ctrl+End Scroll Preview Pane marquee to last entry  

Alt+Ctrl+PageDown Scroll Preview Pane marquee down one page  

Alt+Ctrl+PageUp Scroll Preview Pane marquee up one page  

Alt+Ctrl+. (period) Enters an ellipse (…) at the insertion point  
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Alt Modified Shortcuts 

Shortcut Function Replaces 

Alt+A Reserved for Menu functions  

Alt+B Reserved for Menu functions  

Alt+C Reserved for Menu functions  

Alt+D Reserved for Menu functions  

Alt+E Reserved for Menu functions  

Alt+F Reserved for Menu functions  

Alt+G Reserved for Menu functions  

Alt+H Reserved for Menu functions  

Alt+I Reserved for Menu functions  

Alt+J Reserved for Menu functions  

Alt+K Reserved for Menu functions  

Alt+L Reserved for Menu functions  

Alt+M Reserved for Menu functions  

Alt+N Reserved for Menu functions  

Alt+O Reserved for Menu functions  

Alt+P Reserved for Menu functions  

Alt+Q Reserved for Menu functions  

Alt+R Reserved for Menu functions  

Alt+S Reserved for Menu functions  

Alt+T Reserved for Menu functions  

Alt+U Reserved for Menu functions  

Alt+V Reserved for Menu functions  

Alt+W Reserved for Menu functions  

Alt+X Reserved for Menu functions  

Alt+Y Reserved for Menu functions  

Alt+Z Reserved for Menu functions  

Alt+F1 Toggle Alternate Font 1  

Alt+F2 Toggle Alternate Font 2  

Alt+F3 Toggle Alternate Font 3 New 

Alt+F4 Closes SKY Index  

Alt+F5 Reserved for future Alternate fonts  

Alt+F6 Reserved for future Alternate fonts  

Alt+F7 Reserved for future Alternate fonts  

Alt+F8 Reserved for future Alternate fonts  

Alt+F9 Reserved for future Alternate fonts  

Alt+F10 Remove all formatting (Plain)  

Alt+F11 Refresh Grid  

Alt+F12 Enter Text Edit Mode  
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Alt+Shift Modified Shortcuts 

Shortcut Function Replaces 

Alt+Shift+A Macro F3 

Alt+Shift+B Macro F4 

Alt+Shift+C Macro F5 

Alt+Shift+D Macro F6 

Alt+Shift+E Macro F7 

Alt+Shift+F Macro F8 

Alt+Shift+G Macro F9 

Alt+Shift+H Macro F10 

Alt+Shift+I Macro F11 

Alt+Shift+J Macro F12 

Alt+Shift+K Macro CSF3 

Alt+Shift+L Macro CSF4 

Alt+Shift+M Macro CSF5 

Alt+Shift+N Macro CSF6 

Alt+Shift+O Macro CSF7 

Alt+Shift+P Macro CSF8 

Alt+Shift+Q Macro CSF9 

Alt+Shift+R Macro CSF10 

Alt+Shift+S Macro CSF11 

Alt+Shift+T Macro CSF12 

Alt+Shift+U Macro New 

Alt+Shift+V Macro New 

Alt+Shift+W Macro New 

Alt+Shift+X Macro New 

Alt+Shift+Y Macro New 

Alt+Shift+Z Macro New 

Alt+Shift+F1   

Alt+Shift+F2   

Alt+Shift+F3   

Alt+Shift+F4   

Alt+Shift+F5 Reorder group As Entered New 

Alt+Shift+F6   

Alt+Shift+F7 Reorder group Page Ordered New 

Alt+Shift+F8 Reorder group Sorted New 

Alt+Shift+F9   

Alt+Shift+F10   

Alt+Shift+F11   

Alt+Shift+F12   
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Alt+Ctrl+Shift Modified Shortcuts 

Shortcut Function Replaces 

Alt+Ctrl+Shift+[a-z] Pressing the first letter will take you to the first entry 

in the index starting with that letter. Each subsequent 

key you press narrows down the search so that pressing 

‘c’, then ‘h’, and then ‘u’ would take you to a main 

heading like “church.” This entry is shown and 

highlighted in the Preview Pane, but is not the ‘current’ 

entry. Use Alt+Ctrl+Shift++ to make it the current 

entry. 

New 

Alt+Ctrl+Shift++ Makes the entry found by using the above command 

the current index entry. 

 

Alt+Ctrl+Shift+F1   

Alt+Ctrl+Shift+F2   

Alt+Ctrl+Shift+F3   

Alt+Ctrl+Shift+F4   

Alt+Ctrl+Shift+F5   

Alt+Ctrl+Shift+F6   

Alt+Ctrl+Shift+F7   

Alt+Ctrl+Shift+F8   

Alt+Ctrl+Shift+F9   

Alt+Ctrl+Shift+F10   

Alt+Ctrl+Shift+F11   

Alt+Ctrl+Shift+F12   

Alt+Ctrl+Shift+DownArrow Scroll Preview Pane up (does not move marquee)  

Alt+Ctrl+Shift+UpArrow Scroll Preview Pane down (does not move marquee)  

Alt+Ctrl+Shift+Home Scroll Preview Pane to top (does not move marquee)  

Alt+Ctrl+Shift+End Scroll Preview Pane to bottom (does not move marquee)  

Alt+Ctrl+Shift+PageDown Scroll Preview Pane up one page (does not move 

marquee) 

 

Alt+Ctrl+Shift+PageUp Scroll Preview Pane down one page (does not move 

marquee) 
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Shortcuts by Function 

Navigation 

Data Entry View (Grid)  

 

Description Shortcut 

Move grid marquee down one row Down 

Move grid marquee up one row Up 

Move grid marquee to first column in same row Home 

Move grid marquee to last column in same row End 

Move grid marquee down one page PageDown 

Move grid marquee up one page PageDown 

Move grid marquee to next cell Right; Tab; Enter 

Move grid marquee to previous cell Left; Shift+Tab 

Move grid marquee to first cell of first row in the grid Ctrl+Home 

Move grid marquee to last cell of last row in the grid Ctrl+End 

Move grid marquee to last row in the grid Ctrl+PageDown 

Move grid marquee to first row in the grid Ctrl+PageUp 

Move Preview Pane marquee down Alt+Ctrl+Down 

Move Preview Pane marquee up Alt+Ctrl+Up 

Move Preview Pane marquee to first entry Alt+Ctrl+Home 

Move Preview Pane marquee to last entry Alt+Ctrl+End 

Move Preview Pane marquee down one page Alt+Ctrl+PageDown 

Move Preview Pane marquee up one page Alt+Ctrl+PageUp 

Scroll Preview Pane up (does not move marquee) Alt+Ctrl+Shift+Down 

Scroll Preview Pane down (does not move marquee) Alt+Ctrl+Shift+Up 

Scroll Preview Pane to top (does not move marquee) Alt+Ctrl+Shift+Home 

Scroll Preview Pane to bottom (does not move marquee) Alt+Ctrl+Shift+End 

Scroll Preview Pane up one page (does not move marquee) Alt+Ctrl+Shift+PageDown 

Scroll Preview Pane down one page (does not move marquee) Alt+Ctrl+Shift+PageUp 

Edit View 

 

Description Shortcut 

Move Preview Pane marquee down one entry Down 

Move Preview Pane marquee up one entry Up 

Move Preview Pane marquee down one page PageDown 

Move Preview Pane marquee up one page PageUp 

Move Preview Pane marquee to first entry Ctrl+PageUp; Ctrl+Home 

Move Preview Pane marquee to last entry Ctrl+PageDown; Ctrl+End 

Move Preview Pane up (does not move marquee) Alt+Ctrl+Shift+Down 

Move Preview Pane down (does not move marquee) Alt+Ctrl+Shift+Up 

Move Preview Pane up one page (does not move marquee) Alt+Ctrl+Shift+PageDown 

Move Preview Pane down one page (does not move marquee) Alt+Ctrl+Shift+PageUp 

Move Preview Pane to top (does not move marquee) Alt+Ctrl+Shift+Home 

Move Preview Pane to bottom (does not move marquee) Alt+Ctrl+Shift+End 
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Adding and Editing Index Entries 

 

Description Shortcut 

Add a new index entry (Data Entry View) Ctrl+Ins; 

Ctrl+; 

Add New Heading (Edit View) Ctrl+N 

Add New subheading (Edit View) Ctrl+Shift+N 

Toggle between Text Edit Mode and View Mode (allows you to edit text in the 

grid) 
F2 

Swap F4 

Promote F5 

Demote F6 

Combine F7 

Select Heading F8 

Select Entry F9 

Shift Left to Main F10 

Shift Left (Same as Half Swap) F11 

Shift Right F12 

Formatting and Modifying Text 
 

Description Shortcut 

Toggle Bold Ctrl+B 

Toggle Italic Ctrl+I 

Toggle Underline Ctrl+U 

Toggle Strikeout (Small Caps) Ctrl+Shift+K 

Toggle Superscript Ctrl+Shift+P 

Toggle Subscript Ctrl+Shift+B 

Toggle Hidden Text Ctrl+T 

Toggle Ignored Text Ctrl+K 

Toggle Note Text Ctrl+Shift+O 

Lowercase Ctrl+L 

Uppercase Ctrl+E 

Change case Ctrl+Shift+H 

Title Case Ctrl+Shift+T 

First letter to lowercase Ctrl+W 

First letter to uppercase Ctrl+R 

Apply Alternate Font 1 Alt+F1 

Apply Alternate Font 2 Alt+F2 

Apply Alternate Font 3 Alt+F3 

Plain Text (remove all formatting) Alt+F10 
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Find/Replace 
 

Description Shortcut 

Display Find dialog Ctrl+F 

Display Replace dialog Ctrl+H 

Display Find dialog with Group Results checkbox checked Ctrl+Shift+G 

Find the text under the marquee or the selected text Ctrl+F3 

Find next F3 

Find previous Shift+F3 

 

Grouping 
 

Description Shortcut 

Group using Find Ctrl+Shift+G 

Group on text Alt+Ctrl+G 

Group on main heading (or group on selected records) Shift+F6 

Group on locator Alt+Ctrl+ O 

Group on active label Ctrl+Shift+M 

Ungroup Ctrl+Shift+U 

Refresh Group Alt+Shift+F11 

Group on text under the marquee or the selected text Ctrl+Shift+F3 

Labeling 
 

Description Shortcut 

Toggle Active Label Ctrl+M 

Toggle Label 1 Ctrl+1 

Toggle Label 2 Ctrl+2 

Toggle Label 3 Ctrl+3 

Toggle Label 4 Ctrl+4 

Toggle Label 5 Ctrl+5 

Toggle Label 6 Ctrl+6 

Toggle Label 7 Ctrl+7 

Toggle Label 8 Ctrl+8 

Toggle Label 9 Ctrl+9 

Select Active Label (or define label names and colors) Alt+Ctrl+J 

Group on Active Label Ctrl+Shift+M 
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Other 
 

Description Shortcut 

Generate Index  Shift+F11 

Generate the index and load it into your word processor Shift+F12 

Convert Cross-reference Alt+Ctrl +X 

Toggle see/see also Alt+Ctrl+T 

Swap Acronym Alt+Ctrl+S 

New child heading, Take locators Alt+Ctrl+H 

Remove subheadings, Keep locators Alt+Ctrl+K 

Split Alt+Ctrl+P 

Create Reciprocal Cross-reference Alt+Ctrl+D 

Toggle Reveal Codes Alt+Ctrl+E 

Find All Pages for Entry Alt+Ctrl+A 
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Appendix 

C 
Toolbars 

Overview 

SKY Index contains six toolbars by default. All of these toolbars can be docked at any edge of the 

program screen and can also be torn off, by dragging, the program screen to float above the program. The 

default toolbars are: 

 Standard 

 Edit 

 Acronyms 

 Macros 

 Saved Search 

 Quick Access 

 Label Selector 

Two of these toolbars allow access to the Acronyms and Macros Data Managers. A third allows quick 

access to Saved Searches. Another, the Quick Access toolbar, lets you jump to a particular alphabetic 

area of the index with a mouse click and the remaining two toolbars are the Standard Toolbar and the 

Edit Toolbar. Through customization, you can add or remove toolbars to suit your personal needs. 

Showing/Hiding Toolbars 

You can show or hide any toolbar according to your own preferences. To show or hide a toolbar, do either 

of the following: 

 Right click on an empty area of any toolbar or in the toolbar docking area. A menu will appear. 

Place a checkmark next to all toolbars you wish to be shown. Any unchecked toolbars will be 

hidden. 

 Click the View menu and then the Toolbars submenu and place a checkmark next to the 

toolbars you wish to be shown. Any unchecked toolbars will be hidden. 

The Standard Toolbar 

The standard toolbar (shown below) contains many icons that allow you to perform frequently used 

program functions with a single mouse click. The standard toolbar is made up of seven button groups. 

These groups are: 

 

 

The Standard Toolbar 
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Group Description 

File Functions that manipulate index database files 

Clipboard Functions that support use of the Windows clipboard 

Search Functions that search through the index database 

Format Functions that format index entry text (bold, italic, etc.) 

Sorting/Grouping Functions that change the sort order of the entries in the grid and 

functions that create subsets of the index (groups). 

Configuration Quick access to configuration dialogs. 

Index Functions that relate directly to the index (generate, statistics, resort, etc.) 

To learn what a particular toolbar button does, hold the mouse pointer over the desired button for about 

a second and a hint will appear giving a brief description of what the button's function is. 

Edit Toolbar 

The edit toolbar (shown below) contains several buttons that allow you to perform frequently used 

editing functions with a single mouse click. The following editing functions are included by default, but 

you can add or remove buttons by using customization described later in this appendix: 

 

 Append New  Shift Right 

 Swap  Shift Left to Main 

 Promote  Swap Acronym 

 Demote  Consume Subheadings 

 Combine  Toggle See/See Also 

 Shift Left  

 

 

Edit Toolbar 

Acronym Toolbar 

The acronym toolbar displays the acronyms that you have defined so that you don't have to memorize 

them. It also allows you to define or change the definition of acronyms. If you want to see the expanded 

"full text" of an acronym, hold the mouse pointer over the acronym for about a second and the full text 

will be displayed. If you want to define a new acronym or redefine an existing acronym, click the 

<Add/Edit Acronym> button. 

Although clicking on an acronym button will, indeed, enter the acronym text at the current text insertion 

point, the intent of the acronym toolbar is to provide a reminder of your existing acronyms and a quick 

access way of adding new acronyms. 

 

 

Acronym Toolbar 

See also: Acronym Manager 
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Macro Toolbar 

The Macro toolbar displays the Macros that you have defined so that you don't have to memorize them. 

It also allows you to define or change Macros. If you want to see the definition of a macro, hold the mouse 

pointer over the macro button for about a second and the definition will be displayed. If you want to 

define a new macro or redefine an existing macro, click the <Add/Edit Macro> button. This will display 

the Macro Manager dialog. 

 

 

Macro Toolbar 

See also: Macro Manager 

Quick Access Toolbar 

The quick access toolbar contains the letters of the alphabet. Clicking on a letter of the alphabet will 

cause SKY Index to seek and display the first record in the index that starts with that letter. If no record 

starting with that letter exists, the record that is closest to it will be displayed. 

 

 

Quick Access Toolbar 

Saved Search Toolbar 

The Saved Search toolbar displays the Saved Searches that you have defined so that you don't have to 

memorize them. It also allows you to define or change Saved Searches. If you want to define a new Saved 

Search or redefine an existing Saved Search, click the <Add/Edit Saved Search> button. This will display 

the Saved Search Manager dialog. 

Clicking on a saved search toolbar button will either execute the search if the execute option is enabled 

for that search or it will open the Find/Replace dialog with the settings of the search ready for you to 

make changes or manually execute the search. 

 

 

Saved Search Toolbar 

See also: The Saved Search Manager 
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Label Selector Toolbar 

The Label Selector is a floating toolbar that displays all nine labels as buttons that you can click to apply 

the label. Each button contains the name of the label to help you remember the purpose of each label. A 

screenshot of the Label Selector is shown below. 

 

Label Selector 

 

To display the Label Selector, choose View>Toolbars>Label Selector. The ‘active’ label is shown within 

the less than and greater than signs (<>) and also appears indented rather than raised. In the example 

above, “<Bookmark set>” is the active label. You can change the active label by Control clicking on any 

label. 

While working on your index, you can apply any of the nine labels to the current record in the data entry 

grid (or heading in Edit View) by clicking on the desired label. Clicking again will remove the label since 

the label buttons act as a toggle. 

Note: The label selector cannot be docked. It is a floating toolbar only. 

Customizing Toolbars 

SKY Index allows you to customize your existing toolbars by adding or removing commands and even 

allows you to add your own custom toolbars. 

Opening the customization dialog 

To open the toolbar customization dialog, do the following: 

1. Right click on any toolbar. 

2. Choose Customize 

The Customize dialog will appear as shown below. 
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Customize Dialog 

Adding New Commands to a Toolbar 

Commands are added to toolbars using drag and drop. The available commands are categorized in the 

Commands tab of the Customize dialog. 

To add new commands to a toolbar, do the following: 

1. Open the Customize dialog as described above. 

2. Click the Commands tab. 

3. Click on the category that contains the command to be added. The available commands will 

appear in the Commands list. 

4. Find the desired command and drag it to the toolbar you want it to appear on. 

5. Click Close 

Removing Commands from an Existing Toolbar 

To remove commands for an existing toolbar, do the following: 

1. Open the Customize dialog as described above. 

2. In the actual toolbar containing the command you want to remove, right click on the icon or text 

of the command that you want removed. 

3. Click on Delete. 

4. Click Close 

Modifying the Appearance of Toolbar Commands 

You can modify how a command appears in a toolbar. For instance, you can make it appear as an icon 

only, is text only, or as both an icon and text. You can also change the text that appears for the 

command. 
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To modify the appearance of commands for an existing toolbar, do the following: 

1. Open the Customize dialog as described above. 

2. In the actual toolbar containing the command that you want to modify, right click on the icon or 

text of the command. 

3. Modify the command using the options that are described below. 

4. Click Close 

Options 

Name – Allows you to change the text that appears for the command. 

Default Style – Returns the command to its default style. 

Text Only – Only the text for the command will be displayed. 

Image Only – Only the image (icon) for the command will be displayed. 

Image and Text – Both the image (icon) and text for the command will be displayed. 

 

 

Options Menu for Toolbar Customization 

Notes 

 Any modifications you make are saved when you close SKY Index and are restored when you 

reopen the program. 

Changing Keyboard Shortcuts 

You may customize most of SKY Index’s keyboard shortcuts to assign easier to press shortcuts to 

commonly used functions or to assign shortcuts to commands that don’t currently have a shortcut. For 

instance, you could add a keyboard shortcut for the Backup command. 

Keyboard shortcuts changes are saved when you close SKY Index and are Restored when you reopen the 

program. 

To customize your keyboard shortcuts, right click on a toolbar and choose Customize from the menu that 

appears. In the resulting Customize dialog, click the Keyboard button. The Customize Keyboard dialog 

will appear as shown below. 
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Customize Keyboard dialog 

Use the Categories list and the Commands list to find the command that you want to customize. For 

example, choosing the File Menu category will display all commands on the File menu in the Commands 

list. From there, click on the desired command – for example “Backup”. If there is an existing shortcut, it 

will appear in the Current Keys list. 

Now that you’ve selected the desired command, you should first remove any existing shortcut by clicking 

on the shortcut in the Current Keys list and then click the Remove button. Once you’ve removed the 

existing shortcut, give focus to the “Press new shortcut key” textbox by clicking in it with your mouse. 

Finally, press the desired shortcut on your keyboard. For our example we will use Alt+Ctrl+Z. 

The partial screenshot below shows you what the Press new shortcut key textbox will look like after 

you’ve done this. 

 

Press new shortcut key example 

Now click the Assign button to assign the shortcut to the command. The dialog below shows you how the 

Customize Keyboard dialog will look after you do this. 



254    SKY Index 7.0 User’s Guide 

 

Customize Keyboard dialog after assigning a shortcut 

Repeat the process for as many commands as you wish to customize. When you’ve finished, click Close to 

close the Customize Keyboard dialog and then Close again to close the Customize dialog. 

Notes 

 It is legal to have more than one shortcut for a single command. 

 This dialog does not verify that no other command has already been assigned to the command 

that you enter in the Press new shortcut key textbox. Please use the keyboard shortcuts tables in 

this manual of the online help to verify the commands that you want to use have not already 

been assigned. 

 You may remove the shortcut assignment of a command that already has a shortcut so that the 

shortcut can be assigned to a different command. 
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Appendix 

D 
Specifications 

Specifications 

 

Maximum size of an 

index database: 

1 Gigabyte or available storage space (whichever is less). 

Maximum number of 

records: 

Limited only by the maximum database size. 

Maximum field size: The heading fields (Main and all subheading fields) can contain up to 

32,767 characters each. The Page field can contain a maximum of 255 

characters. 

Max. Sort Key Size: The sort key used for sorting index entries has a maximum size of 255 

characters. The size allocated to each field is based on this equation:  

Int((253/(SubheadingLevels+1))–2). For a standard index with a main and 

subheading, this would mean the Main and Sub1 fields would each have 

124 characters each. For an index with six subheading levels, the allocation 

for each field would be: 34 characters. Although 34 characters is generally 

enough to result in the proper sorting of most material, if the headings are 

unusually long or highly similar, you may have to force the sorting of some 

entries for proper sorting. 

Maximum Record 

size: 

No realistic limit in the context of indexing. 

Locator Format 

Locators in SKY Index Professional have the following form: 

[seclabel1+secsep1] [seclabel2+secsep2] … [seclabel9+secsep9] [page prefix] page [page suffix] 

Example: IV:14.a22g 

seclabel+secsep – These are up to nine optional section labels each with a section separator (delimiter) 

that identify sections of a book such as a volume or chapter. If they exist, there must be both a label 

and separator pair. seclabel is a section label and can contain any combination of letters or numbers 

except the section separator character. secsep is a single character that defines where the section 

label stops and the remainder of the locator begins. It is called the section separator. All characters 
to the left of secsep are considered to be the section label. In the example above "IV" is the section 

label and ":" is the section separator. 
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page prefix   one or more alpha or alphanumeric characters preceding the page number. In the example 

above, "a" is the page prefix. 

page   The page number or a word that identifies the page. This can be a Roman numeral. If it is a 

Roman numeral then you may not use a page prefix or a page suffix 

page suffix   One or more alpha or alphanumeric characters following the page number. In the example 

above, "g" is the page suffix. 

Sorting of Locators 

SKY Index applies the following priority to each locator part with 1 being the highest priority and 12 

being the lowest priority (parts within brackets are optional – if no page exists, its value will be zero ‘0’): 

1. [seclabel1] 

2. [seclabel2] 

3. [seclabel3] 

4. [seclabel4] 

5. [seclabel5] 

6. [seclabel6] 

7. [seclabel7] 

8. [seclabel8] 

9. [seclabel9] 

10. page 

11. [page prefix] 

12. [page suffix] 

Notes 

 SKY Index will automatically detect and sort volume labels or chapter labels that are numbers 

or dates. Also SKY Index lets you specify a different character for printing than for data entry for 

both the volume and chapter separators. 

 If you enter a page number that contains leading zeros, those zeros will internally become part of 

the locator’s Prefix. This means that no matter how many leading zeros, the primary sort is on 

the part of the locator without those leading zeros. So these two locators will sort in the order 

shown: 07, 00012. In other words, the actual page numbers are ‘7’ and ‘12’. ‘0’ and ‘000’ are 

prefixes of their respective page numbers. To achieve a different sort, you will have to use forced 

sorting. 

 It is illegal to format the digits of the ‘page’ part of the locator differently from one another. If 

you apply different formatting to the digits of ‘page’, SKY Index will use only the formatting 

applied to the first digit. For example, if you enter 056, SKY Index will convert it to 056. 

 To force the sort of a locator, you must use a ‘hidden’ number that contains leading zeros to make 

the total number of digits five. In addition, if there are unhidden numbers in any other part of 

the locator, they must be ignored. Otherwise they may be interpreted as the locator and other 

text as the prefix. 

Example: (hidden text is shown in curly braces “{}” and ignored text is shown in square 

brackets “[]” –  “{00066}Plate[ 3]" will force the locator “Plate 3” to sort as page 66 with a 

suffix of Plate. 
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Formatting Codes Used By SKY Index 

Although you don't normally see them, SKY Index uses special formatting codes internally when you 

apply character formatting to entries in your index. If you show the Reveal Codes Pane (View>Reveal 

Codes), you can see these codes. The table below defines the codes that are used and what they do. 

Under normal circumstances, you do not need to know or be concerned with these codes. However, if you 

experience a sorting problem, the problem can sometimes be resolved by viewing these codes. For 

instance, one entry may have an ignored space where another, apparently identical, entry may not have 

that space ignored which would cause the two entries to sort differently even though they appear 

identical. 

Note: These codes are case sensitive. 

 

Format Begin End 

Bold /b1 /b0 

Italic /i1 /i0 

Underline /u1 /u0 

Superscript /p1 /p0 

Subscript /s1 /s0 

Strikeout /k1 /k0 

Alternative Font 1 /f1 /f0 

Alternative Font 2 /f2 /f0 

Alternative Font 3 /f3 /f0 

Ignore Text /y1 /y0 

Hide Text /y2 /y0 

Note Text /y3 /y0 
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Appendix 

E 
Troubleshooting 

Problems and solutions 

General 

If you try a solution for a specific problem that is listed below and it does not cure the problem, try these 

general solutions for fixing a problem: 

 Close and then reopen SKY Index. 

 Resort the index using Index>Resort. 

 Reboot your computer. 

 Create a new, empty, index and then use the Merge command to merge the contents of the 

problem index into the new one. 

Sorting Problems 

Two Identical Entries do not Combine in the Generated Index 

 Try resorting the index by choosing Index>Resort. 

 Examine the entries with Reveal Codes turned on. Are there formatting codes that surround a 

space in one and not in the other? 

 Copy one of the two entries that do not combine and paste it over the other ensuring the two 

entries are, indeed, identical. 

 If there is another heading that is identical except for a leading preposition which is ignored, you 

must make one of the two headings sort uniquely from the other using forced sorting. For 

example, if you have the two subheadings “by government” and “for government”, they have 

exactly the same sort key “government” you must make on unique. If you enter a hidden “1” after 

the word government for the entries ‘for government” they will sort as “government1” and will 

then combine properly in the generated index. 

 If none of the solutions above correct the problem, contact technical support. 

Locators Don’t Sort Correctly 

 Resort the index using Index>Resort 

 Add an additional subheading level to the index by choosing Index>Subheading Levels. Do you 

see a sub-subheading you didn’t know about? If so, remove the extra subheading. 

One or More Entries Sort Somewhere Other than Where you Expect Them 

 Resort the index using Index>Resort 
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 Is there an ignored word at the beginning of the entry that is sorting incorrectly? You can see the 

list of ignored words by choosing Options>Data Entry and then clicking the Ignored Words tab. 

 Is there a Translation that is causing unexpected problem? Make sure all of your translations 

are unique and will not be encountered in normal text. 

Program Behaves Strangely 

 Try rebooting your computer. 

 If rebooting does not work, the index may be corrupt. Try creating a new empty index with a 

different name and then use File>File Management>Merge to merge the index entries from the 

problem index into the new index. 

Some Records are Missing 

Were the missing records labeled? If yes, choose View>Filtered and make sure they have not been 

filtered to be hidden. 

Subscript Out of Range Error Message 

If you get this error message, examine your locators for a typo. Usually this error is caused by a locator 

that has a decimal value of greater than 36728. A very likely cause of this error is a missing hyphen 

between a range of pages. For instance, you might have 103107 instead of 103-107. 

Locators with a page range get mysteriously changed or truncated 

If you enter a locator with a page range and after moving the grid marquee to a different field, the 

locator changes unexpectedly, you may have used a reserved section label character in the locator 

unknowingly. By default, SKY Index uses a colon as a volume label separator (section 1 label) and a 

period as a chapter label separator (section 2 label). If you type either of those two characters, SKY 

Index may modify your locator to fit the rules of locators with section labels. For instance, you might 

enter “101-102 a:b”, SKY Index will change it to “101-102 b” because the volume label for the second 

page must match the volume label of the first page. In this case, the volume label for the first page is 

nothing and so the errant volume label for the second page is removed leaving only the page suffix “b”. 

To cure this, you have two options: 

1. Disable the recognition of Volume and/or Chapter Labels by going to the Locators tab of the 

Index Options dialog and unchecking the Enabled (or Recognize) checkbox for those items. 

2. Use a character other than a colon or period in your locator and use the Translation table to 

translate that character into the desired character during index generation. Please be sure to 

enable the translation for the Page field only. 

Cross-references are not getting italicized or the ‘also’ in a ‘see also’ cross-reference 
does not get italicized 

SKY Index expects all cross-references to be in the page field and to start with the plain text and with 

the words ‘see ‘ or ‘see also ‘ followed by a space. It does not matter if the words have an initial capital or 

not. If a cross-reference or part of a cross-reference is not getting italicized, it is almost certainly because 

there is some kind of unseen formatting. To determine if this is the case, display the Reveal Codes pane 

by pressing Ctrl+Alt+E. It will become obvious if there are, indeed, unseen codes at play. If there are, 

use either Find/Replace or manually alter the cross-references to correct them. Please note that if these 

codes have gotten into AutoComplete, retyping them will likely re-introduce the problem. You’ll need to 

manually edit the cross-references and then update AutoComplete to remove the errant AutoComplete 

entries.
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Index 
This index was written by Ty Koontz using SKY Index Professional v7.0. Page references in italic type 

indicate illustrations. 

Note from SKY Software: This manual will be updated over time and because of that, after Ty 

finished the index, it was embedded into the original document. It is possible that, in the future, 

material will be added that will cause some items that originally appeared on a single page to flow over 

two pages. Because the original entry would not be entered as a range, it will not be automatically 

presented in the updated index as a discussion over two pages. If you notice this kind of problem, please 

let SKY Software know and we’ll correct the embedded entry.

Symbols 

& (ampersand) 
finding with pattern matching active, 122 
for pattern matching, 119, 121–22 

' (apostrophe) as word delimiter, 133 
* (asterisk) 

entering literally in Group on Text dialog, 129 
finding with pattern matching active, 120 
for grouping on text, 129 
for pattern matching, 119–20, 119 
for Wild Match searches, 97 

@ (at sign) 

for maiden name processing, 215 
as word delimiter, 133 

{ } (braces) 
left, as word delimiter, 133 
in macros, 200 
for pattern groups, 123–25 

^ (caret) 
entering literally in macros, 200 

macro code for Ctrl key, 200 
, (comma) 

Adjust Punctuation option, 143 
Duplicate Records and Change Locator command, 8, 61–

62, 61 
editing locators in Edit View and, 27, 138 
Locator Decrement command (Ctrl/Alt+comma), 62–63, 

62–63 
- (dash) 

as page range separator, 158, 178 
in pattern matching character list, 120–21 

… (ellipsis character), entering, 143 
— (em dash), translation for, 202 
– (en dash) 

as page range separator, 178 
translation for, 202 

! (exclamation mark) 

Adjust Punctuation option, 143 
for grouping on text, 129 

! (exclamation mark) (continued) 
in pattern matching character list, 120–21 

> (greater than symbol) 
finding with pattern matching active, 121 

for pattern matching, 119, 121 
- (hyphen) 

as page range separator, 178 
for preventing acronyms from expanding, 194 
as word delimiter, 133 

< (less than symbol) 
finding with pattern matching active, 121 
for pattern matching, 119, 121 

( ) (parentheses) 
entering literally in macros, 200 
left, as word delimiter, 133 
for multiple-key combinations in macros, 201 
removing trailing text in, for cross-references, 163, 173 

% (percent sign) 
entering literally in macros, 200 
macro code for Alt key, 200 

. (period) 
acronyms expanded by, 194 
Adjust Punctuation option, 143 
entering ellipsis character (…), 143 
Locator Increment command (Ctrl/Alt+period), 62–63, 

62–63 
as word delimiter, 133 

+ (plus sign) 
entering literally in macros, 200 

macro code for Shift key, 200 
# (pound sign) 

entering literally in Group on Text dialog, 129 
finding with pattern matching active, 120 
for grouping on text, 129 
for pattern matching, 119, 120 
for sorting Roman numerals, 182 

? (question mark) 

Adjust Punctuation option, 143 
entering literally in Group on Text dialog, 129 
finding with pattern matching active, 120 
for grouping on text, 129 
for pattern matching, 119, 120 
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" (quotation marks) 
Adjust Punctuation option, 143 
beginning, as word delimiter, 133 
enclosing fields, when exporting indexes, 80 
enclosing fields, when importing indexes, 77 

Smart Quotes option, 144 
; (semicolon) 

Append New command (Ctrl+semicolon), 1, 17, 24, 33 
for browsing to subheadings, 103, 104 
deleting cross-references in Edit View and, 27 
for duplicating a record and adding another cross-

reference, 10–11 
‘ (single quote) as word delimiter, 133 

[ ] (square brackets) 
entering in macros, 200 
for finding symbols with pattern matching active, 120, 

121, 122 
for grouping on text, 129 
left, as word delimiter, 133 
for pattern matching, 119, 120–21 
for Unicode translation codes, 206 

~ (tilde) 
for Enter key in macros, 200 
finding with pattern matching active, 122 
for pattern matching, 119, 122 

0 (zero) 
locators with leading zeros, 256 
pattern group {0}, 123 

1-9 pattern groups, 123–25 

A 

Acronym Manager, 193–94 
Acronym toolbar, 248 
acronyms (abbreviations) 

defining, 193 
exporting, 194 
importing, 85, 194 
merging, 194 
methods of expanding, 194 

mouse hover for popup display, 21, 248 
not case-sensitive, 206 
path for saved acronyms, 146 
preventing from expanding, 194 
printing list of, 194 
translations compared to, 202, 206 
using, 194, 248 

acronyms (organization names) 

finding all with pattern matching, 122 
Swap Acronym command for, 4, 58 

active label. See also labeling 
grouping on, 87, 90, 130 
in Label Selector toolbar, 91, 250 
moving to next record having, 87, 90 
setting, 87, 91, 250 
status bar display of, 5, 87, 90 

toggling on and off, 87, 89, 91 
Add Prefix tool, 207 
Add/Remove Volume/Chapter Labels tool, 214 
Add Suffix tool, 208 
adding 

alphabetic sections, 188 

adding (continued) 
commands to toolbars, 251 
words to SmartSwap list, 169 

adding new records. See also duplicating records; pasting 
Append New command for, 1, 17, 24, 33 

from Bad Cross-Reference dialog, 224 
converting cross-reference into index entries, 41 
cross-references in Data Entry View, 9–11 
cross-references in Edit View, 27 
in Data Entry View versus Edit View, 26, 138 
headings in Data Entry View, 7–9, 24 
headings in Edit View, 26–27, 138 
keyboard shortcuts for, 1, 24, 33, 144, 244 

locators in Data Entry View, 8 
locators in Edit View, 17, 27, 138 
splitting entry into two entries, 4, 56–57, 145 
subheadings in Data Entry View, 7–9, 24 
subheadings in Edit View, 27, 138 
tutorial, 7–11 

alignment 
of headers and footers, 153 

of locators, 178 
All direction of search, 93 
alphabetic sections 

adding, 188 
blank lines before or after, 187 
capitalizing, 176 
defining, 187–88 
deleting, 188 

enabling or disabling, 187 
fonts for, 175 
formatting labels for, 175–76 
markup tags for, 158 
members of, 188 
overview, 187 
prefixes for, 185–86 
style name for RTF output, 175 
suffixes for, 186 

suppressing, 188 
alphabetizing. See sorting 
Alt key 

Alt key shortcuts, 240 
Alt+Ctrl key shortcuts, 239 
Alt+Ctrl+Shift key shortcuts, 242 
Alt+Shift key shortcuts, 241 
macro code for, 200 

alternative fonts 
defaults, 176 
defining, 176, 189 
formatting codes for, 257 
keyboard shortcuts for, 189, 244 
using, 189 

Alternative Fonts dialog, 189 
American/British system for measurements, 151, 221–22 

ampersand (&) 
finding with pattern matching active, 122 
for pattern matching, 119, 121–22 

And search operator 
Find dialog radio button for, 93 
logic evaluation with other operators, 99 
logic of, 98 
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angle brackets. See greater than symbol (>); less than symbol 
(<) 

ANSI 
character set, Unicode for, 202 
output format, 157 

apostrophe (') as word delimiter, 133 
Append New command 

Ctrl+A shortcut for (as in v6.0), 1, 144 
keyboard shortcuts (SI7), 1, 17, 24, 33 
using, 24, 33 

Arabic numbers. See also locators; numbers 
page numbering for printed index, 153 
section label data types, 180 

sorting, 182 
articles (Ignored Words), 167–68, 176 
As Entered view, 67, 108 
ASCII 

output format, 157 
sort order, 182 

asterisk (*) 
entering literally in Group on Text dialog, 129 

finding with pattern matching active, 120 
for grouping on text, 129 
for pattern matching, 119–20, 119 
for Wild Match searches, 97 

at sign (@) 
for maiden name processing, 215 
as word delimiter, 133 

AutoCapitalization feature, 161–62, 161 

AutoComplete feature 
bypassing, 196 
case-sensitivity option, 163 
configuring, 162–64, 163 
for controlled vocabulary, 163 
for cross-references, removing trailing text in parentheses, 

163, 173 
how it works, 164, 196 
reopening automatically, 164 

SI7 enhancements for, 5 
tips for using, 196 

AutoComplete list 
editing, 195 
exporting, 195, 196 
importing, 85, 195, 196 
maximum characters per entry, 162, 196 
merging lists, 195 

printing, 195 
refreshing, 195 
updating, 164, 196 

AutoComplete Manager, 164, 194–96 
AutoEntry feature, 85, 165, 197–98 
AutoEntry Manager, 165, 197–98, 197 
Automatically create maiden name entries option, 215 
AutoRepeat feature, 166 

B 

backing up 
currently open index, 74 
file location for, 146 
importance of, 74 
restoring from backup, 83–84 

Backward direction of search, 94 
Bad Cross-Reference dialog, 223–24 
blank lines in output, 187 
bold character style. See also character styles 

for alphabetic section labels, 176 

applying, 131 
for cross-references, 172 
Find dialog checkbox for, 95 
formatting codes for, 257 
for headings and subheadings, 176 
markup tags for, 160 
Replace dialog checkbox, for Replace Text, 111 
Replace dialog option, for Find Text, 110 

bookmark feature, 104 
bookmarks for embedded index entries, 230 
Boolean search operators (AND and OR) 

Find dialog radio buttons for, 93 
logic evaluation with other operators, 99 
logic of, 98 

borders for headers and footers, 153 
braces ({ }) 

left, as word delimiter, 133 
in macros, 200 
for pattern groups, 123–25 

brackets ([ ]) 
entering in macros, 200 
for finding symbols with pattern matching active, 120, 

121, 122 
for grouping on text, 129 

left, as word delimiter, 133 
for pattern matching, 119, 120–21 
for Unicode translation codes, 206 

British/American system for measurements, 151, 221–22 
Browse command, 103–5 
Browse Pane, 103–5 

in Data Entry View, 104 
in Edit View, 105 
finding with, 93–102 

using, 104 
browsing 

bookmark feature with, 104 
with the Browse Pane, 103–5 
starting a new search, 104 
to subheadings, 103, 104 
using keyboard, 104 

C 

canceling. See also reverting or clearing; undoing 
Acronym Manager changes, 194 
AutoComplete Manager changes, 195 
AutoEntry Manager changes, 198 
Data Entry Options dialog changes, 161 
Document Options dialog changes, 151 
Index Options dialog changes, 171 
Macro Manager changes, 199 

Preferences dialog changes, 141 
search using Find dialog, 96 
text editor changes, 226 
Translation Manager changes, 203 

capitalization. See case 
captions for headers and footers, 151, 152–53 
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caret (^) 
entering literally in macros, 200 
macro code for Ctrl key, 200 

carriage returns (markup tags), 159 
case. See also case-sensitivity; small caps character style 

for alphabetic section labels, 176 
AutoCapitalization feature, 161–62 
changing for column of Data Entry Grid, 132 
commands for changing, 132–33 
for cross-reference targets, 173 
for headings and subheadings, 19, 176 
for ignored words, 176 
Initial Cap option for headings, 19, 176 

keyboard shortcuts for commands, 244 
in macro definitions, 201 
maintaining for Replace Text, 111 
matching for Find Text when replacing, 111 
matching in searches, 94 
for sections, volumes, or chapters in locators, 180, 181 
sort recognizing, option for, 183 
swapping, 132 

word delimiters for commands, 133 
case-sensitivity 

acronyms not case-sensitive, 206 
AutoComplete configuration for, 163 
AutoEntry configuration for, 165 
of formatting codes, 257 
of translations, 202, 204, 206 

cells (Data Entry Grid). See also columns (Data Entry Grid); 

fields; headings; locators; subheadings 
copying contents of, 34 
cutting contents of, 33 
deleting contents of, 33 
empty, finding, 97, 101 
maximum number of characters for, 255 
moving between, 24 
shifting contents left by one cell, 52–53 
shifting contents left to main, 53–54 

shifting contents right by one cell, 54–56 
centering headers and footers, 153 
century assumptions, configuring for date sorting, 227 
Change Case command, 132 
Change Page Number tool, 218 
chapters/volumes in locators 

adding or removing labels, 214 
configuring, 179–81, 260 

grouping on, 127, 128 
hiding repeated, 181 
maximum number of labels, 3 
renumbering pages, 217–19 
repaginating, 219–20 
sorting of, 256 
troubleshooting, 260 

character list for pattern matching, 120–21 

Character Map 
SI7 dialog, 209 
using for Unicode translations, 205 
Windows dialog, 205 

Character Style Markup Tags options, 160 
character styles. See also text attributes 

for alphabetic section labels, 176 
applying as you type, 131 

character styles (continued) 
applying to column of Data Entry Grid, 4, 31, 131 
applying to selected text, 131 
AutoComplete functioning with, 164 
AutoEntry configuration for, 165 

changing by finding and replacing, 114–15 
for cross-reference targets, 173 
for cross-references, 172 
Find dialog options for, 95 
finding text with, 96–97, 98 
format priority for locators, 179 
formatting codes for, 257 
Group on Text command sensitive to, 129 

for headings, 176 
for introductory note, 185 
issues when exporting indexes, 77 
keyboard shortcuts for, 131, 244 
for locators, 179, 256 
markup tags for, 160 
mixed, finding and replacing text with, 113–14 
mixed, finding text with, 98 

not included in pattern groups 1 through 9, 124 
removing formatting from text, 136, 164 
Replace dialog options, for Find Text, 110 
Replace dialog options, for Replace Text, 111–12 
for sections, volumes, or chapters in locators, 180, 181 
sort recognizing, option for, 183 
sorting locators by, 179, 224 
for subheadings, 176 

Wild Match search for, 97 
characters, pattern matching symbols for, 119–20 
cheat sheet for keyboard shortcuts, 2 
Chicago Manual of Style (CMS) 

page range conflation presets, 178 
sort order presets, 182 

Chicago University Press output format, 157 
child headings. See subheadings 
Choose Path dialog, 227 

CINDEX 
exporting a DAT file for, 77 
importing an index from, 78 
troubleshooting import problems, 80 

circular cross-references, checking for, 210 
clearing. See reverting or clearing 
clipboard 

copying text and records to, 34 

cutting text and records to, 33–34 
pasting text and records from, 34–35 

closing currently open index, 76 
CMS. See Chicago Manual of Style 
codes for formatting. See also character styles; codes for 

output; text attributes 
case-sensitivity of, 257 
entering directly no longer possible, 2 

export options for, 77 
overview, 257 
Reveal Codes pane for, 72 
table of, 257 
viewing, 72 

codes for macros, 200–201 
codes for output 

ANSI, 157 
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codes for output (continued) 
custom, 157 
HTML, 157 
markup tags, 156, 158–60 
Plain Text, 157 

Quark Xpress, 157 
RTF presets, 156–57, 158 
UCP (University of Chicago Press), 157 

collaborating with other indexers, 77 
Color Dialog, 88–89, 88 
colors. See also labeling 

blue for hidden text, 135 
blue highlight for selections, 230 

blue line for subsearch (Find dialog), 98 
blue text in this manual, 38 
changing for labels, 88–89 
for hyperlinks, 157 
orange text in Find Pane, 96, 105, 112 
orange text in Preview Pane, 176 
orange text in this manual, 38 
Preference settings for, 143, 144 

for proofreading report, 216 
for translation display in Preview Pane, 205 

columns (Data Entry Grid). See also cells (Data Entry Grid); 
fields; subheadings: specifying levels of 

applying character style to, 4, 31, 131 
changing case of text in, 132 
deleting contents of, 31 
keeping equal width, 71 

making equal width, 71 
moving from cell to cell, 24 
selecting, 4 
specifying number of subheadings, 66, 185 

columns for printed index 
calculating Line Count statistics using, 213 
specifying, 155 

Combine command 
Promote command compared to, 47 

tutorial, 15 
using, 39–40 

combining consecutive pages as page range, 179 
combining subheading with heading 

duplicating and swapping and, 14–15, 47–48, 47–48 
in Edit View, 40 
promoting compared to, 47 
for single subheading (Data Entry View), 40 

for subheadings of several records (Data Entry View), 15, 
41 

comma (,) 
Adjust Punctuation option, 143 
Duplicate Records and Change Locator command, 8, 61–

62, 61 
editing locators in Edit View and, 27, 138 
Locator Decrement command (Ctrl/Alt+comma), 62–63, 

62–63 
comma separated value (.csv) files. See text delimited files 
commercial at sign (@) as word delimiter, 133 
compacting an index, 76 
configuration. See also specific dialogs and managers 

Acronym Manager, 193–94 
AutoComplete Manager, 194–96 
AutoEntry Manager, 197–98 

configuration (continued) 
Data Entry Options dialog, 161–70 
default template for the most common settings, 84 
Document Options dialog, 151–60 
before generating an index, 65 

Index Options dialog, 171–91 
Label Manager, 87–88 
loading index options, 85 
Macro Manager, 198–201 
measurement units for settings, 151, 221–22 
for newly created index, 81 
Preferences dialog, 141–50 
Saved Search Manager, 117–18 

saving index options, 84 
SI7 enhancements for, 3 
templates, 84, 146 
Translation Manager, 202–3 
tutorial, 10, 15–19 
using spin controls on dialogs, 221–22 
for v6.0 keyboard shortcuts, 1, 144 

configuration settings, importing, 85 

conflation of page ranges 
custom rules for, 178, 190–91 
options, 178 

Consume locs in range option, 6, 179 
Consume Subheadings command, 4, 40–41 
Control key. See Ctrl key 
controlled vocabulary, AutoComplete list as, 163 
Convert Cross-reference command, 41 

Copy Heading command, 38 
Copy Locators command, 38–39 
copying to clipboard or paste buffer. See also duplicating 

characters from Character Map, 209 
headings, 38 
locators, 38–39 
records, 34 
text, 34 

core editing commands 

Combine, 15, 39–40 
Ctrl modified shortcuts (table), 236 
Ctrl+Shift modified shortcuts (table), 236 
Demote, 44–46, 145 
keyboard shortcuts for, 37, 235, 236 
modifiers for, 37, 235 
Promote, 50–51, 50, 145 
Select Entry, 29, 51 

Select Heading, 14, 29–30, 52 
Shift Left, 52–53 
Shift Left to Main, 53–54 
Shift Right, 54–56 
Swap, 15, 57 

count for splitting entries, 56, 145 
CR (markup tag), 159 
Create Reciprocal Cross-Reference command, 4, 42 

Create Subheadings from Locators command, 4, 42–43 
creating a new index 

from group contents, 84 
starting a new indexing project, 7, 81 

creating groups, 127–30 
Creator field 

described, 70 
filtering on, 69, 70 
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Creator field (continued) 
resetting tag for, 149 
showing or hiding, 70 

criteria symbols for pattern matching 
ampersand (&), 121–22 

asterisk (*), 119–20 
greater than symbol (>), 121 
less than symbol (<), 121 
pound sign (#), 120 
question mark (?), 120 
square brackets ([ ]), 120–21 
table summarizing, 119 
tilde (~), 122 

CRLF (markup tag), 159 
cross-references 

adding in Data Entry View, 9–11, 172, 174 
adding in Edit View, 27, 172, 174 
AutoComplete options, 163 
character styles for, 172 
circular, checking for, 210 
configuring, 10, 171–74, 171 

converting into fully qualified index entries, 41 
deleting in Edit View, 27 
displaying target of, 5, 63 
editing in Edit View, 17, 27, 138 
in embedded indexes, 231 
Error Scan for, 210 
finding all, 101–2 
forcing target formatting to match actual target, 173 

general, options for, 173 
in HTML Mode, 157 
navigating in Edit View, 27 
orphan, options for, 172–73 
Page field for entering, 174 
placement of, 172, 184 
prefix for, 172, 173 
reciprocal, creating, 4, 42 
removing formatting from, for formatted targets, 173 

removing trailing text in parentheses, 163, 173 
separator for, 173 
SI7 enhancements for, 5 
statistics for, 213 
suffix for, 172, 173 
target capitalization settings, 173 
target style settings, 173 
text for, 172, 173 

toggling see/see also references, 4, 59 
tutorial, 9–11 
'under' indicating a subheading of a main, 173 
verifying immediately, dialog for, 223–24 
verifying immediately, option for, 144, 223 

Cross-references options 
Error Scan, 210 
Index Options dialog, 171–74, 171 

CSS (SKY Software Customer Support System), 233–34 
.csv files. See text delimited files 
Ctrl and Ctrl+Shift modifiers for core editing commands 

Ctrl modified shortcuts (table), 236 
Ctrl+Shift modified shortcuts (table), 236 
described, 37, 235 

Ctrl key 
Alt+Ctrl key shortcuts, 239 

Ctrl key (continued) 
Alt+Ctrl+Shift key shortcuts, 242 
Ctrl and Ctrl+Shift modifiers for core editing commands, 

37, 235 
Ctrl key shortcuts, 237–38 

Ctrl modified function keys, 236 
Ctrl+Shift key shortcuts, 238 
Ctrl+Shift modified function keys, 236 
macro code for, 200 

curly braces ({ }) 
left, as word delimiter, 133 
in macros, 200 
for pattern groups, 123–25 

cursor position 
demoting from, 44 
promoting from, 39, 50 
splitting from, 56 

Custom Page Range Conflation Rules dialog, 178, 190–91 
customer support, 233–34, 233–34 
Customer Support System (CSS), 233–34 
Customize dialog, 251 

Keyboard button, 252 
for toolbars, 250–54 

Customize Keyboard dialog, 252–54, 253, 254 
customizing keyboard shortcuts, 252–54 
customizing toolbars, 250–54 

adding new commands, 251 
modifying the appearance of commands, 251–52 
removing commands, 251 

returning toolbar to default style, 252 
Cut Heading command, 42–43 
cutting. See also deleting records; deleting text 

headings, 42–43 
records, 33–34 
text, 33 

D 

damaged index, repairing, 83 
dash (-). See also hyphen (-) 

em dash (—), translation for, 202 
en dash (–), as page range separator, 178 
en dash (–), translation for, 202 
as page range separator, 158, 178 
in pattern matching character list, 120–21 

DAT files 
described, 78 
exporting, 77 

importing, 78 
troubleshooting import problems, 80 

Data Entry Grid. See also columns (Data Entry Grid); fields 
arranging on screen, 23–24, 23–24, 143 
described, 23 
grouping on text under marquee (View Mode), 130 
keyboard shortcuts for navigating, 243 
moving from cell to cell, 24 

proportional scrolling, 142–43 
refreshing, 71–72 
selecting columns, 31 
Text Edit Mode, 24–25 
View Mode, 24–25 



 Index 267 

Data Entry Options dialog, 161–70 
AutoCaps tab, 161–62, 161 
AutoComplete tab, 162–64, 163 
AutoEntry tab, 165 
AutoRepeat tab, 166 

canceling changes to, 161 
help, 161 
Ignored Words tab, 167–68, 167 
overview, 161 
reverting changes to current tab, 161 
SmartSwap tab, 168–70, 168, 169 

Data Entry Options (Preferences dialog), 143–45, 143 
Data Entry View (DEV), 23–24 

adding records in, 7–9, 24 
arranging the Preview Pane and grid, 23–24, 23–24, 143 
Edit View compared to, 18, 26, 137, 138 
keyboard shortcuts for navigating, 243 
labeling records in, 89, 90 
moving from cell to cell, 24 
starting in, option for, 143 
switching to and from Edit View, 15, 17, 71, 137 

Text Edit Mode, 24–25 
View Mode, 24–25 

data managers, 193–206 
Acronym Manager, 193–94 
AutoComplete Manager, 194–96 
AutoEntry Manager, 197–98 
Macro Manager, 198–201 
Translation Manager, 202–6 

data types for volumes or chapters, 179, 180 
database, maximum size of, 255 
Date Created field 

filtering on, 69, 70 
showing or hiding, 70–71 

Date Edited field 
filtering on, 69, 70 
showing or hiding, 71 

Date Options dialog, 183, 227–28 

dates 
century assumptions for, configuring, 228 
as section label data type, 180 
sorting, 182, 227–28 

days of the week, as locator section labels, 180 
decrementing locators (Data Entry View), 62–63 
default.tp7, exporting the most common configuration as, 84 
Delete Heading command, 44 

deleting. See also canceling; reverting or clearing 
alphabetic sections, 188 
custom Index Style options, 185 
an index, 76 
items from Error Scan list, 212 
locators in Edit View, 27 
removing all formatting, 136, 164 
removing commands from toolbars, 251 

removing keyboard shortcut assignment for a command, 
253, 254 

removing volume/chapter labels, 214 
saved searches, 118 
translations, 206 
words from Ignored Words list, 167 
words from SmartSwap list, 169 

deleting records 
consuming subheadings (removing and retaining locators), 

4, 40–41 
cutting headings, 42–43 
cutting to clipboard, 33–34 

duplicate records, 216 
headings, 44 
by labeling and filtering (similar to v6.0), 1 
methods for, 35 
tutorial, 13 
in v6.0 versus v7.0, 1 

deleting text 
for AutoComplete phrases, 164, 196 

column contents (Data Entry Grid), 31 
cross-references in Edit View, 27 
cutting, 33 
one character at a time, 35 
one word at a time, 35 
removing trailing text in parentheses, for cross-references, 

163, 173 
several characters at a time, 35 

delimited text files 
exporting, 77 
importing, 78, 79 
troubleshooting import problems, 80 

delimiters. See also separators for commands; separators for 
index elements 

export options for, 77 
import options for, 80 

for sections, volumes, or chapters in locators, 180 
for words, 133 

Demote command 
separator for, 44, 145, 225 
using, 44–46 

demote separator, changing, 225 
demoting headings 

from cursor position, 44 
in Edit View, 45 

part of a heading (Data Entry View), 45 
separator for, 44, 145, 225 
for several records (Data Entry View), 45 
single heading (Data Entry View), 44–46 

DEV. See Data Entry View 
diacritic marks. See special characters 
Dialog Help Button dialog help button, 21 
dictionary, user 

adding words to, 217 
creating a new dictionary, 147 
specifying path and filename for, 146–47 

digits, pattern matching symbol for, 119, 120 
direction of search, 93–94 
disabling or enabling. See toggling 
docking toolbars, 3, 247 
Document Markup Tags options, 158–59 

Document Options dialog, 151–60 
canceling changes to, 151 
Headers and Footers tab, 152–53, 152 
help, 151 
Margins and Layout tab, 154–55, 154 
measurement units for settings, 151 
Output Format / Markup Tags tab, 156–60 
overview, 151 
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Document Options dialog (continued) 
previewing settings, 151 
reverting changes to current tab, 151 

Don’t Care option (Find dialog), 95 
Don’t Change option (Replace dialog), 111, 112 

double-posting 
automatically (AutoEntry), 165, 197–98 
converting cross-reference into index entries, 41 
creating reciprocal cross-references, 42 
splitting entry into two entries, 4, 56–57, 145 

double spaced output, 187 
double spaces, removing automatically, 144 
draft copy of index, printing, 81–82 

drag and drop 
to embed index entries, 230 
to swap heading levels, 58 

Duplicate and Group command, 46 
Duplicate and Swap command 

Ctrl+P shortcut for (as in v6.0), 1, 144 
in Edit View, 17 
tutorial, 13 

using, 47 
Duplicate command, 13, 46 
duplicate records 

deleting, 216 
ignoring, 178 

Duplicate Records and Change Locator command (Data Entry 
View), 8, 61–62, 61 

Duplicate, Swap and Combine command, 47–48, 47–48 

duplicating records. See also copying to clipboard or paste 
buffer 

automatically using AutoEntry, 165, 197 
and changing locators (Data Entry View), 8, 61–62, 61 
converting cross-reference into index entries, 41 
creating reciprocal cross-references, 42 
Ctrl modifier for, 14, 37, 235 
in Edit View, 46 
and grouping, command for, 46 

and grouping, Ctrl+Shift modifier for, 37, 235 
several records (Data Entry View), 46 
single record (Data Entry View), 13, 46 
splitting entry into two entries, 4, 56–57, 145 
and swapping and combining headings, 14–15, 47–48, 47–

48 
and swapping headings, 1, 13, 17, 47 
tutorial, 13–15 

E 

edit mode. See Text Edit Mode (Data Entry View) 
Edit toolbar, 248 
Edit View (EV), 26–28, See also in-place editor 

adding new child heading (subheading), 27, 138 
adding new heading at current level, 26–27, 138 
applying changes in, 27, 138 
Data Entry View compared to, 18, 26, 137, 138 

described, 4, 15, 26, 137 
duplicating and swapping main and subheading in, 17 
editing existing headings, 15, 16, 28, 138 
entering or editing cross-references, 17, 27, 138 
entering or editing locators, 17, 27, 138 
fields for editing entries, 138 

Edit View (EV) (continued) 
in-place editor, 16–17, 144 
keyboard shortcuts for navigating, 28, 243 
labeling headings in, 89–90, 90 
merged orphans in, 176 

navigating, 17, 27, 28, 138, 139 
starting in, option for, 143 
switching to and from Data Entry View, 15, 17, 71, 137 

editing cross-references 
in Edit View, 17, 27, 138 
reciprocal cross-reference creation, 4, 42 
toggling see/see also, 4, 59 

editing in dialogs 

AutoComplete list, 195 
Error Scan results, 211–12 
Macro Manager, 249 
Saved Search Manager, 249 
saved search names, 118 

editing locators 
adding locators in Data Entry View, 8 
adding locators in Edit View, 27, 138 

adding prefix, 177 
adding suffix, 177 
changing page numbers, 218 
copying, 38–39 
creating subheadings for selected, 4 
duplicating records and changing (Data Entry View), 8, 

61–62, 61 
in Edit View, 17, 27, 138 

finding missing locators (empty Page field), 97 
incrementing or decrementing (Data Entry View), 62–63, 

62–63 
navigating in Edit View, 27 
pasting, 49 
renumbering pages, 217–19 
repaginating the index, 219–20 

editing records. See also deleting records; deleting text 
adding new records in Data Entry View, 7–9, 24, 33 

adding new records in Edit View, 26–27 
applying changes in Edit View, 27, 138 
consuming subheadings (removing and retaining locators), 

4, 40–41 
copying headings, 38 
copying record to clipboard, 34 
copying text to clipboard, 34 
core commands for, 37 

cutting headings, 42–43 
cutting records, 33–34 
cutting text, 33 
demoting headings, 44–46 
duplicating, 46 
duplicating and changing locators (Data Entry View), 8, 

61–62, 61 
duplicating and grouping, 46 

duplicating and swapping, 1, 13, 17, 47 
duplicating, swapping and combining, 14–15, 47–48, 47–

48 
in Edit View, 15–17, 16, 28, 138 
keyboard shortcuts for, 244 
new commands in SI7 for, 4 
pasting headings, 48–49 
pasting records, 35 
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editing records (continued) 
pasting text, 34 
promoting subheadings, 50–51 
propagating edits (Data Entry View), 14, 63–64 
redoing, 36 

selecting (Data Entry View), 29–31, 52 
shifting left by one cell, 52–53 
shifting left to main, 53–54 
shifting right by one cell, 54–56 
splitting entry into two entries, 4, 56–57, 145 
swapping acronyms (organization names), 4, 58 
swapping and duplicating, 1, 13, 17, 47 
swapping, duplicating and combining, 14–15, 47–48, 47–

48 
swapping heading levels, 57 
toggling in and out of Text Edit Mode, 11, 25 
tutorial, 11 
undoing, 36 

Editor field 
described, 70 
filtering on, 69, 70 

resetting tag for, 149 
showing or hiding, 70 

elapsed time statistics, 213 
ellipsis character (…), entering, 143 
em dash (—), translation for, 202 
email, support through, 234 
embedding index entries 

including sort information, 143 

process for, 229–31 
empty fields, finding, 97, 101 
ems (measurement system), 221–22 
en dash (–) 

as page range separator, 178 
translation for, 202 

enabling or disabling. See toggling 
End User License Agreement (EULA). Title Page (back) 
ens (measurement system), 221–22 

entering records. See adding new records 
entries. See also adding new records; headings; records 

bookmark feature, 104 
converting cross-references into, 41 
finding with Goto command, 107 
identical, not combining, 259 
locating specific, 107 
promoting subheadings, 51 

selecting, 29, 51 
shifting right by one cell, 54–56 
shifting subheading left by one cell, 52–53 
shifting subheading left to main, 53–54 
sorting incorrectly, troubleshooting, 259–60 
splitting into two entries, 4, 56–57, 145 
statistics for, 213 

Equal Column Widths option, 71 

erasing. See deleting; deleting records; deleting text 
Error Scan, 210–12, See also Spell Check 

checking your index for errors, 210 
Cross-references options, 210 
deleting items from the list, 212 
merging orphan subheadings, 212 
Other options, 211 
printing the list, 212 

Error Scan (continued) 
Questionable Entries options, 211 
Scan Again button, 212 
SI7 enhancements for, 5 
viewing and editing errors, 211–12 

Error Scan Results dialog, 211–12 
EULA (End User License Agreement). Title Page (back) 
EV. See Edit View 
exclamation mark (!) 

Adjust Punctuation option, 143 
for grouping on text, 129 
in pattern matching character list, 120–21 

Export Index Options feature, 84 

exporting 
acronyms, 194 
AutoComplete list, 195, 196 
AutoEntry list, 198 
backing up, 74 
configuration template (index options), 84 
index, 76–77 
Macro list, 199 

translations, 203 

F 

fields. See also cells (Data Entry Grid); columns (Data Entry 
Grid); headings; locators; subheadings 

AutoCapitalization options, 162 
for cross-reference entry, 174 
in Edit View, 138 
empty, finding, 97, 101 

export options for, 77 
filtering on, 69–70 
Find dialog options for, 96 
mapping when importing indexes, 79–80, 80 
maximum number of characters for, 255 
repeating contents automatically, 166 
Replace dialog options for, 110 
Select Field dialog for commands, 225 
showing or hiding, 70–71 

specifying for translations, 203 
File Locations options, 145–47 
file management 

backing up, 74 
closing currently open index, 76 
compacting an index, 76 
creating a new index, 7, 81 
deleting an index, 76 

exporting an index, 76–77 
Files dialog overview, 73–74, 73 
importing an index, 78–80 
merging two or more indexes, 81 
opening an existing index, 81, 83 
Print Setup, 82 
printing a draft copy, 81–82 
renaming an index, 83 

repairing a damaged index, 83 
saving index with a different name, 84 

file size, compacting to reduce, 76 
file types 

for exporting indexes, 77 
for importing indexes, 78–79 
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filenames 
extension for index with user-defined codes, 159 
renaming an index, 83 
RTF files, 19 
saving index with a different name, 84 

for User Dictionary, specifying, 146–47 
Files dialog, 73–74, 73 
Filter Dialog, 69–70, 69 
Filtered view, 68–70, 69 
filtering 

clearing all options, 70 
defining a filter, 69–70 
index attributes that may be filtered, 68–69 

options for, 69–70 
status bar indicator for, 69 
uses for, 68 

Find dialog, 11–12, 93–96 
blue line indicating subsearch, 98 
Close button, 93 
Direction options, 93–94 
Field options, 96 

Find button, 94 
Find text box, 94 
Font options, 96 
general options, 93–95, 93 
Group Results checkbox, 94 
grouping using, 94, 130 
keyboard shortcuts for, 11, 99–100 
Match Case checkbox, 94 

More button, 94 
Not checkbox, 94 
Options button, 94 
options revealed by clicking More, 95–96 
Or radio button, 93 
Pattern Matching checkbox, 94 
Plus radio button, 93 
Previous Searches list, 5, 94 
And radio button, 93 

Reset button, 94 
resetting, but remembering “Group” setting, 94 
resetting to default values, 94 
restoring the last search or replace, 94 
Save button, 94 
Special options, 95 
Style options, 94, 95 
tutorial, 11–12, 12 

Whole Word checkbox, 95 
Find Next command, 105 
Find Pane, 13, 105, 112 
Find Previous command, 105 
finding, 93–102, 93–102, See also Find dialog; grouping; 

pattern matching 
all cross-references, 101–2 
all italic main headings, 100 

And operator for, 93, 98 
canceling a search, 96 
direction of search, 93–94 
empty fields, 97, 101 
entries, 107 
examples, 100–102 
Field options for, 96 
finding and replacing text versus, 109 

finding (continued) 
grouping results, 94, 130 
highlighted text or heading, 105 
keyboard shortcuts for, 5, 245 
locators for current entry, 108 

logic choices for subsearches, 98 
logic evaluation for subsearches, 99 
matching case for, 94 
next match (Find Next command), 105 
Not operator for, 94 
Or operator for, 93, 98 
pattern matching for, 94, 119–25 
Plus operator for, 93, 98 

previous match (Find Previous command), 105 
Previous Searches list for, 5, 94 
records by locator, 106 
records by record number, 106 
saved searches, using, 117–18 
saving searches, 94, 99 
SI7 enhancements for, 5 
'simple' Find for, 105 

Special options for, 95 
with specific attributes, 96–97 
Style options for, 94, 95 
subsearches, 97–99 
text with mixed character styles, 98 
tutorial, 12–13 
whole words, 95 
Wild Match search for, 97 

finding and replacing text, 109–14, See also finding; pattern 
matching; Replace dialog 

basic outline for, 109 
bringing up the Replace dialog, 110 
on case-by-case basis, 113 
changing character styles using, 114–15 
Find Pane for, 13, 105, 112 
Find Text specification, 110–11 
finding text versus, 109 

finding the first occurrence, 112 
keyboard shortcuts for, 245 
maintaining case for Replace Text, 111 
matching case for Find Text, 110 
with mixed character styles, 113–14, 113–14 
pattern matching for, 119–25 
Plus operator for, 113–14 
Replace Text specification, 111–12 

replacing all occurrences, 113 
saved searches, using, 117–18 
saving searches, 94, 99 
SI7 enhancements for, 5 
tutorial, 12–13 
undoing changes, 13, 113 
whole words, 110–11 

First Letter To Lower command, 132 

First Letter To Upper command, 133 
Fixed option 

for indention, 175 
for turnover lines, 175 

flipping. See swapping heading levels 
floating toolbars, 3, 247 
fonts 

for alphabetic section labels, 175, 176 
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fonts (continued) 
Alternative Fonts dialog, 176, 188–91, 189 
for calculating Line Count statistics, 213 
in Character Map, 209 
Find dialog options for, 95, 96 

for headers and footers, 153 
for headings and subheadings, 175, 176 
removing font attributes, 136 
Replace dialog options for, 111, 112 
with RTF presets, 158 
for screen display (program font), 148 
size in generated output, 153, 175 

footers for printed index, 151, 152–53, 155 

forcing a sort order, 135, 168, See also Ignored text attribute 
foreign language characters. See special characters 
format specification for locators, 255–56 
formatting codes. See also character styles; text attributes 

case-sensitivity of, 257 
entering directly no longer possible, 2 
export options for, 77 
markup tags, 156, 158–60 

output format options, 156–58 
overview, 257 
Reveal Codes pane for, 72 
table of, 257 
viewing, 72 

Forward direction of search, 93 

G 

genealogical indexes. See also name indexes 

combining consecutive pages as page range, 179 
ignoring duplicate records, 178 

general cross-references, options for, 173 
General Preferences, 141–45, 142 
generating an index, 19, 65 
global operations. See index as a whole 
Goto Bookmark command, 104 
Goto command, 107–8, 107 
Goto Locator command, 106–7, 106 

Goto Next Active Label command, 90 
Goto Record command, 105–6, 106 
greater than symbol (>) 

finding with pattern matching active, 121 
for pattern matching, 119, 121 

grid. See cells (Data Entry Grid); columns (Data Entry Grid); 
Data Entry Grid; fields 

Group on Current command, 129–30 

Group on Locator dialog, 127–28, 127 
Group on Main Heading command, 129 
Group on Text dialog, 128–29, 128 
Grouped view, 67–68, 68 
grouping, 127–30 

on active label, 87, 90, 130 
creating a group, 67 
on current main heading, 129 

on current word, 130 
on currently highlighted/selected text, 5 
and duplicating records, command for, 46 
and duplicating records, Ctrl+Shift modifier for, 37, 235 
Find dialog for, 93, 94, 130 
before generating an index, 65 

grouping (continued) 
within a group, 129 
on highlighted text or heading, 105 
keyboard shortcuts for, 245 
on locators, 6, 127–28 

number of records displayed in status bar, 14 
orphan subheadings, 6, 130 
for Proofing Report, 216 
saving group contents, 84 
selected records, 67–68, 68 
on selected text, 130 
SI7 enhancements for, 6 
on text under grid marquee (View Mode), 130 

ungrouping, 15, 129 
on words or phrases, 128–29 

groups, pattern. See pattern groups 

H 

Half Swap or Half Flip 
Shift Left command, 52–53 
Shift Left to Main command, 53–54 

Hart’s (modified) page range conflation, 178 

Hart’s Rules (page range conflation), 178 
hash mark. See pound sign (#) 
headers, alphabet. See alphabetic sections 
headers for printed index, 151, 152–53, 155 
Heading Markup Tags options, 159–60 
Heading Style options (Index Options dialog), 174–76, 174 
headings. See also entries; records; subheadings 

adding in Data Entry View, 7–9, 24 

adding in Edit View, 26–27, 138 
adding Notes to, 136 
alternative fonts for, 188–91, 189 
AutoCapitalization feature, 161–62 
AutoComplete options, 162–64 
AutoRepeat feature, 166 
Capitalization options, 176 
character styles for, 176 
combining subheadings with, 15, 39–40 

configuring, 174–76 
copying, 38 
creating child subheadings for selected locators, 4, 42–43 
cross-reference placement in, 172, 184 
cutting, 42–43 
deleting, 44 
deleting subheadings for, while retaining locators, 4, 40–

41 

demoting to subheadings, 44–46 
double spaced output of, 187 
Find dialog options for, 96 
finding all italic main headings, 100 
font for, 175, 176 
grouping on current main heading, 129 
identical entries not combining, 259 
Initial Cap option, 19 

labeling (Edit View), 89–90, 90 
line space above or below, 175 
mapping when importing indexes, 79–80, 80 
markup tags for, 159–60 
Paragraph Style options, 175 
pasting, 48–49 
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headings (continued) 
prefixes for, 185–86 
promoting subheadings to, 50–51, 50 
Replace dialog options for, 110 
selecting records, 29–30, 52 

selecting records and duplicating, 14 
shifting right by one cell, 54–56 
SmartSwap feature, 6, 168–70, 169 
sorting a level by page, 183 
sorting incorrectly, troubleshooting, 259–60 
splitting entry into two entries, 4, 56–57, 145 
style names for RTF output, 175 
suffixes for, 186 

swapping, 15, 57 
swapping and duplicating, 1, 13, 17, 47 
swapping, combining and duplicating, 14–15, 47–48, 47–

48 
tutorial, 7–9 

help, 21–22 
for Acronym Manager, 194 
for AutoComplete Manager, 195 

for AutoEntry Manager, 198 
for Data Entry Options dialog, 161 
Dialog Help Button, 21 
in dialog windows, 21 
in Document Options dialog, 151 
F1 key for, 21 
for Index Options dialog, 171 
for Macro Manager, 199 

mouse hover for popup display, 21, 249 
in Preferences dialog, 141 
searching for, 22 
Tip of the Day feature, 220 
for Translation Manager, 203 

hexadecimal value for Unicode characters, 205 
Hidden text attribute 

applying, 135 
changing color for, 144 

explained, 135 
Find dialog radio button for, 95 
finding text with, 97 
formatting codes for, 257 
Replace dialog radio button for, 111, 112 
using to force Ignored Words to sort, 168 

Hide Text command, 135 
hiding or showing. See also filtering 

Creator field, 70 
cross-reference target, 5, 63 
Date Created field, 70–71 
Date Edited field, 71 
Edit View, 71 
Editor field, 70 
hiding text from printing (hidden text), 135 
hiding text from sorting (ignored text), 135, 136 

hiding text from sorting or printing (Note text), 136 
labeled records, 69–70 
record numbers, 71 
repeated sections, volumes, or chapters in locators, 181 
Tip of the Day, 220 
toolbars, 70, 247 

hover with mouse for popup hints, 21, 249 
HTML Mode, 157 

HTML output format, 157 
hyperlinks, 157 
hyphen (-). See also dash (-) 

as page range separator, 178 
for preventing acronyms from expanding, 194 

as word delimiter, 133 

I 

identical entries not combining, troubleshooting, 259 
Ignore Text command, 136 
Ignored text attribute 

applying, 135, 136 
changing color for, 144 
color used for hyperlinks in HTML Mode, 157 

explained, 135 
Find dialog radio button for, 95 
for first word in a heading, 136 
formatting codes for, 257 
Replace dialog radio button for, 111, 112 
using to force Ignored Words to sort, 168 

Ignored Words list for sort, 167–68, 176 
Immediate cross-reference verification, 144, 223–24 

Import Field Mapping dialog, 79–80, 80 
Import Index Options function, 85 
importing 

acronyms, 194 
AutoComplete list, 195, 196 
AutoEntry list, 198 
configuration template (index options), 85 
index, 78–80 

Macro list, 199 
translations, 203 

importing an index, 78–80 
appending data to an existing index, 78 
from CINDEX DAT file, 78 
file types supported, 78 
from MACREX MBK file, 78–79 
mapping fields for, 79–80, 80 
to a new index file, 78 

opening a v6.0 index, 1, 78 
from text delimited file, 79–80 
troubleshooting problems, 80 

Incremental option 
for indention, 175 
for turnover lines, 175 

incrementing locators (Data Entry View), 62–63, 62–63 
indentation 

for calculating Line Count statistics, 213 
indented index style, 184 
for subheadings and turnover lines, 175–76 

index as a whole. See also configuration; index views; sorting 
adding prefix to field, 207 
adding suffix to field, 208 
backing up, 74 
closing currently open index, 76 

compacting, 76 
creating a new index, 7, 81 
deleting an index, 76 
embedding, 143, 229–31 
error scanning, 210–12 
exporting, 76–77 
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index as a whole (continued) 
generating, 19, 65 
importing, 78–80 
importing and exporting the configuration options, 84 
introductory note, 185 

markup tags, 156, 158–60 
merging two or more indexes, 6, 81 
opening a v6.0 index, 1, 78 
opening an existing SI7 index, 81, 83 
output format options, 156–58 
printing a draft copy, 81–82 
printing using word processor, 20, 65 
refreshing the Data Entry Grid, 71–72 

renaming, 83, 84 
repaginating, 219–20 
repairing a damaged index, 83 
Replace All operation, 113 
resorting, 66 
restoring from backup, 83–84 
saving with a different name, 84 
selecting all records (Data Entry View), 30 

specifying subheading levels, 66, 185 
statistics information for, 212–13 

index database, maximum size of, 255 
Index Options dialog, 171–91 

canceling changes to, 171 
Cross-references tab, 10, 171–74, 171 
Heading Style tab, 19, 174–76, 174 
help, 171 

Index Style tab, 183–88, 184 
loading saved options, 85 
Locators tab, 177–81, 177 
overview, 171 
reverting changes to current tab, 171 
saving options as a template, 84 
Sorting tab, 18, 181–83, 181 
tutorial, 10, 15–19 

index options, importing, 85 

Index Style options (Index Options dialog), 183–88, 184 
index views, 67–72, See also Data Entry View (DEV); Edit 

View (EV); showing or hiding 
As Entered, 67 
Creator field, 70 
Date Created field, 70–71 
Date Edited field, 71 
Editor field, 70 

equal column widths, 71 
Filtered, 68–70, 69 
Grouped, 67–68, 68 
Page Ordered, 43, 68 
record numbers, 71 
refreshing the Data Entry Grid, 71–72 
Reveal Codes, 72 
Sorted, 68 

status bar indicator for, 14 
toolbars, showing or hiding, 70 

indexer 
Creator field for, 69, 70, 149 
Editor field for, 69, 70, 149 
filtering on fields for, 69 
identification information, 149 
showing or hiding fields for, 70 

indexes. See index as a whole 
Initial Cap option for headings, 19, 176 
initial words ignored by sort (Ignored Words list), 167–68, 

176 
initials, indexer’s, 149 

in-place editor (Edit View), 16, See also Edit View (EV) 
adding a locator with, 17 
editing a heading with, 16 
editing a locator with, 17 
invoking, 16 
navigating, 17 
Preferences option for, 144 

international characters. See special characters 

Internet, the 
HTML Mode, 157 

introductory note for index, 185 
ISO sort order presets, 18, 182 
italic character style. See also character styles 

for alphabetic section labels, 176 
applying, 131 
for cross-references, 172 

Find dialog checkbox for, 95 
finding all main headings in, 100 
finding and replacing with underline, 114–15 
finding main entry with no subheadings, 97 
formatting codes for, 257 
for headings and subheadings, 176 
markup tags for, 160 
Replace dialog checkbox, for Replace Text, 111 

Replace dialog option, for Find Text, 110 

K 

keyboard shortcuts, 235–46 
for adding entries, 244 
Alt key shortcuts, 240 
Alt+Ctrl key shortcuts, 239 
Alt+Ctrl+Shift key shortcuts, 242 
alternative fonts, 189 
Alt+Shift key shortcuts, 241 

Append New command (SI7), 1, 17, 24, 33 
Append New command, using Ctrl+A, 1, 144 
for browsing, 104, 105 
case-changing commands, 132 
changing, 252–54 
character styles, 131 
cheat sheet for, 2 
core editing commands, 37, 235, 236 

Ctrl and Ctrl+Shift modifiers for core editing commands, 
37, 235 

Ctrl key shortcuts, 237–38 
Ctrl modified function keys, 236 
Ctrl+Shift key shortcuts, 238 
Ctrl+Shift modified function keys, 236 
Duplicate and Swap, using Ctrl+P, 1, 144 
for editing entries, 244 

Find dialog, 11, 99–100, 245 
for finding text, 5, 245 
for formatting and modifying text, 244 
by function, 243–46 
function keys, 236 
Goto Bookmark command, 104 
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keyboard shortcuts (continued) 
for grouping, 245 
keyboard template for, 2 
for labeling, 87, 89, 90, 245 
listed by keycap and modifier, 235–42 

multiple for one command, 254 
navigation (Data Entry Grid), 243 
navigation (Edit View), 28, 243 
other (table), 246 
removing the shortcut assignment for a command, 253, 

254 
Replace dialog, 12, 245 
Shift modified function keys, 237 

for text editor, 226 
upgrading to SI7 and, 1 

keywords (MACREX). See acronyms (abbreviations); 
translations 

L 

Label Manager, 87–88, 88 
Label Selector toolbar, 90–91, 91, 250 
labeling, 87–90 

active label, 87, 91, 250 
changing label colors, 88–89 
to delete records similarly to v6.0, 1 
feature described, 5, 87 
filtering labeled records, 69–70 
grouping on active label, 87, 90, 130 
headings in Edit View, 89–90, 90 
keyboard shortcuts for, 87, 89, 90, 245 

Label Selector toolbar, 90–91, 91, 250 
moving to next record with active label, 87, 90 
multiple selected records, 90 
naming labels, 87, 88 
records in Data Entry View, 89 
setting the active label, 87, 91, 250 
sorting not affected by, 90 
status bar display of active label, 5, 87, 90 
toggling the active label on and off, 87, 91, 250 

labels, alphabetic. See alphabetic sections 
labels, chapter/volume. See chapters/volumes in locators 
Landscape orientation 

for printed index, 155 
for proofreading report, 82, 216 

layout options. See alphabetic sections; page setup 
leaders for locators, 177 
leading (line spacing) options, 175 

less than symbol (<) 
finding with pattern matching active, 121 
for pattern matching, 119, 121 

letter-by-letter sort order. See also sorting 
CMS, 182 
ISO, 18, 182 

LF (markup tag), 159 
license agreement. Title Page (back) 

Line Count statistics, 213 
line spacing options, 175 
loading. See also importing; importing an index 

configuration templates (index options), 85 
index into word processor, 20, 65 
last index automatically, 142 

Locator Format Priority dialog, 179, 224 
Locator Increment or Decrement command (Data Entry 

View), 62–63, 62–63 
locators. See also chapters/volumes in locators; cross-

references; Roman numerals 

adding in Data Entry View, 8 
adding in Edit View, 17, 27, 138 
alignment of, 178 
AutoRepeat feature, 166 
changed mysteriously, troubleshooting, 260 
changing page numbers, 218 
character styles with, 179, 256 
combining consecutive pages as page range, 179 

configuring, 177–81, 177 
conflating page ranges, 178, 190–91 
Consume locs in range option, 6, 179 
copying, 38–39 
creating subheadings for selected, 4, 42–43 
cross-reference placement in relation to, 172, 184 
deleting in Edit View, 27 
deleting subheadings and retaining, 4, 40–41 

duplicating records and changing (Data Entry View), 8, 
61–62, 61 

editing in Edit View, 17, 27, 138 
in embedded indexes, 230 
Error Scan options, 211 
Find dialog Page option for, 95, 96 
finding for current entry, 108 
finding records by, 106 

forcing the sort of, 256 
format priority for, 179 
grouping on, 6, 127–28 
incrementing or decrementing (Data Entry View), 62–63, 

62–63 
leaders for, 177 
leading zeros of, 256 
mapping when importing indexes, 79–80, 80 
markup tags for page ranges, 158 

missing (empty Page field), finding, 97 
navigating in Edit View, 27 
navigating to next or previous, for current entry, 108 
Next page reminder option, 144 
numerous per entry, checking for, 211 
Page Ordered view, 68 
page range configuration, 178–79 
page ranges for embedded indexes, 230 

pasting, 49 
prefix for, 177 
punctuation for, 177, 178 
renumbering pages, 217–19 
repaginating the index, 219–20 
separator between, 177, 178 
separator for page ranges, 178 
sorting incorrectly, troubleshooting, 259 

sorting of, 256 
sorting priority for formatted, specifying, 179, 224 
specification for format of, 255–56 
statistics for, 213 
Subscript Out of Range error message, 260 
suffix for, 177 
truncated, troubleshooting, 260 
tutorial, 7–9 
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locators (continued) 
undifferentiated, checking for, 211 

Locators options (Index Options dialog), 177–81, 177 
lower case. See also case 

for alphabetic section labels, 176 

applying to text, 132 
for headings and subheadings, 176 

Lowercase command, 132 

M 

M’ or Mc or Mac, sorting, 183 
MACREX 

exporting an MBK file for, 77 
importing an index from, 78–79 

Macro Manager, 198–201 
Macro toolbar, 248–49 
macros 

codes for, 200–201 
defining, 198, 200–201 
described, 198 
editing, 249 
example, 201 

less needed with SI7, 2 
mouse hover for popup display, 21, 248–49 
path for saved macros, 146 
v6.0, rewriting needed for, 2 

maiden name entries 
creating automatically, 144, 215 
Process Maiden Names function, 215 

main heading. See headings 

Maintain Case replace option, 111 
managers 

Acronym Manager, 193–94 
AutoComplete Manager, 194–96 
AutoEntry Manager, 197–98 
Label Manager, 87–88 
Macro Manager, 198–201 
Saved Search Manager, 117–18 
Translation Manager, 202–6 

margin settings for printing, 155 
marking records. See labeling 
Markup Tags options, 156–57, 158–60 
Match Case search option 

for finding and replacing text, 110 
for finding text, 94 

maximum sizes 
characters per AutoComplete list entry, 162, 196 

characters per field, 255 
characters per record, 255 
index database, 255 
number of index records, 255 
number of subheading levels, 3 
number of subsearches, 5, 98 
number of volume/chapter labels, 3 
sort key, 255 

MBK files 
described, 78 
exporting, 77 
importing, 78–79 

Mc or M’ or Mac, sorting, 183 
measurement units for settings, 151, 221–22 

members of alphabetic sections, 188 
merging 

acronyms, 194 
AutoComplete entries, 195 
AutoEntry lists, 198 

indexes, 6, 81 
Macro lists, 199 
orphan cross-references, options for, 172–73 
orphan subheadings found by Error Scan, 212 
translations, 203 

metric system measurements, 151, 221–22 
Microsoft Word. See word processor 
mirror margins, 155 

missing records, troubleshooting, 260 
modifiers for core editing commands, 37, 235 
months, as locator section labels, 180 
More search options 

Field options, 96 
Find dialog button for, 93, 94 
finding text with specific attributes, 96–97 
Special options, 95 

Style options, 95 
Wild Match searches using, 97 

mouse 
drag and drop to embed index entries, 230 
drag and drop to swap heading levels, 58 
hover for popup hints, 21, 249 
selecting column of Data Entry Grid, 31 
selecting contiguous records, 31 

selecting non-contiguous records, 31 
moving around. See navigating 

N 

name, indexer’s, 149 
name indexes. See also genealogical indexes 

Automatically create maiden name entries option, 144 
sorting, 183 
Split command for, 4, 56–57, 145 

names, file. See filenames 

naming 
labels, 87, 88 
renaming an index, 83 
renaming saved searches, 117, 118 
saving index with a different name, 84 
styles for RTF output formats, 175 

navigating 
bookmark feature for, 104 

browsing, 103–5 
from cell to cell in the grid, 24 
in Edit View, 27, 28, 138, 139 
in-place editor (Edit View), 17 
keyboard shortcuts for (Data Entry Grid), 243 
keyboard shortcuts for (Edit View), 243 
to locators for current entry, 108 
to next record with active label, 87, 90 

Quick Access toolbar for, 249 
New Child Heading command (Edit View), 27, 138 
new features overview, 3–6 
New Heading command (Edit View), 26–27, 138 
new line characters (markup tags), 159 
Next page reminder option, 144 
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None option 
Find dialog, 95 
Replace dialog, 111, 112 

Not search operator, 93, 94 
note, introductory, 185 

Note text attribute 
applying, 136 
changing color for, 145 
described, 4, 136 
Find dialog radio button for, 95 
formatting codes for, 257 
Replace dialog radio button for, 111, 112 

Note Text command, 136 

numbers. See also locators; Roman numerals 
for pages of printed index, 153, 155 
pattern matching symbols for, 119, 120, 121–22 
record, including in proofreading report, 216 
record, showing or hiding, 71 
for repeating keys in macros, 201 
as section label data type, 180 
sorting, 182 

O 

Open Path option, 147 
opening 

cheat sheet for keyboard shortcuts, 2 
creating a new index, 7, 81 
existing SI7 index, 81, 83 
existing v6.0 index, 1, 78 
Find dialog, 93, 106 

recently opened indexes list for, 6, 83 
Replace dialog, 110 
template for keyboard shortcuts, 2 

options, configuration. See configuration 
Options|Export Index Options, 84 
Options|Import Index Options, 85 
Or search operator 

Find dialog radio button for, 93 
logic evaluation with other operators, 99 

logic of, 98 
orientation 

for printed index, 155 
for proofreading report, 82, 216 

orphan subheadings 
cross-reference options, 172–73 
in embedded indexes, 230 
Error Scan for, 210, 211, 212 

grouping, 6, 130 
merging automatically, 6, 176 

output codes 
ANSI, 157 
custom, 157 
HTML, 157 
markup tags, 156, 158–60 
Plain Text, 157 

Quark Xpress, 157 
RTF presets, 156–57, 158 
UCP (University of Chicago Press), 157 

Output Format options, 156–58 

P 

page numbering for index output, 153, 155 
page numbers. See locators 
Page Ordered view, 43, 68, 108 
Page Range Conflation Rules dialog, 178, 190–91 

page ranges 
changed mysteriously, troubleshooting, 260 
combining consecutive pages as, 179 
conflation rules, 178 
Consume locs in range option, 6, 179 
creating for embedded indexes, 230 
custom conflation rules for, 178, 190–91 
embedding index entries, 230 

format priority for, 179 
hiding repeated sections, volumes, or chapters, 181 
including pages in a group, 127, 128 
markup tags for, 158 
separator character for, 178 
truncated, troubleshooting, 260 

page setup 
columns, 155 

headers and footers, 151, 152–53, 155 
margins, 155 
Markup Tags options, 156–57, 158–60 
orientation, 82, 155, 216 
Output Format options, 156–58 
page numbering, 153, 155 
paper size, 154–55 
printer settings, 82, 216 

for proofreading report, 82 
page size, 154–55 
Pages Indexed statistics, 212–13 
pages of material 

added or removed, renumbering locators to accommodate, 
217–19 

indexed before final pagination, repaginating, 219–20 
statistics for, 212–13 

paper size, 154–55 

paragraph (run-on) index style, 184 
parentheses [( )] 

entering literally in macros, 200 
left, as word delimiter, 133 
for multiple-key combinations in macros, 201 
removing trailing text in, for cross-references, 163, 173 

Paste Heading command, 48–49 
Paste Plain Text Only 

setting for, 144 
pasting 

characters from Character Map, 209 
headings, 48–49 
locators, 49 
plain text option for, 144 
records, 35 
text, 34 

paths 
Choose Path dialog, 227 
Preference settings for, 145–47 

pattern groups, 123–25 
character styles with, 124 
defined, 123 
examples, 124–25, 125 
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pattern groups (continued) 
group zero {0}, 123 
groups 1 through 9, 123, 124 
subsearches not possible with, 124 
using, 123 

pattern matching, 119–25 
any single character, 120 
any single digit, 120 
character list for, 120–21 
examples, 121, 122, 124–25, 125 
Find dialog checkbox for, 93, 94 
first character, 121 
with Group on Text dialog, 129 

last character, 121 
pattern groups for, 123–25, 125 
symbols for, 119–22 
whole number, 121–22 
wild card (any number of characters), 119–20 
word, 122 

percent sign (%) 
entering literally in macros, 200 

macro code for Alt key, 200 
period (.) 

acronyms expanded by, 194 
Adjust Punctuation option, 143 
entering ellipsis character (…), 143 
Locator Increment command (Ctrl/Alt+period), 62–63, 

62–63 
as word delimiter, 133 

phone, support by, 234 
Plain command (remove formatting), 136, 164 
Plain Text output format, 157 
Plus search operator 

Find dialog radio button for, 93 
finding and replacing mixed character styles using, 113–14 
finding mixed character styles using, 98 
logic evaluation with other operators, 99 
logic of, 98 

plus sign (+) 
entering literally in macros, 200 
macro code for Shift key, 200 

points (measurement system), 221–22 
popup hints with mouse hover, 21, 249 
Portrait orientation 

for printed index, 155 
for proofreading report, 82, 216 

pound sign (#) 
entering literally in Group on Text dialog, 129 
finding with pattern matching active, 120 
for grouping on text, 129 
for pattern matching, 119, 120 
for sorting Roman numerals, 182 

Preferences dialog, 141–50 
abandoning changes and closing, 141 

Data Entry Options, 143, 144 
File Locations tab, 141, 145–47, 146 
General Preferences, 141–43, 142 
General tab, 141–45 
help, 141 
overview, 141 
Program Font tab, 141, 148 
reverting changes to current tab, 141 

Preferences dialog (continued) 
saving changes and closing, 141 
scope of settings, 141 
Text Colors options, 143, 144 
User Info tab, 141, 149 

prefixes 
adding to field of Data Entry Grid, 207 
for cross-references, 172, 173 
Index Style options (Index Options dialog), 185–86 
for locators, 177 
for sections, volumes, or chapters in locators, 180 

prepositions (Ignored Words), 167–68, 176 
Preview Pane 

arranging on screen, 23–24, 23–24, 143 
described, 23 
in Edit View, 4 
in HTML Mode, 157 
keyboard shortcuts for navigating, 243 
merged orphans in, 176 
navigating in Edit View, 28 
orange text in, 176 

Previous Searches list, 5, 94 
Print Draft command, 81–82 
Print Setup dialog, 82, 216 
printer settings, 82, 216 
printing 

acronyms list, 194 
AutoComplete list, 195 
AutoEntry list, 198 

Error Scan list, 212 
Macro list, 199 
Translation Table entries, 203 

printing an index 
columns settings for, 155 
defining alphabetic sections for, 187–88 
draft copy, 81–82 
entering text hidden from printing, 135 
headers and footers setup for, 151, 152–53, 155 

Index Style options for (Index Options dialog), 183–88, 
184 

margin settings for, 155 
Markup Tags options, 156–57, 158–60 
orientation for, 155 
Output Format options, 156–58 
page numbering for, 153, 155 
paper size settings for, 154–55 

printer settings for, 82, 216 
proofreading report print setup, 82, 216 
using word processor, 20, 65 

Process Maiden Name Entries function, 215 
Process Maiden Names function, 215 
Program Font preferences, 148 
program options. See Preferences dialog 
Promote command 

Combine command compared to, 47 
separator for, 50, 145, 225 
using, 50–51, 50 

promote separator, changing, 225 
promoting subheadings 

automatically using AutoEntry, 165, 197–98 
combining compared to, 47 
from cursor position, 39, 50 
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promoting subheadings (continued) 
in Edit View, 50 
part of a subheading (Data Entry View), 50–51 
separator for, 50, 145, 225 
for several entries (Data Entry View), 51 

single subheading (Data Entry View), 50 
Proofing Report 

overview, 215 
Print Setup for, 82, 216 
record numbers in, 71, 216 
SI7 enhancements for, 6 

Propagate Edits command (Data Entry View), 14, 63–64 
proportional grid scrolling, 142–43 

punctuation. See also specific punctuation marks 
for cross-references, 172, 173 
editing locators in Edit View and, 27, 138 
full stop characters for sorting, 182 
ignored when sorting, configuring, 182 
for locators, 177, 178 
preference for adjusting, 143 
for sections, volumes, or chapters in locators, 180, 260 

word delimiters for commands, 133 

Q 

Quark Xpress output format, 157 
question mark (?) 

Adjust Punctuation option, 143 
entering literally in Group on Text dialog, 129 
finding with pattern matching active, 120 
for grouping on text, 129 

for pattern matching, 119, 120 
Quick Access toolbar, 249 
quotation marks (") 

Adjust Punctuation option, 143 
beginning, as word delimiter, 133 
enclosing fields, when exporting indexes, 80 
enclosing fields, when importing indexes, 77 
Smart Quotes option, 144 

R 

ranges of pages. See page ranges 
recently opened indexes list, 6, 83 
reciprocal cross-references, creating, 4, 42 
Recognize Style and Case option (sorting), 183 
record numbers 

finding using, 106 
including in proofreading report, 71, 216 
showing or hiding, 71 

records. See also adding new records; entries; headings 
bookmark feature, 104 
copying to clipboard, 34 
cutting, 33–34 
duplicating and grouping, command for, 46 
duplicating and grouping, Ctrl+Shift modifier for, 37, 235 
duplicating, command for, 13, 46 
duplicating, Ctrl modifier for, 37, 235 

finding, 106 
finding by locator, 106 
grouping selected, 67–68, 68 
labeled, filtering, 69–70 

records (continued) 
labeling (Data Entry View), 89, 90 
maximum number of, 255 
maximum size for, 255 
missing, troubleshooting, 260 

pasting, 35 
redoing changes after undoing, 36 
selecting (Data Entry View), 29–31, 52 
sorting incorrectly, troubleshooting, 259–60 
undoing changes to, 36 

Redo command, 36 
Refresh command, 71–72 
refreshing 

Acronym Manager, 194 
Data Entry Grid, 71–72 
Macro list, 199 
resorting AutoComplete list, 195 
updating AutoComplete list, 164, 196 

Remove Duplicate Records tool, 216 
removed pages, renumbering locators to accommodate, 217–

19 

removing. See canceling; deleting; deleting records; deleting 
text; reverting or clearing; showing or hiding 

renaming 
changing keyboard shortcuts, 252–54 
index file, 83 
saved searches, 117, 118 
saving index with a different name, 84 
toolbar commands, 252 

Renumber Pages tool, 217–19 
Repaginate tool, 219–20 
repairing a damaged index, 83 
repeating field contents automatically, 166 
Replace dialog, 110 

Find button, 112 
Find options, 110–11 
Font options, 111, 112 
keyboard shortcuts for, 12 

Maintain Case checkbox, 111 
Match Case checkbox, 110 
opening, 110 
Plus radio button, 113–14 
Replace All button, 113 
Replace button, 113 
Replace options, 111–12 
Special options, 111, 112 

Style options, 110, 111–12 
tutorial, 12–13, 13 
Whole Field checkbox, 112 

replacing text. See also finding and replacing text 
with Propagate Edits command (Data Entry View), 14, 63–

64 
reset options for Find dialog, 94 
Reset Tips 

Preferences option, 144 
resorting. See also sorting 

AutoComplete list, 195 
index, 66 

restoring 
AutoComplete list, 164 
index from backup, 83–84 
last search or replace, 94 
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Reveal Codes pane, 72 
reverting or clearing. See also canceling; undoing 

Acronym Manager changes, 194 
AutoComplete Manager changes, 195 
AutoEntry Manager changes, 198 

Data Entry Options dialog changes, 161 
Document Options dialog changes, 151 
filter options, 70 
Index Options dialog changes, 171 
Macro Manager changes, 199 
Preferences dialog changes, 141 
redoing changes after undoing, 36 
resetting Find dialog to defaults, 94 

returning toolbar to default style, 252 
Translation Manager changes, 203 

Rich Text Format. See RTF 
Roman numerals 

Consume locs in range option, 6, 179 
grouping on locators, 6, 127–28 
incrementing or decrementing (Data Entry View), 62–63, 

62–63 

page numbering for printed index, 153 
as section label data type, 180 
sorting, 182 

RTF output format, 156–57, 158 
RTF Plain output format, 157, 158 
RTF (Rich Text Format) 

described, 19 
generating a file, 19, 65 

Output Format options, 156–57, 158 
style names for, 175 
translation option for, 204 

RTF Spaces output format, 157, 158 
RTF Tabs output format, 157, 158 
run-on index style, 184 

S 

Save As command, 84 
Saved Search Manager, 117–18, 117 

Saved Search toolbar, 249 
saved searches 

adding previous search to list, 118 
changing order of list, 118 
defining a new search, 118, 249 
deleting, 118 
described, 5, 117 
editing, 249 

executing, 249 
number available, 5, 99 
renaming, 117, 118 
saving, 94, 99 
undoing changes in Saved Search Manager, 118 

saving. See also exporting 
Acronym Manager changes, 194 
AutoComplete list, 164, 195 

AutoComplete Manager changes, 195 
AutoEntry Manager changes, 198 
backing up, 74 
configuration templates (index options), 84 
custom Index Style options, 185 
disk space, compacting for, 76 

saving (continued) 
Edit View changes (applying changes), 27, 138 
group contents, 84 
Macro Manager changes, 199 
searches, 94, 99 

Translation Manager changes, 203 
scale systems for settings, 151, 221–22 
scanning index for errors. See Error Scan; Spell Check 
screen font, specifying, 148 
Search for Help On option, 22 
searching. See finding 
searching and replacing. See finding and replacing text 
sections, alphabetic 

adding, 188 
defining, 187–88 
deleting, 188 
formatting labels for, 175–76 
markup tags for, 158 
members of, 188 
overview, 187 
prefixes for, 185–86 

style name for RTF output, 175 
suffixes for, 186 
suppressing, 188 

sections (chapters/volumes) in locators 
adding or removing labels, 214 
configuring, 179–81, 260 
grouping on, 127, 128 
hiding repeated, 181 

maximum number of labels, 3 
renumbering pages, 217–19 
repaginating, 219–20 
sorting of, 256 
troubleshooting, 260 

“see” and “see also” cross-references. See cross-references 
Select All command, 30 
Select Entry command, 29, 51 
Select Field dialog, 225 

Select Heading command, 14, 29–30, 52 
Select Record command, 29 
selecting characters in Character Map, 209 
selecting records (Data Entry View), 29–31, 52 

all records, 30 
column of Data Entry Grid, 31 
contiguous records, with keyboard, 30 
contiguous records, with mouse, 31 

for embedding, 229 
entry, 29, 51 
grouping selected records, 67–68, 68 
heading level, 29–30, 52 
heading level and duplicating, 14 
non-contiguous records, with mouse, 31 
single record, 29 

semicolon (;) 

Append New command (Ctrl+semicolon), 1, 17, 24, 33 
for browsing to subheadings, 103, 104 
deleting cross-references in Edit View and, 27 
for duplicating a record and adding another cross-

reference, 10–11 
separators for commands 

Demote, 44 
Preference settings for, 145 
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separators for commands (continued) 
Promote, 50 
Split, 56 

separators for index elements. See also delimiters 
alphabetic section labels, 158, 175–76 

cross-references, 173 
locators, 177, 178 
page ranges, 178 
sections, volumes, or chapters in locators, 180, 260 

set-out (indented) index style, 184 
Shift key, macro code for, 200 
Shift Left command, 52–53 
Shift Left to Main command, 53–54 

Shift Right command, 54–56 
shifting right by one cell, 54–56 
shifting subheading left 

to main (Edit View), 54 
by one cell (Edit View), 53 
several entries by one cell (Data Entry View), 53 
several entries to main (Data Entry View), 54 
single entry by one cell (Data Entry View), 53 

single entry to main (Data Entry View), 54 
shortcuts. See acronyms (abbreviations); keyboard shortcuts; 

translations 
showing or hiding. See also filtering 

Creator field, 70 
cross-reference target, 5, 63 
Date Created field, 70–71 
Date Edited field, 71 

Edit View, 71 
Editor field, 70 
hiding text from printing (hidden text), 135 
hiding text from sorting (ignored text), 135, 136 
hiding text from sorting or printing (Note text), 136 
labeled records, 69–70 
record numbers, 71 
repeated sections, volumes, or chapters in locators, 181 
Tip of the Day, 220 

toolbars, 70, 247 
SI7. See SKY Index v7.0 
'simple' Find, 105 
Simple page range conflation, 178 
single quote (‘) as word delimiter, 133 
sizes, maximum. See maximum sizes 
SKY Index v5.x, exporting index for, 77 
SKY Index v6.0 

Ctrl+A shortcut for Append New, using, 1, 144 
deleting records similarly to, 1 
Duplicate and Swap command shortcut, using, 1 
exporting index for, 77 
macros, rewriting needed for, 2 
opening an index, 1, 78 

SKY Index v7.0 (SI7) 
new features, 3–6 

specifications, 255–57 
support, 233–34 
tips for upgraders, 1–2 
troubleshooting, 259–60 

SKY Software Customer Support System (CSS), 233–34 
.sky7 files 

exporting, 77 
importing, 79 

small caps character style. See also character styles 
for alphabetic section labels, 176 
for cross-references, 172 
formatting codes for, 257 
for headings and subheadings, 176 

Preference setting for, 143 
Replace dialog checkbox, for Replace Text, 111 
Replace dialog option, for Find Text, 110 
strikeout excluded by use of, 132 
uppercase text not generated as, 132 

Smart Quotes option, 144 
SmartSwap feature, 6, 168–70, 169 
Sortbar. See Quick Access toolbar 

Sorted view, 68 
sorting 

Arabic numbers, 182 
ASCII, 182 
characters ignored during, 182 
CMS, 182 
configuring, 181–83, 181 
dates, 182, 227 

embedding information for, 143 
entering text ignored by, 135, 136 
of entries, troubleshooting, 259–60 
by entry order (As Entered view), 67 
forcing a sort order, 135, 168, 256 
full stop characters for, 182 
heading level by page, 183 
hiding text from (ignored text), 135, 136 

hiding text from printing and (Note text), 135, 136 
Ignored Words list for, 167–68, 176 
ISO, 18, 182 
labeling not affecting, 90 
letter-by-letter, 18, 182 
by locator order (Page Ordered view), 68 
of locators, specifications for, 256 
of locators, troubleshooting, 259 
maximum sort key size, 255 

name indexes, 183 
presets, 182 
Recognize Style and Case option, 183 
refreshing Data Entry Grid, 71–72 
resorting an index, 66 
Roman numerals, 182 
SI7 enhancements for, 6 
Sorted view, 68 

status bar indicator for method of, 66 
symbols, 182 
troubleshooting, 259–60 
tutorial, 18 
for Unicode translations, 205 
word-by-word, 182 

Sorting options (Index Options dialog), 181–83, 181 
space character 

acronyms expanded by, 194 
bypassing AutoComplete by starting entry with, 196 
characters treated by sorting as, 182 
double spaces, removing automatically, 144 
for indenting, RTF Spaces output for, 157, 158 

spacing between lines, 175 
special characters. See also punctuation; specific characters 

Character Map for, 209 
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special characters (continued) 
characters treated by sorting as symbols, 182 
ignored when sorting, configuring, 182 
issues when exporting indexes, 77 
issues when importing CINDEX DAT files, 80 

macro codes, 200–201 
pattern matching criteria symbols, 119–22 
sorting leading symbols, 183 
Unicode, 6, 202, 203, 204–6 

Special options 
Find dialog, 95 
Replace dialog, 112 

specifications, 255–57 

formatting codes, 256–57, 257 
locator format, 255–56 
maximum sizes, 255 
sorting of locators, 256 

Spell Check 
performing, 216 
User Dictionary for, 146–47 

Spelling Check dialog options, 217 

spin controls on dialogs, using, 221–22 
Split command 

described, 4, 56–57 
separator for, 56, 145 
Split Count for, 56, 145 
using, 56–57 

splitting entry into two entries 
from cursor position, 56 

described, 4, 56–57 
in Edit View, 56 
separator for, 56, 145 
for several records (Data Entry View), 57 
for single record (Data Entry View), 57 
Split Count for, 56, 145 

square brackets ([ ]) 
entering in macros, 200 
for finding symbols with pattern matching active, 120, 

121, 122 
for grouping on text, 129 
left, as word delimiter, 133 
for pattern matching, 119, 120–21 
for Unicode translation codes, 206 

Standard toolbar, 247–48, 247–48 
Statistics tool, 212–13 
status bar 

active label display in, 5, 87, 90 
“Filtered” in, 69 
number of records in group displayed in, 14 
sort method displayed in, 66 
view mode displayed in, 14 

strikeout character style. See also character styles 
for alphabetic section labels, 176 
applying, 131 

Find dialog checkbox for, 95 
formatting codes for, 257 
for headings and subheadings, 176 
markup tags for, 160 
Preference setting for, 143 
Replace dialog checkbox, for Replace Text, 111 
Replace dialog option, for Find Text, 110 
small caps excluded by use of, 132 

Style search options 
Find dialog, 94, 95 
Replace dialog, for Find Text, 110 
Replace dialog, for Replace Text, 111–12 

styles for RTF output formats, 175 

styles, formatting. See character styles 
subheadings. See also headings 

adding in Data Entry View, 7–9, 24 
adding in Edit View, 27, 138 
adding with Convert Cross-reference command, 41 
alternative fonts for, 188–91, 189 
AutoCapitalization feature, 161–62 
AutoComplete options, 162–64 

AutoRepeat feature, 166 
Capitalization options, 176 
character styles for, 176 
combining with parent heading, 15, 39–40 
configuring, 174–76 
consuming (removing and retaining locators), 4, 40–41 
copying, 38 
creating for selected locators, 4, 42–43 

demoting headings to, 44–46 
empty, finding, 97, 101 
Find dialog options for, 96 
font for, 175, 176 
Indention options, 175–76 
line space above or below, 175 
mapping when importing indexes, 79–80, 80 
markup tags for, 159–60 

maximum number of levels, 3 
orphan, grouping, 6, 130 
Paragraph Style options, 175 
prefixes for, 185–86 
promoting to headings, 50–51, 50 
Replace dialog options for, 110 
shifting left by one cell, 52–53 
shifting left to main, 53–54 
shifting right by one cell, 54–56 

SmartSwap feature, 6, 168–70, 169 
sorting a level by page, 183 
specifying levels of, 66, 185 
style names for RTF output, 175 
suffixes for, 186 
swapping, 15, 57 
swapping and duplicating, 1, 13, 17, 47 
swapping, combining and duplicating, 47–48 

tutorial, 7–9 
subscript character style. See also character styles 

applying, 131 
Find dialog checkbox for, 95 
formatting codes for, 257 
markup tags for, 160 
Replace dialog checkbox, for Replace Text, 111, 112 
Replace dialog option, for Find Text, 110 

Subscript Out of Range error message, 260 
subsearches. See also finding; pattern matching 

Find dialog indicator for (blue line), 98 
logic choices for, 98 
logic evaluation for, 99 
maximum number of, 5, 98 
pattern groups not possible with, 124 

subsets. See grouping 
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suffixes 
adding to field of Data Entry Grid, 208 
for cross-references, 172, 173 
Index Style options (Index Options dialog), 186 
for locators, 177 

for sections, volumes, or chapters in locators, 180 
superscript character style. See also character styles 

applying, 131 
Find dialog checkbox for, 95 
formatting codes for, 257 
markup tags for, 160 
Replace dialog checkbox, for Replace Text, 111, 112 
Replace dialog option, for Find Text, 110 

support, 233–34, 233–34 
suppressing alphabetic sections, 188 
Swap Acronym command, 4, 58 
Swap command, 15, 57 
swapping case, 132 
swapping heading levels 

AutoCapitalization option for, 162 
automatically using AutoEntry, 165, 197 

duplicating and, 1, 13, 17, 47 
duplicating and combining and, 14–15, 47–48, 47–48 
in Edit View, 57 
in several records (Data Entry View), 15, 58 
in single record (Data Entry View), 58 
SmartSwap feature, 6, 168–70, 168, 169 
tutorial, 13, 15 
using drag and drop, 58 

symbols (characters). See also specific symbols 
Character Map for, 209 
characters treated by sorting as, 182 
ignored when sorting, configuring, 182 
issues when exporting indexes, 77 
issues when importing CINDEX DAT files, 80 
macro codes, 200–201 
sorting leading symbols, 183 
Unicode, 6, 202, 203, 204–6 

symbols (wild cards) 
for grouping on text, 129 
for pattern matching, 119–22 

T 

.tab files. See text delimited files 
tabs in output (RTF Tabs format), 157, 158 
team projects, collaborating on, 77 
technical support, 233–34, 233–34 

telephone, support by, 234 
template for keyboard shortcuts, 2 
templates for configuration options 

default, for the most common settings, 84 
information saved in, 84 
loading, 85 
saving, 84 
specifying path for, 146 

temporary locators, repaginating, 219–20 
text. See also adding new records; character styles; text 

attributes 
copying to clipboard, 34 
cutting, 33 
deleting column contents (Data Entry Grid), 31 

text (continued) 
deleting one character at a time, 35 
deleting one word at a time, 35 
deleting several characters at a time, 35 
editing (tutorial), 11 

Group on Text dialog, 128–29, 128 
grouping on selected, 130 
keyboard shortcuts for formatting and modifying, 244 
pasting, 34 
Text Colors options, 143, 144 

text attributes. See also character styles 
applying, 135–36 
AutoComplete functioning with, 164 

AutoEntry configuration for, 165 
changing colors for, 144 
described, 135, 136 
Find dialog radio buttons for, 95 
finding text with, 97 
formatting codes for, 257 
keyboard shortcuts for, 244 
removing formatting from text, 136, 164 

Replace dialog radio buttons for, 111, 112 
Wild Match searches for, 97 

Text Colors options (Preferences dialog), 143–45, 144 
text delimited files 

described, 78 
exporting, 77 
importing, 78, 79 
troubleshooting import problems, 80 

Text Edit Mode (Data Entry View) 
toggling between View Mode and, 11, 25 
View Mode compared to, 24–25 

text editor 
canceling changes made in, 226 
for defining acronyms, 194 
for defining macros, 199 
for defining translations, 203 
for header and footer captions, 152, 153 

how to use, 226 
for introductory note, 185 
invoking, 226 

tilde (~) 
for Enter key in macros, 200 
finding with pattern matching active, 122 
for pattern matching, 119, 122 

time spent indexing 

for embedded indexes, 230 
statistics for, 213 

Tip of the Day feature, 220 
title case. See also case 

for alphabetic section labels, 176 
applying to text, 133 
for headings and subheadings, 176 
SI7 enhancements for, 6 

Title Case command, 6, 133 
“to” as page range separator, 178 
Toggle see/see also command, 4, 59 
toggling 

active label on and off, 87, 89, 91, 250 
alphabetic sections, 187 
between bookmarked records, 104 
Edit View and Data Entry View, 71, 137 
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toggling (continued) 
fixed and incremental indents, 175 
Immediate cross-reference verification, 144, 223 
in-place editor preference, 144 
see and see also cross-references, 4, 59 

Text Edit Mode and View Mode, 11, 25 
use of SmartSwap list, 169 

toolbars, 247–52 
Acronym, 248 
adding new commands, 251 
customizing, 250–54 
docking options for, 3, 247 
Edit, 248 

floating, 3, 247 
Label Selector, 90–91, 91, 250 
Macro, 248–49 
modifying the appearance of commands, 251–52 
overview, 247 
popup hints with mouse hover, 21, 248 
Quick Access, 249 
removing commands, 251 

returning to default style, 252 
Saved Search, 249 
showing or hiding, 70, 247 
SI7 enhancements for, 3 
Standard, 247–48, 247–48 

tools, 207–20 
Add Prefix, 207 
Add/Remove Volume/Chapter Labels, 214 

Add Suffix, 208 
Browse, 103–5 
Change Page Number, 218 
Character Map, 209 
Error Scan, 210–12 
Proofing Report, 6, 82, 215 
Remove Duplicate Records, 216 
Renumber Pages, 217–19 
Repaginate, 219–20 

Spell Check, 216–17, 216 
Statistics, 212–13 
Tip of the Day, 220 

tooltips (popup hints with mouse hover), 21, 249 
Translation Manager, 202–6, 202 
translations 

acronyms compared to, 202, 206 
case-sensitivity of, 202, 204, 206 

defining, 202–3 
deleting, 206 
for HTML output format, 157 
importing, 85 
order in which they are applied, 206 
overview, 202 
path for saved translations, 146 
sort order for, 205 

for Unicode characters, 6, 202, 203, 204–6 
uses for, 202 

troubleshooting 
compacting an index, 76 
general solutions, 259 
identical entries not combining, 259 
import problems, 80 
locators sorting incorrectly, 259 

troubleshooting (continued) 
missing records, 260 
program behaving strangely, 260 
repairing a damaged index, 83 
sections, volumes, or chapters in locators, 260 

Subscript Out of Range error message, 260 
turnover lines 

calculating Line Count statistics using, 213 
Fixed option, 175 
Incremental option, 175 
Incremental options, 175 
options for, 175–76, 175 

tutorial, 7–20 

adding entries, 7–11 
conclusion, 20 
configuring the index, 15–19 
creating an index, 7 
cross-references, 9–11 
duplicating records, 13–15 
editing the index, 11 
editing the index in Edit View, 15–17 

finding and replacing text, 12–13 
finding entries, 11–12 
generating an RTF file, 19 
headings, subheadings, and locators, 7–9 
loading the index into a word processor, 20 
outline of, 7 

.txt files. See text delimited files 
typesetting codes. See output codes 

U 

UCP (University of Chicago Press) output format, 157 
underline character style. See also character styles 

for alphabetic section labels, 176 
applying, 131 
for cross-references, 172 
Find dialog checkbox for, 95 
finding and replacing italics with, 114–15 
formatting codes for, 257 

for headings and subheadings, 176 
markup tags for, 160 
Replace dialog checkbox, for Replace Text, 111 
Replace dialog option, for Find Text, 110 

undifferentiated locators, checking for, 211 
Undo command, 36 
undoing 

within a cell or Edit View textbox, 25, 36 

after Replace All, 13, 113 
reversing changes to records, 25, 36 
Saved Search Manager changes, 118 

Ungroup command, 15, 129 
Unicode 

choosing a translation code for, 204 
defining translations for, 204–6 
hexadecimal value for characters, 205 

recommended coding for, 206 
SI7 support for, 6, 202 
Unicode Character Translation Generator dialog, 203, 205 

University of Chicago Press (UCP) output format, 157 
updating the AutoComplete list, 164, 196 
upgrading to SI7, tips for, 1–2 
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upper case. See also case 
for alphabetic section labels, 176 
applying to text, 132 
for headings and subheadings, 176 

Uppercase command, 132 

User Dictionary 
adding words to, 217 
creating a new dictionary, 147 
specifying path and filename for, 146–47 

User Info preferences, 149 
user interface enhancements for SI7, 3 

V 

verifying cross-references, 144, See also Error Scan 

version 5.x, exporting index for, 77 
version 6.0 

Ctrl+A shortcut for Append New, using, 1, 144 
deleting records similarly to, 1 
Duplicate and Swap command shortcut, using, 1 
exporting index for, 77 
macros, rewriting needed for, 2 
opening an index, 1, 78 

version 7.0 (SI7) 
new features, 3–6 
specifications, 255–57 
support, 233–34 
tips for upgraders, 1–2 
troubleshooting, 259–60 

View Mode (Data Entry View) 
grouping on text under grid marquee, 130 

Text Edit Mode compared to, 24–25 
toggling between Text Edit Mode and, 11, 25 

views, 67–72, See also Data Entry View (DEV); Edit View 
(EV); showing or hiding 

As Entered, 67 
Creator field, 70 
Date Created field, 70–71 
Date Edited field, 71 
Editor field, 70 

As Entered, 108 
equal column widths, 71 
Filtered, 68–70, 69 
Grouped, 67–68, 68 
HTML Mode, 157 
Page Ordered, 43, 68, 108 
record numbers, 71 
refreshing the Data Entry Grid, 71–72 

Reveal Codes, 72 
Seek Current Record When Changing option, 142 
Sorted, 68 
status bar indicator for, 14 
toolbars, showing or hiding, 70 

visually challenged users, program font setting for, 148 
vocabulary control, AutoComplete list for, 163 
volumes/chapters in locators 

adding or removing labels, 214 
configuring, 179–81, 260 
grouping on, 127, 128 
hiding repeated, 181 
maximum number of labels, 3 
renumbering pages, 217–19 

volumes/chapters in locators (continued) 
repaginating, 219–20 
sorting of, 256 
troubleshooting, 260 

W 

Web, the 
HTML Mode, 157 
SKY Software Customer Support System, 233–34 
support options using, 233 

Whole Field replace option, 110, 112 
whole number, pattern matching symbol for, 119, 121–22 
Whole Word search option 

Find dialog, 95 

Replace dialog, 110–11 
wild cards 

for grouping on text, 129 
pattern matching symbols, 119–22 

Wild Match searches, 97 
Windows Character Map, 205 
Windows clipboard 

copying text and records to, 34 

cutting text and records to, 33–34 
pasting text and records from, 34–35 

word-by-word sort order. See also sorting 
CMS, 182 
ISO, 182 

word processor 
choosing, 147 
embedding index entries in, 143, 229–31 

generating an index for, 19, 65 
loading an index into, 20, 65 
RTF output format presets for, 156–57, 158 
specifying path for, 147 

words 
AutoCapitalization feature, 161–62, 161 
deleting one at a time, 35 
delimiters for, 133 
grouping on, 128–29, 130 

Ignored Words list for sort, 167–68 
pattern matching symbol for, 119, 122 
SmartSwap list, 6, 168–70 

wrapped (turnover) lines 
calculating Line Count statistics using, 213 
Fixed option, 175 
Incremental option, 175 
options for, 175–76 

toggling fixed and incremental, 175 

Y 

years 
century assumptions for, configuring, 228 
as locator section labels, 181 
sorting dates, 183, 227–28 

Z 

zero pattern group {0}, 123 

zeros, locators with leading, 256 
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